Creazione di un formulario

From Apache OpenOffice Wiki
Jump to: navigation, search



I Database vengono usati per archiviare dati. Ma come si inseriscono i dati nel database? I formulari servono proprio a questo; nel linguaggio dei database, un formulario è l'interfaccia tramite la quale si inseriscono o si modificano i dati.

Un semplice formulario è composto dai campi di una tabella.

I campi di un semplice formulario.

Formulari più complessi possono contenere molto altro: testo aggiuntivo, grafica, caselle di scelta ed altri elementi ancora. La figura sotto riportata mostra la stessa tabella con una etichetta di testo (Acquisti di carburante), un elenco a tendina in TipodiPagamento e uno sfondo grafico.

Semplice Formulario con qualche aggiunta.

Utilizzo della procedura guidata per creare un formulario

Useremo la procedura guidata per la creazione di due formulari: Collezione CD e Vacanze. Collezione CD sarà un formulario semplice mentre Vacanze conterrà al suo interno un formulario secondario. Creeremo il formulario Vacanze con i suoi formulari secondari e modificheremo il formulario della collezione CD utilizzando il medesimo processo.

Nella finestra principale del database, fate clic sull'icona Formulari. Fate doppio clic su Usa procedura guidata per la creazione dei formulari... per aprire la procedura (figura sottostante). Un formulario semplice richiede solo alcuni di questi passi, mentre i formulari più complessi potrebbero utilizzarli tutti.

Passo 1: Selezione dei campi.

  1. In Tabelle o ricerche, selezionate la tabella Vacanze. Campi disponibili elenca i campi della tabella Vacanze.
  2. Fate clic sulla doppia freccia verso destra per spostare tutti i campi nell'elenco Campi nel formulario, quindi fate clic su Avanti.
Fasi della Creazione guidata formulario.

Passo 2: Configurazione di un formulario secondario.

Dal momento che abbiamo già creato una relazione tra le tabelle Carburante e Vacanze, useremo questa. Se non ci fosse nessuna relazione esistente, questa verrebbe definita al passo 4.

  1. Fate clic sulla casella con l'etichetta Aggiungi formulario secondario.
  2. Fate clic sul pulsante di scelta con l'etichetta Formulario secondario basato su una relazione esistente.
  3. Carburante viene elencato come relazione che vogliamo aggiungere. Quindi fate clic su Carburante per evidenziarlo, come mostrato sotto, quindi su Avanti.
Aggiungere un formulario secondario.

Passo 3:Aggiungere i campi nel formulario secondario.

Questo passo è esattamente uguale al passo 1. La sola differenza è che non tutti i campi verranno usati per il formulario secondario.

  1. Selezionate Carburante in Tabelle o ricerche.
  2. Usate il pulsante >> per spostare tutti i campi a destra.
  3. Fate clic su IDCarburante per evidenziarlo.
  4. Ora mediante il pulsante < spostate il campo IDCarburante a sinistra.
  5. Fate clic su Avanti.
Selezione dei campi di un formulario secondario

Passo 4:Caricamento campi uniti.

Questo passaggio è per quelle tabelle o ricerche per le quali non sono state ancora definite delle relazioni. Poiché vogliamo elencare tutte le spese in base al giorno in cui avvengono sia nel formulario che nel formulario secondario, uniremo i campi Data di queste due tabelle (figura sotto).

Selezione dei campi collegati tra un formulario secondario e uno principale.
  1. Selezionate Data dall'elenco a tendina Primo campo collegato del formulario secondario. Questo è il campo Data della tabella Carburante. Non corrisponde alla chiave Primaria nella tabella Carburante, ma è definito invece come una chiave Esterna.
  2. Selezionate Data dall'elenco a tendina Primo campo collegato del formulario principale. Questo è il campo Data della tabella Vacanze, ed è la chiave Primaria di tale tabella. Fate clic su Avanti.
Documentation note.png E' possibile creare tra due tabelle una relazione basata su più di una coppia di campi. Il modo ed il motivo di ciò è discusso nella Guida a Base.
Documentation caution.png Quando selezionate una coppia di campi da due tabelle per utilizzarli come relazione, essi devono avere lo stesso tipo di campo. Questo è il motivo per il quale abbiamo usato il campo Data in entrambe le tabelle: entrambi i campi sono del tipo Data [DATE].

In base al numero di coppie di campi scelte come relazione, occorre che certi requisiti siano soddisfatti perché il formulario possa funzionare:

  • Nessun campo del formulario secondario può essere la chiave Primaria della sua tabella (in questo caso, IDCarburante non può essere usato).
  • I campi di ogni coppia di collegamento devono avere lo stesso tipo di campo.
  • Uno dei campi del formulario principale deve essere la chiave Primaria della sua tabella (in questo caso deve essere usato il campo Data).


Passo 5: Disposizione dei campi di controllo.

Documentation note.png Ogni controllo in un formulario è costituito da due parti: l'etichetta ed il campo. Questo passo nella creazione del formulario determina come l'etichetta ed il campo del controllo sono posizionati l'uno rispetto all'altro. Le quattro scelte da sinistra a destra sono In colonna - testo fisso a sinistra, In colonna - testo fisso in alto, Tabellare e In riga - testo fisso in alto (figura sottostante).
  1. Disposizione del formulario principale: selezionate In colonna - testo fisso in alto. Le etichette saranno poste sopra il campo relativo.
  2. Disposizione del formulario secondario: selezionate Tabellare (le etichette sono i titoli delle colonne ed i campi sono le voci al loro interno, disposti come in un foglio elettronico). Fate clic su Avanti.
Disposizione dei campi di controllo.

Passo 6: Impostazione immissione dati.

A meno che non abbiate uno specifico bisogno di spuntare una di queste voci, scegliete le impostazioni predefinite. Fate clic su Avanti.

Passo 7:Applicare gli stili di formato.

  1. Selezionate il colore che desiderate nell'elenco Applica stili di formato (in questo caso è stato scelto il beige che corrisponde ad Arancione 4 nella tabella Colore).
  2. Selezionate il Bordo campo che desiderate (in questo caso il 3-D; potete sperimentare le differenti configurazioni possibili).
  3. Fate clic su Avanti.

Passo 8:Impostazione del nome.

  1. Inserite il nome del formulario. In questo caso sarà Carburante.
  2. Selezionate il cerchietto a sinistra di Modifica il formulario (questo cerchietto in gergo si chiama “casella di spunta a scelta singola”).
  3. Fate clic su Fine. Il formulario si apre in struttura modulo.

Inizio pagina

Modifica di un formulario

Sposteremo i controlli in parti diverse del formulario e cambieremo lo sfondo con una fotografia. Inoltre modificheremo l'etichetta del campo TipoDiPagamento e trasformeremo il campo in un elenco a tendina.

Per prima cosa, dobbiamo decidere cosa vogliamo cambiare e come. La discussione verrà articolata in dieci passi.

  1. Il campo Data nel formulario principale porta alla necessità di avere un elenco a tendina. Esso inoltre deve essere allungato per mostrare data e giorno della settimana.
  2. Occorre accorciare la lunghezza dei campi pagamento (ovvero tutti i campi che contengono la parola pagamento).
  3. I controlli devono essere disposti in gruppi: cibo, formulario secondario, carburante e varie.
  4. Alcune etichette devono cambiare nella loro formulazione: alcune parole singole dovrebbero diventare due, altre potrebbero essere abbreviate (km. per Chilometraggio).
  5. La larghezza di diversi campi e le etichette devono essere cambiati; solo Pranzo, Cena, Hotel e Pedaggi hanno una lunghezza accettabile. Tuttavia, per ottenere un aspetto più gradevole, apporteremo delle modifiche anche ad essi.
  6. Tutti i campi la cui etichetta termina con Pagamento verranno sostituiti con un elenco a tendina. Questo elenco conterrà le voci inserite nella tabella TipoDiPagamento.
  7. Il campo Nota necessita di un maggiore spazio in verticale e di una barra di scorrimento; inoltre deve essere spostato.
  8. Devono essere fatte delle modifiche alle colonne Data e TipoDiPagamento nel formulario secondario, modifiche simili a quelle del formulario principale.
  9. Devono essere aggiunte delle intestazioni per ogni gruppo creato nel formulario principale.
  10. Lo sfondo verrà sostituito con una immagine ed alcune etichette verranno modificate per essere più leggibili. Anche il colore del carattere dei titoli dovrà essere cambiato.

Questi sono alcuni punti che affronteremo nei passaggi che seguono. I controlli nel formulario principale sono costituiti dalle etichette e dai loro campi. Lavoreremo a volte sull'intero controllo, a volte solo sull'etichetta o sul campo. Altre volte lavoreremo con un gruppo di controlli.

  • Fate clic sull'etichetta o sul campo per selezionare l'intero controllo. Intorno ad esso appare un bordo con otto maniglie verdi (vedere sotto). Tenendo premuto il tasto sinistro potrete trascinarlo dove desiderate.
Un controllo selezionato.
  • Con CTRL+clic potete selezionare solo l'etichetta o solo il campo (vedere sotto).
  • Utilizzando il tasto TAB, potete spostare la selezione dal campo all'etichetta e viceversa.
Selezione del campo di un controllo.
  • Spostare un gruppo di controlli è quasi semplice quanto muoverne uno solo.
  1. Fate clic sul campo di controllo più in alto e a sinistra tra quelli che desiderate spostare, per selezionarlo.
  2. Spostate il cursore appena sopra e a sinistra del campo di controllo selezionato.
  3. Tenendo premuto il tasto del mouse trascinate il cursore verso il basso a destra del gruppo dei controlli, poi rilasciate il tasto.
  4. Mentre trascinate il cursore, appare una casella tratteggiata che evidenzia l'area racchiusa nella selezione. Assicuratevi che questa sia sufficientemente ampia da contenere tutti i campi di controllo.
  5. Quando rilasciate il pulsante del mouse, intorno ai campi di controllo selezionati appare un bordo con delle maniglie verdi (figura sottostante).
  6. Selezione di controlli multipli.
  7. Spostate il cursore su uno dei campi; questo diventa una doppia freccia (vedere sotto).
  8. Doppia freccia
  9. Trascinate il gruppo di controlli dove li volete posizionare.

Prima di cambiare il campo Data, dovremo spostare i controlli Pranzo e Pedaggi verso destra di 5 cm (2 pollici).

Tip.png Quando si vuole ridimensionare o spostare un controllo, è opportuno selezionare due proprietà della barra Struttura del formulario: Cattura alla griglia e Linee guida durante lo spostamento. Sarà più facile allineare i controlli, ed uno schema di ciò che state muovendo si sposterà insieme al cursore.

Sarebbe opportuno anche avere entrambi i righelli attivi (Strumenti > Opzioni > OpenOffice.org Writer > Vista). Poiché il formulario viene creato in Writer, è qui che dovete assicurarvi che entrambe le caselle accanto a Righello verticale ed a Righello orizzontale siano selezionate.


Documentation note.png Utilizzeremo i centimetri per eseguire modifiche nei formulari, poiché sono più precisi dei pollici; quando si spostano i controlli (i campi e le loro etichette) il loro posizionamento risulta più accurato. Potete convertire i righelli da pollici a centimetri cliccandovi sopra con il tasto destro del mouse e selezionando centimetro dal menu contestuale. A questo punto è possibile allineare i controlli, le etichette o i campi a valori specifici sul righello.

Inizio pagina

Passo 1: Modifica del campo Data.

  1. Tenendo premuto il tasto CTRL, fate clic sul campo Data per selezionarlo.
  2. Spostate il cursore sulla maniglia verde al centro del lato destro; questo si trasformerà in una freccia singola.
  3. Freccia singola.
  4. Tenendo premuto il tasto sinistro del mouse, trascinate il cursore verso destra fino a raggiungere la lunghezza di 6 cm. La linea tratteggiata verticale dovrà essere allineata con il numero 6 del righello (che equivale a circa 2.4 pollici). Rilasciate il pulsante del mouse.
  5. Fate clic sull'icona Controllo della barra Struttura del Formulario (vedere sotto); è il comando contrassegnato dal cerchio rosso. Si apre la finestra Proprietà: Campo data, in cui ogni riga rappresenta una proprietà del campo.
  6. La barra Struttura del formulario.
    1. Andate alla proprietà Formato data. Si tratta di un elenco a tendina la cui impostazione predefinita è Standard (breve).
      • Fate clic sull'impostazione predefinita Standard (breve) per aprire l'elenco.
      • Selezionate la voce Standard (esteso).
    2. Scorrete verso il basso fino alla voce Apribile. L'impostazione predefinita è No. Si tratta anche in questo caso di un elenco apribile.
      • Fate clic sul valore predefinito per aprire l'elenco.
      • Selezionate .
Tip.png Per vedere come apparirà il campo Data, fate clic sull'icona Modo bozza On/Off (la seconda icona da sinistra nella figura sopra). Potete fare ciò ogni volta che volete vedere come appare il formulario con i cambiamenti che avete apportato.


Passo 2: Ridurre la lunghezza di un campo.

Tutti i campi nella cui etichetta compare la parola pagamento sono troppo lunghi; prima di spostare i controlli occorre accorciarli.

  1. Tenendo premuto CTRL, fate clic sul campo APagamento (figura sottostante).
  2. Spostate il cursore sulla maniglia verde al centro del lato destro. Questa si trasforma in una freccia singola.
  3. Trascinatela verso sinistra finché il campo raggiunge una larghezza di 2,5 cm (1 pollice).
  4. Ripetete questi passaggi per accorciare i campi: Apagamento, CPagamento, PagamentoSpuntino, MPagamento e AltroPagamento.
Selezione di un campo.
Tip.png Se avete attivato le icone Cattura alla griglia e Linee guida durante lo spostamento nella barra Struttura del formulario, vedrete quanto è lungo il campo mentre lo accorciate.


Passo 3: Spostare i controlli per raggrupparli in categorie.

Vogliamo spostare i controlli in modo che l'insieme assomigli alla figura sottostante.

Posizionamento dei controlli.
  1. Selezionate il primo controllo che volete spostare; intorno ad esso appare un bordo con otto maniglie verdi.
  2. Portate il cursore sopra l'etichetta o il campo del controllo. Esso si trasforma in una doppia freccia.
  3. Trascinate e rilasciate il controllo nella posizione che desiderate.
  4. Usate lo stesso metodo per posizionare nel modo opportuno gli altri controlli.
Documentation caution.png Non utilizzate CTRL + clic quando spostate un campo di controllo, in quanto il CTRL + clic sposta il campo oppure l'etichetta ma non entrambi. Per spostarli entrambi, trascinateli tenendo premuto il tasto del mouse.


Documentation note.png L'unico modo per imparare ad eseguire correttamente questi due passaggi consiste nel fare pratica. Esiste un altro sistema per posizionare i controlli dove volete, ma si tratta di una funzione avanzata e verrà affrontata nella Guida a Base.

Passo 4: Modifica delle etichette

Il nome del campo deve essere costituito da una sola parola. Tuttavia, le etichette dei campi possono essere costituite da più parole, quindi le cambieremo.

  1. Tenendo premuto CTRL, fate clic sull'etichetta NSpuntino. Utilizzate uno dei seguenti modi:
    1. Fate clic con il tasto destro sull'etichetta NSpuntino.
      • Selezionate Campo di controllo dal menù contestuale (vedere sotto). Si apre una finestra chiamata Proprietà: Testo fisso. Essa contiene tutte le proprietà dell'etichetta selezionata.
      • Menù contestuale.
      • Nella casella Didascalia, fate clic tra la N e la S in NSpuntino.
      • Usando la barra spaziatrice dividete NSpuntino in due parole.
      • Inserite un . (punto) dopo la lettera N (di Numero) (figura sotto).
      • Chiudete la finestra delle proprietà.
      • Etichetta a più parole.
    2. In alternativa, fate clic sull'icona Controllo nella barra Struttura del Formulario (vedere sotto); si aprirà la finestra delle Proprietà. Il resto del procedimento è analogo a quanto spiegato sopra.
    3. La barra Struttura del formulario.
  2. Utilizzate la stessa procedura per modificare queste etichette come segue: BPagamento in Pagamento, CPagamento in Pagamento, SPagamento in Pagamento, Varie in Altro, CostoSpuntino in Costo Spuntino, MPagamento in Pagamento, AltroPagamento in Pagamento Varie e Altro in Varie. Note.
  3. Chiudete la finestra Proprietà.
Tip.png Potete modificare tutte le specifiche dell'elenco nella finestra Proprietà. Ad esempio, modificando l'allineamento da sinistra a centro il testo verrà centrato all'interno dell'etichetta. Avendo un po di tempo a disposizione, potete sperimentare le differenti impostazioni giusto per per farvi un'idea di quello che potete ottenere.


Passo 5: Modificare la larghezza delle etichette e dei campi.

Vogliamo che i seguenti controlli siano larghi 2 cm (0.8 pollici): Colazione, Pranzo, Cena, Chilometraggio, N. Spuntino, Pedaggi, Costo Spuntino, Hotel e Varie. Tutti i campi dei pagamenti sono stati modificati nel passo 2, ma Pagamento varie deve essere portato a 3 cm (1.2 pollici).

  1. Fate clic su Colazione. Intorno ad esso appare il bordo con le otto maniglie verdi.
  2. Spostate il cursore sulla maniglia verde al centro del lato destro. Il cursore diventa una freccia singola.
  3. Trascinatela verso sinistra per stringere o verso destra per allargare il controllo e poi rilasciatela. Utilizzate le linee guida per determinarne la larghezza.
  4. Ripetete l'operazione per l'intero elenco dei controlli.

Inizio pagina

Passo 6: Sostituzione di campi con altri campi.

Vogliamo sostituire il campo Pagamento con un elenco a tendina. Così, invece di inserirlo manualmente, potremo scegliere il tipo di pagamento dalla tabella TipoDiPagamento. Nel nostro caso, ogni tipo di pagamento inizia con una lettera differente; inserendo la prima lettera del tipo di pagamento, il resto della parola appare automaticamente. Possiamo così proseguire al campo successivo.

  1. Tenendo premuto CTRL, fate clic sul campo Pagamento per la Colazione. Le maniglie verdi appaiono intorno al campo ma non intorno all'etichetta (figura sottostante).
  2. Selezione del campo di un controllo.
  3. Fate clic con il tasto destro all'interno dell'area evidenziata e selezionate nell'elenco Sostituisci con > Casella di riepilogo (la figura sottoriportata mostra l'elenco dei possibili campi di sostituzione).
  4. Campi di sostituzione.
  5. Fate clic sull'icona Controllo nella barra Struttura del formulario per aprire la finestra Proprietà.
  6. Sulla scheda Generale, scorrete verso il basso e selezionate la voce Apribile. Cambiate il No con in questo elenco apribile (figura sotto).
  7. L'elenco a tendina si apre per mostrare le opzioni.
  8. Fate clic sulla scheda Dati.
  9. L'elenco a tendina Tipo del contenuto della lista.
    • Tipo del contenuto della lista è un elenco a tendina; qui selezionate Sql.
    • Digitate esattamente quanto segue nella casella Contenuto elenco:
      SELECT "TipoDiPagamento", "TipoDiPagamento" FROM "TipoDiPagamento"
    • Contenuto elenco per i campi relativi al tipo di pagamento.
      Tip.png Dovreste poter copiare ed incollare SELECT "TipoDiPagamento", "TipoDiPagamento" FROM "TipoDiPagamento" da questo testo direttamente nella casella Contenuto elenco. Assicuratevi di copiare dalla S di SELECT fino all'ultima doppia virgoletta dopo la frase TipoDiPagamento e niente di più di questo.


      Documentation note.png Quello che avete scritto è un comando SQL. Le parole SELECT e FROM vengono scritte in maiuscolo in quanto sono dei comandi. Quando viene usato, il comando SELECT richiede un nome campo tra virgolette e quindi l'alias del campo, anch'esso tra virgolette. In questo caso, il campo ed il suo alias sono uguali. Il comando FROM richiede il nome della tabella che contiene il campo. Se i nomi delle tabelle sono costituiti da una sola parola nell'istruzione SQL le doppie virgolette non sono richieste; se invece questi sono costituiti da più parole le virgolette diventano necessarie.
    • Ripetete questi passaggi per i campi pagamento relativi a Pranzo, Cena, Motel, Spuntini e Varie. Il formulario principale dovrebbe assomigliare alla figura sottostante, almeno per quanto riguarda la disposizione dei controlli. Essa mostra anche come dovrebbe apparire il controllo Note. Queste modifiche verranno spiegate nel prossimo passaggio.
    Posizione dei controlli nel formulario principale.
  10. Chiudete la finestra Proprietà.

Passo 7: Modifica del campo Note.

Vogliamo spostare il controllo Note dove è raffigurato nella figura sopra riportata. Poiché si tratta di un campo di tipo promemoria necessita di una barra di scorrimento verticale per avere spazio aggiuntivo per il testo, ove necessario.

  1. Tenendo premuto CTRL, fate clic sul campo Note. Le maniglie verdi appariranno intorno al solo campo e non intorno alla sua etichetta.
  2. Fate clic sull'icona Controllo per aprire la finestra delle Proprietà.
  3. Scorrete verso il basso fino alla voce Barre di scorrimento. Modificate la selezione da Nessuno a Verticale nell'elenco a tendina.
  4. Selezione delle Barre di scorrimento nella finestra Proprietà.
  5. Chiudete la finestra Proprietà.
  6. Allungare il campo Note.
    • Spostate il cursore sulla maniglia verde al centro del lato inferiore del campo; il cursore si trasforma in una freccia singola verticale.
    • Trascinatela verso il basso fino ad attenere un'altezza pari a 6 cm (2.4 pollici).

Passo 8: Modifica delle etichette e dei campi in un formulario secondario.

La colonna Data deve essere ampliata. Il campo nella colonna TipoDiPagamento deve essere modificata in un elenco a tendina. L'etichetta della colonna TipoDiPagamento deve essere formata da più parole.

Modifica della colonna TipoDiPagamento:

  1. Fate clic sull'etichetta TipoDiPagamento con il tasto destro del mouse per aprire il menu contestuale (vedi sotto).
  2. Opzioni per modificare un controllo in un formulario secondario.
  3. Selezionate Sostituisci con, e quindi scegliete Casella di riepilogo dal menu contestuale.
  4. Fate ancora clic con il tasto destro sull'etichetta TipoDiPagamento per aprire il menu contestuale.
  5. Selezionate Colonna. Si aprirà la finestra delle Proprietà (figura sotto riportata).
  6. Nella casella Didascalia, modificate TipoDiPagamento in Tipo di pagamento.
  7. Finestra delle proprietà di controllo in un formulario secondario.
  8. Fate clic sulla scheda Dati.
  9. Dall'elenco a tendina Tipo del contenuto della lista, selezionate Sql.
  10. Digitate esattamente quanto segue:
    SELECT "TipoDiPagamento", "TipoDiPagamento" FROM "Tipo Pagamento"
  11. Chiudete la finestra Proprietà.
Tip.png Il Passo 6: Sostituzione di campi con altri campi, a partire dalla parte 5, contiene istruzioni più dettagliate.


Inizio pagina

Passo 9: Assegnare delle intestazioni ai gruppi.

  1. Assicuratevi di aver posizionato il cursore nell'angolo in alto a sinistra del formulario; in caso contrario, fate clic sull'angolo per spostarvi lì.
  2. Usando il tasto Invio spostate il cursore verso il basso di 4 linee.
  3. Nell'elenco a tendina Applica stile sulla barra dei menu cambiate Standard con Intestazione 2.
  4. L'elenco Applica stile.
  5. Utilizzate la barra spaziatrice per spostare il cursore dove volete che inizi l'intestazione.
  6. Digitate l'intestazione Pasti.
  7. Usate la barra spaziatrice per portare il cursore al centro dell'area spuntini.
  8. Digitate l'intestazione Spuntini.
  9. Usate il tasto Invio per spostare il cursore tra il controllo Cena ed il formulario secondario.
  10. Usate la barra spaziatrice per portare il cursore al centro del formulario secondario.
  11. Digitate il titolo Dati Carburante.
Documentation note.png Se sapete usare gli stili, potete aprire la finestra Stili e formattazione con il tasto F11. Selezionando con il tasto destro del mouse il titolo Intestazione 2 potete modificare la rappresentazione dei tre titoli appena inseriti, usando la finestra Stile di paragrafo. Si veda il Capitolo 6 (Introduzionre agli stili) della Guida a Writer.

Passo 10: Modifica dello sfondo di un formulario.

Lo sfondo del formulario può essere costituito da un colore o da una immagine (ad esempio una fotografia). Potete utilizzare qualsiasi colore presente nella Tabella Colori in Strumenti > Opzioni > OpenOffice.org > Colori; se sapete come creare dei colori personalizzati, potete usare anche questi. È anche possibile utilizzare un'immagine (un file grafico) come sfondo; useremo nell'esempio una immagine trovata in OOo: sky.gif. Dal momento che in varie zone di essa il colore di sfondo è scuro, occorre cambiare il colore di molte etichette e dei titoli per renderli visibili.

Immagine di sfondo.
  1. Selezionate le etichette della prima riga di controlli.
    1. Tenendo premuto CTRL, fate clic sull'etichetta Data.
    2. Fate clic sulle altre tenendo invece premuto MAIUSC + CTRL; il bordo della selezione si estenderà progressivamente verso destra man mano che eseguite questa operazione, fino a racchiudere tutte le etichette.
    3. Selezione di più etichette tutte insieme.
    4. Fate clic sull'icona Controllo nella barra Struttura del formulario per aprire la finestra Proprietà: Selezione multipla.
    5. Modificate il colore di sfondo da Standard a Ciano chiaro (si tratta di un elenco a tendina).
  2. Allo stesso modo selezionate le altre etichette e modificate il loro colore di sfondo.
  3. Chiudete la finestra Proprietà.
  4. Documentation note.png Si è scelto di usare il colore Ciano chiaro come sfondo per le mie etichette. Si può scegliere il colore che si desidera, inclusi quelli personalizzati che è possibile creare.
  5. Premete il tasto F11 per aprire la finestra Stili e formattazione. Notate che l'icona più a sinistra ha un bordo grigio scuro intorno ad essa: è l'icona Stili di paragrafo. Sotto troviamo un elenco di stili di paragrafo con i loro relativi nomi.
  6. Parte superiore della finestra Stili e formattazione.
    1. Fate clic con il tasto destro del mouse sulla voce Intestazione 2 e selezionate Modifica dal menu contestuale.
    2. Nella finestra Stile di paragrafo selezionate la scheda Effetto carattere (figura sotto).
    3. Schede della finestra Stile di Paragrafo: Intestazione 2.
    4. Modificate il Colore carattere dall'elenco a tendina in Ciano chiaro.
    5. Lato sinistro della Scheda Effetto carattere.
    6. Fate clic su OK per chiudere la finestra Stile di Paragrafo: intestazione 2.
    7. Premete il tasto F11 per chiudere la finestra Stili e formattazione.
    8. Tip.png Imparare ad utilizzare gli stili può essere molto utile. Utilizzando gli stili, abbiamo cambiato il colore del carattere di tutte e tre le intestazioni contemporaneamente. Ci sono altri metodi per cambiare il colore del carattere, ma richiedono la ripetizione degli stessi passaggi per ogni titolo che si vuole modificare.


  7. Con il cursore sullo sfondo, fate clic con il tasto destro del mouse e selezionate Pagina dal menu contestuale.
  8. Fate clic sulla scheda Sfondo (figura sotto).
  9. Scheda Sfondo in Stile di Pagina.
    1. Nel menù a tendina Come, cambiate Colore con Immagine.
    2. Cercate il file: sky.gif. Lo troverete nella cartella Galleria di OOo.
    3. Fate clic sul pulsante Sfoglia nella sezione File. Navigate fino alla cartella contenente il file sky.gif.
    4. Selezionate il file e fate clic su Apri.
    5. Nella sezione Tipo, selezionate Area.
    6. Fate clic su OK per chiudere la finestra Stile di pagina: Standard.

Il formulario dovrebbe assomigliare a quello nella figura sottostante.

Il formulario ultimato.


Inizio pagina

Passo 11: Modificare l'ordine delle schede.

Il tasto TAB sposta il cursore da un campo all'altro. E' molto più semplice utilizzare questo sistema piuttosto che fare clic su ogni campo per inserirvi i dati. Questo ci permette inoltre di raggruppare le nostre spese in aree prima di iniziare ad inserire i dati. Per esempio, tutte le nostre spese per pasti possono essere raggruppate, così come le spese per gli spuntini e per gli acquisti di carburante.

  1. Tenendo premuto CTRL, fate clic sul campo Data.
  2. Fate clic sull'icona Struttura del formulario nella barra Controlli formulario per aprire la barra Struttura del formulario (vedere sotto). Oppure, utilizzate Visualizza > Barre degli strumenti > Struttura del formulario per aprire questa barra degli strumenti.
  3. Fate clic sull'icona Sequenza di attivazione.
  4. La barra Struttura del formulario con l'icona Sequenza di attivazione cerchiata in rosso.
  5. Ora riorganizzate l'ordine dei campi nella finestra Ordine schede (Figura sottostante).
  6. La finestra Ordine schede.
    • Cercate txtMPagamento in basso nella lista e fateci clic sopra.
    • Fate clic sul pulsante Sposta in alto fino a che txtMPagamento si trovi immediatamente al di sotto di hotel.
    • Ripetete questa procedura per mettere i campi nell'ordine mostrato qui sotto.
    • Sequenza di ordinazione per il formulario principale.
    • Fate clic su OK.
  7. Salvate e chiudete il formulario.
  8. Salvate il database.

Creazione di formulari in Vista struttura

Questo metodo richiede l'uso della barra Controlli formulario e Struttura del formulario: queste tecniche esulano però dallo scopo di questo documento. Le istruzioni per creare formulari utilizzando la Vista struttura sono descritte nella Guida a Base.

Creazione di formulari secondari in Vista struttura

Anche questo argomento va oltre lo scopo del presente documento. La creazione di formulari secondari in Vista Struttura sarà descritta nella Guida a Base.

Inizio pagina


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools