Formatting pages

From Apache OpenOffice Wiki
Jump to: navigation, search

Writer provides several ways for you to control page layouts:

  • Page styles
  • Columns
  • Frames
  • Tables
  • Sections

For more information, see Chapter 4: Formatting Pages in the Writer Guide.

Tip.png Page layout is usually easier if you show text, object, table, and section boundaries in Tools > Options > > Appearance, and paragraph ends, tabs, breaks, and other items in Tools > Options > Writer > Formatting Aids.

Which layout method to choose?

The best layout method varies depending on what the final document should look like and what sort of information will be in the document. Here are some examples.

For a book similar to this user guide, with one column of text, some figures without text beside them, and some other figures with descriptive text, use page styles for basic layout, and tables to place figures beside descriptive text when necessary.


For an index or other document with two columns of text, where the text continues from the left-hand column to the right-hand column and then to the next page, all in sequence (also known as “snaking columns” of text), use page styles (with two columns). If the title of the document (on the first page) is full-page width, put it in a single-column section.


For a newsletter with complex layout, two or three columns on the page, and some articles that continue from one page to some place several pages later, use page styles for basic layout. Place articles in linked frames and anchor graphics to fixed positions on the page if necessary.


For a document with terms and translations to appear side-by-side in what appear to be columns, use a table to keep items lined up, and so you can type in both “columns”.


Creating headers and footers

A header is an area that appears at the top of a page. A footer appears at the bottom of the page. Information, such as page numbers inserted into a header or footer, displays on every page of the document with that page style.

To insert a header, choose Insert > Header > Default (or the page style, if not Default).

Other information such as document titles and chapter titles is often put into the header or footer. These items are best added as fields. That way, if something changes, the headers and footers are updated automatically. Here is one common example.

To insert the document title into the header:

  1. Click File > Properties > Description and type a title for your document.
  2. Add a header (Insert > Header > Default).
  3. Place the cursor in the header part of the page.
  4. Choose Insert > Fields > Title. The title should appear on a gray background (which does not show when printed and can be turned off).
  5. To change the title for the whole document, go back to File > Properties > Description.

Fields are covered in detail in Chapter 14 (Working with Fields) in the Writer Guide.

For more about headers and footers, see Chapter 4 (Formatting Pages) and Chapter 6 (Introduction to Styles) in the Writer Guide.

Numbering pages

To automatically number pages:

  1. Insert a header or footer, as described in Creating headers and footers.
  2. Place the cursor in the header or footer where you want the page number to appear and click Insert > Fields > Page Number.

Including the total number of pages

To include the total number of pages (as in “page 1 of 12”):

  1. Type the word “page” and a space, then insert the page number as above.
  2. Press the spacebar once, type the word “of” and a space, then choose Insert > Fields > Page Count.
Documentation note.png The Page Count field inserts the total number of pages in the document, as shown on the Statistics tab of the document’s Properties window (File > Properties). If you restart page numbering anywhere in the document, then the total page count may not be what you want. See Chapter 4 (Formatting Pages) in the Writer Guide for more information.

Restarting page numbering

Often you will want to restart the page numbering at 1, for example on the page following a title page or a table of contents. In addition, many documents have the “front matter” (such as the table of contents) numbered with Roman numerals and the main body of the document numbered in Arabic numerals, starting with 1.

You can restart page numbering in two ways.

Method 1:

  1. Place the cursor in the first paragraph of the new page.
  2. Choose Format > Paragraph.
  3. On the Text Flow tab of the Paragraph dialog, select Breaks.
  4. Select Insert and then With Page Style and specify the page style to use.
  5. Specify the page number to start from, and then click OK.
Tip.png Method 1 is also useful for numbering the first page of a document with a page number greater than 1. For example, you may be writing a book, with each chapter in a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with page 25 and Chapter 3 with page 51.

Method 2:

  1. Insert > Manual break.
  2. By default, Page break is selected on the Insert Break dialog.
  3. Choose the required page Style.
  4. Select Change page number.
  5. Specify the page number to start from, and then click OK.
Restarting page numbering after a manual page break.

Changing page margins

You can change page margins in two ways:

  • Using the page rulers—quick and easy, but does not have fine control.
  • Using the Page Style dialog—can specify margins to two decimal places.
Documentation note.png If you change the margins using the rulers, the new margins affect the page style and will be shown in the Page Style dialog the next time you open it.

Because the page style is affected, the changed margins apply to all pages using that style.

To change margins using the rulers:

  1. The gray sections of the rulers are the margins. Put the mouse cursor over the line between the gray and white sections. The pointer turns into a double-headed arrow.
  2. Hold down the left mouse button and drag the mouse to move the margin.
Moving the margins.
Tip.png The small arrows on the ruler are used for indenting paragraphs. They are often in the same place as the page margins, so you need to be careful to move the margin marker, not the arrows. Place the mouse pointer between the arrows and, when the pointer turns into a double-headed arrow, you can move the margin (the indent arrows will move with it).

To change margins using the Page Style dialog:

  1. Right-click anywhere on the page and select Page from the pop-up menu.
  2. On the Page tab of the dialog, type the required distances in the Margins boxes.

Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools