12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Building a presentation

From Apache OpenOffice Wiki
Jump to: navigation, search


This process begins with the decision as to what basic characteristics you want all the slides to have. These characteristics determine which slide master you will use for your slides and what modifications if any you will make to it.

Choosing a slide master

A Slide Master is a slide with a specified set of characteristics which is used as the beginning point for creating other slides. These characteristics include the background, objects in the background, formatting of any text used, and any background graphics.

Documentation note.png Impress uses three interchangeable terms for this one concept. Master slide, slide master, and master page all refer to a slide that is used to create other slides. This chapter and the Impress Guide, however, use only the term slide master.

For a simple presentation, there is normally only one Master Page. All slides are created by adding elements to the Master Page. Another Master Page can be used for some of the slides if so desired.

If you decide later that the Master Page you chose does not meet your needs, you can still choose a different Master Page, or you can change parts of your Master Page. All the slides which apply this Master Page will be changed the same way.

Tip.png As you are developing your slide master and then succeeding slides, use F5 or F9 regularly to see what the slide you are working on looks like full screen. Then use the Esc key to return to your work of creating your slide show. You can spot problems sooner and easier this way.


You should first determine the styles you want to use for your presentation. There are five prepackaged slide masters, found in the Master Pages section of the Task pane (shown below). Pick the one that comes closest to what you want. We look at how to make changes in the slide master later.

Available slide masters.
Documentation note.png The Default Master Page is a blank slide with specific Outline styles. The other four Master Pages contain designs as well as specific Outline styles.

To see what is possible to do, look at how the prepackaged Master Pages were made. To do this, select View > Master > Master Slide to open the Master Pages section. Since the Default Master Page is blank, consider only the other four available Master Pages.

Tip.png View > Master > Master Slide allows you to make changes in the slide master. Whatever changes are made to the slide master will be made on all the slides of the presentation. View > Normal allows you to work only on individual slides, but none of these changes will change the slide master on which the slide is based.


The first two steps to building a presentation are: Select the slide master which comes closest to meeting your needs, and save the presentation. Then you need to modify the slide master.

Documentation caution.png Remember to save frequently while working on the presentation, to prevent any loss of information should something unexpected occur. You might also want to activate the AutoRecovery function (Tools > Options > Load/Save > General). Make sure Save AutoRecovery information every is selected and that you have entered a number of minutes. (Set the value between 5 and 10 minutes.)


Make changes to the slide master you have chosen by selecting View > Master > Master Slide. Most of this is done using styles. F11 opens the Styles and Formating window. The Presentation Styles icon should already be selected, if it is not, select it now. Fourteen styles are listed, and all can be modified, but no new styles can be added. To change any of these styles, right-click the style name and choose Modify from the pop-up menu.

Tip.png When you select View > Master > Master Slide, the Master View toolbar also opens. See the Impress Guide for instructions on the use of this toolbar.


Master View toolbar/

The following Presentation styles are available.

Background styles:

  • None means all slide backgrounds will be white.
  • Color allows you to select your own background color.
  • Gradient has 15 prepackaged backgrounds. The increments between one color and the other is automatically set by default, but you can set it manually if you desire. New gradients can be created, using Format > Area > Gradient (tab).
  • Hatching has 10 prepackaged patterns. More can be created using Format > Area > Hatching (tab). A background color can be added to the hatching.
  • Bitmap has 20 prepackaged patterns. More bitmaps can be added to this list if they are one of the graphic formats OOo recognizes. (See the note below.) Use Format > Area > Bitmaps. Use the Import button to locate the bitmap and give it a name. Using F11 and selecting Bitmaps from Background styles, you should see your imported bitmap at the bottom of the list.
Documentation note.png Tools > Options > OpenOffice.org > Colors allows you to create your own custom colors. Once you create a color this way, it will be listed in the selection of colors available for the background. For information on creating new gradients, hatching, and bitmaps, see the Impress Guide. To see all of the graphic formats OOo will accept as a bitmap, select Format > Area > Bitmaps. Click Import. File types contains the entire list of acceptable graphic formats.

Background objects style: Use this to set the characteristics of all objects you add to the slide master. Make any changes you need. Remember to use F5 after making a change to make sure that is what you want. Using the Esc key afterwards will return you to your work.

Documentation note.png Just like Paragraph and Character styles in Writer, Background objects styles can be overridden by applying manual formating. So it is possible to have two background objects with different formating. The use of background objects requires a knowledge of OOo's Draw component and is beyond the scope of this chapter.
Documentation note.png If you want to have notes attached to your slides, right-click the Notes style, select Modify, and set the formating you want your notes to have. Make sure you make the font size large enough to be readable. Just remember that this formatting will be applied to the note of every slide using the same slide master. The bottom part of the Notes window contains an example of what any of your choices looks like.
Documentation note.png At the present time, you cannot view your notes while you are running a slide show. Notes can be included in a printed handout of the slide show.

Outline 1 through Outline 9: These styles set the formatting for each level of text in the text boxes of the slides. All of these have default values that are fairly good. You would probably want to leave most if not all of these values as they are. Since in a simple presentation, only one slide master is used, any changes made will affect all slides containing the affect style. For example, five slides have text with the Outline 2 style. When you change the Outline 2 font size from 20 to 18, this change will be made on all five slides to every paragraph using the Outline 2 style.

Title and Subtitle: Set these styles the same way you set the styles for Outline 1 through Outline 9. Most of these styles work very well as they are. The parts that you might want to change are the Font, Typeface, Font size, and Font color (Font Effects tab).

When you are finished making your changes, use View > Normal. Or, you could click Close Master View in the Master View toolbar.

Top of page

Creating the first slide

The first slide is normally the Title Page. Decide which of the layouts will suit your purposes for your first slide. It is good practice to keep it rather simple. Some suitable layouts are Title Slide (also contains a section for a subtitle), or Title Only slide. The rest of the layouts seem to be better suited for later slides in the presentation, or for more complex presentations.

Documentation note.png For very simple presentations, you may not need a title; for example, if the presentation is simply a group of pictures put together for someone to see. But in most cases, you will need to use the title as the first slide.
Choosing a slide layout.

Top of page

Adding elements to the Title Page

All the suggested layouts contain a title section at their top. To create the title, click the phrase Click to add title. Type the title. Adjustments to the formating of the title can be done by using the F11 key, right-clicking the Title style, and selecting Modify from the pop-up menu.

If you are using the Title Slide layout slide, click the phrase Click to add text to add a subtitle. Make any adjustments in the formating you desire. Do this the same way as if you are changing the title formating: use the F11 key, right-click the Subtitle style, select Modify from the pop-up menu, and make your changes. Click OK to apply your changes to the subtitle.

The Title, Object layout slide can also be used. To do this requires knowledge of how to move and resize graphic images (objects). Insert the object as an OLE Object. To do so:

  1. Double-click the graphic.
  2. Select Create from file and click OK.
  3. Click Search to browse to the file's location. Select the file, and click Open. Then click OK.
  4. Resize and center the object to fit the slide as needed.
Documentation caution.png Choose Link to file only if you are going to keep the presentation and the file in the same directory in which they were originally saved. Otherwise, you may not be able to access your OLE Objects from your slide show when you need them.


Top of page

Inserting additional slides

The steps for inserting additional slides are basically the same as for selecting the title page. It is a process that has to be repeated for each individual slide. Since you are going to be using only one slide master, your only concern right now is the Layouts section of the Tasks pane on the right.

First, you should insert all of the slides your outline indicates you will need. Only after this should you begin adding special effects such as custom animation and slide transitions. (These are covered in the next section.)

Step 1: Insert a new slide. This can be done in a variety of ways. Take your pick.

  • Insert > Slide.
  • Right-click on the present slide, and select New Slide from the context menu.
  • Click the Slide icon in the Presentation toolbar.
Presentation toolbar.

Step 2: Select the layout slide that bests fits your needs.

If your slide consists only of a title with a graphic, chart, or spreadsheet, inserting it as an OLE Object is the simplest. But be advised, doing this for a chart or spreadsheet is not simple. This is an advanced technique.

Step 3: Modify the elements of the slide. At this stage, the slide consists of everything contained in the Master page as well as the chosen layout slide. This includes removing unneeded elements, adding needed elements (pictures and OLE Objects), and inserting text.

Documentation caution.png Changes to any of the prepackaged layouts can only be made using View > Normal which is the default. Attempting to do this by modifying a slide master will result in an error message. (The slide master is modified using View > Master > Master Slide.)


  1. Remove any element on the slide you do not need.
  2. Click the element to highlight it. (The green squares show it is highlighted.)
  3. Press the Delete key to remove it.
Deleting an element of a slide.
Tip.png Sometimes you will accidentally select the wrong layout slide. You can at any time click the correct layout slide and continue your work.


Add any elements to the slide you do need.

Adding pictures to the clipart frame:

  1. Double-click the picture within the frame.
  2. Browse to the location of the picture.
  3. Select the picture and click Open.
  4. Resize the picture as necessary. Follow the directions in the Caution note below.

Adding pictures from graphic files to places other than the clipart frame:

  1. Insert > Picture > From File.
  2. Browse to the graphic file, select it, and click Open.
  3. Move the picture to its location.
  4. Resize the picture if necessary.

Adding OLE Objects is an advanced technique covered in the Impress Guide.

Documentation caution.png When resizing a graphic, right-click the picture. Select Position and Size from the pop-up menu. Make sure Keep ratio is selected. Then adjust the height or width to the size you need. (As you adjust one dimension both dimensions will change.) Failure to do so will cause the picture to become distorted.


Adding text to a slide: If the slide contains text, click the phrase Click to add an outline in the text frame. Type the text into the text frame.

Documentation note.png Text in the slide is in an outline format: each level is indented more than the previous level as you move from level 1 to level 10.

To change Outline Levels as you type, use the left and right arrow buttons.

  • The left arrow changes it to the previous Outline Level (level 3 to level 2 for example).
  • The right arrow changes to the next Outline Level (level 2 to level 3 for example).
Text moving arrows.

To change the order of the paragraphs (lines), use the up and down arrow buttons.

  • The up arrow moves the paragraph higher in the text.
  • The down arrow moves the paragraph lower in the text.
Documentation note.png Moving text around usually requires using a combination of these keys. For example, a paragraph needs to be moved higher and its Outline level needs to be changed to a lower level (closer to 1) or a higher level (closer to 10).

Step 4: To create additional slides repeat steps 1-3.

Top of page

Working with slides

This is the time to review the entire presentation and answer some questions. Run the slide show at least once before answering them. You might want to add some questions of your own.

  1. Are the slides in the correct order? If not, some of them will need to be moved.
  2. Would an additional slide make a particular point clearer? The slide needs to be created.
  3. Would some custom animations help some of the slides? (Advanced technique)
  4. Should some of the slides have a different slide transition than others? The transition of these slides should be changed.
  5. Do some of the slides seem unnecessary? Delete the slide or slides after checking if they are indeed unnecessary.
Documentation caution.png If one or more slides seems to be unnecessary, hide the slide or slides, and view the slide show a few more times to make sure. To hide a slide, right-click the slide in the Slides pane. Select Hide Slide in the pop-up menu. Do not delete a slide until you have done this, otherwise you may have to create that slide again.


Once you have answered these and your own questions, you should made the necessary changes. This is done the easiest in the Slide Sorter view and will be explained there. If you need one or more new slides, create them using the steps listed in Inserting additional slides.

Top of page

Custom animations

If you know how to add a custom animation to a slide, do it now. This is an advanced technique and is explained in the Impress Guide.

Slide transitions

Your first slide show should probably have the same slide transition for all slides. Setting Advance slide to On mouse click is the default and a simple setting. If you want each slide to be shown for a specific amount of time, click Automatic after and enter the number of seconds. Click Apply to all slides.

Tip.png The Slide transition section has a very useful choice: Automatic preview. Select its checkbox. Then when you make any changes in a slide transition, the new slide, including its transition effect, is previewed in the workspace area.


Changes that can be made to slide transitions:

Apply to selected slides has a list of slide transitions.

  • Make sure Automatic preview is checked.
  • Click one of the members of the Apply to selected slides list.
  • Watch the effects of this slide transition.
  • Select the slide transition you want.

Modify transition has two drop-down lists.

  • Select the Speed: slow, medium, and fast.
  • Select a Sound from the list if you want one.

Once you have made your selections, if any, click Apply to all slides to give all slides the same transition.

Play and Slide Show are used to play one or more slides in the presentation.

  • Clicking Play has the same effect as having Automatic Preview checked (ticked): a single slide is shown along with its slide transition.
  • Slide Show begins the slide show at the selected slide and continues until the end.
Tip.png If you want to use this button to play the entire slide show, click the top slide in the Slides pane. Then click Slide Show in the Slides transitions section of the Task pane.


Top of page

Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).

Bold text

Personal tools