From Apache OpenOffice Wiki
Jump to: navigation, search

The top toolbar (default position) is called the Standard toolbar. The Standard toolbar is consistent across the applications.

The second toolbar across the top (default location) is the Formatting toolbar. It is a context-sensitive bar which shows the relevant tools in response to the cursor's current position or selection. For example, when the cursor is on a graphic, the Formatting bar provides tools for formatting graphics; when the cursor is in text, the tools are for formatting text.

Standard and Formatting toolbars.

Floating toolbars

Writer includes several additional context-sensitive toolbars, whose defaults appear as floating toolbars in response to the cursor's current position or selection. For example, when the cursor is in a table, a floating Table toolbar appears, and when the cursor is in a numbered or bullet list, the Bullets and Numbering toolbar appears. You can dock these toolbars to the top, bottom, or side of the window, if you wish (see Moving toolbars).

Long-click buttons and tear-off toolbars

Buttons with a small black triangle will display submenus, tear-off toolbars, and other ways of selecting things with a long click, depending on the button.

Example of a submenu.
Example of a tear-off toolbar.

The tear-off toolbars can be floating or docked along an edge of the screen or in one of the existing toolbar areas. To move a floating tear-off toolbar, drag it by the title bar. See Moving toolbars.

Displaying or hiding toolbars

To display or hide toolbars, choose View > Toolbars, then click on the name of a toolbar in the list. An active toolbar shows a checkmark beside its name. Tear-off toolbars are not listed in the View menu.

Moving toolbars

To move a docked toolbar, place the mouse pointer over the toolbar handle, hold down the left mouse button, drag the toolbar to the new location, and then release the mouse button.

To move a floating toolbar, click on its title bar and drag it to a new location.

Moving a docked toolbar.
Moving a floating toolbar.

Customizing a toolbar

  1. Open the Toolbars page of the Customize dialog in one of these ways:
    • On the toolbar, click the arrow at the end of the toolbar and choose Customize Toolbar.
    • Choose View > Toolbars > Customize from the menu bar.
    • Choose Tools > Customize from the menu bar.
  2. On the Toolbars tab, of the Customize dialog, choose in the Toolbar drop-down list the toolbar you want to customize.
  3. Click the Toolbar button on the right to display a drop-down list of choices including Icons Only, Text Only, Icons and Text, and Restore Default Settings. For toolbars you created, the choices also include Rename and Delete.
  4. To display or hide commands, select or deselect the checkboxes in the Toolbar Content – Commands section.
  5. To change the position of commands on a toolbar, select a command and click the big up and down arrows to the right of the lists.
  6. To add commands to a toolbar, click the Add button on the right. The Add Commands dialog opens. Follow the instructions on this dialog and then click Add to return to the Customize dialog.
  7. In the Save In drop-down list, choose whether to save this changed toolbar for the application (for example, Writer) or for a selected document.
  8. When you have finished, click OK to save your changes.
Figure 6. Customizing a toolbar.
Documentation note.png There is no in-built tool button editor. To use a custom icon, save it to the {install path}/share/config/symbol directory in *.bmp format. OOo automatically searches this directory for new icons each time the Customize Buttons dialog is opened. Custom icons must be 16 x 16 or 26 x 26 pixels in size and cannot contain more than 256 colors.

Creating a new toolbar

To create a new toolbar:

  1. Choose Tools > Customize > Toolbars from the menu bar.
  2. Click New. This will create a toolbar called New Toolbar1.
  3. Customize the toolbar as above.
Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools