Customizing toolbars

From Apache OpenOffice Wiki
Jump to: navigation, search

You can customize toolbars in several ways, including choosing which icons are visible and locking the position of a docked toolbar, as described in Chapter 1 (Introducing Writer), and adding or deleting icons (commands) in the list of those available on a toolbar. You can also create new toolbars. This section describes how to create new toolbars and add or delete icons on existing ones.

To get to the toolbar customization dialog, do any of the following:

  • On the toolbar, click the arrow at the end of the toolbar and choose Customize Toolbar.
  • Choose View > Toolbars > Customize from the menu bar.
  • Choose Tools > Customize from the menu bar and go to theToolbars page.
The Toolbars page of the Customize dialog

To customize toolbars:

  1. In the Save In drop-down list, choose whether to save this changed toolbar for the application (for example, Writer) or for a selected document.
  2. In the section Writer > Toolbars, select from the Toolbar drop-down list the toolbar that you want to modify.
  3. Click on the Toolbar or Modify buttons, and add commands to a toolbar by clicking on the Add button. You can also create a new toolbar by clicking on the New button. These actions are described in the following sections.
  4. When you have finished making all your changes, click OK to save them.

Adding a command to a toolbar

If the list of available buttons for a toolbar does not include all the commands you want on that toolbar, you can add commands. When you create a new toolbar, you need to add commands to it.

  1. On the Toolbars page of the Customize dialog box, select the toolbar in the Toolbar list and click the Add button in the Toolbar Content section of the dialog box.
  2. The Add Commands dialog box (below) is the same as for adding commands to menus. Select a category and then the command, and click Add. The dialog box remains open, so you can select several commands. When you have finished adding commands, click Close. If you insert an item which does not have an associated icon, the toolbar will display the full name of the

item: the next section describes how to choose an icon for a toolbar command.

  1. Back on the Customize dialog box, you can use the up and down arrow buttons to arrange the commands in your preferred sequence.
  2. When you are done making changes, click OK to save.

Choosing icons for toolbar commands

Toolbar buttons usually have icons, not words, on them, but not all of the commands have associated icons.

To choose an icon for a command, select the command in the Toolbar Content – Commands list in the Customize dialog box, and click Modify > Change icon. On the Change Icon dialog box, you can scroll through the available icons, select one, and click OK to assign it to the command.

Change Icon Dialog Box.

To use a custom icon, create it in a graphics program and import it into OOo by clicking the Import button on the Change Icon dialog box. Custom icons must be 16 x 16 or 26 x 26 pixels in size and cannot contain more than 256 colors.

Example: Adding a Fax icon to a toolbar

You can customize so that a single click on an icon automatically sends the current document as a fax.

  1. Be sure the fax driver is installed. Consult the documentation for your fax modem for more information.
  2. Choose Tools > Options > Writer > Print. The dialog box shown below opens.
  3. Select the fax driver from the Fax list and click OK.
  4. Click the arrow icon at the end of the Standard toolbar. In the drop-down menu, choose Customize Toolbar. The Toolbars page of the Customize dialog box appears. Click Add.
    Setting up OOo for sending faxes.
  5. On the Add Commands dialog box (below), select Documents in the Category list, then select Send Default Fax in the Commands list. Click Add. Now you can see the new icon in the Commands list.
  6. In the Commands list, click the up or down arrow button to position the new icon where you want it. Click OK and then click Close. Your toolbar now has a new icon to send the current document as a fax.
    Adding a Send fax command to a toolbar.

    Creating a new toolbar

    To create a new toolbar:

    1. Choose Tools > Customize > Toolbars from the menu bar.
    2. Click New. On the Name dialog, type the new toolbar's name and choose from the Save In drop-down list where to save this changed menu: for the application (for example, Writer) or for a selected document.


    The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new toolbar, you need to add some commands to it, as described above.

    Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools
In other languages