12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Adding graphics (images)

From Apache OpenOffice Wiki
Jump to: navigation, search



Images (also called pictures in OOo), such as corporate logos and photographs of people and products, are probably the most common types of graphic added to a Calc document. They may be downloaded from the Internet, scanned, or created with a graphics program; or they may be photos taken with a digital camera.

Images can be inserted in four ways:

  • Using the Insert File dialog
  • By dragging and dropping a supported file
  • From the gallery
  • From the clipboard by copying and pasting

Inserting an image file

Perhaps the most common way to insert graphics is to use an existing file.


To insert an image from a file, use either of the following methods:

  • Insert Picture dialog
  • Drag and drop

Insert Picture dialog

  1. Click in the location in the Calc document where you want the image to appear.Do not worry too much about the exact placement of the image at this stage; placement can be changed easily as described in Positioning graphics
  2. Choose Insert > Picture > From File from the menu bar, or click the Insert Picture icon InsertPictureIcon.png on the Picture toolbar (f the toolbar is visible).
  3. In the Insert Picture dialog, navigate to the file to be inserted, select it, and click Open.
Documentation note.png The picture is inserted into Calc floating above the cells and anchored to the cell in which the cursor was placed. See Positioning graphics for more about positioning and anchoring graphics.
Inserting a picture from a file

At the bottom of the dialog are two options, Preview and Link. SelectPreview to view a thumbnail of the selected image on the right, so you can verify that you have the correct file. The link option is discussed in the section Linking an image file below.

Documentation note.png Your Insert Picture dialog may look quite different from the one shown here, depending on your operating system, and your choice in Tools > Options > OpenOffice.org > General of whether to use the OOo Open and Save dialogs.

Drag and drop

  1. Open a file browser window and locate the image you want to insert.
  2. Drag the image into the Calc document and drop it where you want it to appear. A faint vertical line marks where the image will be dropped. The picture will be anchored to the cell where it was dropped.

This method always embeds (saves a copy of) the image file in the Calc document.

Linking an image file

To create a link to the file containing the image instead of saving a copy of the image in the Calc document, use the Insert picture dialog and select the Link option. The image is then displayed in the document, but when the document is saved, it contains only a reference to the image file¿not the image itself. The document and the image remain as two separate files, and they are merged temporarily only when you open the document again.

Linking an image has two advantages and one disadvantage:

  • Advantage – Linking can reduce the size of the document when it is saved, because the image file itself is not included. The file size is usually not a problem on a modern computer with a reasonable amount of memory, unless the document includes many large graphics files. Calc can handle quite large files.
  • Advantage – You can modify the image file separately without changing the document because the link to the file remains valid, and the modified image will appear when you next open the document. This can be a big advantage if you (or someone else, perhaps, a graphic artist) is updating images.
  • Disadvantage – If you send the document to someone else, or move it to a different computer, you must also send the image files, or the receiver will not be able to see the linked images. You need to keep track of the location of the images and make sure the recipient knows where to put them on another machine, so the Calc document can find them. For example, you might keep images in a subfolder named Images (under the folder containing the Writer document); the recipient of the Calc file needs to put the images in a subfolder with the same name (under the folder containing the Writer document).
Documentation note.png When inserting the same image several times in the document, it might appear beneficial to create links. However, this is not necessary, as OOo embeds in the document only one copy of the image file.

Embedding linked images

If you originally linked the images, you can easily embed one or more of them later if you wish. To do so:

  1. Open the document in Calc.
  2. Choose Edit > Links from the menu bar. The Edit Links dialog shows all the linked files. In the Source file list, select the files you want to change from linked to embedded.
  3. Click the Break Link button.
  4. Save the Calc document.
The Edit Links dialog
Documentation note.png Going the other way, from embedded to linked, is not so easy—you must delete and reinsert each image, one at a time, selecting the Link option when you do so.

Inserting an image from the clipboard

Using the clipboard, you can copy images into a Calc document from another Calc document, from another component of OOo (Writer, Draw and so on) and from other programs.

To do this:

  1. Open both the source document and the Calc document into which you want to copy the image.
  2. In the source document, select the image to be copied.
  3. Press Control+C to copy the image to the clipboard.
  4. Switch to the Calc window.
  5. Click to place the cursor where the graphic is to be inserted.
  6. Press Ctrl+V to insert the image.
Documentation caution.png If the application from which the graphic was copied is closed before the graphic is pasted into Calc, the image stored on the clipboard could be lost from the clipboard.


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).

Inserting an image from the Gallery

The Gallery provides a convenient way to group reusable objects such as graphics and sounds that can be inserted into documents.

The Gallery is available in all components of OOo. It does not come with many graphics, but you can add your own pictures or find extensions containing more graphics. The Gallery is explained in more depth in Graphics, the Gallery, and Fontwork in the Getting Started guide. For more about extensions, see Setting Up and Customizing Calc in this book.

This section explains the basics of inserting a Gallery image into a Calc document.

  1. To open the Gallery, choose Tools > Gallery, or click on the Gallery icon GalleryIcon3.png.
  2. Navigate through the Gallery to find the desired picture.
  3. To insert the picture, either right-click on the picture and choose Insert > Copy, or click and drag the picture from the Gallery into the Calc document.
Gallery in Calc

By default, the Gallery is docked above the Calc workspace. To expand the Gallery, position the pointer over the line that divides it from the top of the workspace. When the pointer changes to parallel lines with arrows, click and drag downward. The workspace resizes in response.

To expand the Gallery without affecting the workspace, undock it so it floats over the workspace. To do so, hold down the Control key and double-click on the upper part of the Gallery next to the View icons. Double-click in the same area to dock it again (restore it to its position over the workspace).

When the Gallery is docked, to hide it and view the full Calc workspace, click the Hide/Show button in the middle of the thin bar separating the Gallery from the workspace.

Separator between Gallery and workspace

To close the Gallery, choose Tools > Gallery to uncheck the Gallery entry, or click on the Gallery icon again.

Personal tools