Apache OpenOffice Draw FAQ

From Apache OpenOffice Wiki
< Documentation‎ | FAQ
Revision as of 18:38, 25 March 2008 by Bhelfrich (Talk | contribs)

Jump to: navigation, search
doc OOo




Edit-find-replace.png This article needs to be checked for accuracy and style.



Contents

I am creating an organization chart. How do I evenly space my boxes?

Control over object spacing in a presentation or a drawing is called Distribution.

Follow these steps:

  • Select three or more drawing objects.
  • Hold down the right mouse button to get the context menu.
  • Select: Distribution.
  • In the dialog that appears, you have the choice of aligning objects vertically and/or horizontally.
  • Click on OK for your settings to take effect.

How do I crop an image in my drawing?

With the image already inserted into your drawing file:

  • Click once on the image to select it. Just below the command bar, the image toolbar will appear.
  • In this toolbar, click on the right-most Crop button to open the Crop pop-up window.
  • Insert the exact measurements of the canvas you want to crop.
  • Click the OK button to close the window.
  • Click outside the image to deselect it.

I have received a file that has graphics in it but all that shows up are the anchor symbols for the graphics. What's wrong?

Select from the menu bar: Tools > Options > Drawing. The option image placeholders in the View section must be unchecked.

I have a JPEG image that needs its colors changed before I use it in an Openoffice.org file. How do I change the colors?

When you open a JPEG file, OpenOffice.org displays the image toolbar just below the command bar. Once the file is open:

  • Select: Tools > Eyedropper from the Menu bar. It will display a floating window called Eyedropper.
  • Click on the uppermost top left icon, Eyedropper.
  • Enter a tolerance value to define how exact the color match should be. First try a tolerance of 10%. You might need to increase it for any change to be visible. A 30% value is usually effective. You can go as high as 99%, but it may pick up more area than you want.
  • Select in the image the color you want to change. In the eyedropper floating window, that color will be automatically selected.
  • Choose the new color you wish to use from the Replace with... drop down list.
  • Click on the Replace button to confirm your choice. If nothing happens, increase the tolerance.
  • To replace more colors, select another color rectangle to the left of the Eyedropper floating window, then repeat the steps from 2 to 5. Finally, confirm your choices by clicking on the Replace button.

How do I insert a screen shot or other image into my drawing document?

Any graphic in GIF or JPEG format can be inserted into a drawing document:

  • From the Menu bar, select: Insert > Graphics.
  • Navigate to the directory in which the GIF or JPEG images are saved, select the image file, and click Open.

I want to change the size of an image inserted in a drawing document. How can I do this?

To resize an image:

  • Click one time on the image to select it.
  • From the Menu bar select: Format > Position and Size.
  • Choose the Size tab.
  • Insert the desired image size and click the OK button.

or

  • Click one time on the image to select it. Little green squares will appear around the image.
  • Drag one of the squares to resize the image.


To resize an image proportionally, which maintains the horizontal to vertical ratio:

  • Click one time on the image to select it.
  • From the Menu bar select: Format > Position and Size.
  • Choose the Size tab.
  • Insert the desired image size.
  • Check [x] the keep ratio box and click the OK button.

or

  • Click one time on the image to select it. Little green squares will appear around the image.
  • Hold the keyboard shift key down.
  • Drag one of the corners to resize proportionally.

How can I save a Draw document into a standard file format (BMP, JPG, ...)?

The format .sxd used in Draw is not a graphics format, but a document format. To save a Draw document into a graphics format:

  • Select File > Export from the Menu Bar.
  • Select the graphics format you wish to use from the File Type combo box.
  • Click the Export... button.
  • Define the options you wish to use, if options are presented, then click OK.

I'd like to create a CD cover, but I'm not able to rotate the text so that it is readable on the side of the CD. What is the procedure for this action?

Follow this procedure:

  • Click on the Text icon in the Tool bar (the left side bar).
  • Draw a text box of the desired size on the document page and insert your text.
  • Click outside the text box to finish the text insertion.
  • Click with the left button on your text to select it again.
  • Right click on the selected text box to display the context menu.
  • From the context menu choose: Position and Size.
  • Under the Rotation tab, select the desired Pivot Point and Rotation Angle.
  • Click the OK button.

How can I redefine the origin of the drawing coordinates?

Do it in this way:

  • Click on the intersection corner between the vertical and horizontal ruler and hold the mouse button down.
  • When dragging the mouse you can see a hatched cross.
  • Reach the point you want to use as your new origin of the drawing coordinates, then release the mouse button.


Does OpenOffice.org have an equivalent to Word's "WordArt"?

OpenOffice.org's "FontWork" functions are most analogous to Word's "WordArt".

FontWork adds effects to the text in the selected drawing object, including shadows. You can also change the shape of the text baseline.

The FontWork command is only available for objects that contain text.

You can change the shape of the text baseline to match semicircles, arcs, circles and freeform lines.

To access this command (text drawing object selected), choose Format > FontWork.

For more information, see Chapter 15 (Using Fontwork) in the Getting Started guide.


Are there any extra tools for Draw?

Yes, the OOoMacros site has a file: Danny's Power Drawing Tools. This document is a Draw document with macros to create drawings of complex shapes that are difficult to draw by hand. It also includes documentation.

I want a background of a dotted grid as a guide for my drawings. Is this available in OpenOffice.org?

Yes. If it is not already visible, simply right click on the document page and select Visible Grid from the Grid menu.

I'm trying to print a Draw document, but the colors printed by my printer are not the same ones displayed on the screen. How can I edit them using the CMYK color system?

The modern color printers use a % mix of 4 inks (or 6 in the newest ones) to reproduce the colors that are visible to us. In Draw, to edit a color using the exact percentage of an ink you have to:

  1. Click on the object whose color you want to change. It will be selected.
  2. Right click on it and choose Area... from the context menu.
  3. In the pop-up window that appears, flip to the Colors tab.
  4. Select CMYK from the Color System combo box.
  5. Modify the CMYK % values in the boxes below.
  6. Click the OK button. You will be prompted as to whether you want to modify the existing color or to add a new one to the palette. Make your choice.

Otherwise, you can use/modify a ready CMYK palette:

  1. Repeat steps 1, 2, and 3 listed above.
  2. Click on the Load Color List icon.
  3. Select the cmyk.soc file and press the Open button. (standard path: OpenOffice60/user/config/)
  4. Close the window by clicking the OK button.

I'm drawing a web banner. How can I do it using a 'Websafe' color palette?

You can change the standard palette of OpenOffice.org to a palette in which the colors are expressed as hexadecimal values or web color names by following this procedure:

  • Draw an object on the document page.
  • Click on the object to select it.
  • Right click on it to display the context menu.
  • Select the Area... item.
  • In the pop-up window that appears, flip to the Colors tab.
  • Click on the Load Color List icon.
  • Select the html.soc file and click OK. (standard path: OpenOffice60/user/config/)


When I print a Draw document, the drawings near the top or bottom page borders are not printed properly. How can I overcome this problem?

You have probably set the margins of the Draw document page too near the print area borders of your printer. You have to:

  • Check your printer manual to find out the size of your printer's print area.
  • Select Format > Page... from the menu bar.
  • In the Page tab of the Page Setup window, change the top and botton margins to the size you have found in your printer manual. If you do not have it anymore, try a value higher than 2.5 cm (1 inch). It works with many printers.
  • Click the OK button.

Now, you can edit your drawing, making sure that every object is within the new page margins.

How do I export part of a drawing to EPS?

To export just the drawing objects, you will need to:

  1. Select the objects you would like to Export.
  2. Select EPS from the Save as Type pull-down box.
  3. Check the Selection box at the bottom of the dialog.
  4. If you want a preview, select TIFF in the EPS Export Options dialog that appears.
  5. Click OK to save the selecion as EPS.


Where can I get more information on Draw?

See the Draw Guide, available from the Manuals page at the Documentation Project.

Personal tools