From Apache OpenOffice Wiki
Jump to: navigation, search

Is there some reason that this is called JavaEclipseTuto instead of JavaEclipesTutorial?? --Mikeleib 21:52, 17 March 2006 (CET) To make it shorter, but if you mind it would be better... I don't see any problem

--cedricbosdo 09:51, 19 March 2006 (CET)


I'm trying to get a Java component working in OpenOffice, but for some reason I'm not very lucky at it. So I took some step's back and tried your HelloWorld example by the letter.

I still have no successfull creation of a Java component, but I do have some observations and questions.

When I follow the example, an implementation class file pops up in gedit (source/org/openoffice/helloworld/HelloworldImpl) The generated MANIFEST.MF searches that file like:

 ManifestVersion: 1.0
 RegistrationClassName: org.openoffice.helloworld.comp.HelloworldImpl 

There is also a class org.openoffice.helloworld.Helloworld. (I assume this is generated by a tool like JavaMaker?). This is also the class which is refered to in 'types.rdb' and 'Helloworld.rdb' I have the impression, this should be 'HelloworldImpl'. (EDIT: Obviously not)

When I try to export the project, there is an error message about 'services.rdb':


So my questions are:

  • Should I implement HelloworldImpl or Helloworld (EDIT: the Impl)
  • If not the latter, what's the purpose of Helloworld. (SOme kind of placeholder?)
  • What must be done to get rid of the services.rdb missing message
  • can I view error messages or obtain a list of executed commands somewhere (ah, I will do as said in the troubleshooting page. (Not very informative though))

I'm using SDK 2.2 (680m6)(and also 680m14 from Ubuntu:feisty) and OpenOffice 2.2.0-1ubuntu3

  • EDIT 1: using the distribution SDK seems to help a lot indeed. I can generate a HelloworldImpl now.
  • EDIT 2: well, it seems to work. I created my own project, and the export worked. However, I had to change something

(removed and reimported it to eclipse) and the export does not seem to work anymore (An internal error occured during "Package export job"). What are the pre-requisites? How can I find out what's going wrong. (I could find no relevant message in workspace/.metadata/.log)

  • EDIT 3: Appart from 'export', I got my project functioning also (10 July).

Regards, --Steckelfisch 9-11 July 2007

when you build ooeclipseintegration you should add parameter of -Dopenoffice.home and -Declipse.home

Personal tools