이전 안내/파일 공유하기

From Apache OpenOffice Wiki
< KO
Jump to: navigation, search

번역 중인 문서입니다. 원문 : Documentation/OOoAuthors User Manual/Migration Guide/Sharing Files




파일 형식

이 섹션에서는 오픈오피스의 파일 형식에 대한 간략한 소개를 할 것입니다.

오픈오피스는 압축된(zip) XML 형식으로 파일을 저장합니다. 이 형식은 압축을 풀면 사람이 읽을 수 있습니다. 이는 오픈된 문서이며, GNU 라이센스(http://www.gnu.org) 하에서라면 범용으로 사용될 수 있습니다.

ODF 에 관한 자세한 내용은 http://books.evc-cit.info/book.php을 참조하세요.

Documentation note.png 일부 압축 프로그램에서는 파일 확장자만 체크하여 압축된 파일로 인식하지 못할 수도 있습니다. 이러한 압축 프로그램으로 오픈오피스 파일의 압축을 풀려면 파일의 확장자를 .zip 으로 변경하십시오.

이와는 대조적으로 MS 오피스 파일은 사람이 읽을 수 없고 공개되지 않은 독점 포맷으로 저장됩니다. 이때문에 개발자들이 MS 포맷의 파일을 가져오거나 내보내는 필터를 만드는데 어려움을 많이 겪습니다.

오픈오피스 2.0 은 오픈오피스 1.1.x 와 파일 포맷이 약간 달라졌습니다. 이러한 변화는 공개 표준 회의인 OASIS 의 결정에 따른 것입니다. OpenOffice.org 는 공개 문서 포맷(ODF)을 사용하며, KOffice와 같은 다른 프로그램에서도 이러한 ODF 포맷을 지원하고 있습니다.

오픈오피스 2.0 의 파일 확장자(오픈오피스 1.1.x 의 확장자는 괄호안에 표시)
문서 유형 프로그램 확장자 MS 오피스의 경우
텍스트 라이터 odt (sxw) doc
텍스트 서식 라이터 ott (stw) dot
마스터 문서 라이터 odm (sxg) doc
HTML 문서 라이터 html html
스프레드시트 칼크 ods (sxc) xsl
스프레드시트 서식 칼크 ots (stc) xst
그리기 드로우 odg (sxd) N/A
그리기 서식 드로우 otg (std) N/A
프리젠테이션 임프레스 odp (sxi) ppt
프리젠테이션 서식 임프레스 otp (sti) pot
수식 매쓰 odf (sxm) N/A
차트 차트 odc N/A
데이터베이스 베이스 odb mdb
Documentation note.png 오픈오피스는 MS 오피스 파일을 열 수 있습니다. 하지만 그 반대는 불가능합니다. 다만 MS 오피스 2007 SP2부터는 ODF 파일을 지원합니다.

MS 오피스를 사용하는 사람에게 파일을 보내려면, 먼저 오픈오피스 포맷으로 파일을 저장한 다음, MS 오피스 포맷으로 다시 저장을 해야 합니다. 그래야 MS 오피스 포맷으로 정확하게 변환되지 못했을 경우에도 원본 파일을 보존할 수 있습니다.

오픈오피스는 MS 엑세스 파일(.mdb)은 직접 열 수 없습니다. 하지만 DAO 와 ODBC 를 이용하여 테이블 내의 데이터를 사용할 수는 있습니다. 이에 대한 자세한 내용은 데이터 베이스 안내 를 참조하십시오.

한꺼번에 변환하기

오픈오피스를 이용하면 많은 파일을 한번에 변환할 수 있습니다. 파일 > 마법사 > 문서 변환기

대량의 파일을 변환하기 전에 이 문서를 잘 읽고 변환 과정의 한계에 대해 명확히 인지하시기 바랍니다.

Documentation note.png 많은 파일을 변환하는데는 많은 시간이 걸립니다. 따라서 하드디스크에 충분한 공간이 있는지 확인한 뒤, 컴퓨터를 사용하지 않는 시간에 변환을 할 것을 권장합니다. 일반적으로 오픈오피스 파일은 MS 파일보다 적은 용량을 차지합니다. 하지만 변환할 파일과 비슷한 용량을 확보해두는 편이 안전합니다.

파일 열기

텍스트 문서 열기

오픈오피스 라이터는 오픈문서 포맷(.odt, .ott) 외에도 다음과 같은 텍스트 문서 포맷을 가져올 수 있습니다.

MS 워드 6.0/95/97/2000/XP) (.doc, .dot) 워드퍼펙트 문서 (.wpd)
MS 워드 2003 XML (.xml) WPS 2000/Office 1.0 (.wps)
MS 윈워드 5 (.doc) 닥북(DocBook) (.xml)
스타오피스 라이터 포맷 (.sdw, .sgl, .vor) Ichitaro 8/9/10/11 (.jtd, .jtt)
AportisDoc (Palm) (.pdb) 아래아한글 97 (.hwp)
포켓 워드 (.psw) .rtf, .txt, .csv

.HTM 이나 .HTML 파일을 열면 오픈오피스 라이터는 위지윅 에디터로 바뀝니다.

스프레드시트 파일 열기

오픈오피스 칼크는 오픈문서 포맷(.ods, .ots) 외에도 다음과 같은 스프레드시트 포맷을 열 수 있습니다.

마이크로스프트 엑셀 97/2000/XP (.xls, .xlw, .xlt) 고급 텍스트 포맷 (.rtf)
마이크로스프트 엑셀 4.x–5/95 (.xls, .xlw, .xlt) 텍스트 CSV (.csv and .txt)
마이크로스프트 엑셀 2003 XML (.xml) 로터스 1-2-3 (.wk1, .wk1)
데이터 교환 포맷 (.dif) 스타오피스 칼크 포맷 (.sdc, .vor)
dBase (.dbf) SYLK (.slk)
웹페이지 쿼리를 포함한 .htm, .html 파일 포켓 엑셀 (pxl)
Quattro Pro 6.0 (.wb2)

프리젠테이션 파일 열기

오픈오피스 임프레스는 오픈문서 포맷(.odp, .otp) 외에도 다음과 같은 프리젠테이션 포맷을 열 수 있습니다.

MS 파워포인트 97/2000/XP (.ppt, .pps) 컴퓨터 그래픽 메타파일 (.cgm)
MS 파워포인트 97/2000/XP Template (.pot) 스타오피스 드로우, 임프레스 (.sda, .sdd, .sdp, .vor)


그래픽 파일 열기

오픈오피스 드로우는 오픈문서 포맷(.odg, .otg) 외에도 다음과 같은 그래픽 포맷을 열 수 있습니다.

BMP, JPEG/JPG, PCX, PSD, SGV, WMF, DXF, MET, PGM, RAS, SVM, XBM, EMF, PBM, PLT, SDA, TGA, XPM, EPS, PCD, PNG, SDD, TIF/TIFF, GIF, PCT, PPM, SGF, VOR


수식 파일 열기

오픈오피스 매쓰는 오픈문서 수식 파일 외에도 스타오피스 매쓰 파일(.smf) 이나 MathML(.mml) 파일을 열 수 있습니다.

내장된 수식 편집기 개체를 포함한 MS 워드 파일을 열 경우, 도구 > 옵션 > 로드/저장 > Microsoft Office 에서 MathType을 OpenOffice.org Math로 / OpenOffice.org Math를 MathType로 항목의 [L](개체 가져오기와 변환)을 선택해두면 MS 워드 내의 개체를 자동으로 오픈오피스 매쓰 개체로 변환합니다.

파일 저장하기

기본 파일 포맷

오픈오피스는 기본값으로 오픈문서 포맷으로 파일을 저장합니다. 이 기본값은 변경할 수 있습니다. 예를 들어 항상 MS 오피스 파일로 저장하려고 한다면 다음 과정을 따라하십시오.:

  1. 도구 > 옵션 > 로드/저장 > 일반 을 찾아갑니다..
    Figure 1:Choosing default formats for saving files
  2. 이 페이지의 기본 파일 포맷 및 ODF 설정 부분에서 문서 유형(예:“텍스트 문서”)을 선택합니다. 그리고 항상 다음 포맷으로 저장에서 파일 포맷을 선택합니다.
  3. 필요한 경우 각 문서 유형에 대해 같은 과정을 반복합니다.
  4. 확인을 눌러 변경 사항을 저장합니다.
Documentation note.png 도구 > 옵션 > 로드/저장 > 일반에서 “ODF 또는 기본 포맷으로 저장하지 않을 경우 경고 표시”옵션이 체크되어 있으면, 포맷 정보를 일부 잃어버릴 수도 있음을 경고하는 대화상자가 표시됩니다. 하지만 대부분의 경우 그러한 일들은 일어나기 때문에 경고 상자가 귀찮다면 해당 옵션을 비활성화시켜도 됩니다.

AportisDoc (Palm), 포켓 워드, 포켓 엑셀 등을 위한 모바일 장치 필터를 사용하기 위해서는 자바 런타임 환경(JRE)가 필요합니다.

PDF 와 XHTML 로 내보내기

오픈오피스의 각 프로그램은 PDF(Portable Document Format) 포맷으로 직접 내보낼 수 있는 기능을 가지고 있습니다. 일반적인 파일 압축과 보기를 위한 산업 표준 포맷인 PDF 포맷은 다른 사람에게 파일을 보내기에 이상적인 포맷입니다. PDF 파일은 어느 운영 체제에서든지 아크로뱃 리더와 같은 PDF 보기 프로그램으로 볼 수 있습니다.

문서를 PDF 포맷으로 내보내려면, 도구모음에서 프린터 아이콘 옆에 있는 PDF로 내보내기 버튼을 누르거나 메뉴에서 파일 > PDF 로 내보내기 를 선택합니다. 그러면 PDF 로 내보내기 위한 옵션 대화상자가 호출됩니다.

XHTML 로 내보내기를 하려면 파일 > 내보내기 를 선택한 다음, 아래로펼침 상자의 파일 형식란에서 XHTML 을 선택합니다.


다른 포맷으로 파일 저장하기

다른 포맷으로 파일을 저장하려면 파일 > 다른 이름으로 저장 을 선택하고, 파일 형식에서 저장할 포맷을 선택합니다.

Figure 2: 오픈오피스의 다른 이름으로 저장 대화상자 중 저장 포맷이 표시된 부분

라이터로 저장할 수 있는 파일 포맷

오픈문서 포맷 외에 다음 포맷으로 저장할 수 있습니다.:

오픈오피스 라이터 1.x (.sxw, .stw)

MS 워드 97/2000/XP (.doc)

MS 워드 95 (.doc)

MS 워드 6.0 (.doc)

MS 워드 2003 XML (.xml)

MS 포켓 워드 (.psw)

닥북(DocBook) (.xml)

Aportis Doc (Palm) (.pdb)

고급 텍스트 포맷 (.rtf)

스타오피스 라이터 5.0 (.sdw)

스타오피스 라이터 서식 (.vor)

스타오피스 라이터 4.0 (.sdw)

스타오피스 라이터 4.0 서식 (.vor)

스타오피스 라이터 3.0 (.sdw)

스타오피스 라이터 서식 3.0 (.vor)

텍스트 (.txt)

텍스트 인코드 (.txt)

HTML (.html; .htm)

Documentation note.png .rtf 포맷은 프로그램간 텍스트 파일 전송에 자주 사용되는 포맷입니다. 하지만 이를 MS 오피스로 열면 엉망으로 깨진 문서만을 볼 수 있습니다. 따라서 이 파일을 가장 안전하게 MS 워드 사용자에게 보내는 방법은 MS 워드 97/2000/XP (.doc) 포맷으로 저장해 보내는 것입니다.

칼크로 저장할 수 있는 파일 포맷

오픈문서 포맷 외에 다음 포맷으로 저장할 수 있습니다.:

오픈오피스 칼크 1.x (.sxc, .stc)

MS 엑셀 97/2000/XP (.xls; .xlw)

MS 엑셀 97/2000/XP 서식 (.xlt)

MS 엑셀 95 (.xls; .xlw)

MS 포켓 엑셀 (.pxl)

MS 엑셀 2003 XML (.xml)

데이터 교환 포맷 (.dif)

dBase (.dbf)

SYLK (.slk)

텍스트 CSV (.csv; .txt)

스타오피스 칼크 포맷 (.sdc, .vor)

HTM, HTML 파일

임프레스로 저장할 수 있는 파일 포맷

오픈문서 포맷 외에 다음 포맷으로 저장할 수 있습니다.:

MS 파워포인트 97/2000/XP (.ppt; .pps)

MS 파워포인트 97/2000/XP Template (.pot)

스타오피스 드로우, 스타오피스 임프레스 (.sda, .sdd, .vor)

임프레스는 마이크로미디어 플래시 포맷(.swf)으로도 내보낼 수 있습니다. 그리고 아래 드로우 부분에 나열된 모든 그래픽 포맷으로도 내보낼 수 있습니다.

드로우로 저장할 수 있는 파일 포맷

드로우는 오픈문서 포맷과 스타오피스 드로우 포맷 외에 다음 포맷으로 내보낼 수 있습니다.:

BMP, EMF, EPS, GIF, JPEG, MET, PBM, PCT, PGM, PNG, PPM, RAS, SVG, SVM, TIFF, WMF, XPM

HTML 라이터로 저장할 수 있는 파일 포맷

HTML 문서 (.html; .htm)

오픈오피스 1.0 HTML 서식 (.stw)

오픈오피스 2.0 HTML 서식 (.oth)

스타오피스 라이터/웹 5.0 and 4.0 (.vor)

텍스트 (오픈오피스 라이터/웹) (.txt)

텍스트 인코드 (오픈오피스 라이터/웹) (.txt)

개체 연결 및 내장 (OLE)

MS 오피스 OLE 개체에 대한 설정을 변경하려면 도구 > 옵션 > 로드/저장 > Microsoft Office 페이지를 이용하십시오.

여기에 있는 모든 옵션을 체크하면, 내장된 개체를 변환하거나 편집할 수 있습니다.

다른 OLE 개체는 MS 오피스에서 사용하는 것처럼 각 파일이 있는 시스템에 따라 달라지게 됩니다. 따라서 OLE 개체 기반의 MS 윈도 프로그램은 리눅스 상의 오픈오피스에서 보거나 크기 조정을 할 수는 있지만, 편집은 할 수 없습니다.

Figure 3: VBA 속성 로드/저장 선택하기

링크된 파일

특수하게 붙여지거나 RTF 포맷과 링크된 셀을 엑셀에서 복사해 붙여넣은 MS 워드 파일을 라이터로 가져오면 일반적인 테이블로 표시됩니다. 이 말은 엑셀 파일로 연결된 것이 모두 사라진다는 의미입니다.

비슷하게 특수하게 붙여지거나 RTF 포맷과 링크된 차트를 엑셀에서 복사해 붙여넣은 MS 워드 파일을 라이터로 가져오면 차트는 칼크 차트가 아니라 내장된 OLE 개체로 가져와집니다. 이러한 파일을 MS 워드 포맷으로 저장한 뒤, MS 워드로 파일을 열거나 차트를 더블클릭해서 수정하려고 하면 오류 메세지가 표시됩니다.

Documentation caution.png MS 워드와 엑셀 사이의 MS 오피스 파일간의 연결은 MS 오피스 파일을 오픈오피스로 편집하면 사라집니다.

워드아트와 폰트워크

오픈오피스에서 MS 오피스의 워드아트에 해당하는 것으로 폰트워크가 있습니다. 워드아트 개체는 폰트워크 개체로 변환되며, 이 과정에서 약간 달라질 수도 있습니다. 그리고 MS 오피스 포맷으로 저장하면 자동으로 폰트워크 개체를 워드아트 개체로 변환하여 내보냅니다.

벡터 그래픽스

선, 화살표, 사각, 타원 등의 기본 도형의 가져오기와 내보내기는 아무런 문제없이 할 수 있습니다. 오픈오피스는 MS 오피스보다 많은 속성을 조절할 수 있는 기능을 제공합니다. 때문에 오픈오피스 파일을 MS 오피스로 가져가면 화살표 머리모양의 크기나 선 스타일 등의 일부 정보가 변경될 수 있습니다.

MS 오피스에서는 웃는 얼굴 모양따위를 변경하거나 조절할 수 없고 있는 그대로만 사용해야 합니다.

그리고 MS 오피스는 오픈오피스보다 많은 그림자 관련 옵션을 제공합니다. 이에 따라 그림자 모양이 달라질 수도 있습니다. 오픈오피스에서는 MS 오피스의 그림자 스타일 중 1, 2, 4, 6, 17, 18번만 지원합니다. 수평그림자나 점점 사라지는 그림자는 가져올 수 없으며, 왼쪽 아래의 3D 효과는 무시됩니다.

프레임과 텍스트 상자

MS 오피스의 프레임과 텍스트 상자를 오픈오피스로 가져오면, 링크된 텍스트나 링크가 사라집니다.

활성화된 내용 관리

관리 도구모음에서 사용가능한 MS 오피스의 관리 모음입니다. 이는 대체로 문제없이 가져올 수 있지만, 대부분은 매크로를 필요로 하기 때문에 오픈오피스의 사용자 정의 매크로가 없으면 사용할 수 없습니다.

매크로

오픈오피스에서는 MS 오피스의 매크로를 사용할 수 없습니다. 매크로 언어는 상당히 비슷하지만, 기본 개체는 사뭇 다릅니다. 나중에 MS 오피스에서 사용할 수 있도록 MS 워드, 엑셀, 파워포인트 등의 파일에 저장된 매크로를 유지하도록 설정하려면 도구 > 옵션 > 로드/저장 > VBA 등록 정보 에서 설정을 변경합니다.

Documentation note.png 매크로 바이러스에 감염된 MS 오피스 파일도 오픈오피스로 열면 100% 안전합니다.

오픈오피스에는 매크로를 기록할 수 있는 기능이 있습니다. 이를 이용해 응용 프로그램 인터페이스(API)의 사용을 연습해 볼 수도 있습니다.

텍스트 문서의 가져오기, 내보내기, 공유하기에 대한 문제

텍스트 문서를 다루는 좋은 습관

일부 문제들은 좋은 워드 프로세스 사용 습관으로 해결할 수 있습니다.

  • 직접 문서 형태를 만들지 말고, 글자나 단락 스타일을 이용하는 것이 좋습니다.
  • 엔터를 쳐서 단락 간격을 조절하지 말고, 단락 전후 간격 서식을 이용하십시오. 특히 숫자 매기기나 글머리 기호를 이용하는 것이 좋습니다.
  • 수동으로 페이지 나눔을 하지 말고, 단락 내 텍스트 흐름 속성을 이용하는 것이 좋습니다.
  • 탭이나 공백으로 텍스트를 정렬하지 말고, 탭 스톱을 지정하거나 표를 사용하는 것이 좋습니다.
  • 일반적으로 사용되는 글씨체를 사용하는 것이 좋습니다.

현재 작업 문서의 호환성 설정하기

아래 설정 변경을 통해 MS 오피스와 비슷한 편집 환경을 갖출 수 있습니다.

도구 > 옵션 > OpenOffice.org Writer > 호환성 메뉴를 이용.

Figure 4: 호환성 옵션 고르기

현재 문서의 페이지 상단에 단락 및 표 간격 추가

라이터에서 이 옵션을 해제하면 페이지나 컬럼 상단의 간격이 무시됩니다. 반면, MS 워드는 이 간격을 무시하지 않습니다. 이 옵션을 선택하면 라이터가 MS 워드처럼 페이지나 컬럼 상단의 간격을 무시하지 않게 됩니다.

OpenOffice.org 1.1 탭 설정 위치 서식 사용

이 설정은 탭이 포함된 가운데 맞춤 단락과 오른쪽 맞춤 단락을 가운데 맞춤 단락 혹은 오른쪽 맞춤 단락으로의 일괄 표시할지의 여부를 결정합니다. 이 옵션을 설정하면, 마지막 탭의 오른쪽 텍스트들만 오른쪽 맞춤이 되며 다른 텍스트들은 원래 맞춤을 유지하게 됩니다.

OpenOffice.org 1.1 줄 간격 사용

라이터는 아래 단락과의 간격과 위의 단락과의 간격, 이 두 간격 중 어느 큰 하나를 선택해 사용합니다. 반면, MS 워드는 두 간격을 합산해 사용합니다. 이 옵션을 해제하면 라이터가 MS 워드처럼 동작하게 됩니다.

글꼴과 글꼴 간격

MS 워드 파일의 글자 애니메이션 효과는 라이터에서 글자 "깜빡이기" 속성으로 변환되어 읽힙니다. 예컨데 MS 워드의 "붉은 개미 행진" 글자 애니메이션 속성은 "깜빡이기" 속성이 됩니다.

일반적으로 MS 워드의 글자 간격은 라이터의 글자 간격 보다 좁기 때문에, 종종 MS 워드 한 줄에 보다 많은 글자가 포함될 수 있습니다. 줄간격에서도 약간의 차이를 보이기 때문에, 결과적으로 페이지 나누기의 위치가 서로 다를 수 있습니다.

테이블

테이블과 관련한 호환성 문제는 없습니다.

편지 병합 문서

오픈 오피스는 자료 소스에 대한 접근 방법이 MS 오피스와 다릅니다. 따라서, 편지 병합 기능을 이용한 MS 오피스 문서를 읽어들일 때, 자료 소스에 대한 연결 부분을 유지할 수가 없습니다. 이는 자료 소스를 문서와 연결하는 것만으로는 해결될 문제가 아니며 각각의 필드를 다시 채워서 해결해야 합니다. 이 부분은 " 라이터와 MS 워드 사용상의 차이점" 에 대한 문서의 편지 병합 부분을 참고하기 바랍니다.

MS 워드에서는 편지 병합을 위한 자료 소스로써 또다른 MS 워드 문서를 만들 수 있습니다. 하지만 오픈오피스에서는 MS 워드 문서나 라이터 문서를 자료 소스로써 저장할 방법이 없습니다.

라이터에는 데이터 필드가 비었을 때 빈 줄로 대치할 수 있는 옵션이 없기 때문에 조건부 필드를 이용해야 합니다.

라이터는 꺽인 괄호로 묶은 필드의 이름을 기준으로 병합합니다. 예를 들면, <Name>.

요약: 공유된 환경에서 일할 때, "메인 문서"마다 MS 워드 포맷과 오픈오피스 포맷 모두가 필요할 수 있습니다. 만약, 주된 편지 병합 문서를 MS 워드 파일로 만들었다면, MS 워드 문서에서 해당 텍스트를 복사해 라이터에 붙여넣고, 라이터의 편지 병합 마법사 기능을 이용하는 것이 제일 간편한 방법입니다.

양식

MS 오피스에서 만든 양식과 관련된 문제

잠금 상태의 MS 오피스 파일은 잠금 해제 상태로 오픈오피스로 가져오기됩니다; 즉, 디자인 모드가 변경됩니다.

텍스트 양식 필드는 오픈오피스의 입력 필드로 가져오기 때문에 그 유형을 잃게 됩니다. 이를테면, 텍스트 양식 필드를 "숫자"나 "날짜" 양식으로 지정해놓았더라도 아무 텍스트나 입력할 수 있습니다. 오픈오피스의 텍스트 양식 필드를 사용할 때는 텍스트 입력 대화창을 이용하게 됩니다. MS 오피스로 다시 내보내기할 때는 텍스트 양식 필드가 "fillin" 필드로 변경됩니다. 현재 날짜와 시간, 계산 필드는 단순 텍스트로 내보내기됩니다.

확인란 상자는 가져오기와 내보내기 모두 정상 작동합니다.

드롭 다운 양식 필드는 입력 리스트 필드로 가져오기됩니다. 텍스트 양식 필드 작업과 같이 이용자에게 선택 가능한 옵션이 있다면 대화창이 나타납니다. MS 오피스로 다시 내보내기할 때는 다시 드롭 다운 양식 필드로 변환됩니다.

오픈오피스에서 만든 양식과 관련된 문제

콘트롤은 MS 오피스의 해당 콘트롤로 내보내기됩니다. MS 워드가 오픈오피스의 모든 데이터베이스 기능을 갖추고 있지 않고 매크로 역시 호환되지 않기 때문에, 표준 양식 콘트롤 하나를 가지고 두 환경 모두에서 작동되는 양식을 만들기는 어렵습니다.

요약: 공유된 환경에서 양식을 사용하는 일은 쉽지 않습니다. 한가지 해결 방법을 제시하자면, 별개의 입력 필드나 입력 리스트를 이용하는 것입니다. 이런 필드를 삽입하려면, 삽입 > 필드 > 그 외 > 기능 메뉴를 이용하세요.

각주, 미주, 목차, 색인

각주, 미주, 색인에 대한 가져오기와 내보내기 기능은 제대로 작동합니다. 발견된 몇가지 문제는 아래와 같습니다.

  • 미주의 위치가 조금 변경될 수 있습니다 (MS 워드에서 미주는 색인 앞에 위치하지만 라이터에서는 항상 문서의 끝에 위치합니다).
  • 라이터의 참고 문헌 입력 내용은 워드에서 일반 텍스트가 됩니다.
  • 라이터의 세 컬럼 색인은 워드에서도 세 컬럼으로 가져오기되지만 다시 가져오기하면 한 컬럼이 됩니다.
  • 색인 입력 필드가 있는 MS 워드 파일을 가져오기하면, 색인 입력 필드는 텍스트를 포함한 필드 보다 왼쪽의 필드로 가져오기됩니다.

요약: 공유된 환경에서의 작업은 다소의 문제가 있긴하지만 대부분 가능합니다.

번호 매긴 단락, 개요 번호, 상호 참조

번호 매긴 단락, 개요 번호, 상호 참조의 가져오기 / 내보내기는 이상 없이 잘 작동합니다. 다만, 번호 매긴 단락의 상호 참조의 경우 아래와 같은 문제가 있습니다.

  • 라이터에는 개요 번호로 표시되지 않은 번호 매긴 단락의 번호에 대한 상호 참조 기능이 구현되있지 않아 제대로 작동하지 않습니다.
  • 라이터에는 또한, 숫자에 대한 상호 참조를 상대적으로 번호 매기는 기능이 구현되어있지 않습니다.
  • 챕터 번호에 대한 상호 참조는 실제 화면에 보여지는 것과 다를 수 있습니다.

페이지 번호 매기기

MS 워드에서 첫 페이지를 제외한 그 다음 페이지, 즉 두 번째 페이지부터 페이지 번호가 시작되게하고 싶다면 첫 페이지의 레이아웃을 달리하고 페이지 번호를 0번부터 시작되도록 하는 방법이 널리 쓰입니다. 하지만 이렇게 편집된 파일을 오픈오피스에서 불러오기하면 두 번째 페이지 번호가 "1"이 아니라 "2"로 표시됩니다. 이 문제의 해결 방법은 아래와 같습니다.

  1. 두 번째 페이지를 위한 페이지 스타일을 만들고 그 스타일을 새 이름으로 저장합니다.
  2. 두 번째 페이지의 첫 단락에 커서를 위치시킵니다.
  3. 서식 > 단락 > 텍스트 흐름 메뉴를 선택합니다.
  4. 대화상자의 "나누기" 부분에서 "삽입" 확인란을 선택합니다.
  5. "페이지 스타일과 함께" 확인란을 선택합니다.
  6. 첫 번째 단계에서 만들어둔 페이지 스타일을 선택합니다.
  7. "위치" 부분은 "앞" 으로 두고 페이지 번호를 "1"로 설정합니다.

이렇게 수정된 파일은 다시 MS 워드로 불러오기해도 정상적으로 작동합니다. 다만, 다른 점이 있다면, 첫 페이지 맨 끝 부분에 구역 나눔이 따로 설정되었다는 것입니다. 물론, MS 워드에서 작업시, 이와 같이 구역 나눔 설정을 했다면 라이터에서도 문제 없이 의도한 바대로 페이지 번호가 매겨집니다. 이렇게 수정된 문서를 인쇄하거나 인쇄 미리보기할 경우, 표지와 그 다음 페이지 사이에 예전에 없던 빈 페이지가 삽입됩니다.

짝수 페이지와 홀수 페이지에 각각 다른 포맷을 적용하고 페이지 번호를 붙인 경우, 홀수 페이지 번호는 필드가 아닌 첫 번째 홀수 페이지의 텍스트로 불러오기됩니다.

요약: 페이지 번호가 매겨진 문서를 라이터로 불러오기할 때, 약간의 수정 작업이 필요합니다. 하지만 위의 방법으로 라이터에서 수정하면, 해당 문서에서는 내보내기와 불러오기에서 더 이상 페이지 번호와 관련한 문제가 발생하지 않습니다.

날짜와 시간 필드

MS 워드의 문서 생성일나 마지막으로 저장한 날짜와 관련된 필드는 원래와 똑같은 형식으로 불러오기되지 않습니다. 예컨대, MS 워드 문서의 시간 관련 필드는 기본적으로 표시되지 않습니다. 이를 제대로 표시하고 싶다면 아래와 같이 하십시오.

필드를 오른 클릭 > 필드 > 서식 리스트의 아래쪽으로 스크롤 > 추가 서식 > 서식 코드 부분에 "HH:MM:SS" 추가

내보내기할 때, 마지막으로 저장한 날짜 / 문서 수정 여부와 관련한 필드는 텍스트로 내보내기됩니다.

라이터의 시간 고정, 날짜 고정 필드는 텍스트로 내보내기됩니다.

Importing Word fields

Imported Word fields conversion
Word field: Writer converts to:
ASK Input field
AUTHOR DocInformation:Created
AUTONUM Number Range AutoNr
AUTONUMLGL Number range AutoNr
AUTONUMOUT Number range AutoNr
COMMENTS DocInfomation:Comments
CREATEDATE DocInformation:Created
DATE Date
EDITTIME DocInformation:Modified
FILENAME File name
FILLIN Input field
HYPERLINK (as a hyperlink)
INFO xxx DocInformation:xxx
KEYWORDS DocInformation:Keywords
LASTSAVEDBY DocInformation:Modified
MACROBUTTON (the name of the macro?)
MERGEFIELD Mail merge fields (displayed as the name of the field)
MERGEREC Record number
NEXT Next record
NOTEREF Show variable
NUMCHARS Statistics (with select = Characters)
NUMPAGES Statistics (with select = Pages)
PAGE Page numbers
PAGEREF Bookmarks (displayed as name of bookmark)
REVNUM DocInformation:Document number
SAVEDATE DocInformation:Modified
SEQ Number range
SET Set variable
SUBJECT DocInformation:Subject
TEMPLATE Templates
TIME Date
TITLE DocInformation:Title
TOC (Displays the table of contents)

The following fields are not imported into OpenOffice.org (only the text that they displayed when last saved): =, IF, DOCPROPERTY, FILESIZE, LINK, LISTNUM, QUOTE, SECTION, SECTIONPAGES, STYLEREF, TOA, USERADDRESS, USERINITIALS, USERNAME.

The following fields are ignored on import: AUTOTEXT, AUTOTEXTLIST, BARCODE, BIDIOUTLINE, DOCVARIABLE, EQ, GOTOBUTTON, INCLUDETEXT, LISTNUM, MERGESEQ, PRINT, RD, SKIPIF, SYMBOL, TA, TC.

The Word field EDITTIME is mapped to Writer field DocInformation:Modified on import but the meaning has changed to the date and time last saved rather than how long the file has been open for editing.

Import, export and sharing issues in spreadsheets

Form fields

Combo boxes, list boxes and checkboxes with links to spreadsheet cells all import and export properly, although due to font handling the number of rows displayed in list boxes may be slightly different. List boxes in Calc can either have multi-selection or not, whereas Excel has two multi-selection modes: multi and extend. In Excel a link from a multi-selection listbox to a cell is ignored (at least in Excel 2000; the author has not checked Excel XP). In Calc the link works, but if more than one item is selected, the cell’s value is set to #N/A.

Option buttons import into Calc, but the link with cells works differently. In Calc each option button has its own link to a cell, setting its value to true or false depending on whether the option is selected. In Excel the cell link returns the number of the selected option button. On exporting option buttons to Excel, the option buttons lose their radio operation; in other words, they are not grouped so that selecting one “unselects” the others.

Scroll bars and spinners are now implemented in Calc, but are not imported yet.

Array constants

Array constants are not available in OpenOffice.org. The workaround is to have the constant values in cells on a sheet and refer to them. Array constants used as parameters to a function in Excel are omitted when imported into Calc.

Optional parameters in formulas

Some formulas have more than one optional parameter at the end of the parameter list. In Excel it is possible to leave an optional parameter blank and specify a later parameter, but this is not possible in Calc. Formulas with optional parameters are not correctly imported into Calc.

Functions

Statistical, engineering and financial functions

In Excel some of the financial functions accept string parameters for dates; in OpenOffice.org they require a serial number, and thus they are not correctly imported into Calc.

Analysis ToolPak Functions

The function EFFECT provided by the Analysis ToolPak for Excel is converted to EFFECT_ADD in Calc and returns the same results.

Other functions not implemented / imported

Only three other functions are not imported: INFO, GETPIVOTDATA, and HYPERLINK. Hyperlinks are supported but not as a function; use the Hyperlink button on the Function bar.

DataPilot—Pivot Table

DataPilots are Calc’s equivalent to Excel’s Pivot Tables. However there are a number of limitations. Pivot tables import from Excel into Calc (although the cells do not have the PivotTable shading) but as soon as they are worked on these limitations become apparent. The limitations are:

  • There is no PivotChart facility, but a DataPilot can be used as the data source for a chart.
  • The user interface allows a maximum of 8 fields in the data, row or column areas. (An alternative interface which allows more is available from: http://homepages.paradise.net.nz/hillview/OOo/ in a document called MyDataPilot.sxc.
  • There is some ability to group data (for example, a date field grouping by week or quarter but not by month). The workaround is to create a new column with a formula for calculating the grouping, e.g. =Month().
  • You can not define different formats for different fields.
  • Calc can have formulas based on things like “Difference From” or “% of”, but can not have own custom fields (work around create new columns to calculate the desired values).
  • The Application Program Interface specification is incomplete for writing macros that work with DataPilots—for example, the ability to control through another program, such as OpenOffice.org’s own macro language, BASIC, whether the tables have grand totals, or having access to DataPilots created from external data.

AutoFilter

AutoFilter imports and exports correctly with the required rows being hidden. However, there are a number of differences between Excel and Calc:

  • There is only one AutoFilter active for a spreadsheet document at a time. The rows remain hidden but the drop-downs in the first row disappear on applying AutoFilter elsewhere.
  • The remaining visible row numbers do not change color to warn that there is a filter in place.
  • Error values do not show as an option in the drop down lists when cells in the column have errors.
  • In the drop down lists, the equivalent to Excel’s “Custom” is called “Standard”.

Charts

Chart types that Excel provides but Calc does not:

  • Bar of pie converts to a 2D – columns – normal.
  • Pie of pie converts to a 2D – columns – normal.
  • Radar filled converts to 3D – columns deep.
  • Radar with markers – converts to 2D – net – normal but counterclockwise rather than Excel’s clockwise.

Other charting issues include:

  • There are fewer axis options, such as no option for having an inverted y axis (negative at top towards positive at bottom).
  • The data must be contiguous, with the labels in the first row or column.

Number formats

There is no “accounting” format (with the currency symbol at the left edge of the cell). A workaround would be to have another column to the left that contains the currency symbol.

There is no predefined option for bracketing negative numbers. Use a custom format such as “$#,##0.00_);[RED]($#,##0.00)”.

Grid lines

In Excel grid lines are a property of a worksheet; in Calc it is an application-wide option:

Tools > Options > OpenOffice.org Calc > View

Import, export and sharing issues in presentations

Color gradients and borders

The author had not noticed the following changes, so this is a direct quote from StarOffice 7 Migration Guide by Sun.

Unlike Microsoft PowerPoint, StarOffice Impress does not support three-color gradients, double and triple borders, or round-dotted borders. To improve the results of the import, you have to make the necessary adjusts before import. Change three-color presets to similar two-color gradient fills and change double and triple border lines to a single border line with appropriate width. Round-dotted border lines that are mapped to rectangle-border closely resemble the original line style in PowerPoint, so manual editing should not be necessary.

Multimedia

Voice-over narration is not supported by Impress.

There appear to be no settings for multimedia custom animations, such as the ability to play a sound for the next slides.

Chart animations

There is no facility in Impress for “chart effects” as there is in PowerPoint, such as presenting a series or category at a time. On import the charts simply appear. A workaround is to have multiple copies of the chart with each one set up to display as desired.

Pack and Go

The Pack and Go feature in PowerPoint allowed a PowerPoint file to be split over several floppy disks and assured that all related files were included. This facility is not included in Impress, nor can Impress open such files.

Fields

Date fields are exported as text, so they do not automatically update.

Action settings and interaction

PowerPoint provides action settings for mouseover, but Impress does not have this option, only on mouse click, so mouseovers get mapped to mouse clicks. PowerPoint has an option for highlighting the object on mouse click or mouse over; Impress does not have this, so it gets ignored on import.

PowerPoint custom animations and Impress object effects

Table 3 shows how the custom animations and object effects are imported into Impress and exported to PowerPoint.

Importing / exporting custom animations between PowerPoint and Impress
PowerPoint Impress
Appear Appear
Blinds Fade Horizontally
Box Fade To Center
Checkerboard Checkerboard
Diamond Appear
Crawl Fly In From bottom
Dissolve Dissolve
Flash once Appear
Peek Short Fly In from Bottom
Random Bars Horizontal lines
Spiral Spiral Outward Clockwise
Split Close Vertical
Stretch Stretch Vertical
Strips Fade From Top Right
Swivel Rotate Horizontally
Wipe Cross-Fade From Top
Zoom Fade From Center
Random effects Vertical Lines

PowerPoint—Impress slide transitions

Table 4 shows how slide transitions are imported into Impress and exported to PowerPoint.
PowerPoint Impress
Blinds Horizontal Venitian Blinds Horizontal
Blinds Vertical Venitian Blinds Vertical
Box In Box In
Box Out Box Out
Checkerboard Across Checkerboard Across
Checkerboard Down Checkerboard Down
Cover Down Cover Down
Cover Left Cover Left
Cover Right Cover Right
Cover Up Cover Up
Cover Left Down Cover Left-Down
Cover Right Down Cover Right-Down
Cover Left Up Cover Left-Up
Cover Right Up Cover Right-Up
Cut No effect
Cut Through Black No effect
Dissolve Dissolve
Fade Through Black Fade Through Black
Random Bars Horizontally Random Bars Horizontal
Random Bars Vertically Random Bars Vertical
Horizontal In Split Horizontal In
Horizontal Out Split Horizontal Out
Split Vertical In Split Vertical In
Split Vertical Out Split Vertical Out
Strips Left Down Fade From Top Right
Strips Left Up Fade From Bottom Right
Strips Right Down Fade From Top Left
Strips Right Up Fade From Bottom Left
Uncover Down Uncover Down
Uncover Left Uncover Left
Uncover Right Uncover Right
Uncover Up Uncover Up
Uncover Left Down Uncover Left-Down
Uncover Left Up Uncover Left-Up
Uncover Right Down Uncover Right-Down
Uncover Right Up Uncover Right-Up
Wipe Down Wipe Down
Wipe Left Wipe Left
Wipe Right Wipe Right
Wipe Up Wipe Up
Random Transition Random Transition


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools