12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Personalizzazione di OpenOffice.org

From Apache OpenOffice Wiki
Jump to: navigation, search



Questo è il Capitolo 14 della Guida Introduttiva di OpenOffice.org 3, prodotta dal Gruppo It di OOoAuthors. Un file PDF di questo capitolo (in inglese) è reperibile da questa pagina wiki.

Introduzione

Questa Appendice contiene le istruzioni per effettuare alcune delle più comuni personalizzazioni.

In OpenOffice.org è possibile personalizzare il contenuto dei menu, le barre degli strumenti e i tasti di scelta rapida, aggiungere nuovi menu e barre degli strumenti, e assegnare macro agli eventi. Tuttavia non è possibile personalizzare i menu contestuali (tasto destro).

Altre personalizzazioni sono possibili grazie alle estensioni che si possono installare usando il sito di OpenOffice.org o altri provider.

Documentation note.png Le personalizzazioni dei menu si possono salvare in un modello. Per farlo, salvarle prima in un documento e poi salvare il documento come modello, così come descritto nel Capitolo 3 (Stili e modelli).

Personalizzare il contenuto dei menu

Oltre a poter cambiare il tipo di carattere del menu (come descritto nel Capitolo 2), è possibile aggiungere e riorganizzare elementi sulla barra dei menu, aggiungere elementi ai menu e apportare altre modifiche.

Per personalizzare i menu:

  1. Scegliete Strumenti > Personalizza.
  2. Nella finestra di dialogo Personalizza, selezionate la pagina Menu (figura sotto).
  3. Nell' elenco a tendina Salva in, scegliete se salvare il menu modificato per l'applicazione (ad esempio Writer) oppure per il documento selezionato.
  4. Nella sezione OpenOffice.org < nome del programma (esempio: Writer) > Menu, selezionate dall'elenco a tendina Menu il menu che volete personalizzare. L'elenco include tutti i menu principali e i sottomenu contenuti in altri menu. Ad esempio, oltre ai menu File, Modifica, Visualizza, e così via, ci sono i menu File | Invia e File | Modelli. I comandi disponibili per il menu selezionato sono mostrati nella parte centrale della finestra di dialogo.
  5. Per personalizzare il menu selezionato, fate clic sui pulsanti Menu o Modifica. È possibile aggiungere comandi a un menu cliccando sul pulsante Importa. Queste azioni sono illustrate in dettaglio nelle sezioni seguenti. Usate le frecce su e giù poste accanto all'elenco delle Voci per spostare l'elemento del menu selezionato in una posizione diversa.
  6. Una volte terminate tutte le modifiche cliccate su OK per salvarle.
La pagina Menu della finestra di dialogo Personalizza

Creare un nuovo menu

Nella finestra di dialogo Personalizza, cliccate su Nuovo per visualizzare la finestra di dialogo mostrata sotto.

  1. Digitate un nome per il nuovo menu nel campo Nome del menu.
  2. Usate i pulsanti freccia su e giù per spostare il nuovo menu nella posizione desiderata sulla barra dei menu .
  3. Fate clic su OK per salvare.

Il nuovo menu appare ora nella lista dei menu nella finestra di dialogo Personalizza (apparirà sulla barra dei menu dopo aver salvato la personalizzazione).

Dopo aver creato un nuovo menu è necessario aggiungervi dei comandi, come descritto in Aggiunta di un comando ad un menu.

Aggiunta di un nuovo menu

Modificare menu esistenti

Per modificare un menu esistente, selezionatelo nell'elenco Menu, quindi fate clic sul pulsante Menu per visualizzare un elenco di modifiche: Sposta, Rinomina, Elimina. Non tutte le modifiche si possono applicare a tutte le voci nell'elenco dei Menu. Ad esempio, Rinomina ed Elimina non sono disponibili per i menu forniti.

Per spostare un menu (come File), scegliete Menu > Sposta. Si aprirà una finestra di dialogo simile a quella mostrata sopra (ma senza il campo Nome del menu). Usate i pulsanti freccia su e giù per spostare il menu nella posizione desiderata.

Per spostare i sottomenu (come File | Invia), selezionate il menu principale (File) nell'elenco del Menu, quindi, nella sezione Contenuto del menu della finestra di dialogo, selezionate il sottomenu (Invia) nell'elenco delle Voci e utilizzate i tasti freccia per spostarvi su o giù nella sequenza. Un piccolo triangolo nero a destra del nome permette di riconoscere facilmente i sottomenu nella lista delle Voci.

Oltre a rinominare, si può specificare una combinazione di scelta rapida che permette di selezionare un comando del menu premendo su Alt+ la lettera sottolineata nel comando del menu.

  1. Selezionare un menu o una voce del menu.
  2. Fate clic sul pulsante Menu e selezionate Rinomina.
  3. Aggiungete una tilde (~) davanti alla lettera che volete usare come acceleratore. Ad esempio, per selezionare il comando Salva tutto premendo su Alt+V, inserite Sal~va tutto.

Aggiunta di un comando ad un menu

Potete aggiungere comandi ai menu forniti e ai menu che avete creato. Nella finestra di dialogo Personalizza, selezionate il menu nell'elenco dei Menu e fate clic sul pulsante Aggiungi nella sezione Contenuto del menu della finestra di dialogo.

Nella finestra di dialogo Aggiungi comandi, selezionate una categoria e quindi il comando, poi fate clic su Aggiungi. La finestra di dialogo resta aperta, così è possibile selezionare più comandi. Quando avete terminato di aggiungere comandi, fate clic su Chiudi. Tornando indietro alla finestra di dialogo Personalizza, è possibile organizzare i comandi nella sequenza desiderata utilizzando i pulsanti freccia su e giù.

Aggiungere comandi a un menu

Modifica delle voci del menu

Oltre a poter cambiare la sequenza delle voci di un menu o sottomenu, si possono aggiungere sottomenu, rinominare o eliminare voci, e aggiungere separatori di gruppo.

Per iniziare selezionate il menu o sottomenu nell'elenco dei Menu che si trova in alto nella pagina Personalizza, quindi selezionate la voce nell'elenco delle Voci in Contenuto del menu. Fate clic sul pulsante Modifica e scegliete l'azione richiesta dall'elenco a comparsa delle azioni.

La maggior parte delle azioni dovrebbe risultare autoesplicativa. Scegliendo Inizia un gruppo viene aggiunta una linea di separazione dopo la voce evidenziata.



Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools