12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Choosing and applying the background

From Apache OpenOffice Wiki
Jump to: navigation, search


Background can be applied to a number of elements in Impress: the page, a default text area, a graphic object and so on. The procedures to apply a background are always the same.

The following procedure is used to apply a background to the page.

  1. To begin, do one of the following:
    • Select Format > Page from the menu bar and choose the Background tab.
    • Make sure the Presentation Styles icon is selected in the Styles and Formatting window, right-click Background and select Modify from the pop-up menu.
  2. Select the type of fill you want for your background from the five choices, as shown below: None, Color, Gradient, Hatching, or Bitmap.
  3. Background choices
    Background choices.

  4. A list of choices for the selected fill type then appears (see below for an example). Select one of the items on the list and click OK. The fill you have chosen is added to the slide master, replacing any previously selected fill.
  5. Background colors
    Background colors.

Tip.png You can make custom additions to each type of background, with the obvious exception of None. After you create new fills, they are listed in the Background dialog along with the fills provided with OOo. For example, the last color in the figure above, Test Blue, is a custom color. See Chapter 6 for more information.


Adding background objects

This section describes how to add background objects and graphic elements (such as a logo, decorative lines, and so on). OOo supports a large number of picture formats.

Whenever you want the same graphic element to appear on every slide of your presentation, the easiest and quickest solution is to use the slide master. Not only it will save time while creating the presentation, but also when you decide to either modify the graphic element or reposition it on the slide. If the graphic element was added to each slide, the same operations would have to be performed on each individual slide of the presentation.

One of the most common activities when preparing a presentation is to add a picture to the slide master. To insert a picture already available on the hard disk, follow these steps:

  1. Choose View > Master > Slide Master from the menu bar.
  2. Select from the menu bar Insert > Picture > From File.
  3. Navigate to the directory where your picture is and select it. If you want to see a preview, select the corresponding checkbox in the file browser dialog.
Documentation caution.png OOo offers the option to insert a picture as a link to the file rather than embedding it in the document. This can be useful when a presentation is not intended to be distributed elsewhere, and where it will remain in the same hierarchical directory structure. For example, it could be created on a notebook computer, from which the presentation will be given to, typically, a group of clients. If the presentation file is to be distributed, however, the picture should be embedded to avoid the “missing picture" syndrome when the presentation is finally given on a different computer.


Once the picture is inserted you may need to reposition it and modify its size. How to do that is explained in Chapter 4 (Adding and Formatting Pictures).

Tip.png If you want the image to blend with the background, you can set the background color of the picture as transparent. Select the picture, then chose Tools > Eyedropper from the menu bar. Check the first checkbox and then move the mouse on the picture and click on the color you would like to make transparent. This color appears next to the checkbox. Make sure that Replace with... is set to Transparent and click Replace.


In addition to pictures you can add a number of other background objects, for example decorative lines, text and shapes. Below is an example of a slide master with a custom background gradient, a background picture, another picture in the top right corner, some decorative lines and some customized presentation styles.

Slide showing modifications
Example of a complex slide with several modifications.

Modifying the size and shape of default text areas

When a slide master is opened for editing, it contains five areas, as shown below:

  • Title area for AutoLayouts
  • Object area for AutoLayouts
  • Date area
  • Footer area
  • Slide number area

Editable areas
Slide master showing five editable areas.

Click with the left mouse button on any of these areas to display eight green squares (handles) around the rectangle. Use these handles to modify the size and position of the area.

  1. To change the position, move the mouse towards one of the edges, away from the green handles, until the cursor changes shape, then click the left mouse button and drag the area to the desired position. (The shape of the cursor to move and resize objects is operating system specific, therefore no image is provided.)
  2. To modify the shape and size of one of the rectangular area, use one of the 8 green handles. Use the handles in the corners to modify both the sides of the rectangle simultaneously; the handles in the middle of the sides modify only one dimension at a time. The shape of the mouse cursor usually changes when over the handle, giving a clear visual indication of how it will affect the shape of the rectangular area.
Tip.png To keep the ratio between the sides of the rectangular area constant, move the mouse to one of the 4 green handles at the corner of the area and keep the Shift key pressed while dragging the handle with the mouse.


To more accurately control the shape and size as well as the position of the default text area, instead of using the mouse it is better to access the Position and Size dialog. To do that, first select the rectangular area by clicking on any point inside it, then either press F4 or from the main menu select Format > Position and Size. The dialog shown below is displayed.

Position and Size dialog
The Position and Size dialog.

The functions of this dialog are explained in the Draw Guide, so only a short description of the most important fields is provided in this chapter.

Use the Position section to specify the X (horizontal) and Y (vertical) position of the rectangular area. The values represent the distance of the base point (selected on the right hand side) relative to the top left corner of the slide.

Use the Size section to specify the width and height of the rectangular are. Select as the base point the part of the rectangular area that remains fixed. The default setting (top left corner) means that the when resizing the area, the position of the top left corner of the area will not change.

You can also use the Rotation tab of the dialog to rotate one of the axes by 90 degrees to obtain a modern looking layout. In general it is preferable to use only right angles for ease of editing, although the program does not impose restrictions on the values that can be used.

Further modifications to the default text areas

Besides the shape, size and position, it is also possible to modify other aspects of the 5 areas of the slide master, such as the background, add a border, alignment relative to the slide and position relative to other objects.

While background style and line style of an area can be accessed from the Format menu, in order to access the Alignment and Arrange menus you need to either open the Drawing toolbar or use the context menu. To display the Drawing toolbar, select it in View > Toolbars; to open the context menu, right-click on the edge of the rectangular area after selecting it. On the Drawing toolbar, click the arrow next to the Alignment or Arrange icon (highlighted in the figure below) to display choices. See the Draw Guide for details.

Drawing toolbar
The Drawing toolbar.

The date area, footer area, and slide number area do not automatically appear on every slide, even though you have defined them. In order to show them, you need to close the Master View and select the desired field from the menu: Insert > Page number or Insert > Date and time. This procedure is explained in detail in Chapter 8 (Adding and Formatting Slides, Notes, and Handouts).

Adding text to all slides

Some of the supplied slide masters have text objects in the footer. You can add other text objects to the master page for your slides to act as a header or a footer.

  1. Choose View > Master > Slide Master from the menu bar.
  2. On the Drawing toolbar (see Figure 9), select the Text icon.
  3. Click once and drag in the master page to draw a text object, and then type or paste your text into the object or add fields as described below.
  4. Choose View > Normal when you are finished.

To add a field, such as the date or page number, to a text object in the header or footer, choose Insert > Fields. and select the required field from the submenu. If you want to edit a field in your slide, select it and choose Edit > Fields.

The fields you can use in Impress are:

  • Date (fixed)
  • Date (variable)—updates automatically when you reload the file
  • Time (fixed)
  • Time (variable)—updates automatically when you reload the file
  • Author—First and last names listed in the OpenOffice.org user data
  • Page number (slide number)
  • File name
Tip.png To change the number format (1,2,3 or a,b,c or i,ii,iii, etc.) for the page number field, choose Format > Page and then select a format from the list in the Layout Settings area.
To change the author information, go to Tools > Options > OpenOffice.org > User Data.



Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools