12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Exporting graphics

From Apache OpenOffice Wiki
Jump to: navigation, search



Saving drawings in the native OpenOffice.org format (*.odg) means that (currently) in general only OOo (or StarOffice) users can open the files. To make it easier for other users and to use the drawings in other applications, you can export the graphics in other formats. Choose the command File > Export and then in the File format pull-down list select the desired format (see Figure 5).

Section of the file selection list
Figure 5: Section of the file selection list

Exporting the entire file

The file format options in the upper area of the File format box—PDF, Flash and HTML—will result in the complete file being exported. Export in Flash or HTML format will result in each page of the Draw document being exported as a raster graphic. You will then not be able to access individual objects on the page. The Export Assistant can generate—if you choose—a Navigation aid to help in moving from page to page.

If you want to use the object(s) in other applications you would be better advised to select one of the Metafile formats (JPEG, PNG, TIFF, BMP etc) in the lower part of the File format list (see Figure 6). With this type of export only the currently active page is exported.

Lower part of the Export dialog window
Figure 6: Lower part of the Export dialog

Exporting single objects

In order to export individual drawing objects you need to first select them. A selection can include more than one object. Take care to select the option Selection on the Export dialog.

Exporting as a vector graphic

The choice of vector formats is still limited. An export to a DXF format file (Autocad) is not possible. Even the export of a graphic to a SVG format file is not yet fully implemented: the graphic objects are exported as paths and 3D objects only as preview images. Best supported are the Metafile formats and exporting to one of these is usually successful.

Exporting as a raster graphic

The choice of formats for export as a raster graphic is large enough that you can always find one which will be supported by the application you wish to use. In case of any doubt, test out a number of the different formats to see which gives the best results; some programs behave differently depending on the format of the image to be imported into them.

After typing in a name for the exported file and selecting the file format you may be able to set options for the exported image—compression, color format, version of Metafile—depending on the format chosen. Some examples of the various option dialogs are shown in Figure 7.

Adjusting format specific properties prior to export
Figure 7: Adjusting format specific properties prior to export

In cases where the export dialog permits the input of the image resolution, note that this does not affect the number of raster points in the image. Rather it inserts into the picture information that informs other programs the dimensions to be used in displaying the image. This means that, among other things, missing raster points can be interpolated when the graphic is opened in the other program. The number of pixels used is determined by the screen resolution set up within the operating system and through the Drawing scale factor set in Tools > Options > OpenOffice.org Draw > General. This is a limitation of the current user interface; it is possible to set other resolutions using macros.

Embedded raster graphics, or objects which have been converted to a bitmap or Metafile (from the context menu Convert > To Bitmap / To Metafile) may subsequently be saved as a picture; from the context menu choose Save as Picture. In this way the picture is saved, but without Draw-specific additions such as text elements, borders, or shadows, and without the possibility of setting any of the options referred to above.

Draw objects can be exported into Writer, Calc or Impress documents without any problems. For objects used often this is most simply done by storing them in the Gallery or by using the clipboard. As Writer and Calc do not possess the same range of tools available within Draw, it makes sense to use Draw to produce a complex drawing and then to copy it into the other OOo application. A link to single drawing objects is not possible, but you can incorporate Draw documents in the other modules as linked OLE objects.


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools