12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

The Table menu and toolbar

From Apache OpenOffice Wiki
Jump to: navigation, search


All of the table commands described in this chapter are conveniently located in the main menu under the Table item and on the Table toolbar, shown below.

Table 1 describes the effects of using these icons. When you create a table or select an existing table, the Table toolbar may be displayed automatically, or you can manually display it by clicking View > Toolbars > Table. The toolbar can float over the main Writer window (as shown below), or it can be docked along any edge of the main window. See Chapter 1 (Introducing Writer) for more about docking and floating toolbars, and how to hide and display specific tools on a toolbar.

WG3TableToolbar.png
Table toolbar:
1 Table 2 Line Style 3 Line Color (border) 4 Borders 5 Background Color 6 Merge Cells 7 Split Cells 8 Optimize 9 Top 10 Center (vertical) 11 Bottom 12 Insert Row 13 Insert Column 14 Delete Row 15 Delete Column 16 Select Table 17 Select Column 18 Select Row 19 AutoFormat 20 Table Properties 21 Sort 22 Sum

Table 1: Functions of the icons on the Table toolbar

Name Description
Table Opens the Insert Table dialog box where you can set up and insert a table into the document, name the table for use with the Navigator, and set some other options. If you press the small black triangle pointing down next to the icon, you can use the mouse to drag to select the number of rows and columns to include in the table.
Line Style Opens the Border Style window where you can modify the border line style.
Line Color (border) Opens the Border Color window where you can modify the border color.
Borders Opens the Borders window where you can select which sides of the table or of the selected cells will have a border.
Background Color Opens the Background toolbar where you can select the background color of the table or of the selected cells.
Merge Cells Combines the selected cells into a single cell. Refer to Merging and splitting cells on page 14 for an example of using this button.
Split Cells Opens the Split Cell dialog box where you can define how to split a cell. Refer to Merging and splitting cells on page 14 for an example of using this button.
Optimize Opens the a drop down menu with four options you can use to let OOo optimize the distribution of the columns or rows or optimize the row height or column width.
Top Press this button to align the contents of the selected cells to the top of the cell.
Center (vertical) Press this button to align the contents of the selected cells to the vertical center of the cell.
Bottom Press this button to align the contents of the selected cells to the bottom of the cell.
Insert Row Inserts a row below the selected row.
Insert Column Inserts a column after the selected column.
Delete Row Deletes the selected row(s) from the table.
Delete Column Deletes the selected column(s) from the table.
Select Table Selects the entire table.
Select Column Selects the column in which the cursor is positioned.
Select Row Selects the row in which the cursor is positioned.
AutoFormat Opens the AutoFormat dialog box where you can select among several predefined formatting sets. Each set is characterized by its own fonts, shading, and borders styles. You can also select AutoFormat from the Insert Table dialog box.
Table Properties Opens the Table Format dialog box where you can control all the properties of the table—for example: name, alignment, spacing, column width, borders, and background.
Sort Opens the Sort dialog box where you can specify the sort criteria for the selected cells.
Sum Activates the sum function. Refer to Using Spreadsheet Functions in a Table for an example of using this function.


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools