12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Working with templates

From Apache OpenOffice Wiki
Jump to: navigation, search


All documents in OpenOffice.org (OOo) are based on templates. However, Impress is a little different from other OOo components, in that it starts with the Presentation Wizard unless you have elected to turn the Wizard off.

When you choose File > New > Presentation from the menu bar, if the Presentation Wizard is active, the Wizard offers several choices for a new presentation, one of which is From template.

If you have turned the Presentation Wizard off, when you start a new presentation by choosing File > New > Presentation from the menu bar, OOo uses the default presentation template. If you have not defined your own default template, OOo uses an in­built blank template supplied with the program.

Using templates supplied with OOo

OOo comes with five presentation templates. Two are in the Presentations folder and three are in the Presentation backgrounds folder. The difference between them is that “Presentation” templates include a series of slides with sample titles and topics, while “Presentation background” templates have only backgrounds and background objects. Both types have predefined presentation and graphics styles.

You can create a new presentation from a previously saved presentation template by choosing File > New > Templates and Documents from the menu bar. This opens the Templates and Documents – Templates window. To open a new presentation based on a template, double-click that template’s name in the list.

Using templates from other sources

If you have created your own templates, or imported templates from another location, they are probably stored in the My Templates folder in the Templates and Documents – Templates window. Templates installed using the Extension Manager may be installed in their own folders. You can use them in the same way as the templates installed with OOo.

See Importing a template for information on importing templates into OOo.

Installing templates using the Extension Manager

The Extension Manager provides an easy way to install collections of templates, graphics, macros, or other add-ins that have been “packaged” into files with a .OXT extension.

Although individual extensions can be found in different places, the official OpenOffice.org extension repository is at http://extensions.services.openoffice.org/. Some extensions are free of charge; others are available for a fee. Check the descriptions to see what licenses and fees apply to the ones that interest you.

For more about the Extension Manager and some extensions of interest to Impress users, see Chapter 11 (Setting up and Customizing Impress).

To install a collection templates packaged as an extension:

  1. Download the extension and save it anywhere on your computer.
  2. In OOo, select Tools > Extension Manager from the menu bar. In the Extension Manager dialog, click Add.
  3. A file browser window opens. Find and select the extension you want to install and click Open. The extension begins installing. You may be asked to accept a license agreement.
  4. When the installation is complete, the extension is listed in the Extension Manager dialog.

The slide masters from the templates will now appear in the list of Available Master Pages in the Tasks Pane.

Tip.png To get extensions that are listed in the repository, you can open the Extension Manager and click the Get more extensions here link. You do not need to download them separately as in step 1 above.


Setting a default template

You can set a custom presentation template to be the default template. You can reset the default later if you choose.

Setting a custom template as the default

You can set any template to be the default, as long as it is in one of the folders displayed in the Template Management dialog box.

To set a custom template as the default:

  1. From the main menu, choose File > Templates > Organize. The Template Management dialog box opens.
  2. In the box on the left, double-click the folder containing the template that you want to set as the default, then select the template.
  3. Click the Commands button.
  4. From the drop-down menu, choose Set As Default Template. The next time that you create a document by choosing File > New, the document will be created from this template.
Template Management dialog box

Resetting the default to OOo’s in-built Default template

To re-enable OOo’s Default presentation background template as the default:

  1. In the Template Management dialog box, in the box on the left, click the Presentation Backgrounds folder.
  2. Click the Commands button.
  3. From the drop-down menu, choose Reset Default Template > Presentation.

Creating your own templates

To create a template from a presentation:

  1. Open the presentation that you want to use for a template.
  2. From the main menu, choose File > Templates > Save. The Templates window opens.
  3. In the New template field, type a name for the new template.
  4. In the Categories list, click the folder in which you want to store the template. This is usually the My Templates folder, unless you have created other folders. To learn more about template folders, see Organizing templates.
  5. Click OK. OOo saves the new template and the Templates window closes.
Saving a new template

Modifying a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s styles to documents that were created from that template.

Documentation note.png You can only reapply styles. You cannot reapply content.

To edit a template:

  1. From the main menu, choose File > Templates > Edit. A standard file browser window opens.
  2. Find and select the template that you want to edit, and then click Open. The selected template opens in Impress.
  3. Edit the template just as you would any other presentation. To save your changes, choose File > Save from the main menu.

The next time that you open a document that was created from the changed template, the following message appears.

Apply current styles message

Click Yes to apply the template’s changed styles to the document. Click No if you never want to apply the template’s changed styles to the document. Whichever option you choose, the message box closes and the document opens in OOo.

Organizing templates

OOo can only use templates that are in OOo template folders. You can, however, create new OOo template folders and use them to organize your templates. For example, you might have separate template folders for templates for different purposes or projects. You can also import and export templates.

To begin, choose File > Templates > Organize from the main menu. The Template Management dialog box opens.

Documentation note.png All the actions made by the Commands button in the Template Management window can be made as well by right-clicking on the templates or the folders.

Creating a template folder

To create a template folder:

  1. In the Template Management dialog box, click any folder.
  2. Click the Commands button and choose New from the drop-down menu. A new folder called Untitled appears.
  3. Type a name for the new folder, and then press Enter. OOo saves the folder with the name that you entered.

Deleting a template folder

You cannot delete the template folders supplied with OOo or installed using the Extension Manager; you can only delete folders that you have created.

To delete a template folder that you have created:

  1. In the Template Management dialog box, select the folder that you want to delete.
  2. Click the Commands button and choose Delete from the drop-down menu. A message box appears and asks you to confirm the deletion. Click Yes.

Moving a template

To move a template from one template folder to another template folder:

  1. In the Template Management dialog box, double-click the folder that contains the template you want to move. A list of all the templates contained in that folder appears underneath the folder name.
  2. Click the template that you want to move and drag it to the desired folder. If you do not have the authority to delete templates from the source folder, this action copies the template instead of moving it.

Deleting a template

You cannot delete the templates supplied with OOo or installed using the Extension Manager; you can only delete templates that you have created or imported.

To delete a template:

  1. In the Template Management dialog box, double-click the folder that contains the template you want to delete. A list of all the templates contained in that folder appears underneath the folder name.
  2. Click the template that you want to delete.
  3. Click the Commands button and choose Delete from the drop-down menu. A dialog box appears and asks you to confirm the deletion. Click Yes.

Importing a template

If the template that you want to use is in a different location, you must import it into an OOo template folder.

To import a template into a template folder from another location on your computer:

  1. In the Template Management dialog box, click the folder into which you want to import the template.
  2. Click the Commands button and choose Import Template from the drop-down menu. A standard file browser window opens.
  3. Find and select the template that you want to import and click Open. The file browser window closes and the template appears in the selected template folder.
  4. If you want, type a new name for the template, and then press Enter.

Exporting a template

To export a template from a template folder to another location:

  1. In the Template Management dialog box, double-click the folder that contains the template you want to export. A list of all the templates contained in that folder appears underneath the folder name.
  2. Click the template that you want to export.
  3. Click the Commands button and choose Export Template from the drop-down menu. The Save As window opens.
  4. Find the folder into which you want to export the template and click Save.


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools