12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Creating bulleted and numbered lists

From Apache OpenOffice Wiki
Jump to: navigation, search


The procedure to create a bulleted or numbered list is quite different depending on the type of text box used, although the tools to manage the list and customize the appearance are the same.

In text boxes created automatically by Impress (called AutoLayout), the outline styles available are by default bulleted lists, while for normal text boxes an additional step is required to create a bulleted list.

Creating lists in AutoLayout text boxes

Every text box included in the available layouts is already formatted as a bulleted list, therefore to create a bulleted list the only necessary steps are:

  1. From the Layout pane, choose a slide design that contains a text box. Those are easily recognizable from the thumbnail.
  2. Click in the text box that reads Click to add an outline.
  3. Type the text, then press Enter to start a new bulleted line.
  4. The default list type is a bulleted list. The mechanisms to change the list from bulleted to numbered and vice versa are explained in Changing the appearance of the list.
Tip.png Press Shift + Enter to start a new line without creating a new bullet or number. The new line will have the same indentation of the previous line. Press instead the button bullets on/off on the text formatting toolbar for a line without bullet. If the text formatting toolbar is not showing, enable it selecting View > Toolbar > Formatting in the menu bar.


Creating lists in other text boxes

To create a list in a text box, follow these steps:

  1. Place the cursor in the text box.
  2. Click the Bullets On/Off button BulletsOnOff.png on the text formatting toolbar. If the text formatting toolbar is not showing, enable it by selecting View > Toolbar > Formatting from the menu bar.
  3. Type the text and press Enter to start a new bulleted line.
  4. The default list type is a bulleted list. The mechanisms to change the appearance of the list are explained in this section.

Creating a new outline level

  1. If necessary, press Enter to begin a new line.
  2. Press Tab. Each time you press Tab the line indents to the next outline level. Pressing Enter creates a new line at the same level as the previous one. To return to the previous level, press Shift+Tab.

In the AutoLayout text boxes, promoting or demoting an item in the list corresponds to applying a different outline style, so the second outline level corresponds to Outline 2 style, the third to Outline 3 style and so on.

Documentation caution.png Unlike styles in Writer, do not try to change the outline level by selecting the text and then clicking the desired outline style. Due to the way the presentation styles work, it is not possible to apply them in this way.


Changing the appearance of the list

You can fully customize the appearance of a list, changing the bullet type or numbering for the entire list or for single entry. All the changes can be made using the Bullets and Numbering dialog box, which is accessed by selecting Format > Bullets and Numbering or by clicking on the Bullets and Numbering icon BulletControl3.png on the text formatting toolbar.

Selecting the entries

For the entire list:

  1. Select the entire list or click on the gray border of the text box so that just the green resizing handles are displayed.
  2. Select Format > Bullets and Numbering or click on the Bullets and Numbering icon. BulletControl3.png
  3. The Bullets and Numbering dialog box contains five tabs: Bullets, Numbering type, Graphics, Position, and Customize.
    • If a bulleted list is needed, select the desired bullet style from the six default styles available on the Bullets page.
    • If a graphics style is needed, select one from those available on the Graphics page.
    • If a numbered list is needed, select one of the 6 default numbering styles on the Numbering type page.

Later in this section is an explanation on how to add further bullets and numbering styles to the existing ones.

The Bullets and Numbering dialog box

For a single line in the list:

  1. Click anywhere in the line to place the cursor in it.
  2. Follow steps 2–4 of the previous instruction set.

If the list was created in an AutoLayout text box, then an alternative way to change the entire list is to modify the Outline styles. Changes made to the outline style will apply to all the slides using them. Sometimes this is what you want; sometimes it is not, so some care must be taken. Follow the procedure to change the Presentation style described in Modifying a style. The tabs related to list management are the same ones described below.

Bullets, Numbering type and Graphics pages

These three tabs contain predefined formatting for either the bullet type (Bullets and Graphics tabs) or for the numbering. To apply a specific one, it is sufficient to click on the image. A thick border will indicate the selection.

Position page

Use the Position page to fine tune the indentation and spacing of the bullet point and its text. This page is particularly effective when used in combination with the Customize page.

The Position page used to set list indentation

To set up an outline level, first select it from the list on the left hand side of the page. Then set the Indent, which is the spacing between the bullet or number and the text. If you select the Relative option, the indent value will be measured relative to the previous level and not from the margin.

The numbering alignment is only useful when creating a numbered list; use it to specify the alignment of the numbers. For example, you may want to align them to the right to line up one- and two-digit numbers in a pleasing way.

Tip.png To fully appreciate how the Numbering alignment works, try to create a numbered list with more than 10 elements and make sure that enough room has been made for a two (or more) digit number.


The Position page is not available if you are modifying a presentation style or graphics style, however the same effects can be obtained by using the Indents and Spacing page of the dialog box for creating or modifying a slide (see Figure 10).

Customize page

Use the Customize page to alter the style of all the outline levels.

The Customize page for the list outline

The options available on this page depend on the type of marker selected for the list. Select first the level you want to modify on the left hand side of the box. To modify all 9 levels at once, select 1 – 9 as the level. Because the levels are arranged in a hierarchical structure, changing for example the font attribute of one of the levels ripples through all the lower levels.

Depending on the numbering style selected in the Numbering box (bullet, graphic, numbering), some of the following options become available on the page:

  • Before: Enter any text to appear before the number (for example, Step).
  • After: Enter any text to appear after the number (for example, a punctuation mark).
  • Color: Pick the color for the list marker (number or bullet character).
  • Relative size: Specify the size of the number relative to the size of the characters in the paragraph of the list.
  • Start at: Enter the first value of the list (for example, you might want the list to start at 4 instead of 1).
  • Character button: Click this button to select the character for the bullet.
  • Graphics selection button: Opens a list of available graphics (Gallery) or allows the selection of a file on the hard disk to be used as marker.
  • Width and Height: Specify the dimensions of the graphic marker.
  • Keep ratio checkbox: If selected, the ratio between the width and the height of the graphic marker is fixed.

The right hand side of the screen shows a preview of the modifications made.

To revert to the default values, click the Reset button in the bottom right corner.

Using the Customize page, you can create complex structured layouts, for example a nested list with numbering followed by bullets.

Nested list with mixture of numbers and bullets

Changing the order or the outline level lines

Click once in a line of text to place the cursor in it, then click on the Outline tab (to the right of the Normal tab) in the Workspace and use the Promote/Demote buttons in the Text Formatting toolbar to move the text to the appropriate position and give it the appropriate outline level.

Arrows.png The button with the arrow pointing left promotes the list entry by one level (for example from Outline 3 to Outline 2), the right arrow button demotes the list entry by one level, the up and down arrow buttons move the list entry. Numbering adjusts automatically.

Tip.png You can also use the Tab key and Shift + Tab keys to promote and demote the outline level of a line in a list.



Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools