12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

My spell-checker does not seem to work?

From Apache OpenOffice Wiki
Jump to: navigation, search



Checked.png Checked for technical accuracy KNMcKenna 01:39, 9 October 2012 (UTC)


My spell-checker does not seem to work?



If you are upgrading to 3.4.x from an earlier version please read the Known Issues section in the Release Notes at http://www.openoffice.org/development/releases/3.4.1.html and follow the instructions there. If that does not solve the problem follow the procedures laid out in the rest of this FAQ.

There are several options to check:


  • Tools>Options>Language Settings>Writing Aids and check that the Hunspell SpellChecker is ticked, otherwise when you run the spell checker it will not pick up any mistakes.


  • Tools>Options>Language Settings>Languages and select the dictionary you want. If the dictionary is not installed, download it from Dictionaries or go to the OpenOffice Welcome Screen and select Tools>Extension Manager>Get More Extensions online. Once you've downloaded the files you need, in the Extension Manager click Add, find the downloaded files. If you are doing multiple downloads select one file at a time and click Open. On the next screen select whether it is for all users or just yourself, read and accept the licence agreement and the file will then be added to your installation.


  • Check Format>Character>Font tab to make sure there is the little ABC✓ check mark in front of the language (which means that the dictionary is installed). If the dictionary is not installed, download it from Dictionaries or go to the OpenOffice Welcome Screen and select Tools>Extension Manager>Get More Extensions online. Once you've downloaded the files you need, in the Extension Manager click Add, find the downloaded files. If you are doing multiple downloads select one file at a time and click Open. On the next screen select whether it is for all users or just yourself, read and accept the license agreement and the file will then be added to your installation.


  • Check the Default paragraph style Font tab to make sure there is the little ABC✓ check mark in front of the language (which means that the dictionary is installed). To check open the Styles and Formatting window from Format>Styles and Formatting or use the F11 function key. The paragraph styles are the 1st icon at the top let of the window and should be already selected. Right click the Default entry and select modify then click the font tab. If the dictionary is not installed, download it from Dictionaries or go to the OpenOffice Welcome Screen and select Tools>Extension Manager>Get More Extensions online. Once you've downloaded the files you need, in the Extension Manager click Add, find the downloaded files. If you are doing multiple downloads select one file at a time and click Open. On the next screen select whether it is for all users or just yourself, read and accept the license agreement and the file will then be added to your installation.
Documentation note.png The language dictionary could be setup differently in each paragraph and character style. You will need to check the ones you have used individually.


Clairedwood 17:10, 11 February 2010 (UTC)

Personal tools