Namen gebruiken als verwijzing naar items in formules

From Apache OpenOffice Wiki
Jump to: navigation, search


Wie houdt er niet van een formule zoals deze?

  =(E18*F25)/((GEMIDDELDE(C23:C20)) + SOM(D18:D29))

Wel, het rekenwerk is behoorlijk complex en door er alleen naar te kijken wordt ook niet echt duidelijk waarnaar het verwijst.


Als u namen gebruikt zou hebben, die u een meer heldere beschrijvende naam voor delen van uw werkblad zou hebben gegeven, zou het er uit kunnen zien zoals dit.

  =(TotaalVerkopen*TotaalMaanden) / ((GEMIDDELDE(2006Verkopen)) + SOM(VerkopenBonus))

Dat is al iets meer helder.


Maar hoe voeg je die namen toe? U kunt elke naam die u wilt als volgt toepassen:

  1. Selecteer één of meer cellen en kies Invoegen > Namen > Definiëren.
  2. Typ de naam, klik op Toevoegen, en klik dan op OK.


Dan kunt u formules zoals deze maken.

Blad met bereiknamen

Merk op dat u niet =Uitgaven_entertainen+Uitgaven_toelating kunt doen, omdat die namen verwijzen naar bereiken. U kunt =Uitgaven_entertainen+Uitgaven_toelating niet doen omdat u niet =B17:B20+E17:E20 kunt doen.

U moet meer namen maken of alleen maar naar de totalen te kunnen verwijzen. Maak andere namen voor de totaalvelden, bijvoorbeeld het totaalveld =SOM(Uitgaven_entertainen) , zodat u dan kunt typen =Tot_Uitg_entertainen+Tot_Uitg_toelating (Totaal Uitgaven entertainen plus Totaal Uitgaven toelating).


Er bestaat een snellere manier om al uw rijen en kolommen te benoemen. Laten we er van uitgaan dat u deze gegevens hebt.

Voorbeeld
  1. Selecteer alle gegevens en kies Invoegen > Namen > Maken.
  2. In dit geval is het logisch om de keuzevakken voor Bovenste rij en Linkerkolom te selecteren omdat daar de namen staan.
  3. Klik dan op OK.


Kies Invoegen > Namen > Definiëren om de gemaakte namen te bekijken.

Nu kunt u de totalen maken. Merk op dat wanneer u in een formule staat en u begint een naam te typen, die zal verschijnen in het Formuleveld, zoals "Vooraf_betaalde_belasting" dat hier doet. Druk op Enter om dit te accepteren zodat u niet de gehele naam hoeft te typen.

Formules met namen typen

Zoals hiervoor vermeld, wilt u waarschijnlijk velden maken die alleen verwijzen naar de totalen. Selecteer de cel en kies Invoegen > Namen > Definiëren. Typ de naam, bijvoorbeeld TotZakKost voor de cel G3 die de totalen voor de Zakelijke Kosten weergeeft. Klik dan op Toevoegen, en klik op OK.


En dan kunt u iets zoals dit doen met de formule. (Ja, u zou hiervoor een SOM(bereik) kunnen doen maar laten we zeggen dat u al de bedragen, Zakelijke kosten en Salaris etc. , allemaal op aparte bladen of verschillende werkbladdocumenten hebt staan, dan zou u dus in plaats daarvan de + moeten gebruiken)

berekenen met namen in formules


en krijg een resultaat.

Resultaat van de berekening


Tip.png Als u wat visuele hulp wilt hebben om na te gaan waar al die namen vandaan komen, nu u de celverwijzingen niet meer hebt, kunt u Extra > Detective > Trace Precedents.



Deze How To is gebaseerd op Solveig Haugland's Blog

Content on this page is licensed under the Public Documentation License (PDL).
Personal tools