Alle voetnoten in een document selecteren

From Apache OpenOffice Wiki
Jump to: navigation, search


Alle voetnoten in een document selecteren

Selecteren van alle voetnoten in één keer in een document, blijft in OpenOffice.org Writer < 2.4 (via Shift-toets of soortgelijk) een probleem.

Hoewel het niet direct wordt ondersteund, zijn er een aantal workarounds, afhankelijk van het doel dat u wilt bereiken.

Er zijn twee redenen om alle voetnoten te selecteren:

  • Om hun eigenschappen te veranderen (lettertype, opmaakprofiel of anderszins)
  • Om ze te exporteren, mogelijkerwijze om een lijst of bibliografie te maken.

(*Maak een veiligheidskopie van uw originele document, voordat u wijzigingen maakt waarmee u niet goed bekend bent.)


Eigenschappen van voetnoten veranderen (lettertype, opmaakprofiel of anderszins)

Het is behoorlijk eenvoudig te doen, door de globale eigenschappen van het opmaakprofiel dat uw voetnoten hebben te wijzigen (standaard zou het opmaakprofiel: Voetnoot zijn). Er is geen reden om expres alle voetnoten daarvoor te selecteren.

  1. Kies Opmaak > Stijlen en opmaak.
  2. Klik met rechts op uw opmaakprofiel (voetnoot) - wijzig.

De wijzigingen in de eigenschappen hebben een globaal effect.

Zie voor meer details het wiki-item Opmaakprofielen toewijzen met sneltoetsen.

In het geval dat uw voetnoten geen algemeen opmaakprofiel hebben, kijk dan in de volgende sectie en de mogelijkheden die worden aangeboden met reguliere uitdrukkingen.


Om alle voetnoten te exporteren (mogelijkerwijze in een lijst/bibliografie)

Er bestaan twee workarounds om alle voetnoten uit een document in één keer te extraheren naar een lijst.

De eerste is eigenlijk opnieuw een cheat, omdat het niet alle voetnoten selecteert om toch het gewenste resultaat te bereiken. Het wordt echter toch als eerste vermeld, omdat het eenvoudiger is en gewoonlijk goede resultaten oplevert, wat betekent dat het niet de opmaak verminkt in het proces.

De tweede methode maakt het u mogelijk om echt alle voetnoten te selecteren/accentueren.

Door de bestandsopmaak van het document te wijzigen

Het basale idee is om het document dat de voetnoten bevat te Opslaan als in een andere opmaak (bijvoorbeeld txt) en ze dan op te halen met een eenvoudige tekstverwerker, en ze dan terug te kopiëren en plakken in het document van OpenOffice.org.

Groepeer al uw voetnoten aan het einde van het document vóórdat u dit doet.

  1. Extra > Voet-/Eindnoten
  2. tab Voetnoten - Positie > Documenteinde. Het ziet er al perfect uit, maar helaas kunt u nog steeds niet alle voetnoten selecteren.
  3. Kies Bestand > Opslaan als en selecteer uw gewenste bestandsopmaak

Meestal is de slimste keuze om het op te slaan als .html en niet als .txt, omdat .html (en .rtf) de opmaak zoals cursief en vet behoudt.

Het .html-bestand kan worden geopend met elke willekeurige webbrowser en gekopieerd en geplakt worden in uw originele document, waarna u al uw voetnoten kunt selecteren als elke gewone tekst. Dit is waarschijnlijk de standaard manier waarop u uw voetnoten wilt exporteren. Gebruik de volgende manier alleen als u iets meer specifieks nodig hebt.


Door alle voetnoten in een document te selecteren

Het dialoogvenster Zoeken en vervangen biedt u een elegante workaround om echt alle voetnoten in één keer te selecteren.

  1. (Ctrl-F), of Bewerken > Zoeken en vervangen
  2. Breidt het menu Meer opties in het dialoogvenster uit en vink Opmaakprofielen aan.
  3. Selecteer het opmaakprofiel (voetnoot) waar u naar wilt zoeken in Zoeken naar.
  4. Klik op Alles zoeken en Writer selecteert alle voorkomende tekst die dat specifieke opmaakprofiel heeft.

Door de geaccentueerde tekst te kopiëren en weer te plakken kunt u alle voetnoten in één keer extraheren, waarbij nieuwe alinea's uiteraard verloren zullen gaan. (Het zal geplakt worden als een voortgezet tekstblok, maar zal de respectievelijke opmaak behouden - helaas helpt Plakken speciaal, Ctrl-Shift-V niet...)

U kunt echter het probleem met de nieuwe regels oplossen en in een paar seconden een voortreffelijke lijst krijgen, door de kracht van reguliere uitdrukkingen te gebruiken.


Regels/Scheidingstekens invoegen tussen voetnoten met reguliere uitdrukkingen

Indien reguliere uitdrukkingen nieuw voor u zijn, bekijk dan de volgende voorbeelden even vlug, ga dan terug en besteed 15 minuten aan het lezen van enige informatie over reguliere uitdrukkingen.

Zelfs met een paar basale dingen kunt u al heel veel doen. Zie Reguliere uitdrukkingen in Writer

(*15 minuten lezen om een klein idee te krijgen over reguliere uitdrukkingen en u zult worden beloond met een leven lang luxueus en professioneel zoeken in tekst)

1. Accentueer uw nieuwe (doorlopende) lijst

2. Bewerken - dialoogvenster Zoeken en vervangen

3. Breidt Meer opties uit en vink Alleen huidige selectie & Reguliere uitdrukkingen aan.

Bekijk zorgvuldig uw voetnoten en probeer een bepaald patroon in de tekst te vinden dat het begin van een voetnoot markeert.

Voorbeeld:
In het document is een specifieke opmaak genomen om bronnen voor citaten in voetnoten weer te geven:
ACHTERNAAM, Naam: titel..., jaar.

Het begin van een dergelijke voetnoot kan worden gevonden door te zoeken naar een patroon 
".ACHTERNAAM" dat gelijk is aan "(een punt)(hoofdletter)(meer hoofdletters)"
welke verder gelijk is aan de reguliere uitdrukking "\.[A-Z][A-Z]"

4. Typ de benodigde reguliere uitdrukking in het veld Zoeken naar en klik op Alles zoeken. Dat zou alle voorkomende moeten accentueren.

5. In het vak Vervangen door kunt u de tekenreeks invoeren waarnaar u de geaccentueerde tekst wilt wijzigen.

De truc is om het voor elkaar te krijgen dat een nieuwe alinea wordt ingevoegd tussen twee tekens (dat is een toevoeging, geen vervanging). Om deze taak in het bovenstaande voorbeeld uit te voeren: na het accentueren van de hierboven genoemde delen van de tekst, moet u opnieuw aanvinken Alleen huidige selectie en Zoeken naar "\." wat zou worden Alles vervangen door de uitdrukking ".\n" (vervangen van alle punten, in de eerdere selectie, door een punt EN een nieuwe alinea)

Het voorbeeld is bedoeld om u een idee te geven over hoe u verder kunt gaan. De echte mogelijkheden van reguliere uitdrukkingen worden alleen beperkt door uw eigen verbeelding (en door het feit dat Writer nog geen reguliere uitdrukkingen ondersteunt in het veld Vervangen door).

Als de voetnoten het geringste teken van regelmaat vertonen, bestaat er een manier om dat uit te buiten met reguliere uitdrukkingen en uzelf werk te besparen.

Door hetzelfde principe te gebruiken kunt u uw voetnoten onafhankelijk van hun opmaakprofiel extraheren, dat betekent: identificeer ze door een reguliere uitdrukking.

Voorbeeld:
Voetnoten zoals: "Dit is een zeer interessante bron. <www.openoffice.org>"
Kunnen worden opgesomd als 
"(Hoofdletter)(mogelijk meer letters)(punt)(<)(letters)(>)"
(Ideaal gesproken identificeren uw reguliere uitdrukkingen al uw benodigde uitdrukkingen, maar geen andere uitdrukkingen.)

Daarom zou het zoeken naar alle "^[A-Z].*\. <.*>$" in Zoeken en vervangen een goed begin zijn om al deze termen in één keer te accentueren.
Content on this page is licensed under the Public Documentation License (PDL).
Personal tools
In other languages