12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Duplicaat-rijen verwijderen in Calc

From Apache OpenOffice Wiki
Jump to: navigation, search

Duplicaat-rijen verwijderen in Calc

Q: Hoe selecteer ik alle unieke waarden in een kolom in een OOo Calc-werkblad? Ik wil alle overbodige rijen uit een rapport met duizenden rijen verwijderen.

A: Er bestaat geen automatische functie om duplicaat-rijen te verwijderen. Volg onderstaande stappen om alle rijen te verwijderen die een duplicaatwaarde hebben in kolom A:

  1. Selecteer alle cellen van het huidige gegevensbereik.
    Op de meeste systemen kunt u klikken op een cel binnen het gegevensbereik en dan drukken op Ctrl +Vermenigvuldigingstoets op het numerieke toetsenbord.
  2. Sorteer de gegevens in kolom A.
    Kies Gegevens - Sorteren.
  3. Klikop een lege cel in de eerste rij. Laten we aannemen dat dat cel C1 is. Voer de volgende formule in:
    =ALS(A1=A2;1;0)
    Dit zal een 1 weergeven als de huidige rij dezelfde waarde in kolom A heeft als de volgende rij. Het zal 0 weergeven als de waarden van elkaar verschillen.
  4. Kopieer de formule naar beneden voor alle rijen van het gegevensbereik.
    Sleep aan de rechter benedenhoek van cel C1 naar beenden tot en met de laatste rij.
  5. Nu moeten de formules worden vervangen door hun waarden om de inhoud te fixeren.
    Terwijl kolom C nog steeds is geaccentueerd, druk op Ctrl+C om alle geselecteerde cellen naar het klembord te kopiëren.
  6. Druk op Shift+Ctrl+V om het dialoogvenster Plakken speciaal te openen.
    In het gebied Selectie, schakel alleen de opdracht Getallen in; schakel alle andere opdrachten in Selectie uit. Klik op OK.
  7. Selecteer het gehele gegevensbereik inclusief de nieuwe kolom C en sorteer het bereik op kolom C.
    Kies Gegevens - Sorteren.
  8. Selecteer alle rijen die de waarde 1 hebben in kolom C, druk dan op de Del-toets.
  9. Optionele stappen: verwijder kolom C. Selecteer de resterende rijen en sorteer die opnieuw op kolom A.

Tip: Deze methode kan ook worden gebruikt om duplicaat-tekstregels uit een Writer-document te verwijderen. Kopieer de tekst naar een Calc-werkblad. Verwijder de duplicaten, kopieer en plak speciaal als "niet-opgemaakte tekst" naar Writer.

Content on this page is licensed under the Public Documentation License (PDL).
Personal tools