12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

The Table menu and toolbar

From Apache OpenOffice Wiki
Jump to: navigation, search


Table commands are located in the main Table menu and on the Table toolbar, shown in Figure 1. Table 1 describes the functions of these commands and icons.

TableToolbar.png
Table toolbar:
1 Table 2 Line Style 3 Line Color (of the border) 4 Borders 5 Background Color 6 Merge Cells 7 Split Cells 8 Optimize 9 Top 10 Center (vertical) 11 Bottom 12 Insert Row 13 Insert Column 14 Delete Row 15 Delete Column 16 AutoFormat 17 Table Properties 18 Sort 19 Sum

When you create a table or select an existing table, the Table toolbar may be displayed automatically. You can manually display the Table toolbar by clicking View > Toolbars > Table. The toolbar can float on top of the main Writer window (as above) or it can be docked along any side of the window.

Table 1: Functions of the icons on the Table toolbar

Icon Name Description
Table Opens the Insert Table dialog box where you can set up and insert a table into the document, name the table for use with the Navigator, and set some options. You can also use the mouse to click the arrow at the right, drag to select the number of rows and columns to include in the table, and then release the mouse button on the last (lower right) cell.
Line Style Opens the Border Style toolbar where you can modify the style of the border line.
Line Color (of the border) Opens the Border Color toolbar where you can modify the color of the border.
Borders Opens the Borders toolbar where you can select which sides should have a border.
Background Color Opens the Background toolbar where you can select the background color.
Merge Cells Combines the selected cells into a single cell. Refer to Merging and splitting cells for an example of using this button.
Split Cells Opens the Split Cell dialog box where you can define how to split a cell. Refer to Merging and splitting tables for an example of using this button.
Optimize Opens the Optimize toolbar where you can distribute the columns or rows evenly or optimize the row height or column width.
Top Aligns the contents of the selected cells to the top of the cell.
Center (vertical) Aligns the contents of the selected cells to the center of the cell.
Bottom Aligns the contents of the selected cells to the bottom of the cell.
Insert Row Inserts a row below the selected row.
Insert Column Inserts a column after the selected column.
Delete Row Deletes the selected row(s) from the table.
Delete Column Deletes the selected column(s) from the table.
AutoFormat Opens the AutoFormat dialog box where you can select among several predefined formatting sets. Each set is characterized by its own fonts, shading, and borders styles. You can also select AutoFormat from the Insert Table dialog box.
Table Properties Opens the Table Format dialog box where you can modify various properties for the table—for example: name, alignment, spacing, column width, borders, and background.
Sort Opens the Sort dialog box where you can specify the sort criteria for the selected cells.
Sum Activates the sum function. Refer to Using spreadsheet functions in a table for an example of using this function.


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools