12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Inserting a chart

From Apache OpenOffice Wiki
Jump to: navigation, search


Inserting a chart

To add a chart to a slide, select the corresponding layout in the list of predefined layouts in the task pane or use the Insert Chart feature.

Creating a chart in AutoLayout

  1. In the Tasks pane, choose a layout that contains a chart (look for the vertical bars).
  2. Examples of AutoLayout templates with charts
    Examples of AutoLayout templates with charts.

  3. Double-click the chart icon in the center of the chart area. A full-sized chart appears that has been created using sample data.
  4. Chart made with sample data
    Chart made with sample data.

  5. To enter your own data in the chart, see Entering chart data.

Creating a chart using the Insert chart feature

  1. Select Insert > Chart, or click the Insert Chart icon [[Image:]] on the Standard toolbar. A chart appears that has been created using sample data. See Figure 7.
  2. To enter your own data in the chart, see Entering chart data.

Choosing a chart type

  1. Double-click the chart. It should now have a gray border. The main toolbar has now changed to show tools specifically for charts. (If the main toolbar is not showing, select View > Toolbars > Main Toolbar.)
  2. Click the Chart Type icon ChartTypeIcon.png or select Format > Chart Type. The Chart Type dialog appears.
  3. Chart Type dialog showing 2-dimensional charts
    Chart Type dialog showing 2-dimensional charts.

  4. In the section Chart category, select either 2D or 3D to see the different types of charts.
  5. In the section Chart type, click one of the icons to select it and see the different variants of the selected chart type in the Variants section.
  6. Choose a chart variant.
  7. Click OK. The chart in the presentation reflects the new type selected.

Entering chart data

Opening a chart data window

  1. Double-click the chart. It should now have a gray border. The main toolbar has now changed to show tools specifically for charts.
  2. Click the Chart Data icon ChartDataIcon.png or select Edit > Chart Data. The Chart Data window appears. (If the main toolbar is not showing, select View > Toolbars > Main Toolbar.)

Chart Data area
Chart Data area.

Entering data

Enter data in the Chart Data window.

  • Insert buttons insert a row or column.
  • Delete buttons remove the information from a selected row or column.
  • Switch buttons exchange the contents of the selected row with the contents of the row below it, or the contents of a column with those of the column to the right.
  • Sort buttons organize the content in ascending order. You can sort data within a selected row or column, or sort the rows or columns themselves.
  • Apply to Chart transfers the data from the table to the chart.
  • Input fields are where you insert data. Enter information in the boxes within the desired rows and columns.
Tip.png By dragging the Chart Data window so that your chart is visible, you can immediately see the results after clicking the Apply to Chart button.


Formatting the chart

Format menu

The format menu has many options for formatting and fine-tuning the look of your charts.

Double-click the chart so that it is enclosed by a gray border. Click Format in the main menu list.

Chart format menu
Chart format menu.

  • Title formats the titles of the chart, the x axis and y axis.
  • Legend formats the location, borders, background, and type of the legend.
  • Axis formats the lines that create the chart as well as the font of the text that appears on both the X and Y axes.
  • Grid formats the lines that create a grid for the chart.
  • Chart Wall, Chart Floor, and Chart Area are described in the following sections.
  • Chart Type changes what kind of chart is displayed and whether it is two- or three-dimensional.
  • Auto Format takes you through the AutoLayout feature.
  • 3D Effects formats various elements of a 3D chart.
  • 3D View formats the various viewing angles of 3D chart.
Documentation note.png Chart Floor, 3D Effects, and 3D View options are only available for a 3D chart. These options are unavailable (grayed out) if a two-dimensional chart is selected.

The two main areas of the chart control different settings and attributes for the chart.

Chart wall and Chart area
The Chart wall and Chart area.

  • Chart wall contains the graphic of the chart displaying the data.
  • Chart area is the area surrounding the chart graphic. The main title and the key are in the chart area.
Documentation note.png Chart Floor, from the Format menu, is only available for 3D charts and has the same formatting options as 3Chart Area and Chart Wall.

Knowing the difference between the chart wall and chart area is helpful when formatting a chart.

Resizing the chart

  1. Click on the chart to select it. Green sizing handles appear around the chart.
  2. To increase or decrease the size of the chart, click and drag one of the markers in one of the four corners of the chart. To maintain the correct ratio of the sides, hold the Shift key down while you click and drag.

Moving chart elements

  1. Double-click the chart so that is enclosed by a gray border.
  2. Click any of the elements—the title, the key, or the chart graphic—to select it. Green resizing handles appear.
  3. Move the pointer over the selected element. When it becomes a four-headed arrow, click and drag to move the element.
  4. Release the mouse button when the element is in the desired position.
Documentation note.png If your graphic is 3D, round red handles appear which control the three-dimensional angle of the graphic. You cannot resize or reposition the graphic while the round red handles are showing. With the round red handles showing, Shift+Click to get the green resizing handles. You can now resize and reposition your 3D chart graphic. See the following tip.
Tip.png You can resize the chart graphic using its green resizing handles (Shift+Click, then drag a corner handle to maintain the proportions). However, you cannot resize the title or the key.


Changing the chart area background

  1. The chart area is the area surrounding the chart graphic, including the main title and key.
  2. Double-click the chart so that it is enclosed by a gray border.
  3. Select Format > Chart Area. The Chart Area dialog appears.
  4. Choose the desired format settings.
Chart Area dialog
Chart Area dialog.

Changing the chart graphic background

The chart wall is the area that contains the chart graphic.

  1. Double-click the chart so that it is enclosed by a gray border.
  2. Select Format > Chart Wall. The Chart Wall dialog appears. It has the same formatting options as described in Changing the chart area background.
  3. Choose your settings and click OK.


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools