12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Toolbars

From Apache OpenOffice Wiki
Jump to: navigation, search



The various Draw toolbars can be displayed or hidden, according to your needs.

To display or hide the toolbars, click View > Toolbars. On the menu that appears, choose which toolbars you want to display.

You can also select the icons that you wish to appear on the toolbars. Some toolbars have icons that are not displayed by default, but you can choose to display them; you can also hide any icons that do appear on the toolbars by default. To change the visible icons on any toolbar, click the arrow at the right-hand end of the toolbar and select Visible Buttons. On the list of the available tools that appears, select or de-select the icons you want to be visible. A checkmark next to an icon indicates that it will be visible.

Floating toolbars

Many toolbar icons are marked with a small arrow. The arrow indicates that this icon has additional functions. Click the arrow, and a sub-menu or floating toolbar appears, showing its additional functions (see Figure 6).

You may wish to keep this sub-menu displayed on your screen, but in a different position. You can make a sub-menu into a floating toolbar. To do so, click the area at the top of the sub-menu, drag it across the screen, and then release the mouse button. Floating toolbars can be re-docked on an edge of the screen or within one of the existing toolbar areas at the top of the screen, as described in Chapter 4.

Most icons marked with the small arrow can become floating toolbars. The floating toolbar capability is common to all components of the OpenOffice.org suite.

An arrow next to a icon indicates additional functions
Figure 6: An arrow next to a icon indicates additional functions.

Tip: If you double-click on an icon on a floating toolbar, the command corresponding to that icon is executed. You can then repeat this as often as you like. To exit from this mode, press the Esc key or click on another icon (for example [[Image:]]).

Note: The icon of a floating toolbar always shows the last used command. This can mean that the icon you see on your screen may differ from that shown in this Guide.

Similarly, click on the arrow on the title bar of a floating toolbar to display additional functions (see Figure 7).

An arrow on a floating toolbar indicates additional functions
Figure 7: An arrow on a floating toolbar indicates additional functions.

In Draw, as in all components of OpenOffice.org, toolbars can be moved to a new position with the mouse. Hover the mouse over the end of the toolbar (look for two vertical columns of dots) until the cursor becomes two crossed arrows and then drag and drop as desired).

The tools available in the various toolbars are explained in the following sections.

Standard toolbar

The Standard toolbar is the same for all components of OpenOffice.org and is not described in detail here.

Standard toolbar
Figure 8: Standard toolbar.

Line and Filling toolbar

The Line and Filling toolbar lets you modify the main properties of a drawing object: the icons and pulldown lists vary according to the type of object selected. For example, to change the thickness of a line with the spinner, hover the mouse over the spinner and click the up or down arrow to achieve the desired thickness.

Line and Filling toolbar
Figure 9: Line and Filling toolbar.

In the example above, the available functions enable you to change the color, style and width of the line drawn, or the fill color, style, and other properties of an object. The object must first be selected with a mouse click. If the selected object is a text frame, the buttons for line style and fill color are changed to Invisible.

When text is selected, the Line and Filling toolbar changes to the Text Formatting toolbar, which is very similar to the Formatting toolbar in Writer. A more detailed explanation of the buttons on this toolbar can be found in Chapter 4.

Text Formatting toolbar
Figure 10: Text Formatting toolbar.

Drawing toolbar

The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary functions for drawing various geometric and freehand shapes and organizing them on the page. It is described in detail in Chapter 2.

Drawing toolbar
Figure 11: Drawing toolbar.

Color bar

To display the Color bar, use View > Toolbars > Color Bar. The toolbar then appears at the bottom of the workspace and shows you the current color palette.

Color bar
Figure 12: Color bar.

This toolbar lets you rapidly choose the color of the various objects—lines, areas, 3D effects—in your drawing. The first box in the panel corresponds to transparency (no color).

You can access several specialised color palettes in Draw as well as change individual colors to your own taste. This is done using the Area dialog, reached by choosing Format > Area as shown in Figure 13, or the pouring can symbol on the Line and Filling toolbar (Figure 9).

Two ways to display the Area dialog
Figure 13: Two ways to display the Area dialog.

On the Area dialog, choose the tab marked Colors (Figure 14).

To load another palette, click on the Load Color List button (circled). The file selector dialog asks you to choose one of the standard OpenOffice.org palettes (files bearing the file extension *.soc). For example, web.soc is a color palette that is particularly adapted to creating drawings that are going to appear in Web pages; the colors will be correctly displayed on workstations with screens displaying at least 256 colors.

A more detailed description of color palettes and their options can be found in Chapter 8.

Changing the color palette
Figure 14. Changing the color palette.

Options toolbar

The Options toolbar lets you activate or deactivate various drawing aids. The Options Bar is not one of the toolbars displayed by default. To display it, select View > Toolbars > Options.

Options toolbar
Figure 15: Options toolbar.

The most important options for starting work in Draw are enclosed in red above. Their functions are described in the table below. The other buttons are described in detail in the relevant chapters of this Guide.

Table 1: Functions on the Options toolbar

Icon     Function
DisplayHideGridIcon.png Display or hide the Grid
DisplayHideGuidesIcon.png Display or hide the Guides
DisplayHideGuidesMovingIcon.png Display or hide Guides when moving
SnaptoGridIcon.png Snap to Grid
SnaptoGuidesIcon.png Snap to Guides
SnaptoPageMarginsIcon.png Snap to Page Margins
SnaptoObjectBordersIcon.png Snap to Object Borders
SnaptoObjectPointsIcon.png Snap to Object Points

Drawing grid and guides

Draw offers a grid as a drawing aid. The grid can be turned on or off by clicking on the Grid icon on the Options toolbar. The points of the grid displayed on the screen are not shown on the printed drawing. The color, spacing and resolution of the grid points can be individually chosen for each axis. This is described in more detail in Chapter 8 (in the section titled “Configuring the Grid”).

Guides are special “helper lines” that can be turned on or off by clicking on the Guides icon on the Options toolbar. Draw offers a “Snap” function (1), with which you can place drawings exactly on these guides. All snap functions are described in detail in Chapter 8.

Showing the position of the object while moving it makes positioning the object much easier. If this function is activated, pairs of vertical and horizontal lines enclosing the object are shown while moving the object. These lines extend to the edges of the drawing area. This function is also described in detail in Chapter 8.

(1) Drawing objects can be snapped; that is, they can be attached to a grid point, a guide, a page margin, or a border or point of another object.

Customizing toolbars

For greater control, you can add other functions to a toolbar and move tools between toolbars. To do this, in the View > Toolbars menu select Customize, click on the Toolbars tab (see Figure 16), select the toolbar you want to change, and then select the desired buttons for that toolbar. Each toolbar has a different list of buttons.

Customizing a toolbar
Figure 16: Customizing a toolbar.


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools