12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Printing envelopes

From Apache OpenOffice Wiki
Jump to: navigation, search


Instead of printing mailing labels, you may wish to print directly onto envelopes. There are two basic ways to create envelopes, one where the envelope is embedded within a letter, generally as the first page (Insert in the Envelope dialog box), and another where the envelope is an independent document (New Doc. in the dialog box). In each case the addressing data may be manually entered, for example by copying and pasting from the letter with which it is associated, or it may originate within an address data source.

This section assumes the use of an address data source and, for convenience, a free-standing envelope.

The production of envelopes involves two steps, setup and printing, as described in this section.

Setting up envelopes for printing

To set up envelopes to be printed with your letters:

  1. Choose Insert > Envelope from the menu bar.
  2. In the Envelope dialog box, select the Format tab (shown below), where you can select the envelope format to use. You can then arrange the layout of the envelope to suit your requirements, together with the character and paragraph attributes to be used in the Sender and Addressee areas. These attributes are accessed using the Edit buttons to the right of the dialog, next to the word Format.
  3. Tip.png At this stage it is not possible to vary the dimensions of the frames that will hold the Sender and Addressee information, but once the envelope has been created this will become possible and you may wish to make some cosmetic adjustments.


    Envelope formatting dialog.
  4. The next step is to select the Printer tab, from where you may choose the printer you intend to use, its setup—for example, specification of the tray holding envelopes—and other printer-related options such as envelope orientation and shifting. You may need to experiment with these settings to achieve the best results with your printer.
  5. Choosing printer options for an envelope.
  6. You now have the choice of creating the Addressee fields by dragging and dropping from the data source headings (as described in Creating a form letter, or using the facilities of the Envelope tab.
  7. If you prefer dragging and dropping, than click New Doc., drag your data source headings into the Addressee area on your new envelope and skip to step 7), otherwise continue with steps 5 and 6.

  8. Select the Envelope tab. Verify, add, or edit the information in the Addressee and Sender boxes (Sender is the “from” on the envelope). You can use the right-hand dropdown lists to select the database and table from which you can access the Addressee information, in a similar fashion to that described for Printing mailing labels, paragraphs 3, 4 and 5. The similarity of the method with the figures in that section will be clear.
  9. Choosing Envelope Addressee fields and Sender Information for Envelopes.
  10. When you have finished formatting, click either the New Doc. or Insert button to finish. As might be expected, New Doc creates only the envelope template in a new document, whereas Insert inserts the envelope into your current document as page 1.
  11. If you don’t want to proceed with this envelope, click Cancel or press the Esc key. You can also click Reset to remove your changes and return to the original settings when the dialog box opened.

  12. Quite often some of the fields in your address data source will be unused, leading to blank lines in your envelope Addressee area. If this is not important, you can skip the next few paragraphs and go straight to Merging and printing the envelopes, otherwise continue as described here.
  13. Tip.png The following procedure is very similar to that used for a similar purpose in the section on printing mailing labels. It is reproduced here for purposes of clarity.


    1. First ensure that the envelope is showing the field contents (data source headings), rather than their underlying field names. If this is not the case, then either press Ctrl+F9 or select View > Field Names to toggle the view.
    2. Next, ensure that you can see non‑printing characters, such as paragraph marks, line breaks and so on. If these are not already visible, select View > Nonprinting Characters from the menu bar, or press Ctrl+F10, or click on the large paragraph icon ParagraphIcon.png in the Standard toolbar.
    3. You will now see that address field separation is created by line breaks LineBreakSym.png, rather than paragraphs ParagraphSym.png. As the suppression of blank address fields depends on hiding paragraphs, not lines, you need to replace line breaks with paragraphs as follows.

    4. Click at the end of the first data source address field. Press Delete to remove the new line and then press Return (or the Enter key) to insert a paragraph. Repeat this action for each data source address field.
    5. If the line spacing in the Addressee area is not satisfactory, you may wish to correct this before proceeding, by modifying the paragraph style associated with the address. Unless you have changed it, the address uses the Default style.

    6. Click again at the end of the first paragraph to be suppressed and then select Insert > Fields > Other. Select the Functions tab and then click on Hidden Paragraph in the Type column. Now click in the Condition box and enter the details of the condition that defines a blank address field. It has the general form of:
      ![Database.Table.Database field] where the ‘!’ (NOT) character indicates the negative case and the square brackets delineate the condition.
    7. For example, in our Points database the condition to test if the Last Name field is empty would be:

      ![Points.Sheet1.Last Name].

      To test for multiple conditions, use the operators AND and/or OR between the conditional statements, for example:

      ![Points.Sheet1.Title]AND![Points.Sheet1.Last Name].

      Click Insert, but do not close the dialog until all lines have been amended.

    8. Repeat for each paragraph to be conditionally suppressed, remembering to advance the cursor to the end of the line in question before changing the last element of the condition and Inserting the result.

Merging and printing the envelopes

To merge addresses and print the envelopes:

  1. Choose File > Print. A message box appears. Click Yes.
  2. The Mail Merge dialog appears. As with form letters and mailing labels, you can choose to print envelopes for one, several or all address records in the database.
  3. Make your selections and then click OK to print direct to the printer. If you wish to check the envelopes before printing them, see Step 9 of Creating a form letter for instructions.


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools