Documentation/How Tos/Doing Formulas in Writer Calc and Impress

From Apache OpenOffice Wiki
Jump to: navigation, search

Sooner or later, no matter who you are, you are going to have to talk about pi. Or you are going to need to talk about squaring lambda. Or you will need to have a+b+c divided by 2.

How do you do that in OpenOffice.org?


To Use the Special Characters Window

  1. If you just want a Special Character, pi or lambda or something, choose Insert > Special Character.
  2. Find the special character you want. If you select several you will see them all displayed at the bottom of the window and they will all be inserted.
  3. Then just click Ok. The character will show up.
Tip.png If you have to insert the same formula several times you can make an AutoText entry for it.



To Use the Formulas Features

  1. If you need something more complex, then instead, choose Insert > Object > Formula.
    You get an editing window at the bottom, a box for the equation in the document, and a little Selection window floating off to the side.
  2. Now, in the Selection window click an item above the line, then click an item below the line. That inserts some placeholder stuff for you in the editing window.
  3. Click in the document when you are done.


But just writing the formulas in the editing window is reasonably easy once you memorize a few tips.

  • Use the Formula Reference Tables online help list to see how to enter formulas. Basically, do it how you think it would work. Use the OpenOffice.org Math Examples online help list to see examples. These are really good. Just press F1 while you are in the editing window and type examples into the Index window.
  • Use ^ for exponents, as in 3^2 which would be three, squared.
  • Use sqrt for square root
  • Use % in front of the written version of a symbol, as in %pi


So here are a few formulas. They are pretty easy to figure out.

Enter a + b / %pi in the editing window


Enter a + b over %pi in the editing window


Enter (a + b) over %pi in the editing window

If You do Not Know How to Write Out Special Characters Like π

  1. Click the Catalog icon in the tools bar at the top to add a special character.
  2. Scroll through the Symbols dialog, select something from the list, and click insert.
  3. If you do not see what you need, click Edit.
  4. Find what you want, by scrolling and manipulating all the dropdowns. Then name it, and click Add. The new symbol will show up in the symbol list.
  5. Click in the document to stop editing the formula.
  6. If you want to get back into the formula to change it, double-click the box the formula is in.

To Format the Formula

You have got a great formula. But it is really small. Or you would like a different font.

  1. Select the formula in the editing window and choose Format > Fonts. You get to choose the font by the type: variables, etc.
  2. Click and hold down on the Modify button to change any font.
  3. Select the font in this window, then click OK all the way back out of the windows.
  4. To change the font size, select Format > Font Size.



See Also




This How To comes from Solveig Haugland's Blog

Content on this page is licensed under the Public Documentation License (PDL).
Personal tools
In other languages