12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Java Runtime Environment (JRE)

From Apache OpenOffice Wiki
Jump to: navigation, search


Edit-find-replace.png This article needs to be checked for accuracy and style.

Documentation exclamation.png    This article is outdated.    


Where do I get a Java Runtime Environment (JRE) for Mac OS X 10.5 "Leopard"?



There is currently [Opened: Thu Oct 21 13:52:00 +0000 2010] a Bug reported for those using OpenOffice 3.2.1 with OSX http://www.openoffice.org/issues/show_bug.cgi?id=115180


Apple confidently tells you that "Every version of Mac OS X comes with Java out of the box." Specifically, Leopard comes with J2SE 5.0 preinstalled, based on JDK 1.5.0_13_b05.

However, Java is structured differently on Leopard than it was on Mac OS X 10.4 "Tiger". Thus OpenOffice 2.3.x is not able to recognise the JRE on Leopard. As of 2008-Mar-14, the Mac OS X 10.4/5 download page says,

Please note that the Java features of OpenOffice.org are only available from OpenOffice.org 2.4 (more specifically milestone m237) and later. This means that the Wizards, Base and some other things are unavailable in 2.3.1 or earlier. All other functionality of OpenOffice.org remains on Leopard.

As of 2008-Mar-14, Open Office 2.4.x development versions do appear to recognise the Java Runtime Environment on Leopard successfully. Look for milestone m237 or later. (Ref: "JRE with Database", Fri, 8 Feb 2008 14:39:16 +0100, Guy Voets) Base, a Java-dependent part of OOo, apparently works on Leopard using OOo 2.4RC4. (Ref: "Jre on Leopard", Thu, 13 Mar 2008 13:50:23 -0700, Rodney D. Myers). Download development builds from http://ooopackages.good-day.net/pub/OpenOffice.org/MacOSX/ .


Personal tools