12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

How do I open a tab-delimited file in OpenOffice.org Spreadsheet? What if I have a different type of delimiter?

From Apache OpenOffice Wiki
< Documentation‎ | FAQ‎ | Calc‎ | Files
Jump to: navigation, search


How do I open a tab-delimited file in OpenOffice.org Spreadsheet? What if I have a different type of delimiter?


First, if your ASCII file is not already named with a .txt extension, rename it that way.

  1. Select File > Open from the main menu and browse to find and select the file.
  2. Select File type: Text CSV (.csv; .txt)
    Note: This choice is near the bottom in the spreadsheet file types section of the list.
  3. Click Open.
  4. In the dialog that appears next, select the Separator options.
    These are the characters or methods used in the file to separate the fields of data. The same methods must be specified in this box as those used in the file to import the data into a spreadsheet. After selecting the separator type, a preview of the data will be displayed in the Fields section. If the data visually lines up in columns, then the correct separator has been selected. If not, a different separator type may be used in the file. The goal is to match the correct character used as a separator in the file, so that the data will line up nicely in the visible cells.
  5. When the data lines up, click OK.

Hints:

  • The characters used as a separators and delimiters will be visible, if you open the .txt file in Writer and enable the hidden characters (View > Nonprinting Characters).
  • If your file still only opens in Writer, check if it doesn't contain illegal characters, e.g. null characters. They will show as (rows of) #'s in Writer. Delete these illegal characters (in Writer), save (a copy of?) the file and reopen this in Calc, as "Text CSV".
  • Use Windows Explorer to find subject file i.e. XYZ.TAB, then click Right on this file and use Open with ... and select OO Calc as the program to open it.
    OO will now show the Separator Options window. Select Tabulator.


Personal tools