Linux Build Requirements

From Apache OpenOffice Wiki
Jump to: navigation, search

Make sure that your system meets the following build requirements.

Hardware Requirements

  • 1 or more reasonable fast CPUs, x-way CPU's recommended.
  • 1 GB Ram ( 2 GB recommended )
  • 10 GB free disk space

Software Requirements

  • glibc: for OOo<=3.1: 2.2.x or higher , for OOo>3.1: 2.3.2 or higher
  • C/C++ Compiler: has been successfully build on Linux with gcc versions greater 3.3.x. Currently "officially used" GCC version is 4.2.3
  • The X11 development libraries and header files should be installed. Should be in place with most Linux distributions. Note the there are currently some issues with X version 4.3
  • PAM (should come with most Linux distributions). You must install the development package for your distribution.
  • Shell: either bash or csh are supported.

  • GTK - If you enable the crash reporter in configure then you need the gtk 2, jpeg and tiff development libraries.
Content on this page is licensed under the Public Documentation License (PDL).
Personal tools