Building old versions

From Apache OpenOffice Wiki
Jump to: navigation, search


Introduction

It can be useful to build an old version of Apache OpenOffice, for example in order to regression test a bug in the latest version.

However, over time, patches get committed to allow building on newer build environments (newer operating systems, newer settings, newer libraries (as old ones may be unavailable), etc). Thus old AOO versions may be unable to build with the latest operating systems and latest libraries. Instead of the long and difficult process of setting up an old build environment, we can backport certain patches that added the features we need, and still build older versions on newer build environments.

How to

From the base directory of trunk/, for each patch that is newer that the version you are building and that you need, run this in REVERSE ORDER of the order given below, (ie. bottom to top, which is oldest to newest):

svn diff -c <version> | patch -p0

(eg. svn diff -c 1825798 | patch -p0)

SVN revision Feature provided
1825849 All: fix building lucene with Java 1.9
1825802
1825798
Windows: support building on Windows using Cygwin64.
1825763 Windows: allow oowintool to auto-detect Java 1.9
1815542 Windows: allow oowintool to auto-detect 32 bit VC++ on Cygwin64.
1814757 Windows: allow oowintool to auto-detect Java 1.8

Personal tools