Documentation/FAQ/Writer

From Apache OpenOffice Wiki
< Documentation‎ | FAQ
Revision as of 00:04, 16 April 2007 by Jeanweber (Talk | contribs)

Jump to: navigation, search


This is a user FAQ for OpenOffice.org Writer.

Contents

Automatic functions

If I click in the middle of a table cell or in an empty paragraph, OpenOffice.org inserts tabs in front of the cursor position. How do I stop this?

This is caused by a setting in the OpenOffice.org interface called 'Direct Cursor'. To change this behavior:

  1. From the main menu bar, select Tools -> Options.
  2. In the dialog that appears, select OpenOffice.org Writer - Formatting Aids.
  3. Change the 'Insert' value to 'Left Paragraph Margin' (it was set to 'Tabs').
  4. Click on OK.


A series of '#' characters on a line by themselves has generated a bold black double line. How can I remove this line?

A series of # symbols is a keyboard shortcut to creating a solid line below a paragraph in a text document. To remove this line, click anywhere in the paragraph just above the thick line and choose Format -> Paragraph. The line set will appear on the Borders tab. To remove the line, keep the cursor in the paragraph above the line and choose Format -> Default.

Learn more about automatisms.


OpenOffice.org is changing my decimals into fractions. How do I reverse this setting?

To reverse this setting:

  • select Tools-AutoCorrect/AutoFormat-[Replace].
  • near the top of the list, find the replacement choice for '.5'
  • select this replacement description and click on the 'Delete' button to the right of the dialog
  • click 'OK' at the bottom of the dialog to apply the change.

Learn more about automatisms .


URLs (Uniform Reference Locators) appear underlined and in a different color from the rest of my text. How do I reverse this setting?

To reverse this setting:

  • Select Tools-AutoCorrect/AutoFormat-[Options]
  • Scroll down in the list that appears to the choice called 'URL recognition'.
  • Click the box to the left of this choice to turn the behavior off.
  • Click 'OK' at the bottom of the dialog to apply the change.

URL recognition also recognizes anything with the '@' symbol as an email address. Turning this option off will cause email addresses to remain unrecognized.

To selectively determine which addresses should be treated as links, leave URL recognition on, but turn off recognition by one of the following two methods:

  • Drag select the entire address
  • Hold down the context (right mouse) button
  • Select 'Default'

An address which has converted to a link may be converted back to normal text by entering Ctrl-Z before the text cursor is moved.

Learn more about automatisms.


When lower case text is typed, OpenOffice.org changes the first letter to uppercase. How do reverse this setting?

This setting is designed to correct sentences mistakenly typed starting with a lower case letter.

To reverse this setting:

  • Select Tools-AutoCorrect/AutoFormat-[Options].
  • Near the top of the list, uncheck the box next to "Capitalize the first letter of every sentence"
  • Click 'OK' at the bottom of the dialog to apply the change.

Learn more about automatisms.


When using asterisks [ asterisk = * ], OpenOffice.org removes the asterisks [ * ] and presents the text in bold. How do reverse this setting?

Typing an asterisk [ * ] before and after a word or words allows for words to be made bold without using the mouse. Similarly, typing an undersc ore [underscore = _] before and after a word or words allows for words to be underlined.

To reverse this setting:

  • Select Tools-AutoCorrect/AutoFormat-[Options]
  • Near the top of the list click the checkbox next to "Automatic *bold* and _underline_" to deselect this choice.
  • Click 'OK' at the bottom of the dialog to apply the change.

Learn more about automatisms.


How do you turn off the Automatic word completion behavior?

Open a text document. From the pulldown menus, select: Tools->AutoCorrect/AutoFormat. Select the "Word Completion" tab. Deselect the check box to the left of "Complete Words". Click on OK.


These automatisms suck!!

OpenOffice is configured in standard to execute, while typing a text, automatical formatting tasks. Those automatisms can be amazing or boring - especially because they can occur when you don't expect them.

You have two solutions: turn them off or learn to know them and domesticate them.

  • Turn them ALL off/on: under Format-AutoFormat-While Typing.
  • Turn some of them off/on: under Tools-AutoCorrect/Autoformat.

To USE them you have to know them and first recognize them, so...

How to recognize them?

When I type

I get

caused by

Note:

module

DNA

And

the replacement table

(3)
(1)

All

XImport

Ximport

 

(3)

All

coordination

Coordination

Capitalize first letter of every sentence

(3)

All

It was excl. on this day

The lowercase won't be replaced by a capital though there is a dot and I check the option "Capitalize first letter of every sentence" in the AutoFormat.

the exceptions table

(2)

Writer only

*Hello* _world_

Hello world

Automatic bold and underline

(3)

All

www.openoffice.org
john@sun.com

www.openoffice.org
john@sun.com

The URL recognition

(3)

All

1st, 2nd, 4th

1st, 2nd, 4th

The AutoFormat of the cardinal numbers

(3)

All

1/2 1/4 3/4

½ ¼ ¾

The AutoFormat of

(3)

All

The man -- yes, him!
The man--yes, him!

The man – yes, him!
The man—yes, him!

Replace dashes

(3)

All

<2_spaces>

The second space doesn't appear

Ignore double spaces

(3)

All

1 bottle of milk <Return>

1. bottle of milk
2.

Apply numbering

(3)

Writer only

---<Return> ===<Return>

          ___<Return>

horizontal lines created

Apply border

(3)

Writer only

+---+---+

a table

Create table

(3)

Writer only

My title
<Return>
<Return>

My title

Use styles

(3)

Writer only

one

*one> *test

Replace bullets

(3)

Writer only

"

« or an other typographical quote

Custom quotes

(4)

Writer only

Int

Int|roduction|
(the word is completed)

Word completion

(5))

 

1.1
in a table

01/01/03
(a date)

Number recognition

(6))

Writer only

Documentation note.png 1
Menu Tools-AutoCorrect/AutoFormat, tabpage [Replace]
Documentation note.png 2
Menu Tools-AutoCorrect/AutoFormat, tabpage [Exceptions]
Documentation note.png 3
Menu Tools-AutoCorrect/AutoFormat, tabpage [Options]
Documentation note.png 4
Menu Tools-AutoCorrect/AutoFormat, tabpage [Custom quotes]
Documentation note.png 5
Menu Tools-AutoCorrect/AutoFormat, tabpage [Word completion]
Documentation note.png 6
Menu Tools-Options-Text document-Table-Input in table-Number recognition


Formatting text

How to easily come back to the default character format while typing when I just wanted to format one word?

Example: you write default, then underlined for a while and you want to come back to the normal styles.

In this example, you have pressed [Ctrl]+U after "then" to format your text italic.
To return to the normal attribute press [Right] immediatly after the first "to" as following:

You write default, then [Ctrl]+U underlined for a while and you want to [Right] come back to the normal styles.


How to format a piece of text (not a whole page) in columns?

You have to use a section:


How to correct the text of a hyperlink? (if I click on the text the target document loads)

Quick methode: [Alt]+click

Permanant state: in the staus bar, click the field "HYP" (HYPerlink) to toggle it to "SEL" (SELection)


How to move paragraphs with the keyboard?


How to select multiple parts of the text?

Copy, cut, format, delete parts of the text in differents areas of the document:

An other method exists - the "lazy" one (don't feel about holding [Ctrl] over 150 pages!):

-> the ADD mode has the same function than [Ctrl] + click
and EXT the same function than [Shift]+click.


How do I insert a special character?

The simplest method for inserting special characters is to select them from the special character dialog:

On certain platforms, OpenOffice.org does not have certain characters available in any font, including emdash and curly double quote characters.

Characters used in mathematical formulas may be inserted using this method:

Formulas are graphical objects and characters inserted using this method may not convert well to other applications. OpenOffice.org also supports entry of certain characters (accented characters, ligatures, monetary symbols, etc.) via compose (keyboard) sequences.


How do I insert a trademark symbol?

This symbol is only available in certain fonts. On Solaris platforms, the symbol is available in the 'Symbols', 'Serif' and San-Serif' font. To insert:


I want to insert special characters with keyboard shortcuts. How do I do this?

From OpenOffice.org Version 1.1 on you can use the built in macro recorder. To assign a character to a key, follow these steps:

then insert it and close the special character dialog.

Be sure to save it under Standard, not in the tree for the document currently open. That way you'll be able to use the macro use it any time a OOo Writer window is open.

Now that you have recorded the macro, you'll need to assign it to a keystroke.

Your macro will appear in the Function window when you've found the right module.

The key you have selected will appear in the Keys window.


I have some text that I want to appear with the first character of each word in uppercase and the rest of the word in lowercase (initial uppercase or 'title case'). How do I do this automatically?

Follow these steps:

  1. Select the desired text (for example, by drag selecting).
  2. From the main menu bar, select Format -> Character (or right-click on the selected text and choose Character).
  3. On the Character dialog, choose the 'Font Effects' tab.
  4. In the 'Effects' drop-down list, choose 'Title Case'.
  5. Click on OK.

This method also works for anything that can be drag-selected, such as a table row or column.

Note: You can also set up a paragraph or character style with this characteristic and apply the style. For example, if you want all Level 1 headings to be in title case, change the Heading 1 paragraph style and apply that paragraph style to all Level 1 headings.


How do I create a hanging indent in my document?

You have two basic options, depending on how you want your hanging indent to look.


Is there something like a Format Painter feature that copies the formats of one part of the text to other parts?

There are two possibilities within OOo Writer.

For the first, follow these steps:

Another solution would be to actually add a button that acts like a format painter: It's an unofficial, but excellent addon written by the Francophone project. It adds two paintbrush icons to the tool bar, which copy and paint styles. Get it from here: [1]


Formatting lists

How do I create a simple outline-style numbered list? It should look like:

1. List Title
   1.1 First Item
   1.2 Second Item
   1.3 Third Item

There are two tools in OpenOffice.org that give you the ability to create numbered lists. One is the Format Stylist, accessed by selecting Stylist from the pulldown menu. It will open in a separate window and will default to opening the "Paragraph Styles" view. If you click on the fifth icon from the left, "Numbering Styles", you will see a list of pre-defined number styles. The other tool that you need is the numbering toolbar. At the extreme far right of the text toolbar (the bar that displays font name, font size, etc.), there is a small arrow that points to the left. Click on it. You will now see the numbering toolbar. You will not see this arrow if you are not already in a text area that has a numbering style assigned. It turns out that the numbering you want for the simple list above is already defined in the pre-defined numbering styles. If the style you need does not exist, you may also create your own styles. To create the list above:

If you need to make your own list numbering style, it is suggested to select one of the existing styles that is similar (in the Stylist), then right click to get a context menu. Select "New..." to make a new style based on the style that was selected. You will get a dialog with many tabs that allow you to configure your own numbering style. By the way, you can set up heading numbering the same way. Each heading level can be assigned a different paragraph style (e.g. Heading 1, Heading 2, Heading 3) but they all would be assigned the same NUMBERING style - so the list would number correctly. Note: OpenOffice.org will often make numbering difficult when you do the following actions:


How do I remove a large number of hard returns from text that were pasted into my document (for example, from an email message)?

Follow these steps:

Note: Regular expressions do not appear to work in the 'Replace' field.


The space between the letters in a word seems just a bit too wide. It would look better if that space is being reduced. How can I achieve this?

What you need to enable is "Kerning". Kerning is part of the typesetting process, where the space between letters is adjusted to the appearance of the letter and its neighbour. For example, when a V is followed by an A, the shape of the letters would result in a little too much space between them, and this just doesn't look nice. The A should be moved a little towards the V.

This text is not kerned:
Lvat1.jpg
As you can see, the space between the letters is just too wide. This text is kerned:
Lvat2.jpg

So how do you enable kerning?

If you need kerning only for selected parts of your text, follow these steps:

If you need the whole text to be "kerned", follow here

Note that kerning is controlled by information in the font data (in particular the font metrics). Fonts that do not need such precise corrections, like fixed width fonts, will not be subject to kerning.


Formatting pages and documents

How do I insert a Landscape page into my (portrait) document?

In your open document in OpenOffice.org:

To end the Landscape area in your document:


How do I remove an envelope from a document?

Removing an envelope from a document can be tricky.  Work is being done to make this easier in the future.  In the meantime, here are the steps to manually remove the envelope:

  1. Place the cursor at the beginning of the envelope page.
  2. If the "Stylist" dialog box is not open, press F11 or use the Menu Option Format->Stylist to open it up.
  3. Change to the Page Styles options. It's the fourth icon from the left.
  4. Double Click on "Default"
  5. Remove the remaining elements.


How can I change the defaults for a new writer document?

You need to create a template that has the settings you want and then make that template the default. The way you do this is as follows:

Part 1: Create a template

Part 2: Make your new template the default


How can I rotate a graphic with a given angle?

Up to version 1.x, Writer doesn't contain a rotation facility for graphics. To be able to rotate graphics one needs to use Draw:


How can I place a time/date variable (or field) that updates automatically into a document?

You need to insert a time/date field that indicates the time when the doc last has been modified. Follow here:


How to print an envelope in OpenOffice.org?

You need to print an envelope. Follow these steps:

  1. Open OOo Writer
  2. Insert Envelope
  3. On the Envelope tab, enter your address info.
  4. On the Format tab, set Size > Format to DL. Adjust layout to suit.
  5. On the Printer tab, Select the layout that reflects how to feed.
  6. On the same tab, you next, click on Setup. This opens a new dialogue.
  7. On the Setup dialogue, select your printer and click Properties.
  8. On the Properties dialogue, select the envelope size in the dialogue.
  9. Same dialogue, select Orientation. This depends on how your envelope feeds (see step 5) In any case, landscape means that the text is rotated 90 degrees so that it is parallel to the envelope and vice versa for portrait.
  10. If you have a manual feed tray, select this under Device.
  11. Click OK
  12. Click OK
  13. Select New Doc if you only want the envelope or insert to add it to your existing doc. I tested with New Doc.
  14. In the new window, check that all is okay and click the print icon.

Now you have an envelope.

This may seem a bit complicated but it is historical. If you would like OOo print setup to set the printer too, please vote for http://www.openoffice.org/issues/show_bug.cgi?id=47121

Skipping steps 6 through 12 will cause you no end of problems.


How to re-enable update of template style in OpenOffice.org 2.0.2?

Sub FixDocument
  TemplateName = ThisComponent.DocumentInfo.Template
  if TemplateName <> "" then
    ThisComponent.DocumentInfo.Template = TemplateName
  end if
End Sub

Next time when you open this document you will have the update from template feature back.

This is issue Issue 63320


What is the equivalent of MSO outline mode in OpenOffice.org?

Open the Navigator to have most of this functionality. The Navigator can be found in Writer's drop-down menus: Edit > Navigator.


How do I do revision marking (redlining) in OpenOffice.org?

To enable the Revision feature:

Start making your changes. You will note that all new text passages you enter are underlined in color, while all text that you delete remains visible but is crossed out and shown in color.


How do I make my first page a cover/title page and start page numbering (Page 1) on the second page of my document?

Here is the basic procedure for breaking a document into sections (for whatever purpose) as well as placing a page number in a footer of the second page:

Note: by picking a different style for the next page, you are in
effect breaking the document into two sections. The sections then
can have different characteristics (headers, footers, page
numbering, etc.). The page style that is assigned for each section
of the document can be seen by clicking into the desired page. Look
below the document window area, to the right of the "Page x/n"
block to see the page style name for the current page/section.


How do I make a header appear on only the first page of my document?

Follow these steps:


How do I make a logo appear on the top of every page of my document?

Follow these steps:

If the graphic does not appear on every page, there are two possible problems. The page style in use could have the wrong header settings. To check the settings:

If the graphic appears on one or more pages, then stops appearing, the cause is likely to be a different page style that is applied on the page where the logo ceases to appear. Look below the document, just to the right of where the page number information appears. The name that appears is the page style name. If the style name is different, the document has been broken into sections. To change this:


How do I perform a word count of my document?

Open the file, then select: File -> Properties. Click on the "Statistics" tab. The word count (and other statistics) will appear in the dialog.


How do I insert 'dummy text' into my document?

Follow these steps:


How do I create labels in OpenOffice.org?

Select: File -> New -> Labels. In the dialog that appears, you will be able to enter the initial text for the label(s) and select the label type (Avery, etc.) desired. Click on "New Document" to open the document using the settings you selected.


How do I insert a Landscape page into my (portrait) document?

In your open document in OpenOffice.org:

To end the Landscape area in your document:


I have a blank page in my word processing document. All of my content seems to fit on the previous page. How do I get rid of this extra page?

Select View -> Nonprinting Characters from the pull down menus (so that the choice is checked). This will allow you to see the special control character that is pushing the page over to another sheet. Locate that character and delete it (after making a backup of your file). Be sure to turn these options off before printing. (If left 'on' you will be prompted for whether you want to print them or not). In rare cases, playing around with the Insert -> Manual Break feature using a change of page style can cause 'ghost' pages. These are pages that have no apparent content, no hidden characters, and cannot hold a text cursor. In the case tested, these 'ghost' pages were removed by the following procedure:


How do I perform a spellcheck in a multilingual text?

When OOo checks the spelling of a word (note: word, not paragraph or text) it chooses the spelling dictionary appropriate to the language this single word comes from. This is defined in > Format > Character > Font. This individual language setting normally is set to the default language but can be changed to any other supported language.

So, to perform a spellcheck on a multilingual text you need to select each word that isn't part of the default language and assign the appropriate language in > Format > Character > Font.

However, if you want to set the whole text to a new language, highlight the whole text and change the setting in > Format > Character > Font.


How do I protect (lock) a section of text so that the content cannot be changed?

Follow these steps to protect a section of text:

To insert a password on a protected section:

Follow these steps to modify a section that you have previously protected:

Note that, once you put a password on a section, you will be prompted for that password before receiving any dialog that might have a chance to access that section of text.


How do I insert a variable for the current date into the footer of my document?

Follow these steps:

(if you don't already have one) by selecting: Insert->Footer ->Standard

You should now see the current date. If you see the name of the date field, select: View -> Fields (to turn off the check mark next to this choice). If you see nothing, it may be because you have not yet saved your document for the first time.


Tables of Contents

How do I insert a Table of Contents into my document?

Before inserting a Table of Contents, the Stylist must be used to identify headings.

To mark headings:

To Insert the Table of Contents:


How do I update my table of contents (TOC)? I've added more data and it does not reflect my new headings.

Click inside the TOC (so that your text cursor is blinking somewhere inside it), then hold down your right mouse button to get the context menu. Select "Update Index".


Trying to use the version control features for my word processing document, but some of the menu choices I've seen before do not appear. What's wrong?

Some version management functions become unavailable when you create an index (such as Table of Contents) within your document. Menu choices that will no longer appear include:


Page numbering

How do I insert a page number of the form 'Page 1 of N'?

The page number should appear in the footer or header of every page.


How do I make page numbers alternate? (eg. even page numbers on the top-left, odd page numbers on the top-right).

There are two ways to do this.

First method, using one page style only:

  1. From the main menu bar, select Format -> Page (or right-click anywhere on the page and choose Page).
  2. On the Page Style dialog, go to the Page tab.
  3. In the Layout Settings section, set Page layout to 'Mirrored'.
  4. On the Header tab, select the 'Header on' checkbox and deselect the 'Same content left/right' checkbox.

Now you can insert page numbers in the headers. On a left-hand (even-numbered) page, align the number to the left. On a right-hand (off-numbered) page, align the number to the right.

Second method, using two page styles:

  1. Open the Styles and Formatting window (F11).
  2. Select the Page Styles icon.
  3. Right-click on the 'Right Page' style to open the Page Style dialog.
  4. On the Organizer tab, set 'Next Style' to 'Left Page' (you'll have to create Left Page first if it does not exist).
  5. On the Page tab, set 'Page layout' to 'Only left'.
  6. On the Header tab, select the 'Header on' checkbox. The 'Same content left/right' checkbox is not available. Click OK to save.
  7. Back in the Styles and Formatting window, right-click on 'Left Page' to open the Page Style dialog.
  8. On the Organizer tab, set 'Next Style' to 'Right Page'.
  9. On the Page tab, set 'Page layout' to 'Only right'.
  10. On the Header tab, select the 'Header on' checkbox. The 'Same content left/right' checkbox is not available. Click OK to save.

This sets up the pages to alternate styles automatically. Now you can insert page numbers in the header as usual.

How can I change the page number of the first page of my document to something other than "1"?

  1. Click in the first paragraph of your first page and select Format > Paragraph (or right-click and select Paragraph from the pop-up menu).
  2. Go to the 'Text Flow' tab.
  3. Under 'Breaks', select 'Insert'.
  4. Make sure it says 'Page' as Type, and 'Before' as Position.
  5. Select 'With Page Style' and choose 'Default' as Page Style (or any other style according to your needs).
  6. Now choose the page number you need. Note that the '0' in the Page Number dropdown list does not denote a page number but simply means that the present page number won't be changed.

Working with tables

How to delete a table?

For this, you need to highlight the whole table, then rightclick into the highlighted area and choose > Row > Delete.


How do I join two adjacent tables?

The tables must be right next to each other for the "Join Tables" menu choice to appear. Even if there is only one text style between the tables with no content, the choice will not show up. When the tables appear to be almost touching, place your cursor into one of the tables. Right click to get the context menu. Select "Join Tables".


How do I make a table heading row repeat on each page of my word processing document that the table appears on?

A repeating header row is the default in OpenOffice.org when creating a new table. If you have an existing table, or if you are using a different text document template, follow the following instructions:


In my document, how do I repeat more than one table row when the table breaks across pages?

This function is not very intuitive, but it is possible:

If this method is used, the THEAD and TBODY tags are used when exporting to HTML format.

Retrieved from "https://wiki.openoffice.org/w/index.php?title=Documentation/FAQ/Writer&oldid=30208"
Views
Personal tools
Navigation
Print/export
Tools