Standaardbrieven maken vanuit txt-/csv-bestanden of werkbladen

From Apache OpenOffice Wiki
Jump to: navigation, search


Dit is alles wat u nodig hebt om een aardig eenvoudig document te maken, gebaseerd op gegevens in tekstbestanden of in werkbladen.


Uw gegevens ophalen

Zo zouden uw gegevens eruit moeten zien. Het mag een .txt- of .csv-bestand zijn dat met komma's of door tab's is gescheiden. Of zet ze in een werkblad. De kolommen die u wilt gebruiken bepaalt u zelf. Zet er die gegevens in die u wilt gebruiken. Zet er bijvoorbeeld Plaats, Provincie, etc. in allemaal in verschillende kolommen. Zorg er voor dat u bovenaan vermeld wat voor veld het is: Vooraam, Achternaam etc. Dat is belangrijk.


De gegevensbron maken (instructies voor tekstbestanden)

Indien uw gegevens in tekstbestanden staan volgt u deze stappen:

  1. Kies Bestand > Nieuw > Database.
  2. Selecteer Verbinden met een bestaande database, en dan Tekst als de indeling.
  3. Klik op "Volgende.
  4. Specificeer de map waar de tekstbestanden staan. Elk tekstbestand in die map zal een tabel in uw database zijn. Selecteer dan het item dat de velden van elkaar scheidt, d.i. een tab of een komma of iets anders.
  5. Wanneer alle instellingen er goed uitzien, klik op Volgende.
  6. Verwijder het vinkje van de optie om de database te openen om te bewerken. U mag het openen; het is alleen niet nodig.
  7. Klik op Voltooien.
  8. Sla de gegevensbron (alias database) op onder een naam die u zal helpen te onthouden wat het is.


De gegevensbron maken (instructies voor werkbladen)

Volg deze stappen als uw gegevens in een werkblad staan.

  1. Kies Bestand > Nieuw > Database.
  2. Selecteer Verbinden met een bestaande database, en dan Werkblad als de indeling.
  3. Klik op "Volgende.
  4. Specificeer het werkbladbestand. Elk blad in dat werkblad zal een tabel in uw database zijn.
  5. Klik op "Volgende.
  6. Verwijder het vinkje van de optie om de database te openen om te bewerken. U mag het openen; het is alleen niet nodig.
  7. Klik op Voltooien.
  8. Sla de gegevensbron (alias database) op onder een naam die u zal helpen te onthouden wat het is.


Uw standaardbrief maken en de gegevens uit de gegevensbron ophalen

  1. Maak een nieuw Writer-document of open een document dat de tekst bevat die u in uw standaardbrief wilt hebben.
  2. Kies Beeld > Gegevensbronnen. Alles wat u hebt gemaakt zal worden weergegeven.
  3. Klik op het teken + bij de gegevensbron die u wilt gebruiken en klik dan op de + bij Tabellen totdat u de gegevens ziet die u wilt gebruiken.
  4. Typ alle inhoud die u wilt en pas de opmaak toe. U kunt dat ook later doen.
  5. Klik op de veldnaam, niet de gegevens, die u in uw standaardbrief wilt hebben.
  6. Sleep het in het document en laat dan los. De veldnaam zal verschijnen. Wanneer u afdrukt zullen de juiste gegevens verschijnen.
  7. Voeg alle andere inhoud en velden toe die u wilt.
  8. Sla het document op. U kunt nu gaan afdrukken.

Standaardbrieven afdrukken

1. Kies Bestand > Afdrukken.

2. U zult een bericht zien waarin u wordt gevraagd of u een standaardbrief wilt afdrukken. Klik op Ja.

Documentation caution.png Selecteer NIET het keuzevak dat zegt dat u dit bericht niet meer wilt zien.

3. In het venster Standaardbrief, indien u niet alle records wilt gebruiken, selecteert u het eerste record, houdt de Ctrl-toets ingedrukt en selecteert de volgende, enzovoort. Of, specificeer het bereik van de records.

4. Specificeer om af te drukken naar een printer, of naar bestanden en klik op OK.

5. Specificeer, in het venster Afdrukken, de printer en klik op OK.


Enveloppen afdrukken

Enveloppen is niet zo erg als u eenmaal hebt uitgedokterd hoe het de eerste keer moet. Dit zijn de belangrijkste punten.

  • U moet uw printer leren kennen en die laten weten om envelopvormen te verwachten, geen vormen als A4 of letter.
  • U dient ook een beetje uit te proberen om uit te vogelen waar (links, rechts, loodrecht, parallel) in de lade uw printer de enveloppen verwacht. Koop een mapje met goedkope enveloppen en verwacht er een paar te verbruiken als u hiermee experimenteert.
  • Zorg er dan voor dat uw document voor de enveloppe zo is ingesteld dat die wordt afgedrukt op de grootte van de enveloppe die uw printer verwacht. Enveloppe 10 is goed.
    • U kunt uw gegevens voor de enveloppe intypen of een gegevensbron gebruiken. De eenvoudigste manier is door te kiezen Bestand > Nieuw > Tekstdocument, en dan Opmaak > Paginagrootte en in plaats van Letter of A4, Enveloppe 10 te kiezen en de richting te wijzigen naar liggend. Plaats dan, met de opmaak voor standaardmarges of met frames, de tekst waar u doe wilt hebben.
    • Als een andere manier om het document voor de enveloppe te maken, kunt u ook kiezen voor Invoegen > Enveloppe, en het venster met de drie tabs gebruiken dat dan verschijnt.
  • Druk de enveloppen afzonderlijk van uw brief, of andere document dat met de enveloppe meegaat, af. Het compliceert dingen teveel met de papiergrootte die de printer verwacht. Indien u gegevensbronnen gebruikt, klik op Ja in het dialoogvenster dat verschijnt en vraagt of u een standaardbrief wilt afdrukken.
  • De volgende keer dat u enveloppen wilt, gebruikt u eenvoudigweg hetzelfde document dat u al gemaakt hebt en wijzigt de adressen. Sla het document op in mijnbelangrijkedocumenten\enveloppen, of, als u iemand bent die van sjablonen houdt, maak er een sjabloon van. (Bestand > Sjablonen > Opslaan, selecteer een categorie en geef de sjabloon een naam, kies dan Bestand > Nieuw > Sjablonen en documenten en kies de sjabloon van uw enveloppe.)


Tip.png Soms zit de pijn van de enveloppen in de instelling van de printer. Voeg, in plaats van het constant wijzigen en controleren van de instellingen van de printer, een extra instantie van die printer toe, configureer die voor enveloppen en noem die "enveloppe." Kies dan deze printer voor het afdrukken van een enveloppe in plaats van de standaard printer. Op die manier zijn uw instellingen altijd hetzelfde.


Etiketten afdrukken

Als u eenmaal de database hebt ingesteld in OpenOffice.org, bent u er klaar voor.

  1. Kies Bestand > Nieuw > Etiketten.
  2. Selecteer, op de tab Etiketten van het venster Etiketten, de database die u hebt gemaakt in de openklaplijst Database. (U zoekt naar de naam van de database die u hebt gemaakt door te kiezen Bestand > Nieuw > Database, niet het werkblad, adresboek, of tekstbestand dat de gegevens bevat.)
  3. Selecteer een tabel uit de lijst Tabel. Dit zal Blad1 zijn of eender welke bladnaam, indien u een werkblad gebruikt om uw gegevens in op te slaan.
  4. Selecteer het eerste veld dat u wilt gebruiken uit de lijst Databaseveld en klik op de pijl daarnaast om het in te voegen in het veld Etikettekst.
  5. Gebruik de lijst Databaseveld om alle andere velden in te voegen die u wilt. Typ een spatie na het veld en u kunt het volgende veld toevoegen, zoals Achternaam. Indien u velden op de tweede regel wilt hebben, klik dan achter het laatste teken van het laatste veld dat u hebt ingevoegd, in het grote tekstvak, en druk gewoon op Enter. Indien u later de schikking in het gemaakte document met etiketten wilt wijzigen, dan kan dat.
  6. In de keuzelijst Merk, selecteer Avery A4 als u geen Letter gebruikt.
  7. In de keuzelijst Type, scroll door de vele etiketten. Selecteer het type etiket dat u gebruikt.
  8. Klik op de tab Opties.
  9. Optioneel: Selecteer de optie Inhoud synchroniseren indien u opmaak wilt toepassen, zoals een ander lettertype of kleuren of afbeeldingen wilt toevoegen, en maak die wijzigingen van toepassing op al uw etiketten.
  10. Klik op de knop Configureren naast de weergave van de printer.
  11. Selecteer de printer waar u naartoe wilt afdrukken.
  12. Specificeer, in de printeropties (dit kan variëren afhankelijk van uw besturingssysteem), de van toepassing zijnde invoer van papier of papierlade. Selecteer, op dit moment, Handmatige invoer.
  13. Klik op de knop Nieuw document onder in het venster. De etiketten zullen verschijnen. U zult nog geen gegevens zien, u ziet de veldnamen, zoals bijvoorbeeld Voornaam. Wanneer u afdrukt zullen de juiste gegevens verschijnen.
  14. Indien u optioneel het keuzevak Inhoud synchroniseren selecteerde: Als u wijzigingen wilt maken, zoals het toevoegen van spaties, velden opnieuw schikken of opmaak wijzigen, doe dat dan in het etiket linksboven. Geef de tekst een interessant lettertype, of maak het de grootte die u nodig hebt. Klik dan op Inhoud synchroniseren om deze wijzigingen op alle etiketten toe te passen. U kunt ook met rechts klikken op de rand van het etiket rechtsboven, Frame kiezen, naar de tab Achtergrond gaan, en het een achtergrondkleur geven.
  15. Kies Bestand > Afdrukken en ga dan door zoals hierboven beschreven in "Standaardbrieven afdrukken".

U kunt het document met etiketten opslaan en er naar terug gaan als u het weer opnieuw wilt gebruiken.

Documentation note.png Indien u problemen hebt met afdrukken, controleer dan de instelling van uw printer met behulp van de gereedschappen voor uw besturingssysteem.
Tip.png Zoals hierboven vermeld, ziet u de veldnamen, niet de veldinhoud, in standaardbrieven. Druk op F4 om de inhoud van uw gegevensbronnen te zien. Breidt de gegevensbron uit die u gebruikt, selecteer de tabel die u gebruikt, klik op het blanco grijze vak in de linker bovenhoek van de tabel om alle rijen te selecteren, en klik op het pictogram Gegevens naar velden op de werkbalk Tabelgegevens boven de tabel.



Zie ook


Deze How To is gebaseerd op Solveig Haugland's Blog

Content on this page is licensed under the Public Documentation License (PDL).
Personal tools
In other languages