12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

Printing envelopes

From Apache OpenOffice Wiki
Jump to: navigation, search


Printing envelopes involves two steps: setup and printing.

To set up an envelope to be printed by itself or with your document:

  1. Click Insert > Envelope from the menu bar.
  2. In the Envelope dialog box, start with the Envelope tab. Verify, add, or edit the information in the Addressee and Sender boxes (the “from" on the envelope). You can use the right-hand drop-down lists to select the database or table from which you can draw the envelope information, if desired. See Setting up envelope details from a database for details.
  3. Envelope dialog box
    Choosing addressee and sender information for an envelope.

  4. On the Format page, verify or edit the positioning of the addressee and the sender information. The preview area on the lower right shows the effect of your positioning choices.
  5. Envelope format
    Choosing position and size of envelope elements.

  6. To format the text of these blocks, click the Edit buttons to the right. In the drop-down list you have two choices: Character and Paragraph.
    • In Character, you can choose Fonts (Sizes...), Fonts Effects (Underlining, Color...), Position (Rotating/scaling...), Hyperlink, Background and more.
    • In Paragraph, you can choose Indents & Spacing, Alignment, Text Flow, Tabs, Drop Caps, Borders and Backgrounds.
  7. In the lower left of this page, choose the envelope format from the drop-down list. The width and height of the selected envelope then show in the boxes below the selected format. If you chose a pre-existing format, just verify these sizes. If you chose User defined in the Format list, then you can edit the sizes.
  8. After formatting, go to the Printer page to choose printer options such as envelope orientation and shifting. You may need to experiment a bit to see what works best for your printer. You can also choose a different printer or alter printer setup (for example, specify the tray that holds envelopes) for this print job.
  9. Envelope printer
    Choosing printer options for an envelope.

  10. When you have finished formatting and are ready to print, click either the New Doc or Insert button to finish.
    • New Doc makes only an envelope or starts a new document with the envelope. Insert inserts the envelope into your existing document as page 1.
    • To not proceed with this envelope, click Cancel or press the Esc key. You can also click Reset to remove your changes and return to the original settings when the dialog box opened.
  11. When the Envelope dialog box closes, you are returned to your document, which now has the envelope in the same file as the document. Save this file before you do anything else.

To print the envelope:

  1. Choose File > Print from the menu bar.
  2. On the Print dialog box, under Print range, choose Pages and type 1 in the box. Click OK to print.

Setting up envelope details from a database

You can use a database as a source of name and address details for printing one or a series of envelopes, either alone or with accompanying letters. Mozilla address books, dBase databases, spreadsheets, databases created by OOo Base, and others can be used as data sources.

For details on how to set up a database or address book as a data source, see Chapter 10 (Getting Started with Base) in the Getting Started guide.

After you have set up a data source, you need to register it with OOo so OOo can access it. To register a data source, select File > New > Database, select Connect to an existing database, and select the type of data source to connect to. The exact source can then be chosen in the wizard.

To use the database when printing envelopes:

  1. Click Insert > Envelope from the menu bar.
  2. On the Envelope dialog box, select from the Database list the name of the data source. In the Table list, select the database table or sheet containing the address data that you want to insert. The Database field list will now show a list of the fields in the selected database.
  3. Select database fields
    Choosing a database and table from which to use addressee details.

  4. Select the field containing the first piece of data (for example, First name) that you want to insert, then click the left arrow button to add the data to the Addressee box.
  5. To put another field on the same line in the Addressee box, select that field and click the left arrow button again. Be sure to include punctuation or spaces between fields in the Addressee box as needed.
  6. To put a field (for example, the address) on a new line, press Enter at the end of the previous line in the Addressee box. When you are finished selecting fields, the Envelope dialog box will look something like the figure below.
  7. Database fields for envelope
    The Envelope dialog box after choosing database fields for Addressee.

  8. Click Insert or New Doc. A formatted envelope is now visible in your document.
  9. Click File > Print from the menu bar. The dialog box shown below appears. Click Yes.
  10. Confirm merge
    Confirmation dialog box for merging database fields.

  11. The Mail Merge dialog box appears. Here you can choose to print envelopes addressed to one, several or all address records in the database. For more about using mail merge, see Chapter 11 (Using Mail Merge).
  12. Make your selections and then click OK to begin printing.
  13. Mail Merge dialog box
    Choosing records to use when printing envelopes.

Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools