12 April 2014: The OpenOffice Wiki is not, and never was, affected by the heartbleed bug. Users' passwords are safe and wiki users do not need take any actions.

I want to insert special characters with keyboard shortcuts. How do I do this?

From Apache OpenOffice Wiki
Jump to: navigation, search


I want to insert special characters with keyboard shortcuts. How do I do this?


From OpenOffice.org Version 1.1 on you can use the built in macro recorder. To assign a character to a key:

  • Select Tools > Macros > Record Macro to start the recording process.
  • Click Insert > Special Character and choose the character you want,

then insert it and close the special character dialog.

  • Click on "Stop recording" in the small macro recorder dialog. A dialog appears asking you to save the macro with a name.

Be sure to save it under Standard, not in the tree for the document currently open. That way you'll be able to use the macro in any OOo Writer document.

Now that you have recorded the macro, you'll need to assign it to a keystroke.

The way to assign a keystroke has changed in newer versions of OpenOffice.org. The easy way to tell whether you have an old or new version is to try to follow the menu path Tools > Macro > Macros. In a newer version, that path isn't there any more, so use the new instructions.

For older versions of OpenOffice.org:

  • Select Tools > Macro > Macros > Assign.
  • Now follow > Keyboard > Functions and find your macro using the Category tree.

Your macro will appear in the Function window when you've found the right module.

  • Select a keystroke in the Shortcut Keys list, and click Modify.

The key you have selected will appear in the Keys window.

For newer versions (checked under V3.1), a nicely-illustrated version of the following procedure can be found in this How_To. Here is the short narrative:

  • Select Tools > Customize > Keyboard.
  • In the Category pane at the lower left, open the tree OpenOffice.org Macros. If you have followed the saving instructions above, the path you want is user > Standard > Module1. Your macro will appear in the center Function pane when you've found the right module.
  • If your macro name is not highlighted, click on the name to select it.
  • Select a keystroke in the Shortcut Keys list at the top left, and click Modify.

The key you have selected will appear in the Keys pane at the lower right.

  • Click OK to save your change.
Personal tools