Difference between revisions of "SL/VCLTestTool"

From Apache OpenOffice Wiki
Jump to: navigation, search
m (Dodatne povezave)
(Deleted link to category 'Quality Assurance')
 
(17 intermediate revisions by 2 users not shown)
Line 1: Line 1:
[[ko:KO/VCLTesttool]]
 
 
{{DISPLAYTITLE:Orodje VCLTesttool}}
 
{{DISPLAYTITLE:Orodje VCLTesttool}}
 
== O orodju VCLTesttool ==
 
== O orodju VCLTesttool ==
Line 13: Line 12:
  
 
===== CVS/SVN =====
 
===== CVS/SVN =====
Na sistemu morate imeti delujoč CVS ali SVN (migracija na SubVersion se je začela z milestone DEV300_m32).
+
Na sistemu morate imeti delujoč CVS ali SVN (migracija na SubVersion se je začela z mejnikom DEV300_m32).
  
 
Preberite si [http://qa.openoffice.org/servlets/ProjectSource nastavitev odjemalca CVS (v angl.)], ki razloži, kako nastavite odjemalca na OpenOffice.org.
 
Preberite si [http://qa.openoffice.org/servlets/ProjectSource nastavitev odjemalca CVS (v angl.)], ki razloži, kako nastavite odjemalca na OpenOffice.org.
Line 19: Line 18:
 
Preberite si [[OOo_and_Subversion]], ki razloži, kako uporabljate SubVersion na OpenOffice.org.
 
Preberite si [[OOo_and_Subversion]], ki razloži, kako uporabljate SubVersion na OpenOffice.org.
  
Druga, enostavnejša možnost je, da si prenesete testautomation checkouts, ki so dodani arhivu. Oglejte si [[http://wiki.services.openoffice.org/wiki/VCLTesttool#VCLTesttool_framework_.28testautomation.29]], kjer so zapisane podrobnosti.
+
Druga, enostavnejša možnost je, da si prenesete testautomation checkouts, ki so dodani arhivu. Oglejte si [[SL/VCLTestTool#VCLTesttool_framework_.28testautomation.29]], kjer so zapisane podrobnosti.
  
 
===== OpenOffice.org =====
 
===== OpenOffice.org =====
Line 57: Line 56:
 
''svn checkout svn://svn.services.openoffice.org/ooo/tags/DEV300_m32/testautomation testautomation_m32''
 
''svn checkout svn://svn.services.openoffice.org/ooo/tags/DEV300_m32/testautomation testautomation_m32''
  
Če ne želite uporabljati CVS ali SVN, lahko prenesete archives z testautomation checkouts, ki jih izdeluje [http://accc.riken.jp/maho/ Nakata Maho] na strežniku Good Day. Enostavno prenesite in extract the archive, ki se ujema z vašo različico OpenOffice.org, ki jo želite preizkusiti, z naslednjega mesta: http://ooopackages.good-day.net/pub/OpenOffice.org/qa/testautomation/
+
Če ne želite uporabljati CVS ali SVN, lahko prenesete archives z testautomation checkouts, ki jih izdeluje [http://accc.riken.jp/maho/ Nakata Maho] na strežniku Good Day. Enostavno prenesite in razpakirajte arhivsko datoteko, ki se ujema z vašo različico OpenOffice.org, ki jo želite preizkusiti, z naslednjega mesta: http://ooopackages.good-day.net/pub/OpenOffice.org/qa/testautomation/
  
 
===== Orodje VCLTestTool =====
 
===== Orodje VCLTestTool =====
 
S samodejnim preizkušanjem OpenOffice.org lahko začnete, ko imate tudi na svojem sistemu kopijo orodja VCLTesttool.
 
S samodejnim preizkušanjem OpenOffice.org lahko začnete, ko imate tudi na svojem sistemu kopijo orodja VCLTesttool.
  
[http://qa.openoffice.org/ooQAReloaded/AutomationTeamsite/ooQA-TeamAutomationBin.html Prenesite najnovejšo različico VCLTesttool] za svoj operacijski sistem na želeno mesto na računalniku in extract the archive na svoj sistem. After all files are extracted prvič zaženite testtool.bin (testtool.exe v okolju Windows). Ko zaženete VCLTesttool, pojdite v Tools->Options.
+
[http://qa.openoffice.org/ooQAReloaded/AutomationTeamsite/ooQA-TeamAutomationBin.html Prenesite najnovejšo različico VCLTesttool] za svoj operacijski sistem na želeno mesto na računalniku in razširite arhivsko datoteko na svoj sistem. Ko so vse datoteke razpakirane, prvič zaženite testtool.bin (testtool.exe v okolju Windows). Ko zaženete VCLTesttool, pojdite v Extra->Settings.
  
 
'''(vsi vnosi v spodnjih posnetkih namizja so zgolj primeri in jih je potrebno prilagoditi vašim potrebam)'''
 
'''(vsi vnosi v spodnjih posnetkih namizja so zgolj primeri in jih je potrebno prilagoditi vašim potrebam)'''
Line 78: Line 77:
 
3. Base directory (Mapa skriptov): Mapa s skripti za samodejno preizkušanje (testautomation).
 
3. Base directory (Mapa skriptov): Mapa s skripti za samodejno preizkušanje (testautomation).
  
4. Default HID directory se nastavi [[VCLTesttool/hid.lst_file | samodejno]] in ga v večini primerov ne smete prirejati.
+
4. Default HID directory (Privzeta mapa HID) se nastavi [[VCLTesttool/hid.lst_file | samodejno]] in ga v večini primerov ne smete prirejati.
 
+
  
  
Line 86: Line 84:
 
[[Image: Testtool-option-crashreport.jpg]]
 
[[Image: Testtool-option-crashreport.jpg]]
  
Potrdite polje 'Allow contact' ('Dovoli stik') in vnesite svoj veljaven e-poštni naslov OpenOffice.org v polje 'EMail' ('E-poštni naslov'). Ta naslov bo uporabljen, ko VCLTesttool pošlje poročilo o sesutju. Kasneje, ko se seznanite s samodejnim preizkušanjem, lahko svoje rezultate dodate v  [[QUASTe]] (Quality Assurance Statuspage oz. stran stanja zagotavljanja kakovosti). Zato je veljaven e-poštni naslov zelo pomemben.
+
Potrdite polje 'Allow contact' ('Dovoli stik') in vnesite svoj veljaven e-poštni naslov OpenOffice.org v polje 'EMail' ('E-poštni naslov'). Ta naslov bo uporabljen, ko VCLTesttool pošlje poročilo o sesutju. Kasneje, ko se seznanite s samodejnim preizkušanjem, lahko svoje rezultate dodate v  [[SL/QUASTe|QUASTe]] (Quality Assurance Statuspage oz. stran stanja zagotavljanja kakovosti). Zato je veljaven e-poštni naslov zelo pomemben.
  
 
* Zavihek 'Misc' ('Razno')
 
* Zavihek 'Misc' ('Razno')
Line 106: Line 104:
 
== Izvajanje posameznega samodejnega preizkusa ==
 
== Izvajanje posameznega samodejnega preizkusa ==
  
Izvajanje posameznega samodejnega preizkusa je razmeroma enostavno, ko ste uspeli prenesti skripte na svoj računalnik in opravili vse potrebne nastavitve, opisane v odseku 'Hitri začetek'. Če potrebujete več informacij o tem, katere samodejne preizkuse je potrebno izvesti, obiščite [http://wiki.services.openoffice.org/wiki/QUASTe#Category_model to stran (v angl.)].
+
Izvajanje posameznega samodejnega preizkusa je razmeroma enostavno, ko ste uspeli prenesti skripte na svoj računalnik in opravili vse potrebne nastavitve, opisane v odseku 'Hitri začetek'. Če potrebujete več informacij o tem, katere samodejne preizkuse je potrebno izvesti, obiščite [[SL/QUASTe#Model_kategorije|to stran]].
  
 
* Zaženite VCLTesttool in izberite File->Open (Datoteka->Odpri)
 
* Zaženite VCLTesttool in izberite File->Open (Datoteka->Odpri)
Line 119: Line 117:
 
== Nalaganje rezultatov v QUASTe ==
 
== Nalaganje rezultatov v QUASTe ==
  
Če želite rezultate naložiti v [[QUASTe]], morate dodati dve vrstici v datoteko ~/.testtoolrc (v okolju Linux):
+
Če želite rezultate naložiti v [[SL/QUASTe|QUASTe]], morate dodati dve vrstici v datoteko ~/.testtoolrc (v okolju Linux):
  
 
[Others]
 
[Others]
  
 
PCname=<Ime računalnika>
 
PCname=<Ime računalnika>
 +
 +
== Vnos zadev v IZ o samodejnih preizkusih ==
 +
 +
Vse zadeve, ki se tičejo samodejnih preizkusov, morajo imeti naslednje nastavitve, da jih bo zagotovo prepoznala ekipa automation:
 +
 +
* Component: qa
 +
* Subcomponent: testscripts
 +
* assigned to: automat@openoffice.org
 +
* Povzetek (Summary) se mora začeti z besedilom: [Automation]
 +
 +
Če poleg tega veste, kdo je lastnik samodejnega preizkusa, lahko neposredno zadevo dodelite lastniku. Seznam samodejnih preizkusov in njihovih lastnikov si lahko ogledate tukaj: [http://quaste.services.openoffice.org/index.php?option=com_quaste&task=tests_overview Pregled samodejnih preizkusov (angl.)] na [http://quaste.services.openoffice.org QUASTe].
  
 
== Dodatne povezave ==
 
== Dodatne povezave ==
Line 129: Line 138:
 
1. [[Run_OOo_versions_parallel]] (v angl.)
 
1. [[Run_OOo_versions_parallel]] (v angl.)
  
 
+
[[Category:SL]]
[[Category:Quality_Assurance]]
+

Latest revision as of 09:27, 30 March 2010

O orodju VCLTesttool

VCLTesttool je program, ki ga uporabljamo za samodejno preizkušanje OpenOffice.org. VCLTesttool komunicira s TCP/IP-vmesnikom OpenOffice.org in lahko preizkusi vsako namestitev OpenOffice.org na računalniku ali v krajevnem omrežju (LAN). Program VCLTesttool lahko uporabljamo od OpenOffice.org 1.1beta naprej in z vsemi novejšimi različicami. Ker pa so v novejših izdajah OpenOffice.org nezdružljive spremembe, morate zato z njimi uporabljati tudi novejšo različico VCLTesttool. Najnovejše različice programa VCLTesttool lahko vedno najdete tukaj.

Hitri začetek

Če želite pomagati pri samodejnem preizkušanju in takoj začeti z delom, je ta vodnik prava izbira. Ponuja začetna navodila po korakih in je napisan za preizkušanje OpenOffice.org različic 3.x. Kljub temu je ta vodnik namenjen preizkuševalcem z osnovnim znanjem kot tudi izkušenejšim.

Zahteve

Če so vse sledeče zahteve izpolnjene, lahko začnete s samodejnim preizkušanjem.

CVS/SVN

Na sistemu morate imeti delujoč CVS ali SVN (migracija na SubVersion se je začela z mejnikom DEV300_m32).

Preberite si nastavitev odjemalca CVS (v angl.), ki razloži, kako nastavite odjemalca na OpenOffice.org.

Preberite si OOo_and_Subversion, ki razloži, kako uporabljate SubVersion na OpenOffice.org.

Druga, enostavnejša možnost je, da si prenesete testautomation checkouts, ki so dodani arhivu. Oglejte si SL/VCLTestTool#VCLTesttool_framework_.28testautomation.29, kjer so zapisane podrobnosti.

OpenOffice.org

Na sistemu morate imeti nameščen paket OpenOffice.org, zelo pomembno je, da veste, katero različico boste preizkušali.

Če niste prepričani, katera različica je nameščena na vašem sistemu, to lahko preverite v datoteki

  • .versionrc (sistemi UNIX) ali
  • version.ini (sistemi Windows)

v mapi nameščenega programa
(poglejte v <MAPA_NAMESTITVE>/OpenOffice.org 3/program).

Odprite datoteko in si oglejte območje [Version]:

Primer:

ProductMajor=300

ProductMinor=29

ProductSource=DEV300

Ogrodje VCLTesttool (testautomation)

Ogrodje VCLTesttool vsebuje vse skripte, ki so na voljo za preizkušanje mejnika, ki temelji na trenutni podveji, in se nahajajo v CVS/SVN kot modul testautomation. Vse te datoteke najdete v CVS/SVN OpenOffice.org in jih enostavno prenesete na svoj datotečni sistem z cvs/svn checkout. Recimo, da boste preizkusili različico iz veje 'DEV300' mejnika 'm29'.

Zapomnite so, da so vsi mejniki DEV300 pred m32 nahajajo v CVS in vsi mejniki od m32 naprej v SVN.

Uporabite naslednji ukaz cvs za pridobivanje izvorne kode:

cvs checkout -r DEV300_m29 -d testautomation_m29 testautomation

(neobvezni parameter -d uporabimo za checkout v navedeno mapo, da boste lahko vzporedno hranite več različic.)

Checkout prek SubVersion:

svn checkout svn://svn.services.openoffice.org/ooo/tags/DEV300_m32/testautomation testautomation_m32

Če ne želite uporabljati CVS ali SVN, lahko prenesete archives z testautomation checkouts, ki jih izdeluje Nakata Maho na strežniku Good Day. Enostavno prenesite in razpakirajte arhivsko datoteko, ki se ujema z vašo različico OpenOffice.org, ki jo želite preizkusiti, z naslednjega mesta: http://ooopackages.good-day.net/pub/OpenOffice.org/qa/testautomation/

Orodje VCLTestTool

S samodejnim preizkušanjem OpenOffice.org lahko začnete, ko imate tudi na svojem sistemu kopijo orodja VCLTesttool.

Prenesite najnovejšo različico VCLTesttool za svoj operacijski sistem na želeno mesto na računalniku in razširite arhivsko datoteko na svoj sistem. Ko so vse datoteke razpakirane, prvič zaženite testtool.bin (testtool.exe v okolju Windows). Ko zaženete VCLTesttool, pojdite v Extra->Settings.

(vsi vnosi v spodnjih posnetkih namizja so zgolj primeri in jih je potrebno prilagoditi vašim potrebam)

  • Zavihek 'Profile' ('Profil')

Testtool-option-profile.jpg

Ustvarite profil za trenutni modul testautomation, ki ga boste uporabili. Tako vnesite:

1. Profile (Profil): DEV300m29

2. Log base directory (Mapa zapisnikov): Semkaj se zapisujejo vse datoteke rezultatov, ki nastanejo med preizkušanjem.

3. Base directory (Mapa skriptov): Mapa s skripti za samodejno preizkušanje (testautomation).

4. Default HID directory (Privzeta mapa HID) se nastavi samodejno in ga v večini primerov ne smete prirejati.


  • Zavihek 'Crashreport' ('Poročilo o sesutju')

Testtool-option-crashreport.jpg

Potrdite polje 'Allow contact' ('Dovoli stik') in vnesite svoj veljaven e-poštni naslov OpenOffice.org v polje 'EMail' ('E-poštni naslov'). Ta naslov bo uporabljen, ko VCLTesttool pošlje poročilo o sesutju. Kasneje, ko se seznanite s samodejnim preizkušanjem, lahko svoje rezultate dodate v QUASTe (Quality Assurance Statuspage oz. stran stanja zagotavljanja kakovosti). Zato je veljaven e-poštni naslov zelo pomemben.

  • Zavihek 'Misc' ('Razno')

Testtool-option-misc.jpg Na tem zavihku lahko nastavite možnosti, ki jih uporablja VCLTesttool pri komuniciranju z OpenOffice.org. V večini primerov lahko te vrednosti ostanejo privzete. Če VCLTesttool ne more zagnati vašega programa OpenOffice.org, so morda vrata 'Testtool Port' ali 'Remote UNO Port' blokirana ali rezervirana s strani vašega sistema. 'OOo Program Dir' lahko nastavite na programsko mapo svojega paketa OpenOffice.org, ki ga boste preizkusili z VCLTestTool. V večini primerov lahko to polje pustite prazno, saj bi VCLTesttool moral najti vaš OpenOffice.org. Če ga ne, lahko tukaj poskusite dodati pot do programa. Primer: <MAPA_NAMESTITVE>/OpenOffice.org 3/program

Vse spremembe možnosti VCLTestTool se shranijo v:

    • ${HOME}/.testtoolrc (sistemi UNIX) ali
    • "$HOME/Library/Application Support/.testtoolrc" (Mac OS X) ali
    •  %APPDATA%\testtool.ini (sistemi Windows).

Kliknite gumb 'OK' ('V redu') v Options ('Možnosti'), s čimer shranite vnesene spremembe in zapustite VCLTestTool.

Zdaj so izpolnjeni vsi predpogoji!

Izvajanje posameznega samodejnega preizkusa

Izvajanje posameznega samodejnega preizkusa je razmeroma enostavno, ko ste uspeli prenesti skripte na svoj računalnik in opravili vse potrebne nastavitve, opisane v odseku 'Hitri začetek'. Če potrebujete več informacij o tem, katere samodejne preizkuse je potrebno izvesti, obiščite to stran.

  • Zaženite VCLTesttool in izberite File->Open (Datoteka->Odpri)
  • spremenite vrsto datoteke v *.bas
  • izberite mapo, v kateri se nahajajo preizkusni skripti
  • izberite datoteko *.bas, ki bo zagnana naslednja
  • Pritisnite 'OK' ('V redu') v pogovornem oknu izbirnika datotek
  • Pritisnite 'F5' ali izberite 'Program->start'; samodejni preizkus se prične.

Zdaj morate le počakati, da se preizkus konča in da se analizirani rezultati preizkusa zapišejo v datoteko *.res.

Nalaganje rezultatov v QUASTe

Če želite rezultate naložiti v QUASTe, morate dodati dve vrstici v datoteko ~/.testtoolrc (v okolju Linux):

[Others]

PCname=<Ime računalnika>

Vnos zadev v IZ o samodejnih preizkusih

Vse zadeve, ki se tičejo samodejnih preizkusov, morajo imeti naslednje nastavitve, da jih bo zagotovo prepoznala ekipa automation:

  • Component: qa
  • Subcomponent: testscripts
  • assigned to: automat@openoffice.org
  • Povzetek (Summary) se mora začeti z besedilom: [Automation]

Če poleg tega veste, kdo je lastnik samodejnega preizkusa, lahko neposredno zadevo dodelite lastniku. Seznam samodejnih preizkusov in njihovih lastnikov si lahko ogledate tukaj: Pregled samodejnih preizkusov (angl.) na QUASTe.

Dodatne povezave

1. Run_OOo_versions_parallel (v angl.)

Personal tools