Difference between revisions of "ReleaseStatus Minutes 2010-03-01 IRC log"
(Created page with '(15:00:00) #oooreleases: The topic for #oooreleases is: Release-Stauts-Meeting, every monday at 15:00 Hamburg Time (13:00 UTC in summer)<br> (15:00:04) mla: hi<br> (15:00:30) p…')
|Line 90:||Line 90:|
(15:44:40) kai_a left the room.<br>
(15:44:40) kai_a left the room.<br>
(15:44:41) mla: bye
(15:44:41) mla: bye
Latest revision as of 19:07, 16 March 2010
(15:00:00) #oooreleases: The topic for #oooreleases is: Release-Stauts-Meeting, every monday at 15:00 Hamburg Time (13:00 UTC in summer)
(15:00:04) mla: hi
(15:00:30) paveljanik: Hi
(15:00:39) mdamboldt [~mdamboldt@nat/sun/x-pyqysiwpxkcgbmti] entered the room.
(15:00:41) rtimm [~Ruediger@nat/sun/x-ijmqcukeuubmdkxm] entered the room.
(15:00:47) mdamboldt: Hi
(15:01:19) stefan_b: Moin moin!
(15:01:48) UweL [~chatzilla@nat/sun/x-dlvotismtfobcocu] entered the room.
(15:02:13) mdamboldt: On top of todays agenda I can find a "general topic" item added about Mirrorbrain.
(15:02:26) mdamboldt: ml1: Marcus do you want to take over and explain details?
(15:02:33) mla: yes
(15:02:52) mla: as written we are done with our new download service via mirrorbrain
(15:03:07) mla: in order to provide a good basis for statistics
(15:03:18) kai_a [~Kai_Ahren@nat/sun/x-zbexpyynhiwxrmeq] entered the room.
(15:03:18) mla: we need a new policy for filenames
(15:03:33) mla: to get rid of inconsistencies
(15:03:59) mla: this would decrease a lot of work, now we need to workaround these issues
(15:04:15) mla: I think I havent't provided the correct link
(15:04:27) mla: the new draft can be found here
(15:04:27) mla: http://development.openoffice.org/releases/filenames_new.html
(15:05:04) mla: e.g., we have tried to resolve all optional parts and make them mandatory or put together with other
(15:05:15) mla: s/and/or
(15:06:21) mla: when we can approve it, it could be possible to see this new thing with the next release
(15:06:51) mla: that's it for now
(15:07:27) mdamboldt: I already had a look at the proposed changes and think those are good. So you have my +1 for this.
(15:10:25) mla: thanks, I'll let the affected people know that it's accepted and that we can take the next step (implementation)
(15:10:36) mdamboldt: Other thoughts on this?
(15:13:05) MechtiIde: I don't have to add annything
(15:13:43) rtimm: I do not care so much for these naming details. If it fits your needs better - go on
(15:13:54) mdamboldt: Ok.
(15:14:01) paveljanik: +1 if this is the final naming scheme :-))
(15:14:12) MechtiIde: rtimm, you said it in a better way
(15:14:13) rtimm: I guess you still have to do some renaming when uploading files?
(15:14:25) paveljanik: why?
(15:14:41) paveljanik: I really do not want to rename anything :-)
(15:14:54) paveljanik: I think these files should go out directly from the build process
(15:15:21) mla: no, this is also an advantage because we want to implement the new schema also in the build process (at least here in HH)
(15:15:38) paveljanik: great!
(15:15:40) paveljanik: +1
(15:15:45) rtimm: as the pack process does not know about differences between 'dev builds', 'beta', RC,. ...
(15:16:07) mdamboldt: Anything else for todays meeting somebody like to add?
(15:16:10) rtimm: So, how to determine whether to put a date into the file name or not?
(15:16:36) mla: rtimm: Ingo will know this ;-)
(15:17:00) rtimm: How should he?
(15:20:59) rtimm: I do not want anyone, not even Ingo, to maintain config files and change 'rc1' to 'rc2' to 'rc3' from one milestone to the other
(15:21:32) mla: maybe it's not possible, I don't know, let's see what Ingo will say
(15:21:56) rtimm: But OK, except from these (rare) cases the rest looks good and more consistent to what we have. So, go on.
(15:23:02) rtimm: Whether some milestone is called 'rc' gets decided here in this meeting. You cannot determine that automatically.
(15:24:30) MechtiIde: is it necessary to have the RCX instead of mX in the file name?
(15:26:37) mla: mechtilde: IMHO yes, to show the world that we have reached another step in development
(15:28:36) rtimm: ml1: Your naming scheme switches from something like 'DEV300m70' to '3.2.0rc1_20100118', probably triggered by having a DEV-product or not.
(15:28:40) mla: rtimm: yes, but first we will decided about a specific milestone as RC; then build it ;-)
(15:29:20) rtimm: The 'rc1'-part is something which cannot be automated.
(15:29:50) MechtiIde: we switch from DEV300 over OOO3X0 to 3.X RC
(15:29:55) rtimm: You can get OOo_3.2.0_20100118_Linux_x86_install-rpm-wJRE_en-US.tar.gz out of the build process, if you want to
(15:30:32) rtimm: But giving that a name like 'beta' or 'rcx' is no automatic process, at least up to now.
(15:30:34) mla: rtimm: do we want really to discuss here how it could be implementated or not?
(15:30:56) mdamboldt: I think you can take this offline and we can close todays meeting :)
(15:30:59) mla: I don't think so
(15:31:46) rtimm: We discuss here whether we will be able to say 'though build m2 was rc2, the next milestone will not be rc3, as we know it has bugs. Wait for the next milestone' ...
(15:31:52) rtimm: We had this for 3.2
(15:32:57) mdamboldt: I think it's obvious that we need to stay with the "RCx" naming schema. However this is put into file names.
(15:33:04) mla: no, we are discussing implementations but not decisions
(15:33:05) rtimm: So, let the build create 'version_date', as in OOo_3.2.0_20100118_Linux_x86_install-rpm-wJRE_en-US.tar.gz, but not more.
(15:33:39) rtimm: The rest has to be done manually when uploading files.
(15:33:59) mla: rtimm: maybe your are right, I don't know at this point
(15:35:37) _rene_: rtimm: and then the build runs over midnight and you get different dates? ;)
(15:35:56) rtimm: I like good, clear naming schemes. But I do not like have to change a config file for every milestone in release times.
(15:36:03) rtimm: _rene_: good point
(15:36:28) mla: rene: IMHO we have taken the date of starting
(15:36:59) mla: at least when renaming the files for uploading
(15:38:22) _rene_: that depends on when you calculate version_date
(15:38:23) rtimm: To summarize: I like the naming scheme for 'CWS Builds' and 'Developer Snapshots', also for final releases. (+1) But I have objections against the proposed scheme for Betas and RCs, as long as you want to create those names automatically. You would have to rename manually to reach this scheme.
(15:38:37) _rene_: and what if you start the build on 23:59 and it finishes the next day? :P
(15:38:46) _rene_: (yeah, I know, you people won't do that, but...)
(15:39:57) mla: even at 23:59 the date is clear
(15:40:10) rtimm: ml1: rene is correct. we often have the case that some install sets are from the evening, some from the next morning.
(15:40:24) rtimm: Wouldn't that be confusing?
(15:40:52) mla: as long as we won't have real nightly builds this will happen
(15:41:33) mla: rtimm: to start a build at 23:59? yes :-)
(15:42:05) gibi33 [~email@example.com] entered the room.
(15:42:14) rtimm: ml1: start a build in the afternoon. Get some install sets from this day, some from the next.
(15:42:19) rtimm: Would that be a problem?
(15:42:28) mla: not for me
(15:43:01) rtimm: OK
(15:43:59) mdamboldt: Are we done for today meeting? - I think so.....
(15:44:15) mla: I've no other points
(15:44:29) mdamboldt: bye
(15:44:37) rtimm: bye
(15:44:40) kai_a left the room.
(15:44:41) mla: bye