Difference between revisions of "RU/sun report builder/documentation"

From Apache OpenOffice Wiki
< RU
Jump to: navigation, search
(Functions)
(Function Example)
Line 323: Line 323:
  
 
== Examples ==
 
== Examples ==
=== Function Example ===
+
=== Пример функции ===
The illustration below shows how subtotal fields are created in Report Builder, using functions:
+
В рисунке ниже показано, как итог поля создаются в дизайнере отчетов, с помощью функций:
  
 
[[Image:SumFieldInReportBuilder.jpg]]
 
[[Image:SumFieldInReportBuilder.jpg]]
  
The report source table is shown on the upper left.
+
В таблице исходных отчетов показано в левом верхнем углу.
  
The resulting report layout is illustrated below the table. A group has been defined on the plProductType field. The sum field is created on the group footer. The rightmost part of the image shows the definition of a function that serves as the data source for the sum field.
+
Итоговый отчет макет показано ниже в таблице. Группа была определена на plProductType области. Сумма поле создается на группу колонтитула. Правая часть изображения показывает определение функции, которая выступает в качестве источника данных для суммы области.
  
 
=== Query Example ===
 
=== Query Example ===

Revision as of 16:06, 24 February 2010


Contents

Кому нужна отчетность

Вы можете быть прощены за то, что Вы думали, что единственная цель отчетов состоит в том, чтобы обеспечить привлекательные распечатки отчетов базы данных. Механизм сообщения обеспечивает основные инструментальные средства для того, чтобы они поместили данные в базу данных для некоторого практического использования. Отчеты позволяют Вам сектору и рассматривают данные многими различными способами. Как внештатный сотрудник, Вы можете использовать отчеты следить за временем, которое Вы проводите на специфическом проекте, рассматриваете свой доход в течение указанного месяца, и видите, какой клиент приносит Вам большинство работы. Аналогично, Вы можете использовать отчеты генерировать счета, "готовые послать". Если Вы изучаете иностранный язык, то Вы можете использовать отчеты напечатать список новых слов для специфической темы и следить за Вашим продвижением. Вы можете также создать простую базу данных, чтобы следить за Вашими достижениями и генерировать профессионально выглядящее резюме, используя отчет. Другими словами, Вы можете использовать отчеты для большого разнообразия задач.

Почему Дизайнер отчетов

Вместе с OpenOffice.org поставляется функция встроенной отчетности, Вы могли бы задаться вопросом, почему Вы захотите другой отчет поверх этого. Во-первых, функция встроенной отчетности не могут использоваться ни для чего кроме самых простых отчетов. В то время как Волшебник Сообщения делает процесс из создания сообщения довольно прямым, инструменты сообщения по умолчанию не очень интуитивны и не особенно гибки, который ограничивает Вашу способность настроить сообщения Вашей симпатии. Строитель Сообщения о Солнце (СРБ) разработан, чтобы преодолеть недостатки встроенных способностей сообщения, добавляя сильный двигатель сообщения и убивание изящных инструментов аллоуниг Вы, чтобы создать более продвинутые сообщения. Расширение добавляет и передовую сортировку и группировку способностей так же как способности использовать вопросы СКЛ и функции в сообщениях. Что еще более важно СРБ делает значительно легче создать сложное расположение сообщения через бремя-и-снижение. Далее, СРБ позволяет Вам вставлять диаграммы в свои сообщения.

Системные требования

Расширению SRB требуется достаточно свежая версия OpenOffice.org. В идеале, вы должны использовать последние версии продуктов. Поскольку SRB написана на Java, вы также должны проверить как наличие Java Runtime Environment (JRE) (Исполнительная среда Java) на вашем компьютере так и настроен ли OpenOffice.org на использование его. Чтобы сделать это, зайдите в Сервис -> Параметры -> OpenOffice.org -> Java. Убедитесь, что флажок "Использовать Java Runtime" установлен а JRE выбрана из списка установленных. Если этот список пуст, то вам придется установить JRE, которую можно загрузить с www.java.com.

Установка дизайнера отчетов

Поскольку SRB является расширением OpenOffice.org, его установка на вашем компьютере, не вызовет особых трудностей. Загрузите последнюю версию SRB из репозитория расширений OpenOffice.org. В OpenOffice.org, выберите Сервис -> Extension Manager. Нажмите кнопку Добавить, выберите загруженный .oxt файл и нажмите "Открыть". Перезапустите OpenOffice.org (В Windows, вы так же должны выйти из быстрого запуска), теперь все готово.

Приступаем к работе с Построителем отчетов от SUN.

Нижеследующее изложение относится к SRB версии 1.0.x.

Расширение "Построитель отчетов от SUN" добавляет мощные возможности по созданию отчетов в OpenOffice.org Base и использование его для создания отчетов очень просто, в чем вы убедитесь на простом примере. Предположим, что вы внештатный писатель, и хотите отслеживать свои публикации, используя простую базу данных в OpenOffice.org Base, которая хранит наименование публикации, дату создания, текущее состояние и оплату. Это решение достаточно полезно, однако при добавлении отчетов превращает базу данных в удобный аналитический инструмент. С помощью дизайнера отчетов можно создать отчет, показывающий список статей, сгруппированных по наименованиям содержащая оплате сумм и диаграммы для каждого издания.

Чтобы облегчить вам следовать приведенным ниже инструкциям, я добавил представленных таблиц, а также доклад Submissions_by_Publication к базе данных WriterDB.odb. Эта база данных является частью инструменты расширения Writer, которую вы можете скачать здесь.

Когда у вас база данных готова, откройте ее в OpenOffice.org Base, перейдите в раздел отчетов, и нажмите кнопку "Создать отчет в режиме дизайнера отчетов. При этом откроется окно конструктора отчетов и до начала работы над отчетом, давайте внимательнее взглянем на основные компоненты конструктора отчетов:

Sun Report Builder's Interface

Sun Report Builder's Interface

A - Панель инструментов Управление отчетами содержит кнопки, которые можно использовать для добавления полей, этикетки, графики и диаграммы к докладу.

B - Основная панель инструментов позволяет вам включить Добавление поля, навигатор отчетов, сортировки и группировки палитры.

C - Выравнивание и согласования на панели инструментов раздел поможет выровнять поля и другие элементы в докладе.

D - пустая страница отчета по умолчанию состоит из трех разделов: Page Header(Заголовок старницы), Detail(Содержимое страницы) и Page Footer(Нижний колонтитул).

E - Палитра "Добавить поле" позволяет быстро заполнить отчет полями, перетаскивая их из палитры на отчет.

F - Палитра "Сортировка и группировка" используется для группировки и сортировки элементов отчета.

G - Навигатор отчетов позволяет быстро найти и выбрать конкретный элемент в отчете.

H - панели свойств позволяет просмотреть/задать свойства выбранного поля/элемента управления. Например, если вы выбираете поле, то используя панель свойств, можно задать источник данных поля и такие свойства, как размер, расположение, формат и т.д.

Чтобы создать отчет, который группирует все заявления по номеру, вы должны добавить новую группу в секцию "Заголовок страницы", выбрав поле "Номер"(заявления) из палитры "Сортировка и группировка". Укажите желаемый вариант сортировки (по возрастанию или по убыванию) и выберите Present от Заголовка группы списка. Используйте палитру "Добавить поле" для размещения поля "Номер" в созданной секции группировки(см. выше). Вы можете использовать имеющиеся варианты форматирования на вкладке "Общие" панели "Свойства" для оформления поля. Секция "Содержимое"(Спецификация) страницы разработана для отображения списка записей базы данных(или запроса). В нашем случае этот список будет содержать записи относящиеся к заявкам. Используя палитру "Добавить поле" добавте желаемые поля(например, Название, Дата заявки и Оплата) в раздел "Содержимое". Выравнивание полей и надписей может быть достаточно утомительным, но имеется панель "Выровнять/Выровнять в разделе" которая содержит общие варианты которые могут быть полезны. Вы можете просмотреть доклад, нажав на кнопку Execute доклад на основной панели инструментов, чтобы создать список всех материалов, сгруппированных по публикации.

Хотя вы уже можете использовать созданный отчет, однако вы можете сделать несколько других вещей, чтобы сделать его еще более полезным. Например, вы можете добавить поле, которое рассчитывает суммы платежей по каждой публикации, а также общий итог. Начнем с последнего. Щелкните на кнопке Надпись на панели инструментов "Управление отчетами" и нарисовать поле в разделе нижний колонтитул. На панели "Свойства" перейдите на вкладку "Данные" и выберите необходимые параметры следующим образом:

  • Поле данных типа: Функция
  • Поле данных: Оплата
  • Функция: Накопления
  • Область: Доклад

Чтобы добавить поле, которое отображает суммы платежей по каждой публикации, вы в первую очередь необходимо включить секцию Групповой Нижний Колонтитул. Выберите Present из раскрывающегося списка Примечания в группе Сортировка и Группировка палитры. Потяните поле в добавленном Нижнем колонтитуле и определите опции поля следующим образом:

  • Поле данных типа: Функция
  • Поле данных: Оплата
  • Функция: Накопления
  • Область: Группа: Публикация

Можно также добавить, что граф отображает платежей публикации. Для этого необходимо сначала создать запрос, который извлекает данные на графике. Закрыть доклада, перейти к разделу запросы, и нажмите кнопку Создание запроса в режиме конструктора ссылку для создания нового запроса. Выберите таблицу, содержащую представление данных и добавить публикацию и выплаты полей в запросе. От функции выпадающего списка выберите группу в колонке Публикация и суммы платежей в столбце. Сохраните созданный запрос и открытый доклад для редактирования. Нажмите на кнопку графике в главной панели инструментов, а также привлечь графа в разделе "Нижний колонтитул. В панели свойств, перейдите на вкладку Данные и запроса на выборку из раскрывающегося Тип содержимого списке и создал запрос из содержимого списка.

Если вам не по душе графа столбцов по умолчанию, то Вы можете настроить его свойств, дважды щелкнув на график, чтобы войти в режим редактирования. Здесь вы можете задать различные настройки с помощью правой кнопки меню контекста. Например, с помощью меню пункт Тип диаграммы можно изменить график умолчанию колонки с круговой диаграммы и добавить 3-D посмотреть на него. Как вы можете видеть, процесс создания отчетов через дизайнер отчетов прост. Как только вы освоили основы, вы можете использовать отчетов разобраться в данных, хранящихся в OpenOffice.org Base.



Просмотр навигатор отчетов в дизайнере отчетов

Давайте определим несколько ключевых компонентов SRB как видно из навигатор отчетов. Навигатор отчетов находиться под View в выпадающем меню. Для просмотра свойств окна, переключитесь на них, своства отображаться под view в выпадающем меню. Расширенные советы определяют много информации о компонентах. Для просмотра расширенной подсказки, переключитесь на нее, она отображается под Помощью в выпадающем меню. Текст ниже дополняет расширенные советы Вашей специфической версии SRB. Кроме того, контекстная помощь доступна для различных диалогов нажав клавишу F1.

Навигатор отчетов -> Отчет

Показаны различные варианты доклада в целом. Они отличаются различными вариантами отдельных компонентов отчета. Например, если вы используете фильтр по докладу в целом, то не ждите, чтобы выполнялись функции по значениям, которые вы просто отфильтровали.

Навигатор отчетов-> Отчет -> Свойства вкладка "Общие"

Это контролирует формат и презентацию доклада.

  • Имя: название вашего доклада может быть чем угодно по вашему выбору.
  • Верхний Колонтитул:
  • Нижний колонтитул:
  • Распечатать повторяются значения: вы можете не захотеть печатать повторяющиеся значения для каждого отчета.

Навигатор отчетов -> Отчет -> Свойства закладка Данные

Это контролирует данные из базы данных, которая отображается в отчете.

  • Тип содержимого: может быть таблица, запрос или SQL запрос.
  • Содержание: значение зависит от типа содержимого выше.
  • Анализ SQL запроса: стоит ли разрешить SQL запросы, которые будут проанализированы.
  • Фильтр: фильтрует SQL запросы при выполнении в базе данных.

Навигатор отчетов -> Отчет -> Функции

Контролирует функции, вычисленные в отчете помощью OpenFormula. Как правило, все функции, которые определены в OpenFormula должно быть поддержаны. Но в настоящее время продолжается работа по поддержке и функции могут измениться после каждого выпуска дизайнера отчетов

Навигатор отчетов -> Отчет -> Функции -> Функции -> Свойства вкладка "Общие"

Функция позволяет пользователю выполнять расчеты (см. раздел Поддержка функций) в базе данных и для отображения результатов. Функции могут быть как в глобальном контексте самого отчета или в какой-либо группе (см. раздел Группы ниже). Функции созданных с помощью View -> Навигатор отчетов-> Отчет -> Функции. Щелкните правой кнопкой мыши на Функции и выберите новую функцию. После того как вы выбрали новую функцию в контекстном меню по функциям записи, которую вы можете настроить функцию.

  • Имя: Имя вашего функция может быть чем угодно по вашему выбору.
  • Формула: см. функцию пример ниже
  • Начальное значение: см. пример ниже функциям
  • Глубокий обход:
  • Предварительная оценка: Вы не можете хотеть, чтобы функция была оценена, пока отчет не закончен.

Навигатор отчетов-> Отчет -> Верхний Колонтитул -> Свойства вкладка "Общие"

Это контролирует заголовок на каждой странице отчета. В многостраничном докладе, это можно показать в верхней части каждой страницы. Он может содержать другие компоненты, такие как текстовые поля, надписи, изображения контроля, графиков, линий и т.д. Каждый из этих компонентов также имеют свои соответствующие компоненты.

  • Имя:
  • Видимый:
  • Высота:
  • Условное Выражение Печати: условные выражения печати позволяет пользователю определить, элемент или раздел должны или не должны быть видны при выполнении отчета. Если печать выражение истинно, то элемент будет включен в отчет. Синтаксис такой же, как и для функций.
  • Цвет фона:
  • Фон прозрачный:

Навигатор отчетов -> Отчет -> Отчет Заголовок -> Свойства вкладка "Общие"

Это контролирует заголовке отчета. В многостраничном докладе, это покажет только один раз в верхней части отчета. Он может содержать другие компоненты, такие как текстовые поля, надписи, изображения контроля, графиков, линий и т.д. Каждый из этих компонентов также имеют свои соответствующие компоненты.

  • Имя:
  • Вызовите Новую Страницу: является ли текущий раздел и / или печатается в следующем разделе на новой странице
  • Хранить вместе: если текущий раздел полностью не помещаются на странице, то распечатать его на следующей странице
  • Видимый:
  • Высота:
  • Условное Выражение Печати:
  • Цвет фона:
  • Фон прозрачным:

Навигатор отчетов-> Отчет -> Группы -> сортировки и группировки окон

Это контролирует ли и как вы объединяющая базу данных. Вы можете вставить группировки данных в докладе: Вид -> Сортировка и группировка. В нем подробно полями, на которых, как тем, какие условия и т.д., вам будет группировка данных. Для более подробной информации, пожалуйста, см. здесь this.

  • Поле / выражение: Либо поле из базы данных или выражение. Примером выражения может быть, чтобы дать пользователю возможность сделать арифметические расчеты со стоимостью других выражений, а также значения столбцов. (Фактическое осуществление является частью выражения двигателем 4,1.)
  • Сортировка: по возрастанию или по убыванию
  • Группа Заголовок: либо показать или скрыть
  • Группа Footer: либо показать или скрыть
  • Группа С: То, что данные, сгруппированные на зависит от типа данных, выбранного в Поле / выражение
  • Группа Интервал: Это также зависит от типа данных, выбранного в Поле / выражение
  • Держаться вместе:
Навигатор отчетов-> Отчет -> Группы -> <Имя группы> -> Свойства вкладка "Общие"

Это контролирует визуального представления ваших групп.

  • Держаться вместе:
  • Начало новой колонки: (В будущих релизах, несколькими колоннами будут доступны из меню Формат -> страница)
  • Вернуть номер страницы:
Навигатор отчетов -> Отчет -> Группы -> <Имя Группы> -> Функции -> Функции -> Свойства вкладка "Общие"

Это позволяет выполнять расчеты (см. раздел Поддерживаемые функции) по данным группам и отображения результатов. Опять же, функции создаются правой кнопкой мыши и выберите Функции новой функции.

  • Имя:
  • Формула: ввод, используя синтаксис OpenFormula
  • Начальное значение: первоначальные оценки стоимости OpenFormula выше
  • Глубокий обход:
  • Предварительная оценка:
Навигатор отчетов-> Отчет -> Группы -> <Имя Группы> -> Группа Заголовок -> Свойства вкладка "Общие"

Это контролирует условия, при которых группа заголовке отображается как и многие другие атрибуты в заголовке группы.

  • Имя:
  • Новая страница:
  • Держаться вместе:
  • Повтор раздела:
  • Видимый:
  • Высота:
  • Условная печати выражения:
  • Цвет фона:
  • Фон прозрачным:

Навигатор отчетов -> Отчет -> Подробно -> Свойства вкладка "Общие"

Это контролирует подробности доклада. Это основной части доклада. Он может содержать другие компоненты, такие как текстовые поля, надписи, изображения контроля, графиков, линий и т.д. Несомненно, этот раздел содержит базу данных, которые вы хотите вытащил в Вашем докладе.

  • Имя:
  • Новая страница:
  • Держаться вместе:
  • Повтор раздела:
  • Видимый:
  • Высота:
  • Условная печати выражения:
  • Цвет фона:
  • Фон прозрачным:

Навигатор отчетов -> Отчет -> Отчет Footer -> Свойства вкладка "Общие"

Это уважение разделе Заголовок отчета и содержит те же компоненты, как заголовке отчета.

Навигатор отчетов -> Отчет -> Нижний Колонтитул -> Свойства вкладка "Общие"

Это уважение раздел заголовка страницы и содержит те же компоненты, как в заголовке страницы.



Общепринятые компоненты в любом разделе

В каждом из вышеперечисленных разделов можно использовать часто используемые данные компоненты на панели инструментов Контроль отчетов, что эффективно сказывается на использованииь этого отчета. Это заключаются в следующем:

Доклад Управления Панели инструментов -> Поле Метки -> Свойства вкладка "Общие"

  • Имя:
  • Лейбл:
  • Позиция X:
  • Позиция Y:
  • Ширина:
  • Высота:
  • Распечатать повторяющиеся значения:
  • Условная печати выражения:
  • Шрифт:
  • Печать, когда группа изменений:
  • Цвет фона:
  • Фон прозрачным:
  • (По горизонтали) Выравнивание:
  • Вертикальное выравнивание:

Доклад Управления Панели инструментов -> Отформатированное Поле -> Свойства вкладка "Общие"

  • Имя:
  • Позиция X:
  • Позиция Y:
  • Ширина:
  • Высота:
  • Распечатать повторяющиеся значения:
  • Условная печати выражения:
  • Шрифт:
  • Печать, когда группа изменений:
  • Цвет фона:
  • Фон прозрачным:
  • Форматирование:
  • (По горизонтали) Выравнивание:

Доклад Управления Панели инструментов -> Отформатированное Поле -> Свойства закладка Данные

  • Поле данных типа: тип данных (поля или формулы, функции, счетчик, определяемые пользователем функции)
  • Поле данных колонок / полях доклада источник
  • Функции: например, суммы, минимум, максимум
  • Область: Содержит все имена всех групп. Это включает в себя группу, в которой этот элемент содержится в, а также сам доклад как верхнего уровня сферы.

Смотрите here здесь для более подробной информации.

Доклад Управления Панели инструментов -> Управление Изображением -> Свойства вкладка "Общие"

  • Имя:
  • Сохранить ссылку как:
  • Позиция X:
  • Позиция Y:
  • Ширина:
  • Высота:
  • Распечатать повторяющиеся значения:
  • Условная печати выражения:
  • Печать, когда группа изменений:
  • Цвет фона:
  • Фон прозрачным:
  • Графика:
  • (По горизонтали) Выравнивание:
  • Масштаб:

Панель инструментов Управление Отчетом -> Управление Изображением -> Свойства закладка Данные

  • Поле данных Тип:
  • Поле данных:
  • Функция:
  • Область:

Панель инструментов Управление Отчетом->Диаграмма/Форма -> Свойства вкладка "Общие"

  • Имя:
  • Позиция X:
  • Позиция Y:
  • Ширина:
  • Высота:
  • Распечатать повторяющиеся значения:
  • Условная печати выражения:
  • Печать, когда группа изменений:
  • Шрифт:
  • Цвет фона:
  • Тип диаграммы:
  • Предварительный строки:

Панель инструментов Управление Отчетом -> Диаграмма/Форма -> Свойства закладка Данные

  • Тип содержимого:
  • Содержание:
  • Анализ SQL зароса:
  • Фильтр:
  • Сортировка:
  • Свяжите ведущие поля:
  • Свяжие ведомые поля

Панель инструментов Управление Отчетом -> Fixed Line -> Свойства вкладка "Общие"

  • Имя:
  • Позиция X:
  • Позиция Y:
  • Ширина:
  • Высота:
  • Ориентация:


Синтаксис

  • quote for [ is \
  • \\
  • [] as reference for formula or field name
  • "" to quote strings
  • . as decimal separator
  • date as in java specific
  • parameter separator is ; (semicolon) and it is allowed to let some parameters empty inside a call like XYZ(;kk;;kkb)


Функции

Все текущих отчетов (Версон 1.0.x) включает в себя функции в следующих категориях:

Datetime
DATE, DATEDIF, DATEVALUE, DAY, DAYS, HOUR, MINUTE, MONTH, NOW, SECOND, TIME, TIMEVALUE, TODAY, WEEKDAY, YEAR

Financial
Financial

Information
CHOOSE, COUNT, COUNTA, COUNTBLANK, HASCHANGED, ISBLANK, ISERR, ISERROR, ISEVEN, ISLOGICAL, ISNA, ISNONTEXT, ISNUMBER, ISODD, ISREF, ISTEXT, NA

Logical
AND, FALSE, IF, NOT, OR, TRUE, XOR

Math
ABS, AVERAGE, EVEN, MAX, MAXA, MIN, MINA, MOD, ODD, SUM

Rounding
INT

Text
EXACT, FIND, LEFT, LEN, LOWER, MID, REPLACE, REPT, RIGHT, SUBSTITUTE, T, TEXT, TRIM, UNICHAR, UNICODE, UPPER, URLENCODE

Userdefined
NULL

Подробные объяснения указанных выше функций можно найти здесь. Дополнительная информация и код можно найти здесь.

Пожалуйста, обратите внимание, что эти функции являются специфическими для SRB. Дополнительная функциональность может быть получена из базы данных возможностей. Например, если вы используете родную OpenOffice.org базу данных HSQL, то вы можете также использовать HSQL функций и хранимых процедур вместе с OpenOffice.org запросы для получения широкого спектра информации, указанной в отчетах.



Examples

Пример функции

В рисунке ниже показано, как итог поля создаются в дизайнере отчетов, с помощью функций:

SumFieldInReportBuilder.jpg

В таблице исходных отчетов показано в левом верхнем углу.

Итоговый отчет макет показано ниже в таблице. Группа была определена на plProductType области. Сумма поле создается на группу колонтитула. Правая часть изображения показывает определение функции, которая выступает в качестве источника данных для суммы области.

Query Example

The URL below shows how to use queries in Report Builder:

See here.

Computed Fields Example

Computed fields can be created in the way that the formula is entered directly into the data field.

E.g. 100*[Population]/[PopulationCount] to get the percentage of the current population


Extensions

EuroOffice Map Chart

One extension further extends the functionality of Sun Report Builder. A detailed description of its use together with the basic steps of creating your first report can be found here. This tutorial goes from creating your first report to defining a quite complicated new function, so it can be a useful resource for beginners and advanced users alike (not just for those looking for a way to create map charts).

Personal tools
In other languages