Difference between revisions of "IT/Documentation/OOo3 User Guides/Getting Started/Using data sources"

From Apache OpenOffice Wiki
Jump to: navigation, search
(Documenti Writer)
 
(12 intermediate revisions by 2 users not shown)
Line 5: Line 5:
 
|NextPage=IT/Documentation/OOo3_User_Guides/Getting Started/Entering data in a form
 
|NextPage=IT/Documentation/OOo3_User_Guides/Getting Started/Entering data in a form
 
}}__NOTOC__
 
}}__NOTOC__
 
 
 
 
 
 
 
 
Pagina in traduzione - Translation in progress
 
 
 
 
 
 
 
 
 
 
OpenOffice.org consente l'accesso a sorgenti dati e quindi il loro collegamento con documenti di OOo. Per esempio, una stampa in serie collega un documento esterno contenente un elenco di nomi e di indirizzi ad una lettera, generando una copia della lettera per ogni voce della lista.
 
OpenOffice.org consente l'accesso a sorgenti dati e quindi il loro collegamento con documenti di OOo. Per esempio, una stampa in serie collega un documento esterno contenente un elenco di nomi e di indirizzi ad una lettera, generando una copia della lettera per ogni voce della lista.
  
Line 28: Line 11:
 
Una volta che la sorgente dati è stata registrata, può essere utilizzata anche dagli altri componenti di OpenOffice.org (ad esempio da Writer oppure Calc) facendo clic su '''Visualizza > Sorgenti dati''' oppure premendo il tasto ''F4'' della tastiera.
 
Una volta che la sorgente dati è stata registrata, può essere utilizzata anche dagli altri componenti di OpenOffice.org (ad esempio da Writer oppure Calc) facendo clic su '''Visualizza > Sorgenti dati''' oppure premendo il tasto ''F4'' della tastiera.
  
{{Documentation/Tip|Tra le sorgenti dati si può accedere alla rubrica di Mozilla e a database dBase; è inoltre possibile aggiungere delle voci o modificarle.}}
+
{{Tip|Tra le sorgenti dati si può accedere alla rubrica di Mozilla e a database dBase; è inoltre possibile aggiungere delle voci o modificarle.}}
  
{{Documentation/Caution|È possibile accedere a fogli elettronici, ma in questo caso non è possibile effettuare modifiche; tutte le modifiche desiderate in una tabella derivata da un foglio elettronico devono essere fatte nel foglio stesso. Aggiornate il database e salvatelo; a questo punto potrete vedere nel vostro database le modifiche fatte e salvate nel foglio di lavoro. Se create e salvate una tabella aggiuntiva nel vostro foglio di lavoro, troverete una nuova tabella nel database, alla sua successiva apertura.}}
+
{{Warn|È possibile accedere a fogli elettronici, ma in questo caso non è possibile effettuare modifiche; tutte le modifiche desiderate in una tabella derivata da un foglio elettronico devono essere fatte nel foglio stesso. Aggiornate il database e salvatelo; a questo punto potrete vedere nel vostro database le modifiche fatte e salvate nel foglio di lavoro. Se create e salvate una tabella aggiuntiva nel vostro foglio di lavoro, troverete una nuova tabella nel database, alla sua successiva apertura.}}
  
 
==Accedere ad un database dBase==
 
==Accedere ad un database dBase==
Line 37: Line 20:
 
<li>Selezionate '''File > Nuovo > Database''' per visualizzare la finestra ''Creazione guidata database''.</li>
 
<li>Selezionate '''File > Nuovo > Database''' per visualizzare la finestra ''Creazione guidata database''.</li>
  
{{Documentation/Note|Per visualizzare la finestra di dialogo ''Creazione guidata Database'' potete anche fare clic sulla piccola freccia accanto all'icona ''Nuovo'' e poi selezionare ''Database'' nel menù a tendina.}}
+
{{Note|Per visualizzare la finestra di dialogo ''Creazione guidata Database'' potete anche fare clic sulla piccola freccia accanto all'icona ''Nuovo'' e poi selezionare ''Database'' nel menù a tendina.}}
  
 
<li>Selezionate l'opzione '''Collega a un database esistente'''. Premete il tasto ''TAB'' per selezionare l'elenco a tendina ''Tipo database''; poi, premendo il tasto ''D'', selezionate ''dBase''. Fate clic su '''Avanti.'''</li>
 
<li>Selezionate l'opzione '''Collega a un database esistente'''. Premete il tasto ''TAB'' per selezionare l'elenco a tendina ''Tipo database''; poi, premendo il tasto ''D'', selezionate ''dBase''. Fate clic su '''Avanti.'''</li>
  
{{Documentation/Note|Potete anche fare clic sul pulsante con la freccia per aprire un menu nel quale potrete selezionare ''dBase'' (figura sotto).}}
+
{{Note|Potete anche fare clic sul pulsante con la freccia per aprire un menu nel quale potrete selezionare ''dBase'' (figura sotto).}}
  
 
: [[Image:Base_se_ti_db.png|thumb|none|500px|''Selezione del tipo di database.'']]
 
: [[Image:Base_se_ti_db.png|thumb|none|500px|''Selezione del tipo di database.'']]
Line 67: Line 50:
 
# Se è necessario specificare un nome utente, indicatelo. Se è necessaria anche una password, attivare la corrispondente opzione. Fate clic su '''Avanti'''.
 
# Se è necessario specificare un nome utente, indicatelo. Se è necessaria anche una password, attivare la corrispondente opzione. Fate clic su '''Avanti'''.
  
{{Documentation/Caution|Questo metodo di accesso al foglio elettronico non vi permette di fare nessuna modifica nel foglio stesso. Tutte le modifiche devono essere fatte all'interno del foglio di lavoro. Questo metodo consente solo di visualizzare il contenuto del foglio di lavoro, eseguire ricerche e creare rapporti basati sui dati che sono già stati inseriti nel foglio elettronico.}}
+
{{Warn|Questo metodo di accesso al foglio elettronico non vi permette di fare nessuna modifica nel foglio stesso. Tutte le modifiche devono essere fatte all'interno del foglio di lavoro. Questo metodo consente solo di visualizzare il contenuto del foglio di lavoro, eseguire ricerche e creare rapporti basati sui dati che sono già stati inseriti nel foglio elettronico.}}
  
 
==Registrare un database creato con OpenOffice.org 2.x e successivi==
 
==Registrare un database creato con OpenOffice.org 2.x e successivi==
Line 107: Line 90:
 
I dati possono essere inseriti in documenti Writer e Calc attraverso le tabelle della finestra sorgente dati. In Writer, possono essere inseriti valori di singoli campi, ed è anche possibile creare una tabella completa. Un tipico modo di utilizzare una sorgente dati è quello della stampa in serie.
 
I dati possono essere inseriti in documenti Writer e Calc attraverso le tabelle della finestra sorgente dati. In Writer, possono essere inseriti valori di singoli campi, ed è anche possibile creare una tabella completa. Un tipico modo di utilizzare una sorgente dati è quello della stampa in serie.
  
{{Documentation/Tip| Selezionate '''Strumenti > Stampa guidata in serie''' oppure fate clic sull'icona Stampa in serie (una piccola icona in cima al pannello della visualizzazione sorgenti dati che rappresenta un foglio e una busta), per avviare la procedura guidata Stampa in serie di OpenOffice.org, che permette di creare un documento di preparazione per la stampa in serie. Questo argomento è trattato nel Capitolo 11 (Usare la stampa in serie) della [[../../Writer Guide|Guida a Writer]].}}
+
{{Tip| Selezionate '''Strumenti > Stampa guidata in serie''' oppure fate clic sull'icona Stampa in serie (una piccola icona in cima al pannello della visualizzazione sorgenti dati che rappresenta un foglio e una busta), per avviare la procedura guidata Stampa in serie di OpenOffice.org, che permette di creare un documento di preparazione per la stampa in serie. Questo argomento è trattato nel [[../../Writer Guide/Using Mail Merge|Capitolo 11 (Uso della Stampa in serie)]] della ''Guida a Writer''.}}
  
 
===Documenti Writer===
 
===Documenti Writer===
Line 123: Line 106:
 
#* Assicuratevi di avere il giusto spazio tra il nome del campo e le parole inserite prima e dopo il campo.
 
#* Assicuratevi di avere il giusto spazio tra il nome del campo e le parole inserite prima e dopo il campo.
 
#* Risultato: Il giorno <Data> la nostra colazione del costo di <Colazione>,
 
#* Risultato: Il giorno <Data> la nostra colazione del costo di <Colazione>,
 
 
 
 
 
# Sostituite il primo nome:
 
# Sostituite il primo nome:
 
+
#* Continuate a scrivere dopo <Colazione>: è stata pagata da (assicuratevi di avere aggiunto lo spazio successivo).
*  
+
#* Fate clic sul nome del campo APagamento e trascinatelo alla destra della frase appena digitata.
** <nowiki>Continuate a scrivere dopo <Colazione>: </nowiki>''è stata pagata da ''(assicuratevi di avere aggiunto lo spazio successivo).
+
#* Inserite una virgola dopo il campo <APagamento>.
** Fate clic sul nome del campo ''APagamento'' e trascinatelo alla destra della frase appena digitata.
+
#* Risultato: Il giorno <Data> la nostra colazione del costo di <Colazione> è stata pagata da <APagamento>,
** <nowiki>Inserite una virgola dopo il campo <APagamento>.</nowiki>
+
** Risultato: Il giorno <nowiki><Data></nowiki> la nostra colazione del costo di <nowiki><Colazione></nowiki> e stata pagata da <nowiki><APagamento></nowiki>,
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
# Seguite questi esempi per riempire il resto dei campi della frase.
 
# Seguite questi esempi per riempire il resto dei campi della frase.
 
+
#* Usate <Pranzo> e <BPagamento> per la seconda coppia di (costo) e (nome) della frase.
*  
+
#* Usate <Cena> e <CPagamento> per la terza parte (costo) e (nome) della frase.
** <nowiki>Usate <Pranzo> e <BPagamento> per la seconda coppia di (costo) e (nome) della frase.</nowiki>
+
#* Risultato finale: Il giorno <Data> la nostra colazione del costo di <Colazione> è stata pagata da <APagamento>, il nostro pranzo del costo di <Pranzo> é stato pagato da <BPagamento>, la nostra cena del costo di <Cena> è stata pagata da <CPagamento>.
** <nowiki>Usate <Cena> e <CPagamento> per la terza parte (costo) e (nome) della frase.</nowiki>
+
** Risultato finale: Il giorno <nowiki><Data></nowiki> la nostra colazione del costo di <nowiki><Colazione></nowiki> è stata pagata da <nowiki><APagamento></nowiki>, il nostro pranzo del costo di <nowiki><Pranzo></nowiki> é stato pagato da <nowiki><BPagamento</nowiki>, la nostra cena del costo di <nowiki><Cena></nowiki> è stata pagata da <nowiki><CPagamento></nowiki>.
+
 
+
 
# Aggiungete ora i dati ai campi della frase:
 
# Aggiungete ora i dati ai campi della frase:
 +
#* Fate clic nel riquadro grigio a sinistra della riga in cui volete aggiungere i dati. Questa riga dovrebbe essere evidenziata come la seconda riga nella figura sottostante.
 +
#* Fate clic sull'icona Dati in campi (cerchiata in nero nella figura sottostante). Questa operazione dovrebbe mostrarvi i campi compilati con i dati della riga che avete scelto.
 +
#* Selezionate un'altra riga e fate ancora clic su questa icona. I dati nella frase cambiano con quelli della riga scelta ora.
 +
# Salvate il documento.
  
*
+
Aggiungere dati in una tabella è più semplice e richiede forse meno passaggi. Alcuni dei passaggi sono molto simili.
** Fate clic nel riquadro grigio a sinistra della riga in cui volete aggiungere i dati. Questa riga dovrebbe essere evidenziata come la seconda riga nella Figura 61.
+
** Fate clic sull'icona ''Dati in campi ''(cerchiata in nero nella Figura 61). Questa operazione dovrebbe mostrarvi i campi compilati con i dati della riga che avete scelto.
+
** Selezionate un'altra riga e fate ancora clic su questa icona. I dati nella frase cambiano con quelli della riga scelta ora.
+
** Salvate il documento.
+
  
Aggiungere dati in una tabella è più semplice e richiede forse meno passaggi. Parte dei passaggi sono molto simili.
+
{{Note|In questo modo i dati possono essere aggiunti in due modi: come campi o come testo, seguendo i passi successivi. Lasciamo al lettore che vuole sperimentare la possibilità di cambiare le selezioni in Inserisci colonne database per vedere il risultato che si può ottenere.}}
  
 +
<ol>
 +
<li>Spostatevi nella posizione in cui volete inserire la tabella e fate clic.</li>
 +
<li>Fate clic sul riquadro grigio a sinistra di ogni riga della sorgente dati che volete importare come riga nella vostra tabella.</li>
 +
<li>Fate clic sull'icona Dati in testo per aprire la finestra Inserisci colonne di database (l'icona ''Dati in testo'' è contrassegnata con un cerchio rosso nell'immagine sotto riportata).</li>
 +
[[Image:Base_ri_se_rsd_it.png|thumb|none|500px|''Riga selezionata nel riquadro sorgenti dati.'']]
 +
[[Image:Base_fi_in_co_db_it.png|thumb|none|500px|''Finestra Inserisci colonne di database.'']]
 +
<li>Spostate i campi che desiderate nella tabella dall'elenco Colonne Database all'elenco Colonne Tabella.</li>
 +
* Per posizionare i campi nell'ordine che desiderate, fateci clic sopra ed usate la freccia singola per spostarli nell'ordine preferito. Potete anche usare solo i campi che vi occorrono e non necessariamente tutti quelli disponibili.
 +
* Se desiderate invece selezionare tutti i campi, usate la doppia freccia che punta verso destra per spostarli tutti assieme. L'ordine dei campi nella tabella creata sarà lo stesso della tabella sorgente dati.
 +
* Se volete rimuovere un campo dall'elenco Colonne tabella, fateci clic sopra ed utilizzate la freccia singola che punta a sinistra.
 +
* Se volete ricominciare la procedura spostando tutti i campi indietro nell'elenco Colonne database, fate clic sulla doppia freccia che punta verso sinistra.
 +
<li>Scegliete la configurazione della vostra tabella. Utilizzate la configurazione standard mostrata nella figura sopra riportata.</li>
 +
<li>Fate clic su OK.</li>
 +
<li>Salvate il documento.</li>
 +
</ol>
  
{| style="border-spacing:0;"
+
===Fogli elettronici di Calc===
| style="border-top:0.035cm solid #000080;border-bottom:0.035cm solid #000080;border-left:none;border-right:none;padding:0.15cm;"| <center>'''Nota'''</center>
+
| style="border-top:0.035cm solid #000080;border-bottom:0.035cm solid #000080;border-left:none;border-right:none;padding:0.15cm;"| In questo modo i dati possono essere aggiunti in due modi: come campi o come testo, seguendo i passi successivi. Lasciamo al lettore che vuole sperimentare la possibilità di cambiare le selezioni in ''Inserisci colonne database ''per vedere il risultato che si può ottenere.
+
 
+
|}
+
<center>[[Image:|thumb|<center></center> <center>''Figura 5: Riga selezionata nel riquadro sorgenti dati''</center>]]</center>
+
 
+
# Spostatevi nella posizione in cui volete inserire la tabella e fate clic.
+
# Fate clic sul riquadro grigio a sinistra di ogni riga della sorgente dati che volete importare come riga nella vostra tabella.
+
# Fate clic sull'icona ''Dati in testo ''per aprire la finestra Inserisci colonne di database (Figura 6) (l'icona ''Dati in testo'' è contrassegnata con un cerchio rosso nella Figura 5).
+
 
+
<center>[[Image:|thumb|<center>''Figura 6: Finestra Inserisci colonne di database''</center>]]</center>
+
 
+
# Spostate i campi che desiderate nella tabella dall'elenco ''Colonne database'' all'elenco ''Colonne tabella''.
+
 
+
*
+
** Per posizionare i campi nell'ordine che desiderate, fateci clic sopra ed usate la ''freccia singola'' per spostarli nell'ordine preferito. Potete anche usare solo i campi che vi occorrono e non necessariamente tutti quelli disponibili.
+
** Se desiderate invece selezionare tutti i campi, usate la ''doppia freccia ''che punta verso destra per spostarli tutti assieme; l'ordine dei campi nella tabella creata sarà lo stesso della tabella sorgente dati.
+
** Se volete rimuovere un campo dall'elenco ''Colonne tabella'', fateci clic sopra ed utilizzate la ''freccia singola ''che punta a sinistra.
+
** Se volete ricominciare la procedura spostando tutti i campi indietro nell'elenco ''Colonne database'', fate clic sulla ''doppia freccia ''che punta verso sinistra.
+
 
+
# Scegliete la configurazione della vostra tabella. Utilizzate la configurazione standard mostrata nella Figura 6.
+
# Fate clic su '''OK'''.
+
# Salvate il documento.
+
 
+
=== Fogli elettronici di Calc ===
+
 
Ci sono due modi per inserire dati in un foglio di lavoro di Calc. Uno permette di inserire i dati nelle celle del foglio elettronico. L'altro crea dei record nel foglio elettronico, così come vengono gestiti nella creazione di un formulario in un database. È possibile accedere direttamente ai dati contenuti nelle celle del foglio di calcolo, mentre i dati dei record creati nel foglio di calcolo possono essere solo visualizzati.
 
Ci sono due modi per inserire dati in un foglio di lavoro di Calc. Uno permette di inserire i dati nelle celle del foglio elettronico. L'altro crea dei record nel foglio elettronico, così come vengono gestiti nella creazione di un formulario in un database. È possibile accedere direttamente ai dati contenuti nelle celle del foglio di calcolo, mentre i dati dei record creati nel foglio di calcolo possono essere solo visualizzati.
  
Per inserire i dati direttamente nelle celle del foglio di calcolo si utilizza l'icona ''Dati in testo'', come per inserire una tabella in un documento Writer. Ma tra questi due casi esistono delle differenze.
+
Per inserire i dati direttamente nelle celle del foglio di calcolo si utilizza l'icona Dati in testo, come per inserire una tabella in un documento Writer. Ma tra questi due casi esistono delle differenze.
  
 
La procedura è molto semplice.
 
La procedura è molto semplice.
Line 208: Line 151:
 
# Usate F4 per aprire la finestra sorgente dati e selezionate la tabella della quale volete utilizzare i dati.
 
# Usate F4 per aprire la finestra sorgente dati e selezionate la tabella della quale volete utilizzare i dati.
 
# Selezionate le righe dei dati che volete inserire nel foglio di calcolo:
 
# Selezionate le righe dei dati che volete inserire nel foglio di calcolo:
 
+
#* Fate clic nel riquadro grigio a sinistra della riga che volete selezionare, se è solo di una riga che avete bisogno. Tale riga sarà evidenziata.
*
+
#* Per selezionare più righe, tenete premuto il tasto MAIUSC mentre fate clic sul riquadro grigio delle righe di cui avete bisogno. Queste righe verranno evidenziate.
** Fate clic nel riquadro grigio a sinistra della riga che volete selezionare, se è solo di una riga che avete bisogno. Tale riga sarà evidenziata.
+
#* Per selezionare tutte le righe presenti, fate clic sul riquadro grigio nell'angolo superiore sinistro. Tutte le righe verranno evidenziate.
** Per selezionare più righe, tenete premuto il tasto ''MAIUSC'' mentre fate clic sul riquadro grigio delle righe di cui avete bisogno. Queste righe verranno evidenziate.
+
# Fate clic sull'icona Dati in testo per inserire i dati nelle celle del foglio di calcolo.
** Per selezionare tutte le righe presenti, fate clic sul riquadro grigio nell'angolo superiore sinistro. Tutte le righe verranno evidenziate.
+
 
+
# Fate clic sull'icona ''Dati in testo'' per inserire i dati nelle celle del foglio di calcolo.
+
 
# Salvate il foglio di calcolo.
 
# Salvate il foglio di calcolo.
  
Aggiungere dei record ad un foglio di calcolo è molto semplice. Dovete aver aperta la finestra ''Sorgenti dati ''ed il vostro foglio di calcolo, e selezionata la tabella dalla quale desiderate prelevare i dati.
+
Aggiungere dei record ad un foglio di calcolo è molto semplice. Dovete aver aperta la finestra Sorgenti dati ed il vostro foglio di calcolo, e selezionata la tabella dalla quale desiderate prelevare i dati.
  
 
# Fate clic nel riquadro grigio con il nome del campo che desiderate usare per evidenziarlo.
 
# Fate clic nel riquadro grigio con il nome del campo che desiderate usare per evidenziarlo.
Line 223: Line 163:
 
# Ripetete questo passaggio fino a che avete posizionato tutti i campi che vi occorrono nella giusta posizione.
 
# Ripetete questo passaggio fino a che avete posizionato tutti i campi che vi occorrono nella giusta posizione.
 
# Chiudete la finestra Sorgenti dati: utilizzate il tasto ''F4''.
 
# Chiudete la finestra Sorgenti dati: utilizzate il tasto ''F4''.
# Salvate il foglio di calcolo e fate clic sul pulsante ''Modifica file'' per impostare il foglio come di sola lettura. Tutti i campi visualizzeranno il valore dei dati del primo record che avete selezionato.
+
# Salvate il foglio di calcolo e fate clic sul pulsante Modifica file per impostare il foglio come di sola lettura. Tutti i campi visualizzeranno il valore dei dati del primo record che avete selezionato.
# Aggiungete la barra ''Navigazione formulario'': '''Visualizza > Barre degli strumenti > Navigazione formulario'''.
+
# Aggiungete la barra Navigazione formulario: '''Visualizza > Barre degli strumenti > Navigazione formulario'''.
 +
# Fate clic sulle frecce della barra Navigazione formulario per vedere i diversi record della tabella (le frecce sono cerchiate in rosso). Il numero nella casella cambia in base al numero del record selezionato facendo clic sulle frecce. I dati nei campi variano in base al contenuto del record selezionato.
  
<center>[[Image:|thumb|''Figura 7: Frecce di navigazione del formulario'']]</center>
+
[[Image:NavArrows.png|thumb|none|500px|''Frecce di navigazione del formulario.'']]
  
# Fate clic sulle frecce della barra ''Navigazione formulario'' per vedere i diversi record della tabella (le frecce sono cerchiate in rosso). Il numero nella casella cambia in base al numero del record selezionato facendo clic sulle frecce. I dati nei campi variano in base al contenuto del record selezionato.
+
[[#top|Inizio pagina]]
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
# Replacing the first name:
+
#* Continue typing after <Breakfast>: paid by making sure to add a space afterward.
+
#* Click the Bpayment field name and drag it to the right of what you just typed.
+
#* Place a comma after <Bpayment>.
+
#* Results so far: On <Date> our breakfast cost <Breakfast> paid by Dan<BPayment>,
+
# Follow these examples to fill in the rest of the fields in the sentence.
+
#* Use <Lunch> and <Lpayment> for the second set of (amount) and (name) in the sentence.
+
#* Use <Supper> and <Spayment> for the third set of (amount) and (name) in th sentence.
+
#* Final results: On <Date> our breakfast cost <Breakfast> paid by <BPayment>, our lunch cost <Lunch> paid by <LPayment>, our supper cost <Supper> paid by <SPayment>.
+
# Add data to the fields of the sentence:
+
#* Click the gray box to the left of the row of data you want to add. That row should be highlighted like the second row of Figure 61.
+
#* Click the Data to Fields icon (circled in black in Figure 61).This should fill the fields with the data from the row you chose.
+
#* Click another row and then click this icon again. The data in the sentence changes to this selected row of data.
+
# Save the document.
+
 
+
Adding data in table format is a little easier and takes perhaps a few less steps. Some of the steps will be quite similar.
+
 
+
{{Documentation/Note|Data can be added this way as a fields or text. Following the following steps. I leave this to the reader with which to experiment by changing the selections in the Insert Database Columns to see what results you can get.}}
+
 
+
<ol>
+
<li>Navigate to the place you want to place the table and click the location.</li>
+
<li>Click the gray box to the left of each row of the data source that you want to be a row in your table.</li>
+
<li>Click the Data to text icon to open the Insert Database Columns dialog. (The ''Data to text'' icon is circled in red below.)</li>
+
[[Image:DataToSourceIcon.png|thumb|none|500px|''Selected row in data source window.'']]
+
[[Image:InsDBCols.png|thumb|none|500px|''Insert Database Columns dialog.'']]
+
<li>Move the fields you want in your table from the Database Columns list to Table column(s) list.</li>
+
* To place the fields in the order you select, click the field and use the single arrow to move the fields in the order you desire. You can also limit the fields you use to less than all of the fields available.
+
* If you want to use all of the fields, use the double arrow pointing to the right to move all of them at one time. The order of the fields in the table you create will be the same as in the data source table.
+
* If you want to remove a single field from the Table Column(s) list, click the field and use the single arrow pointing to the left.
+
* If you want to start over by moving all of the fields back to the Database Columns list, click the double arrow pointing to the left.
+
<li>Select the settings for your table. Use the default settings as in the figure above.</li>
+
<li>Click OK.</li>
+
<li>Save the document.</li>
+
</ol>
+
 
+
===Calc spreadsheets===
+
There are two ways to enter data in a Calc spreadsheet. One enters the data into the spreadsheet cells. The other creates records in the spreadsheet just like they are done in creating a form in a database. While you can directly access the data in the spreadsheet cells, you can only see the data in the records created in the spreadsheet.
+
 
+
Entering data directly to the spreadsheet cells uses the Data to Text icon as we did to make a table in a Writer document. But differences exist in these two situations.
+
 
+
The steps are straightforward.
+
 
+
# Click the cell of the spreadsheet which you want to be the top left of your data including the column names.
+
# Use F4 to open the database source window and select the table whose data you want to use.
+
# Select the rows of data you want to add to the spreadsheet:
+
#* Click the gray box to the left of the row you want to select if only selecting one row. That row is highlighted.
+
#* To select multiple rows, hold down the shift key while clicking the gray box of the rows you need. Those rows are highlighted.
+
#* To select all the rows, click the gray box in the upper left corner. All rows are highlighted.
+
# Click the Data to text icon to insert the data into the spreadsheet cells.
+
# Save the spreadsheet.
+
 
+
Adding records to a spreadsheet is fairly easy. You need to have the Data Source window open, your spreadsheet open, and the table you want to use selected.
+
 
+
# Click the gray box above the field name you wish to use to highlight it.
+
# Drop and drag the gray box to where you want the record to appear in the spreadsheet.
+
# Repeat until you have moved all of the fields you need to where you want them.
+
# Close the Data Source window: use ''F4''.
+
# Save the spreadsheet and click the Edit File button to make the spreadsheet read only. All of the fields will show the value for the data of the first record you selected.
+
# Add the Form Navigation toolbar: '''View > Toolbars > Form Navigatio'''n.
+
# Click the arrows on the Form Navigation toolbar to view the different records of the table. (The arrows are circled in red.) The number in the box changes when you change the record number by clicking an arrow. The data in the fields changes correspondingly to the data for that particular record number.
+
 
+
[[Image:NavArrows.png|thumb|none|500px|''Navigation arrows of a form.'']]
+
 
+
[[#top|Top of page]]
+
  
  
 
{{CCBY}}
 
{{CCBY}}
 
[[Category:Getting Started (Documentation)]]
 
[[Category:Getting Started (Documentation)]]

Latest revision as of 09:53, 16 July 2018



OpenOffice.org consente l'accesso a sorgenti dati e quindi il loro collegamento con documenti di OOo. Per esempio, una stampa in serie collega un documento esterno contenente un elenco di nomi e di indirizzi ad una lettera, generando una copia della lettera per ogni voce della lista.

Per registrare una sorgente dati, scegliete File > Nuovo > Database per aprire la creazione guidata database. Selezionate Collega ad un database esistente; questo vi consente di accedere all'elenco delle sorgenti dati che possono essere registrate con OOo. Potete accedere a queste sorgenti dati nello stesso modo con cui accedete ad un database dBase, come spiegato nella sezione successiva.

Una volta che la sorgente dati è stata registrata, può essere utilizzata anche dagli altri componenti di OpenOffice.org (ad esempio da Writer oppure Calc) facendo clic su Visualizza > Sorgenti dati oppure premendo il tasto F4 della tastiera.

Tip.png Tra le sorgenti dati si può accedere alla rubrica di Mozilla e a database dBase; è inoltre possibile aggiungere delle voci o modificarle.


Documentation caution.png È possibile accedere a fogli elettronici, ma in questo caso non è possibile effettuare modifiche; tutte le modifiche desiderate in una tabella derivata da un foglio elettronico devono essere fatte nel foglio stesso. Aggiornate il database e salvatelo; a questo punto potrete vedere nel vostro database le modifiche fatte e salvate nel foglio di lavoro. Se create e salvate una tabella aggiuntiva nel vostro foglio di lavoro, troverete una nuova tabella nel database, alla sua successiva apertura.

Accedere ad un database dBase

  1. Selezionate File > Nuovo > Database per visualizzare la finestra Creazione guidata database.
  2. Documentation note.png Per visualizzare la finestra di dialogo Creazione guidata Database potete anche fare clic sulla piccola freccia accanto all'icona Nuovo e poi selezionare Database nel menù a tendina.
  3. Selezionate l'opzione Collega a un database esistente. Premete il tasto TAB per selezionare l'elenco a tendina Tipo database; poi, premendo il tasto D, selezionate dBase. Fate clic su Avanti.
  4. Documentation note.png Potete anche fare clic sul pulsante con la freccia per aprire un menu nel quale potrete selezionare dBase (figura sotto).
    Selezione del tipo di database.
  5. Fate clic su Sfoglia e selezionate la cartella che contiene il database. Fate clic su Avanti.
  6. Accettate le impostazioni predefinite: Sì, registra il database e Apri il database per la modifica, poi fate clic su Fine. Assegnate un nome al database e salvatelo nella cartella desiderata.
  7. Create il Formulario utilizzando la Creazione guidata formulario come spiegato alla pagina Creazione di un formulario.

Accedere ad una Rubrica Mozilla

La procedura per accedere a una rubrica Mozilla è molto simile a quella vista per accedere a un database dBase.

  1. Selezionate File > Nuovo > Database.
  2. Selezionate Collega ad un database esistente. Selezionate Rubrica Mozilla come tipologia di database.
  3. Registrate questa sorgente dati.

Questo corrisponde ai passaggi 1, 2 e 4 di Accedere ad un database dBase.

Accedere ai fogli elettronici

Anche in questo caso la procedura è molto simile a quella vista per accedere ai database dBase.

  1. Selezionate File > Nuovo > Database.
  2. Selezionate l'opzione Collega a un database esistente. Selezionate Foglio elettronico come tipo di Database.
  3. Fate clic su Sfoglia per cercare il foglio elettronico a cui volete collegarvi. Se il foglio elettronico è protetto da password, attivate l'opzione Password necessaria. Fate clic su Avanti.
  4. Se è necessario specificare un nome utente, indicatelo. Se è necessaria anche una password, attivare la corrispondente opzione. Fate clic su Avanti.
Documentation caution.png Questo metodo di accesso al foglio elettronico non vi permette di fare nessuna modifica nel foglio stesso. Tutte le modifiche devono essere fatte all'interno del foglio di lavoro. Questo metodo consente solo di visualizzare il contenuto del foglio di lavoro, eseguire ricerche e creare rapporti basati sui dati che sono già stati inseriti nel foglio elettronico.

Registrare un database creato con OpenOffice.org 2.x e successivi

Si tratta di una procedura molto semplice. Fate clic su Strumenti > Opzioni > OpenOffice.org Base > Database. Sotto la scritta database registrati, c'è un elenco di questi database. Sotto questo elenco sono visibili tre pulsanti: Nuovo, Elimina, Modifica. Per registrare un database creato con OpenOffice.org 2.x e successivi;

  1. Fate clic su Nuovo.
  2. Navigate fino alla cartella in cui si trova il database.
  3. Assicuratevi che il nome registrato sia corretto.
  4. Fate clic su OK.

Inizio pagina

Utilizzo delle sorgenti dati in OpenOffice.org

Le sorgenti dati registrate, siano esse fogli elettronici, documenti di testo, database esterni o altre sorgenti compatibili, possono essere utilizzate con gli atri componenti di OpenOffice.org, inclusi Writer e Calc.

Visualizzazione delle sorgenti dati

Aprite un documento con Writer oppure Calc. Per visualizzare le sorgenti dati a disposizione potete premere F4 o selezionare nel menu a scomparsa Visualizza > Sorgenti dati. In questo modo viene mostrato un elenco dei database registrati, incluso Bibliography e qualsiasi altro database registrato.

Per visualizzare ciascun database fate clic sul segno + a sinistra del nome del database (nella figura sottostante si vede il contenuto del database Automobile). In questo modo si visualizzano le tabelle e le ricerche del database. Fate clic sul segno + accanto a Tabelle per visualizzare le singole tabelle create. Ora fate clic su una tabella per visualizzare tutti i record in essa contenuti.

Database.

Modifica delle sorgenti dati

Alcune sorgenti dati (ma non i fogli elettronici) possono essere modificate all'interno della finestra Visualizza Sorgenti dati; è possibile modificare, aggiungere o eliminare record di dati. I dati sono visualizzati nella parte destra dello schermo; fate clic in un campo per modificarne il valore.

Al di sotto dei record di dati sono presenti cinque piccoli pulsanti. I primi quattro permettono di spostarsi indietro o avanti attraverso i record, oppure direttamente all'inizio o alla fine. Il quinto pulsante, sul quale è raffigurata una piccola stella, permette di inserire un nuovo record (vedere sotto).

Pulsanti di navigazione all'interno di Visualizzazione sorgenti dati.

Per eliminare un record, fate clic con il tasto destro sul riquadro grigio a sinistra della riga per evidenziarla, quindi selezionate Elimina righe per rimuovere la riga selezionata.

Eliminazione di una riga nella finestra di Visualizzazione dati.

Avvio di Base per lavorare con sorgenti dati

È possibile avviare in qualsiasi momento OpenOffice.org Base dal pannello Visualizzazione delle sorgenti dati. È sufficiente fare clic con il tasto destro del mouse sull'icona di un database, o delle sue Tabelle o Ricerche, e selezionare la voce Modifica file del database. Una volta avviato Base, è possibile modificare, aggiungere o eliminare tabelle, ricerche, formulari e rapporti.

Utilizzo di sorgenti dati nei documenti di OpenOffice.org

I dati possono essere inseriti in documenti Writer e Calc attraverso le tabelle della finestra sorgente dati. In Writer, possono essere inseriti valori di singoli campi, ed è anche possibile creare una tabella completa. Un tipico modo di utilizzare una sorgente dati è quello della stampa in serie.

Tip.png Selezionate Strumenti > Stampa guidata in serie oppure fate clic sull'icona Stampa in serie (una piccola icona in cima al pannello della visualizzazione sorgenti dati che rappresenta un foglio e una busta), per avviare la procedura guidata Stampa in serie di OpenOffice.org, che permette di creare un documento di preparazione per la stampa in serie. Questo argomento è trattato nel Capitolo 11 (Uso della Stampa in serie) della Guida a Writer.


Documenti Writer

Per inserire un campo di una tabella dalla finestra Sorgenti dati all'interno di un documento Writer, fate clic sul nome del campo (il rettangolo grigio sovrastante l'elenco del campo) e, tenendo premuto il tasto sinistro del mouse, trascinate il campo nel documento. Nel documento Writer, esso apparirà come <CAMPO> (in cui CAMPO rappresenta il nome del campo trascinato).

Per esempio, inserite il costo dei pasti e chi li ha pagati in un certo giorno della vacanza. Create una frase di questo tipo: “Il giorno (data), la nostra colazione del costo di (costo) è stata pagata da (nome), il nostro pranzo del costo di (costo) è stato pagato da (nome), e la nostra cena del costo di (costo) è stata pagata da (nome)”. Scrivete le parole della frase ad eccezione delle parole in parentesi, ed utilizzate poi i nomi dei campi corretti al posto delle parole tra parentesi.

  1. Sostituire (data)
    • Cominciate la frase scrivendo Il giorno.
    • Fate clic sul nome del campo Data nella finestra Sorgente dati e trascinatelo a destra della parola giorno.
    • La frase diventa: Il giorno . Se avete attivato l'ombreggiatura dei nomi di campo (Visualizza > Contrassegni), il campo <Data> sarà contrassegnato da uno sfondo grigio; in caso contrario, no.
  2. Sostituire il primo (costo)
    • Continuate a scrivere dopo <Data>: la nostra colazione del costo di.
    • Fate clic sul campo Colazione e trascinatelo a destra della frase che avete appena scritto.
    • Assicuratevi di avere il giusto spazio tra il nome del campo e le parole inserite prima e dopo il campo.
    • Risultato: Il giorno <Data> la nostra colazione del costo di <Colazione>,
  3. Sostituite il primo nome:
    • Continuate a scrivere dopo <Colazione>: è stata pagata da (assicuratevi di avere aggiunto lo spazio successivo).
    • Fate clic sul nome del campo APagamento e trascinatelo alla destra della frase appena digitata.
    • Inserite una virgola dopo il campo <APagamento>.
    • Risultato: Il giorno <Data> la nostra colazione del costo di <Colazione> è stata pagata da <APagamento>,
  4. Seguite questi esempi per riempire il resto dei campi della frase.
    • Usate <Pranzo> e <BPagamento> per la seconda coppia di (costo) e (nome) della frase.
    • Usate <Cena> e <CPagamento> per la terza parte (costo) e (nome) della frase.
    • Risultato finale: Il giorno <Data> la nostra colazione del costo di <Colazione> è stata pagata da <APagamento>, il nostro pranzo del costo di <Pranzo> é stato pagato da <BPagamento>, la nostra cena del costo di <Cena> è stata pagata da <CPagamento>.
  5. Aggiungete ora i dati ai campi della frase:
    • Fate clic nel riquadro grigio a sinistra della riga in cui volete aggiungere i dati. Questa riga dovrebbe essere evidenziata come la seconda riga nella figura sottostante.
    • Fate clic sull'icona Dati in campi (cerchiata in nero nella figura sottostante). Questa operazione dovrebbe mostrarvi i campi compilati con i dati della riga che avete scelto.
    • Selezionate un'altra riga e fate ancora clic su questa icona. I dati nella frase cambiano con quelli della riga scelta ora.
  6. Salvate il documento.

Aggiungere dati in una tabella è più semplice e richiede forse meno passaggi. Alcuni dei passaggi sono molto simili.

Documentation note.png In questo modo i dati possono essere aggiunti in due modi: come campi o come testo, seguendo i passi successivi. Lasciamo al lettore che vuole sperimentare la possibilità di cambiare le selezioni in Inserisci colonne database per vedere il risultato che si può ottenere.
  1. Spostatevi nella posizione in cui volete inserire la tabella e fate clic.
  2. Fate clic sul riquadro grigio a sinistra di ogni riga della sorgente dati che volete importare come riga nella vostra tabella.
  3. Fate clic sull'icona Dati in testo per aprire la finestra Inserisci colonne di database (l'icona Dati in testo è contrassegnata con un cerchio rosso nell'immagine sotto riportata).
  4. Riga selezionata nel riquadro sorgenti dati.
    Finestra Inserisci colonne di database.
  5. Spostate i campi che desiderate nella tabella dall'elenco Colonne Database all'elenco Colonne Tabella.
    • Per posizionare i campi nell'ordine che desiderate, fateci clic sopra ed usate la freccia singola per spostarli nell'ordine preferito. Potete anche usare solo i campi che vi occorrono e non necessariamente tutti quelli disponibili.
    • Se desiderate invece selezionare tutti i campi, usate la doppia freccia che punta verso destra per spostarli tutti assieme. L'ordine dei campi nella tabella creata sarà lo stesso della tabella sorgente dati.
    • Se volete rimuovere un campo dall'elenco Colonne tabella, fateci clic sopra ed utilizzate la freccia singola che punta a sinistra.
    • Se volete ricominciare la procedura spostando tutti i campi indietro nell'elenco Colonne database, fate clic sulla doppia freccia che punta verso sinistra.
  6. Scegliete la configurazione della vostra tabella. Utilizzate la configurazione standard mostrata nella figura sopra riportata.
  7. Fate clic su OK.
  8. Salvate il documento.

Fogli elettronici di Calc

Ci sono due modi per inserire dati in un foglio di lavoro di Calc. Uno permette di inserire i dati nelle celle del foglio elettronico. L'altro crea dei record nel foglio elettronico, così come vengono gestiti nella creazione di un formulario in un database. È possibile accedere direttamente ai dati contenuti nelle celle del foglio di calcolo, mentre i dati dei record creati nel foglio di calcolo possono essere solo visualizzati.

Per inserire i dati direttamente nelle celle del foglio di calcolo si utilizza l'icona Dati in testo, come per inserire una tabella in un documento Writer. Ma tra questi due casi esistono delle differenze.

La procedura è molto semplice.

  1. Fate clic nella cella del foglio di calcolo che volete sia l'angolo superiore sinistro della tabella, includendo anche il nome della colonna.
  2. Usate F4 per aprire la finestra sorgente dati e selezionate la tabella della quale volete utilizzare i dati.
  3. Selezionate le righe dei dati che volete inserire nel foglio di calcolo:
    • Fate clic nel riquadro grigio a sinistra della riga che volete selezionare, se è solo di una riga che avete bisogno. Tale riga sarà evidenziata.
    • Per selezionare più righe, tenete premuto il tasto MAIUSC mentre fate clic sul riquadro grigio delle righe di cui avete bisogno. Queste righe verranno evidenziate.
    • Per selezionare tutte le righe presenti, fate clic sul riquadro grigio nell'angolo superiore sinistro. Tutte le righe verranno evidenziate.
  4. Fate clic sull'icona Dati in testo per inserire i dati nelle celle del foglio di calcolo.
  5. Salvate il foglio di calcolo.

Aggiungere dei record ad un foglio di calcolo è molto semplice. Dovete aver aperta la finestra Sorgenti dati ed il vostro foglio di calcolo, e selezionata la tabella dalla quale desiderate prelevare i dati.

  1. Fate clic nel riquadro grigio con il nome del campo che desiderate usare per evidenziarlo.
  2. Trascinate il riquadro grigio dove volete che il record venga inserito nel foglio di calcolo.
  3. Ripetete questo passaggio fino a che avete posizionato tutti i campi che vi occorrono nella giusta posizione.
  4. Chiudete la finestra Sorgenti dati: utilizzate il tasto F4.
  5. Salvate il foglio di calcolo e fate clic sul pulsante Modifica file per impostare il foglio come di sola lettura. Tutti i campi visualizzeranno il valore dei dati del primo record che avete selezionato.
  6. Aggiungete la barra Navigazione formulario: Visualizza > Barre degli strumenti > Navigazione formulario.
  7. Fate clic sulle frecce della barra Navigazione formulario per vedere i diversi record della tabella (le frecce sono cerchiate in rosso). Il numero nella casella cambia in base al numero del record selezionato facendo clic sulle frecce. I dati nei campi variano in base al contenuto del record selezionato.
Frecce di navigazione del formulario.

Inizio pagina


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools