Effetti speciali

From Apache OpenOffice Wiki
Jump to: navigation, search







Pagina in traduzione





Con Draw, potrete applicare molti effetti speciali ad un oggetto o a gruppi di oggetti. La sezione successiva descrive alcuni di questi effetti. Altri effetti possono essere distorsione, ombre, e trasparenza. Vedere la Guida di Draw per esempi riguardanti i molti effetti disponibili.

Capovolgere un oggetto

Selezionate un oggetto e fate clic sull'icona Ribalta[[Image:]]. Vedrete una linea tratteggiata passare attraverso il centro dell'oggetto.
[[Image:]]
La linea tratteggiata è l'asse di simmetria. L'oggetto sarà riflesso attorno a questa linea. Muovete una od entrambe le estremità della linea con il mouse per impostare l'asse.
[[Image:]]
Dopo di che, prendete una delle otto maniglie verdi e portatela al di la della linea tratteggiata. La nuova posizione della figura viene mostrata con una linea tratteggiata sino a che il muose non sarà rilasciato.
[[Image:]]







Nota
Se terrete premuto il tasto Maiuscolo mentre spostate la linea, la linea ruoterà con incrementi di 45°.

Rispecchiare un oggetto

Ufficialmente questo comando non esiste (ancora) in Draw. Può comunque essere emulato facilmente.

Spostate l'asse di simmetria nella posizione desiderata dell'asse speculare. Copiate l'oggetto negli Appunti. Capovolgete l'oggetto, poi fate clic in un punto vuoto dell'area di Draw sullo schermo per deselezionare l'oggetto. Incollate l'oggetto prendendolo dal blocco note, posizionandolo nella posizione originale ed avrete ottenuto una copia speculare.


[[Image:]]
[[Image:]]

Distorcere un immagine

Ci sono tre strumenti nel menù Effetti che permettono di tirare gli angoli ed i bordi di un oggetto per distorcere l'immagine.

Lo strumento Distorci distorce un oggetto in prospettiva, gli strumenti Poni su cerchio (inclina) e Poni su cerchio (prospettiva) creano degli pseudo effetti tridimensionali. Vedere il Capitolo 4 della Guida di Draw per ulteriori dettagli.

Gradienti dinamici

Potete controllare i gradienti di trasparenza con lo stesso metodo utilizzato per i gradienti di colore. Entrambi i tipi di gradiente possono essere usati insieme. Con il gradiente di trasparenza, la direzione e l'angolo del colore di riempimento di un oggetto cambia da opaco a trasparente (in un gradiente regolare, il riempimento varia da un colore ad un altro, ma il grado di trasparenza rimane invariato). Vedere il Capitolo 4 della Guida di Draw per ulteriori dettagli.

Duplicazione

Con la duplicazione potete fare delle copie di un oggetto mentre applicate delle modiche (al colore o alla rotazione) dei duplicati. Come risultato di una duplicazione si ottiene un nuovo gruppo.

Per iniziare la duplicazione, fate clic su di un oggetto o un gruppo di oggetti e sceglietee Modifica > Duplica. Apparirà la finestra di dialogo mostrata nella Figura 26.

Le opzioni scelte e visualizzate nella Figura 26 quando applicate ad ad un rettangolo blù producono il risultato seguente.

[[Image:]]
[[Image:|thumb|Figura 26: Duplicare un oggetto]]

Dissolvenza incrociata

Con la dissolvenza incrociata potete trasformare una forma in un altra, OpenOffice.org gestirà le transizioni intermedie. Il risultato sarà un nuovo gruppo di oggetti compresi i due punti terminali ed i passaggi intermedi.

Per eseguire una dissolvenza incrociata, dovete selezionare entrambi gli oggetti (tenete premuto il tasto Maiuscolo mentre a turno selezionate gli oggetti) poi scegliete dal menù Modifica > Morphing e apparirà la seguente finestra di dialogo.

[[Image:]]

Nella finestra di dialogo scegliete il numero degli incrementi (le fasi di transizione). Probabilmente vorrete avere selezionate entrambe le voci Includi gli attributi e Stesso orientamento. Il risultato finale è mostrato nellaFigura 27.

Figura 27: Esempio di dissolvenza incrociata






Flip an object

Select an object and click on the Flip icon FlipIcon.png. You will see a dashed line through the middle of the object.

DG4-f.png

This dashed line is the axis of symmetry. The object will be reflected about this line. Move one or both ends of the line with your mouse to set the axis.

DG4-g.png

Then, grab any one of the eight green handles and move it across to the other side of the dashed line. The new position of the figure is shown dashed until the mouse is released.

DG4-h.png

Template:Documentation/Note

Mirror copies

Officially, this useful command does not (yet) exist in Draw. It can, however, be easily emulated.

Move the axis of symmetry to the desired location of the mirror axis. Copy the object to the clipboard. Flip the object, then click on an empty area of the Draw screen in order to deselect the object. Paste from the clipboard to put a copy of the object in its original location and now you have a mirror copy.

Mirror1.png      Mirror2.png

Distorting an image

There are three tools on the Effects menu that let you drag the corners and edges of an object to distort the image.

The Distort tool distorts an object in perspective, the Set to Circle (slant) and Set in Circle (perspective) tools both create a pseudo three-dimensional effect. See Chapter 4 of the Draw Guide for details.

Dynamic gradients

You can control transparency gradients in the same manner as color gradients. Both types of gradient can be used together. With a transparency gradient, the direction and degree of an object’s fill color changes from opaque to transparent (in a regular gradient, the fill changes from one color to another, but the degree of transparency remains the same). See Chapter 4 of the Draw Guide for details.

Duplication

Duplication makes copies of an object while applying a set of changes (such as color or rotation) to the duplicates. The result of a duplication is a new group.

To start duplication, click on an object or group and choose Edit > Duplicate. The dialog shown below appears.

Duplicating an object

The options above applied to a blue rectangle produce the following result.

DrawDuplication.png

Cross-fading

Cross-fading transforms a shape from one form to another, with OpenOffice.org handling all of the intermediate transitions. The result is a new group of objects including the two end points and the intermediate steps.

To carry out a cross-fade, select both objects (hold the Shift key while selecting each object in turn) and then choose Edit > Cross-fading The following dialog appears.

Crossfade.png

On the dialog choose the number of increments (transition steps). You probably want to have Cross-fade attributes and Same orientation both checked. The end result is shown below.

Cross-fading example


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools