Difference between revisions of "IT/Documentation/OOo3 User Guides/Getting Started/Saving Writer documents as web pages"

From Apache OpenOffice Wiki
Jump to: navigation, search
 
(5 intermediate revisions by one other user not shown)
Line 5: Line 5:
 
|NextPage=IT/Documentation/OOo3_User_Guides/Getting Started/Saving Calc spreadsheets as web pages
 
|NextPage=IT/Documentation/OOo3_User_Guides/Getting Started/Saving Calc spreadsheets as web pages
 
}}__NOTOC__
 
}}__NOTOC__
 
 
 
 
 
 
Pagina in traduzione - translation in progress
 
 
 
 
 
 
 
 
 
Le funzioni HTML di Writer includono il salvataggio di documenti esistenti nel formato HTML, la creazione di nuovi documenti HTML e la creazione di diversi tipi di pagine web mediante l'utilizzo di una procedura guidata.
 
Le funzioni HTML di Writer includono il salvataggio di documenti esistenti nel formato HTML, la creazione di nuovi documenti HTML e la creazione di diversi tipi di pagine web mediante l'utilizzo di una procedura guidata.
  
Line 26: Line 12:
 
Per salvare un documento come una singola pagina web (in formato HTML), selezionate '''Salva con nome''' dal menù '''File''' e scegliete come tipo di file Documento HTML.
 
Per salvare un documento come una singola pagina web (in formato HTML), selezionate '''Salva con nome''' dal menù '''File''' e scegliete come tipo di file Documento HTML.
  
{{Documentation/Note|Writer non sostituisce gli spazi multipli nel documento originale con il codice HTML per gli spazi non interrotti. Se volete avere degli spazi extra nel file HTML o nella pagina Web, è necessario inserire spazi non interrotti in OOo. Per farlo, premete ''(Ctrl) + barra spaziatrice'' invece della sola ''barra spaziatrice''.}}
+
{{Note|Writer non sostituisce gli spazi multipli nel documento originale con il codice HTML per gli spazi non interrotti. Se volete avere degli spazi extra nel file HTML o nella pagina Web, è necessario inserire spazi non interrotti in OOo. Per farlo, premete ''(Ctrl) + barra spaziatrice'' invece della sola ''barra spaziatrice''.}}
  
 
==Salvare un documento come una serie di pagine web==
 
==Salvare un documento come una serie di pagine web==
Line 38: Line 24:
 
[[Image:Web_ser_pag_web_it.png|thumb|none|600px|Creare una serie di pagine web da un unico documento.]]
 
[[Image:Web_ser_pag_web_it.png|thumb|none|600px|Creare una serie di pagine web da un unico documento.]]
  
== Creare pagine web utilizzando una procedura guidata. ==
+
==Creare pagine web utilizzando una procedura guidata.==
 
La procedura guidata per la creazione di pagine web di OOo permette di creare diversi tipi di pagine web standard. Per utilizzarla:
 
La procedura guidata per la creazione di pagine web di OOo permette di creare diversi tipi di pagine web standard. Per utilizzarla:
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
# Selezionate '''File > Procedure guidate > Pagina Web'''. Nella prima pagina della procedura guidata, selezionate le impostazioni desiderate e fate clic su '''Avanti'''.
 
# Selezionate '''File > Procedure guidate > Pagina Web'''. Nella prima pagina della procedura guidata, selezionate le impostazioni desiderate e fate clic su '''Avanti'''.
 +
{{Note| Se questa è la vostra prima pagina web l'unica opzione disponibile per le impostazioni è quella ''Standard''.}}
 +
[[Image:Web_pr_gu_pa_we_01_it.png|thumb|none|600px|Procedura guidata pagina Web - passo 1.]]
 +
2. Scegliete o scorrete sino al documento al quale volete applicare la formattazione. Il ''Titolo'', il ''Sommario'' e le informazioni sull'''Autore'' sono ricavate dalle proprietà del documento; se necessario potete modificarle. Fate clic su '''Avanti.'''[[Image:Web_pr_gu_pa_we_02_it.png|thumb|none|600px|Procedura guidata pagina Web - passo 2.]]
 +
3. Scegliete un layout per il sito web facendo clic sui riquadri di layout. Fate clic su '''Avanti.'''[[Image:Web_pr_gu_pa_we_03_it.png|thumb|none|600px|Procedura guidata pagina Web - passo 3.]]
 +
4. Scegliete le informazioni da elencare e la risoluzione dello schermo. Fate clic su '''Avanti.'''[[Image:Web_pr_gu_pa_we_04_it.png|thumb|none|600px|Procedura guidata pagina Web - passo 4.]]
 +
5. Selezionate uno stile per la pagina. Utilizzate l'elenco a discesa per scegliere tra i differenti stili e le combinazioni di colori. È possibile selezionare un'immagine di sfondo e un insieme di icone dalla Gallery. Fate clic su '''Avanti.'''[[Image:Web_pr_gu_pa_we_05_it.png|thumb|none|600px|Procedura guidata pagina Web - passo 5.]]
 +
6. Inserite le informazioni generali, come il Titolo e i Metadati HTML. Fate click su''' Avanti.'''[[Image:Web_pr_gu_pa_we_06_it.png|thumb|none|600px|Procedura guidata pagina Web - passo 6.]]
 +
7. Scegliete dove salvare il file; se volete, potete visualizzare l'anteprima della pagina. Fate clic su '''Fine'''.[[Image:Web_pr_gu_pa_we_07_it.png|thumb|none|600px|Procedura guidata pagina Web - passo 7.]]
  
 +
Per modificare o visualizzare il codice HTML del documento, fate clic su '''Visualizza > Testo sorgente HTML''' oppure fate clic sull'icona '''Testo sorgente HTML''' [[Image:HTMLSourceIcon.png]] sulla barra degli strumenti principale.
  
{| style="border-spacing:0;"
+
[[#top|Inizio pagina]]
| style="border-top:0.035cm solid #000080;border-bottom:0.035cm solid #000080;border-left:none;border-right:none;padding:0.15cm;"| <center>'''Nota'''</center>
+
| style="border-top:0.035cm solid #000080;border-bottom:0.035cm solid #000080;border-left:none;border-right:none;padding:0.15cm;"| Se questa è la vostra prima pagina web l'unica opzione disponibile per le impostazioni è quella Standard.
+
 
+
|}
+
<center>[[Image:]]</center>
+
 
+
# Scegliete o scorrete sino al documento al quale volete applicare la formattazione. Il ''Titolo'', il ''Sommario'' e le informazioni sull'''Autore'' sono ricavate dalle proprietà del documento; se necessario potete modificarle. Fate clic su '''Avanti.'''
+
 
+
<center>[[Image:]]</center>
+
 
+
# Scegliete un layout per il sito web facendo clic sui riquadri di layout. Fate clic su '''Avanti.'''
+
 
+
<center>[[Image:]]</center>
+
 
+
# Scegliete le informazioni da elencare e la risoluzione dello schermo. Fate clic su '''Avanti.'''
+
 
+
<center>[[Image:]]</center>
+
 
+
# Selezionate uno stile per la pagina. Utilizzate l'elenco a discesa per scegliere tra i differenti stili e le combinazioni di colori. È possibile selezionare un'immagine di sfondo e un insieme di icone dalla Gallery. Fate clic su '''Avanti.'''
+
 
+
<center>[[Image:]]</center>
+
 
+
# Inserite le informazioni generali, come il Titolo e i Metadati HTML. Fate click su''' Avanti.'''
+
 
+
<center>[[Image:]]</center>
+
 
+
# Scegliete dove salvare il file; se volete, potete visualizzare l'anteprima della pagina. Fate clic su '''Fine'''.
+
 
+
<center>[[Image:]]</center>
+
 
+
Per modificare o visualizzare il codice HTML del documento, fate clic su '''Visualizza > Testo sorgente HTML '''oppure fate clic sull'icona '''Testo sorgente HTML'''[[Image:]] sulla barra degli strumenti principale.
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
 
+
==Creating web pages using a Wizard==
+
 
+
OOo's Web wizard allows you to create several types of standard web pages. To use it:
+
 
+
#Choose '''File > Wizards > Web Page'''. On the first page of the Wizard, choose settings and click '''Next'''.
+
{{Documentation/Note| If this is your first web page, the only choice is ''default''.}}[[Image:WebWizard1.png|thumb|none|600px|Figure 5. Web page wizard step 1.]]
+
2. Choose or browse to the document you would like to format. The ''Title, Summary'' and ''Author'' information is picked up from the document’s properties; if necessary, edit it. Click '''Next'''. [[Image:WebWizard2.png|thumb|none|600px|Figure 6. Web page wizard step 2.]]
+
3. Chose a layout for the web site by clicking on the layout boxes. Click '''Next.''' [[Image:WebWizard3.png|thumb|none|600px|Figure 7. Web page wizard step 3.]]
+
4. Chose the information to be listed and the screen resolution. Click '''Next.'''
+
[[Image:WebWizard4.png|thumb|none|600px|Figure 8. Web page wizard step 4.]]
+
5. Select a style for the page. Use the drop-down list to choose different styles and color combinations. You can browse to a background image and icon set from the Gallery. Click '''Next'''. [[Image:WebWizard5.png|thumb|none|600px|Figure 9. Web page wizard step 5.]]
+
6. Enter general information such as Title and HTML Metadata information. Click''' Next'''. [[Image:WebWizard6.png|thumb|none|600px|Figure 10. Web page wizard step 6.]]
+
7. Chose where to save the file and preview the page if you wish. Click '''Finish'''. [[Image:WebWizard7.png|thumb|none|600px|Figure 11. Web page wizard step 7.]]
+
 
+
To edit or view the document's underlying HTML code, open the document, and then choose '''View > HTML Source''' or click the '''HTML Source''' icon [[Image:HTMLSourceIcon.png]] on the Main toolbar.
+
 
+
[[#top|Top of page]]
+
  
 
{{Manual}}
 
{{Manual}}
 
[[Category:Getting Started (Documentation)]
 
[[Category:Getting Started (Documentation)]

Latest revision as of 12:36, 7 July 2018


Le funzioni HTML di Writer includono il salvataggio di documenti esistenti nel formato HTML, la creazione di nuovi documenti HTML e la creazione di diversi tipi di pagine web mediante l'utilizzo di una procedura guidata.

Il metodo più semplice per creare documenti in formato HTML è utlizzare un documento esistente realizzato con Writer. È possibile vedere come esso apparirà su una pagina web usando Visualizza > Layout Web.

Salvare un documento come una singola pagina web.

Per salvare un documento come una singola pagina web (in formato HTML), selezionate Salva con nome dal menù File e scegliete come tipo di file Documento HTML.

Documentation note.png Writer non sostituisce gli spazi multipli nel documento originale con il codice HTML per gli spazi non interrotti. Se volete avere degli spazi extra nel file HTML o nella pagina Web, è necessario inserire spazi non interrotti in OOo. Per farlo, premete (Ctrl) + barra spaziatrice invece della sola barra spaziatrice.

Salvare un documento come una serie di pagine web

Writer può salvare un documento di grandi dimensioni come una serie di pagine web (differenti file HTML) collegate da una pagina indice. Per eseguire questa operazione procedete come segue:

  1. Decidete quali intestazioni nel documento devono iniziare in una nuova pagina e assicuratevi che tutte abbiano lo stesso modello di formato (per esempio, Intestazione 1).
  2. Selezionate File > Invia > Crea documento HTML.
  3. Nella finestra di dialogo (vedere sotto), inserite il nome del file nel quale salvare le pagine web. Indicate anche quale modello di formato contraddistingue una nuova pagina (come deciso al punto 1).
  4. Fate clic su Salva per creare un documento HTML con pagine multiple. (Per coloro ai quali potesse interessare, il file HTML ottenuto è conforme alla specifica HTML 4 Transitional.)
Creare una serie di pagine web da un unico documento.

Creare pagine web utilizzando una procedura guidata.

La procedura guidata per la creazione di pagine web di OOo permette di creare diversi tipi di pagine web standard. Per utilizzarla:

  1. Selezionate File > Procedure guidate > Pagina Web. Nella prima pagina della procedura guidata, selezionate le impostazioni desiderate e fate clic su Avanti.
Documentation note.png Se questa è la vostra prima pagina web l'unica opzione disponibile per le impostazioni è quella Standard.
Procedura guidata pagina Web - passo 1.
2. Scegliete o scorrete sino al documento al quale volete applicare la formattazione. Il Titolo, il Sommario e le informazioni sull'Autore sono ricavate dalle proprietà del documento; se necessario potete modificarle. Fate clic su Avanti.
Procedura guidata pagina Web - passo 2.
3. Scegliete un layout per il sito web facendo clic sui riquadri di layout. Fate clic su Avanti.
Procedura guidata pagina Web - passo 3.
4. Scegliete le informazioni da elencare e la risoluzione dello schermo. Fate clic su Avanti.
Procedura guidata pagina Web - passo 4.
5. Selezionate uno stile per la pagina. Utilizzate l'elenco a discesa per scegliere tra i differenti stili e le combinazioni di colori. È possibile selezionare un'immagine di sfondo e un insieme di icone dalla Gallery. Fate clic su Avanti.
Procedura guidata pagina Web - passo 5.
6. Inserite le informazioni generali, come il Titolo e i Metadati HTML. Fate click su Avanti.
Procedura guidata pagina Web - passo 6.
7. Scegliete dove salvare il file; se volete, potete visualizzare l'anteprima della pagina. Fate clic su Fine.
Procedura guidata pagina Web - passo 7.

Per modificare o visualizzare il codice HTML del documento, fate clic su Visualizza > Testo sorgente HTML oppure fate clic sull'icona Testo sorgente HTML HTMLSourceIcon.png sulla barra degli strumenti principale.

Inizio pagina

Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
[[Category:Getting Started (Documentation)]
Personal tools