IT/Documentation/OOo3 User Guides/Getting Started/Creating a database form

From Apache OpenOffice Wiki
< IT‎ | Documentation‎ | OOo3 User Guides‎ | Getting Started
Revision as of 23:45, 20 August 2010 by Elcico (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Creazione di un formulario

I Database vengono usati per archiviare dati. Ma come si inseriscono i dati nel database? I formulari servono proprio a questo; nel linguaggio dei database, un formulario è l'interfaccia tramite la quale si inseriscono o si modificano i dati.


[[Image:|thumb|Figura 1: I campi di un semplice formulario]] [[Image:|thumb|Figura 2: Semplice Formulario con qualche aggiunta]]

Un semplice formulario è composto dai campi di una tabella (Figura 1). Formulari più complessi possono contenere molto altro: testo aggiuntivo, grafica, caselle di scelta ed altri elementi ancora. La Figura 2 mostra la stessa tabella con una etichetta di testo (Acquisti di carburante), un elenco a tendina in TipodiPagamento e uno sfondo grafico.

Utilizzo della procedura guidata per creare un formulario

Useremo la procedura guidata per la creazione di due formulari: Collezione CD e Vacanze. Collezione CD sarà un formulario semplice mentre Vacanze conterrà al suo interno un formulario secondario. Creeremo il formulario Vacanze con i suoi formulari secondari e modificheremo il formulario della collezione CD utilizzando il medesimo processo.

Nella finestra principale del database (Errore: sorgente del riferimento non trovata), fate clic sull'icona Formulari. Fate doppio clic su Usa procedura guidata per la creazione dei formulari... per aprire la procedura (Figura 3). Un formulario semplice richiede solo alcuni di questi passi, mentre i formulari più complessi potrebbero utilizzarli tutti.

Passo 1: Selezione dei campi.

  1. In Tabelle o ricerche, selezionate la tabella Vacanze. Campi disponibili elenca i campi della tabella Vacanze.
  2. Fate clic sulla doppia freccia verso destra per spostare tutti i campi nell'elenco Campi nel formulario, quindi su Avanti.
[[Image:|thumb|Figura 3: Fasi della Creazione guidata formulario]]

Passo 2: Configura un formulario secondario.

Dal momento che abbiamo già creato una relazione tra le tabelle Carburante e Vacanze, useremo questa. Se non ci fosse nessuna relazione esistente, questa verrebbe definita al passo 4.

  1. Fate clic sulla casella con l'etichetta Aggiungi formulario secondario.
  2. Fate clic sul pulsante di scelta con l'etichetta Formulario secondario basato su una relazione esistente.
  3. Carburante viene elencato come relazione che vogliamo aggiungere. Quindi fate clic su Carburante per evidenziarlo, come nella Figura 4, quindi su Avanti.
[[Image:|thumb|Figura 4: Aggiungere un formulario secondario]]

Passo 3: Aggiungi campi nel formulario secondario.

Questo passo è esattamente uguale al passo 1. La sola differenza è che non tutti i campi verranno usati per il formulario secondario.

  1. Selezionate Carburante in Tabelle o ricerche.
  2. Usate il pulsante >> per spostare tutti i campi a destra.
  3. Fate clic su IDCarburante per evidenziarlo.
  4. Ora mediante il pulsante < spostate il campo IDCarburante a sinistra (Figura 5).
  5. Fate clic su Avanti.
[[Image:|thumb|Figura 5: Selezione dei campi di un formulario secondario]]

Passo 4: Carica campi uniti.

Questo passaggio è per quelle tabelle o ricerche per le quali non sono state ancora definite delle relazioni. Poiché vogliamo elencare tutte le spese in base al giorno in cui avvengono sia nel formulario che nel formulario secondario, uniremo i campi Data di queste due tabelle (Figura 6).

[[Image:|thumb|Figura 6: Selezione dei campi collegati tra un formulario secondario e uno principale]]
  1. Selezionate Data dall'elenco a tendina Primo campo collegato del formulario secondario. Questo è il campo Data della tabella Carburante. Non corrisponde alla chiave primaria nella tabella Carburante, ma è definito invece come una chiave esterna.
  2. Selezionate Data dall'elenco a tendina Primo campo collegato del formulario principale. Questo è il campo Data della tabella Vacanze, ed è la chiave primaria di tale tabella. Fate clic su Avanti.


Nota
E' possibile creare tra due tabelle una relazione basata su più di una coppia di campi. Il modo ed il motivo di ciò è discusso nella Guida a Base.
Attenzione
[[Image:]]
Quando selezionate una coppia di campi da due tabelle per utilizzarli come relazione, essi devono avere lo stesso tipo di campo. Questo è il motivo per il quale abbiamo usato il campo Data in entrambe le tabelle: entrambi i campi sono del tipo Data [DATE].

In base al numero di coppie di campi scelte come relazione, occorre che certi requisiti siano soddisfatti perché il formulario possa funzionare:

  • Nessun campo del formulario secondario può essere la chiave Primaria della sua tabella (in questo caso, IDCarburante non può essere usato).
  • I campi di ogni coppia di collegamento devono avere lo stesso tipo di campo.
  • Uno dei campi del formulario principale deve essere la chiave primaria della sua tabella (in questo caso deve essere usato il campo Data).


Passo 5: Disponi campi di controllo.


Nota
Ogni controllo in un formulario è costituito da due parti: l'etichetta ed il campo. Questo passo nella creazione del formulario determina come l'etichetta ed il campo del controllo sono posizionati l'uno rispetto all'altro. Le quattro scelte da sinistra a destra sono In colonna - testo fisso a sinistra, In colonna - testo fisso in alto, Tabellare e In riga - testo fisso in alto (Figura 7).
  1. Disposizione del formulario principale: selezionate In colonna - testo fisso in alto. Le etichette saranno poste sopra il campo relativo.
  2. Disposizione del formulario secondario: selezionate Tabellare (le etichette sono i titoli delle colonne ed i campi sono le voci al loro interno, disposti come in un foglio elettronico). Fate clic su Avanti.
[[Image:|thumb|Figura 7: Disposizione dei campi di controllo]]

Passo 6: Imposta immissione dati.

A meno che non abbiate uno specifico bisogno di spuntare una di queste voci, scegliete le impostazioni predefinite. Fate clic su Avanti.

Passo 7: Applica stili di formato.

  1. Selezionate il colore che desiderate nell'elenco Applica stili di formato (io ho scelto il beige che corrisponde ad Arancione 4 nella tabella Colore).
  2. Selezionate il Bordo campo che desiderate (io ho scelto il 3D); potete sperimentare le differenti configurazioni possibili.
  3. Fate clic su Avanti.

Passo 8: Imposta nome.

  1. Inserite il nome del formulario. In questo caso sarà Carburante.
  2. Selezionate il cerchietto a sinistra di Modifica il formulario (questo cerchietto in gergo si chiama “casella di spunta a scelta singola”).
  3. Fate clic su Fine. Il formulario si apre in struttura modulo.

Modifica di un formulario

Sposteremo i controlli in parti diverse del formulario e cambieremo lo sfondo con una fotografia. Inoltre modificheremo l'etichetta del campo TipoDiPagamento e trasformeremo il campo in un elenco a tendina.

Per prima cosa, dobbiamo decidere cosa vogliamo cambiare e come. La discussione verrà articolata in dieci passi.

  1. Il campo Data nel formulario principale porta alla necessità di avere un elenco a tendina. Esso inoltre deve essere allungato per mostrare data e giorno della settimana.
  2. Occorre accorciare la lunghezza dei campi pagamento (ovvero tutti i campi che contengono la parola pagamento).
  3. I controlli devono essere disposti in gruppi: cibo, formulario secondario, carburante e varie.
  4. Alcune etichette devono cambiare nella loro formulazione: alcune parole singole dovrebbero diventare due, altre potrebbero essere abbreviate (km. per Chilometraggio).
  5. La larghezza di diversi campi e le etichette devono essere cambiate; solo Pranzo, Cena, Hotel e Pedaggi hanno una lunghezza accettabile. Tuttavia, per ottenere un aspetto più gradevole apporteremo delle modifiche anche ad essi.
  6. Tutti i campi la cui etichetta termina con Pagamento verranno sostituiti con un elenco a tendina. Questo elenco conterrà le voci inserite nella tabella TipoDiPagamento.
  7. Il campo Nota necessita di un maggiore spazio in verticale e di una barra di scorrimento; inoltre deve essere spostato.
  8. Devono essere fatte delle modifiche alle colonne Data e TipoDiPagamento nel formulario secondario affinché siano simili a quella del formulario principale.
  9. Devono essere aggiunte delle voci per ogni gruppo creato nel formulario principale.
  10. Lo sfondo verrà sostituito con una immagine ed alcune etichette verranno modificate per essere più leggibili. Anche il colore del carattere dei titoli dovrà essere cambiato.

Questi sono alcuni punti che affronteremo nei passaggi che seguono. I controlli nel formulario principale sono costituiti dalle etichette e dai loro campi. Lavoreremo a volte sull'intero controllo, a volte solo sull'etichetta o sul campo. Altre volte lavoreremo con un gruppo di controlli.

  • Fate clic sull'etichetta o sul campo per selezionare l'intero controllo. Intorno ad esso appare un bordo con otto maniglie verdi (Figura 8). Tenendo premuto il tasto sinistro potrete trascinarlo dove desiderate.
  • Con CTRL + clic potete selezionare solo l'etichetta o solo il campo (Figura 9).
[[Image:|thumb|Figura 8: Un controllo selezionato]]
  • Utilizzando il tasto TAB, potete spostare la selezione dal campo all'etichetta e viceversa.
[[Image:|thumb|Figura 9: Selezione del campo di un controllo]]
  • Spostare un gruppo di controlli è quasi semplice quanto muoverne uno solo.
    1. Fate clic sul campo di controllo più in alto e a sinistra tra quelli che desiderate spostare, per selezionarlo.
    2. Spostate il cursore appena sopra e a sinistra del campo di controllo selezionato.
    3. Tenendo premuto il tasto del mouse trascinate il cursore verso il basso a destra del gruppo dei controlli, poi rilasciate il tasto.

Mentre trascinate il cursore, appare una casella tratteggiata che evidenzia l'area racchiusa nella selezione. Assicuratevi che questa sia sufficientemente ampia da contenere tutti i campi di controllo.

Quando rilasciate il pulsante del mouse, intorno ai campi di controllo selezionati appare un bordo con delle maniglie verdi (Figura 10).

[[Image:|thumb|Figura 10: Selezione di controlli multipli]]

Spostate il cursore su uno dei campi; questo diventa una doppia freccia (Figura 11).

[[Image:|thumb|Figura 11: Doppia freccia]]

Trascinate il gruppo di controlli dove li volete posizionare.

Prima di cambiare il campo Data, dovremo spostare i controlli Pranzo e Pedaggi verso destra di 5 cm (2 pollici).


Suggerimento
Quando si vuole ridimensionare o spostare un controllo, è opportuno selezionare due proprietà della barra Struttura del formulario: Cattura Griglia, e Linee guida durante lo spostamento. Sarà più facile allineare i controlli, ed uno schema di ciò che state muovendo si sposterà insieme al cursore.

Sarebbe opportuno anche avere entrambi i righelli attivi (Strumenti > Opzioni > OpenOffice.org Writer > Vista). Poiché il formulario viene creato in Writer, è qui che dovete assicurarvi che entrambe le caselle accanto a Righello verticale ed a Righello orizzontale siano selezionate .

Nota
Utilizzeremo i centimetri per eseguire modifiche nei formulari, poiché sono più precisi dei pollici; quando si spostano i controlli (campi e le loro etichette) il loro posizionamento risulta più accurato. Potete convertire i righelli da pollici a centimetri cliccandovi sopra con il tasto destro del mouse e selezionando centimetro dal menu contestuale. A questo punto è possibile allineare i controlli, le etichette o i campi a valori specifici sul righello.

Passo 1: Modifica del campo Data.

  1. Tenendo premuto il tasto CTRL, fate clic sul campo Data per selezionarlo (Figura 9).
  2. Spostate il cursore sulla maniglia verde al centro del lato destro; questo si trasformerà in una freccia singola (Figura 12).
[[Image:|thumb|Figura 12: Freccia singola]]
  1. Tenendo premuto il tasto sinistro del mouse, trascinate il cursore verso destra fino a raggiungere la lunghezza di 6 cm. La linea tratteggiata verticale dovrà essere allineata con il numero 6 del righello (che equivale a circa 2.4 pollici). Rilasciate il pulsante del mouse.
  2. Fate clic sull'icona Controllo della barra Struttura del Formulario (Figura 13); è il comando contrassegnato dal cerchio rosso. Si apre la finestra Proprietà: Campo data, in cui ogni riga rappresenta una proprietà del campo.
[[Image:|thumb|Figura 13: La barra Struttura del formulario ]]
    • Andate alla proprietà Formato data. Si tratta di un elenco a tendina la cui impostazione predefinita è Standard (breve): fateci clic sopra per aprire l'elenco. Selezionate la voce Standard (esteso).
    • Scorrete verso il basso fino alla voce Apribile; l'impostazione predefinita è No. Si tratta anche in questo caso di un elenco apribile: fate clic sul valore predefinito per aprire l'elenco, e selezionate .


Suggerimento
Per vedere come apparirà il campo Data, fate clic sull'icona Modo bozza On/Off (la seconda icona da sinistra nella Figura 13). Potete fare ciò ogni volta che volete vedere come appare il formulario con i cambiamenti che avete apportato.

Passo 2: Ridurre la lunghezza di un campo.

Tutti i campi nella cui etichetta compare la parola pagamento sono troppo lunghi; prima di spostare i controlli occorre accorciarli.

  1. Tenendo premuto CTRL, fate clic sul campo APagamento (Figura 14).
[[Image:|thumb|Figura 14: Selezione di un campo]]
  1. Spostate il cursore sulla maniglia verde al centro del lato destro. Questa si trasforma in una freccia singola.
  2. Trascinatela verso sinistra finché il campo raggiunge una larghezza di 2,5 cm (1 pollice).


Suggerimento
Se avete attivato le icone Cattura alla griglia e Linee guida durante lo spostamento nella barra Struttura del formulario, vedrete quanto è lungo il campo mentre lo accorciate.
  1. Ripetete questi passaggi per accorciare i campi: Apagamento, CPagamento, PagamentoSpuntino, MPagamento e AltroPagamento.

Passo 3: Spostate i controlli per raggrupparli in categorie.

Vogliamo spostare i controlli in modo che l'insieme assomigli alla Figura 15.

[[Image:|thumb|Figura 15: Posizionamento dei controlli]]
  1. Selezionate il primo controllo che volete spostare; intorno ad esso appare un bordo con otto maniglie verdi.
  2. Portate il cursore sopra l'etichetta o il campo del controllo. Esso si trasforma in una doppia freccia (Figura 11).
  3. Trascinate il controllo nella posizione che desiderate.


Attenzione
[[Image:]]
Non utilizzate il comando CTRL + clic quando spostate un campo di controllo: questo comando sposta il campo oppure l'etichetta ma non entrambi. Per spostarli entrambi, trascinateli tenendo premuto il tasto del mouse.
  1. Usate lo stesso metodo per posizionare nel modo opportuno gli altri controlli.


Nota
L'unico modo per imparare ad eseguire correttamente questi due passaggi consiste nel fare pratica. Esiste un altro sistema per posizionare i controlli dove volete, ma si tratta di una funzione avanzata e verrà affrontata nella Guida a Base.

Passo 4: Modifica delle etichette

Il nome del campo deve essere costituito da una sola parola. Tuttavia, le etichette dei campi possono essere costituite da più parole, quindi le cambieremo.

  1. Tenendo premuto CTRL, fate clic sull'etichetta NSpuntino. Utilizzate uno dei seguenti modi:
    • Fate clic con il tasto destro sull'etichetta NSpuntino.
      • Selezionate Campo di controllo dal menù contestuale (Figura 16). Si apre una finestra chiamata Proprietà: Testo fisso. Essa contiene tutte le proprietà dell'etichetta selezionata.
[[Image:|thumb|Figura 16: Menù contestuale]]
      • Nella casella Didascalia, fate clic tra la N e la S in NSpuntino.
      • Usando la barra spaziatrice dividete NSpuntino in due parole.
      • Inserite un . (punto) dopo la lettera N (di Numero) (Figura 17).
      • Chiudete la finestra delle proprietà.
[[Image:|thumb|Figura 17: Etichetta a più parole]]
    • In alternativa, fate clic sull'icona Controllo nella barra Struttura del Formulario (Figura 18); si aprirà la finestra delle Proprietà. Il resto del procedimento è analogo a quanto spiegato sopra.
[[Image:|thumb|Figura 18: La barra Struttura del formulario]]
  1. Utilizzate la stessa procedura per modificare queste etichette come segue: BPagamento in Pagamento, CPagamento in Pagamento, SPagamento in Pagamento, Varie in Altro, CostoSpuntino in Costo Spuntino, MPagamento in Pagamento, AltroPagamento in Pagamento Varie e Altro in Varie. Note.
  2. Chiudete la finestra Proprietà.


Suggerimento
Potete modificare tutte le specifiche dell'elenco nella finestra Proprietà. Ad esempio, modificando l'allineamento da sinistra a centro il testo verrà centrato all'interno dell'etichetta. Avendo un po di tempo a disposizione, potete sperimentare le differenti impostazioni giusto per per farvi un'idea di quello che potete ottenere.

Passo 5: Modificare la larghezza delle etichette e dei campi.

Vogliamo che i seguenti controlli siano larghi 2 cm (0.8 pollici): Colazione, Pranzo, Cena, Chilometraggio, N. Spuntino, Pedaggi, Costo Spuntino, Hotel, e Varie. Tutti i campi dei pagamenti sono stati modificati nel passo 2, ma Pagamento varie deve essere portato a 3 cm (1.2 pollici).

  1. Fate clic su Colazione. Intorno ad esso appare il bordo con le otto maniglie verdi.
  2. Spostate il cursore sulla maniglia verde al centro del lato destro. Il cursore diventa una freccia singola;
  3. trascinatela verso sinistra per stringere o verso destra per allargare il controllo. Utilizzate le linee guida per determinarne la larghezza.
  4. Ripetete l'operazione per l'intero elenco dei controlli.

Passo 6: Sostituzione di campi con altri campi.

Vogliamo sostituire il campo Pagamento con un elenco a tendina. Così, invece di inserirlo manualmente, potremo scegliere il tipo di pagamento dalla tabella TipoDiPagamento. Nel nostro caso, ogni tipo di pagamento inizia con una lettera differente; inserendo la prima lettera del tipo di pagamento, il resto della parola appare automaticamente. Possiamo così proseguire al campo successivo.

  1. Tenendo premuto CTRL, fate clic sul campo Pagamento per la Colazione. Le maniglie verdi appaiono intorno al campo ma non intorno all'etichetta (Figura 19).
[[Image:|thumb|Figura 19: Selezione del campo di un controllo]]
  1. Fate clic con il tasto destro all'interno dell'area evidenziata e selezionate nell'elenco Sostituisci con > Casella di riepilogo (la Figura 16 mostra il menu contestuale contenente la voce Sostituisci con , mentre la Figura 20 mostra l'elenco dei possibili campi di sostituzione).
[[Image:|thumb|Figura 20: Campi di sostituzione]]
  1. Fate clic sull'icona Controllo nella barra Struttura del formulario (Figura 18) per aprire la finestra Proprietà.
  2. Sulla scheda Generale, scorrete verso il basso e selezionate la voce Apribile. Cambiate il No con in questo elenco apribile (Figura 21).
[[Image:|thumb|Figura 21: L'elenco a tendina si apre per mostrare le opzioni]]
  1. Fate clic sulla scheda Dati.
    • Tipo del contenuto della lista è un elenco a tendina; qui selezionate Sql.
[[Image:|thumb|<center>
Figura 22: L'elenco a tendina Tipo del contenuto della lista]]</center>
    • Digitate esattamente quanto segue nella casella Contenuto elenco:

SELECT "TipoDiPagamento", "TipoDiPagamento" FROM "TipoDiPagamento"

[[Image:|thumb|<center>
Figura 23: Contenuto elenco per i campi relativi al tipo di pagamento]]</center>


Suggerimento
Dovreste poter copiare ed incollare SELECT "TipoDiPagamento", "TipoDiPagamento" FROM "TipoDiPagamento" da questo testo direttamente nella casella Contenuto elenco. Assicuratevi di copiare dalla S di SELECT fino all'ultima doppia virgoletta dopo la frase TipoDiPagamento e niente di più di questo.
Nota
Quello che avete scritto è un comando SQL. Le parole SELECT e FROM vengono scritte in maiuscolo in quanto sono dei comandi. Quando viene usato, il comando SELECT richiede un nome campo tra virgolette e quindi il campo alias, anch'esso tra virgolette; in questo caso, il campo ed il suo alias sono uguali. Il comando FROM richiede il nome della tabella che contiene il campo. Se i nomi delle tabelle sono costituiti da una sola parola nell'istruzione SQL le doppie virgolette non sono richieste; se invece questi sono costituiti da più parole le virgolette diventano necessarie.
    • Ripetete questi passaggi per i campi pagamento relativi a Pranzo, Cena, Motel, Spuntini e Varie. Il formulario principale dovrebbe assomigliare alla Figura 24, almeno per quanto riguarda la disposizione dei controlli. Essa mostra anche come dovrebbe apparire il controllo Note. Queste modifiche verranno spiegate nel prossimo passaggio.
    • Chiudete la finestra Proprietà.
[[Image:|thumb|Figura 24: Posizione dei controlli nel formulario principale]]

Passo 7: Modifica del campo Note.

Vogliamo spostare il controllo Note dove è raffigurato nella Figura 24. Poiché si tratta di un campo di tipo promemoria necessita di una barra di scorrimento verticale per avere spazio aggiuntivo per il testo, ove necessario.

  1. Tenendo premuto CTRL, fate clic sul campo Note. Le maniglie verdi appariranno intorno al solo campo e non intorno alla sua etichetta.
  2. Fate clic sull'icona Controllo per aprire la finestra delle Proprietà (Figura 25).
  3. Scorrete verso il basso fino alla voce Barre di scorrimento. Modificate la selezione da Nessuno a Verticale nell'elenco a tendina.
[[Image:|thumb|Figura 25: Selezione delle Barre di scorrimento nella finestra Proprietà]]
  1. Chiudete la finestra Proprietà.
  2. Allungare il campo Note.
    1. Spostate il cursore sulla maniglia verde al centro del lato inferiore del campo; il cursore si trasforma in una freccia singola verticale;
    2. trascinatela verso il basso fino ad attenere un'altezza pari a 6 cm (2.4 pollici).

Passo 8: Modifica delle etichette e dei campi in un formulario secondario.

La colonna Data deve essere ampliata; la colonna del campo TipoDiPagamento deve essere modificata in un elenco a tendina; l'etichetta della colonna TipoDiPagamento deve essere formata da più parole.

Modifica della colonna TipoDiPagamento:

  1. Fate clic sull'etichetta con il tasto destro del mouse per aprire il menu contestuale (Figura 26).
[[Image:|thumb|Figura 26: Opzioni per modificare un controllo in un formulario secondario]]
  1. Selezionate Sostituisci con, e quindi scegliete Casella di riepilogo dal menu contestuale.
  2. Fate ancora clic con il tasto destro sull'etichetta TipoDiPagamento per aprire il menu contestuale.
  3. Selezionate Colonna. Si aprirà la finestra delle Proprietà (Figura 27).
  4. Nella casella Didascalia, modificate TipoDiPagamento in Tipo di pagamento.
  5. Fate clic sulla scheda Dati.
  6. Dall'elenco a tendina Tipo del contenuto della lista, selezionate Sql.
  7. Digitate esattamente quanto segue:

SELECT "Type", "Type" FROM "TipoDiPagamento"

  1. Chiudete la finestra Proprietà.
[[Image:|thumb|Figura 27: Finestra delle proprietà di controllo in un formulario secondario]]


Suggerimento
Il Passo 6: Sostituzione di campi con altri campi., a partire dalla parte 5, contiene istruzioni più dettagliate.

Passo 9: Assegnare delle intestazioni ai gruppi.

  1. Assicuratevi di aver posizionato il cursore nell'angolo in alto a sinistra del formulario; in caso contrario, fate clic sull'angolo per spostarvi lì.
  2. Usando il tasto INVIO spostate il cursore verso il basso di 4 linee.
  3. Nell'elenco a tendina Applica stile sulla barra dei menu cambiate Standard con Intestazione 2.
[[Image:|thumb|Figura 28: L'elenco Applica stile]]
  1. Utilizzate la barra spaziatrice per spostare il cursore dove volete che inizi l'intestazione.
  2. Digitate l'intestazione Pasti.
  3. Usate la barra spaziatrice per portare il cursore al centro dell'area spuntini.
  4. Digitate l'intestazione Spuntini.
  5. Usate il tasto Invio per spostare il cursore tra il controllo Cena ed il formulario secondario.
  6. Usate la barra spaziatrice per portare il cursore al centro del formulario secondario.
  7. Digitate il titolo Dati Carburante.


Nota
Se sapete usare gli stili, potete aprire la finestra Stili e formattazione con il tasto F11. Selezionando con il tasto destro del mouse il titolo Intestazione 2 potete modificare la rappresentazione dei tre titoli appena inseriti, usando la finestra Stile di paragrafo. Si veda il Capitolo 6 della Guida a Writer.

Passo 10: Modifica dello sfondo di un formulario.

Lo sfondo del formulario può essere costituito da un colore o da una immagine (ad esempio una fotografia). Potete utilizzare qualsiasi colore presente nella Tabella Colori in Strumenti > Opzioni > OpenOffice.org > Colori; se sapete come creare dei colori personalizzati, potete usare anche questi. È anche possibile utilizzare un'immagine (un file grafico) come sfondo; useremo nell'esempio una immagine trovata in OOo: sky.gif (Figura 29). Dal momento che in varie zone di essa il colore di sfondo è scuro, occorre cambiare il colore di molte etichette e dei titoli per renderli visibili.

[[Image:|thumb|Figura 29: immagine di sfondo]]
  1. Selezionate le etichette della prima riga di controlli.
    1. Tenendo premuto CTRL, fate clic sull'etichetta Data.
    2. Fate clic sulle altre tenendo invece premuto MAIUSC + CTRL; il bordo della selezione si estenderà progressivamente verso destra man mano che eseguite questa operazione, fino a racchiudere tutte le etichette.
[[Image:|thumb|Figura 30: Selezione di più etichette tutte insieme]]
    1. Fate clic sull'icona Controllo nella barra Struttura del formulario per aprire la finestra Proprietà: Selezione multipla.
    2. Modificate il colore di sfondo da Standard a Ciano chiaro (si tratta di un elenco a tendina).
  1. Allo stesso modo selezionate le altre etichette e modificate il loro colore di sfondo.
  2. Chiudete la finestra Proprietà.
  3. Premete il tasto F11 per aprire la finestra Stili e formattazione (Figura 31). Notate che l'icona più a sinistra ha un bordo grigio scuro intorno ad essa: è l'icona Stili di paragrafo. Sotto troviamo un elenco di stili di paragrafo con i loro relativi nomi.


Nota
Ho scelto di usare il colore Ciano chiaro come sfondo per le mie etichette. Voi siete liberi di scegliere il colore che desiderate, inclusi quelli personalizzati che è possibile creare.
[[Image:|thumb|Figura 31: Parte superiore della finestra Stili e formattazione]]
    1. Fate clic con il tasto destro del mouse sulla voce Intestazione 2 e selezionate Modifica dal menu contestuale.
    2. Nella finestra Stile di paragrafo selezionate la scheda Effetto carattere (Figura 32).
[[Image:|thumb|Figura 32: Schede della finestra Stile di Paragrafo: Intestazione 2 ]]
    1. Modificate il Colore carattere dall'elenco a tendina in Ciano chiaro.
[[Image:|thumb|Figura 33: Lato sinistro della Scheda Effetto carattere]]
    1. Fate clic su OK per chiudere la finestra Stile di Paragrafo: intestazione 2.
    2. Premete il tasto F11 per chiudere la finestra Stili e formattazione.


Suggerimento
Imparare ad utilizzare gli stili può essere molto utile. Utilizzando gli stili, abbiamo cambiato il colore del carattere di tutte e tre le intestazioni contemporaneamente. Ci sono altri metodi per cambiare il colore del carattere, ma richiedono la ripetizione degli stessi passaggi per ogni titolo che si vuole modificare.
  1. Con il cursore sullo sfondo, fate clic con il tasto destro del mouse e selezionate Pagina dal menu contestuale.
  2. Fate clic sulla scheda Sfondo (Figura 34).
[[Image:|thumb|Figura 34: Scheda Sfondo in Stile di Pagina]]
    1. Nel menù a tendina Come, cambiate Colore con Immagine.
    2. Cercate il file: sky.gif. Lo troverete nella cartella Galleria di OOo.
    3. Fate clic sul pulsante Sfoglia nella sezione File. Navigate fino alla cartella contenente il file sky.gif.
    4. Selezionate il file e fate clic su Apri.
    5. Nella sezione Tipo, selezionate Area.
    6. Fate clic su OK per chiudere la finestra Stile di pagina: Standard.

Il formulario dovrebbe assomigliare a quello in Figura 35.

[[Image:|thumb|Figura 35: Il formulario ultimato]]

Passo 11: Modificare l'ordine delle schede .

Il tasto TAB sposta il cursore da un campo all'altro. E' molto più semplice utilizzare questo sistema piuttosto che fare clic su ogni campo per inserirvi i dati. Questo ci permette inoltre di raggruppare le nostre spese in aree prima di iniziare ad inserire i dati. Per esempio, tutte le nostre spese per pasti possono essere raggruppate, così come le spese per gli spuntini e per gli acquisti di carburante.

  1. Tenendo premuto CTRL, fate clic sul campo Data.
  2. Fate clic sull'icona Struttura del formulario nella barra Controlli formulario per aprire la barra Struttura del formulario (Figura 36). Oppure, utilizzate Visualizza > Barre degli strumenti > Struttura del formulario per aprire questa barra degli strumenti.
  3. Fate clic sull'icona Sequenza di attivazione.
[[Image:|thumb|Figura 36: La barra Struttura del formulario con l'icona Sequenza di attivazione cerchiata in rosso]]
  1. Ora riorganizzate l'ordine dei campi nella finestra Ordine schede (Figura 37).
[[Image:|thumb|Figura 37: La finestra Ordine schede]]
    • Cercate txtMPagamento in basso nella lista e fateci clic sopra.
    • Fate clic sul pulsante Sposta in alto fino a che txtMPagamento si trovi immediatamente al di sotto di hotel.
    • Ripetete questa procedura per mettere i campi nell'ordine mostrato nella Figura 38. Fate clic su OK.
[[Image:|thumb|Figura 38: Sequenza di ordinazione per il formulario principale]]
  1. Salvate e chiudete il formulario.
  2. Salvate il database.

Creazione di formulari in Vista struttura

Questo metodo richiede l'uso della barra Controlli formulario e Struttura del formulario: queste tecniche esulano però dallo scopo di questo documento. Le istruzioni per creare formulari utilizzando la Vista struttura sono descritte nella Guida a Base.

Creazione di formulari secondari in Vista struttura

Anche questo argomento va oltre lo scopo del presente documento. La creazione di formulari secondari in Vista Struttura sarà descritta nella Guida a Base.

Personal tools