Labels and Form Letters

From Apache OpenOffice Wiki
< Documentation‎ | Writer for Students
Revision as of 13:04, 13 January 2014 by DiGro (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search



This is not what you are going to need for your studies. But perhaps in the course of a traineeship or at your work place you might be asked to organise a bulk mailing. It’s really quite easy:

  1. First open an empty spreadsheet and use the first line for the Column Headings; these might be termed “Name”, “Street”, “City”, “Telephone number”, “Mobile number” and “Email”; the lines below you fill out with all relevant information using one line per person; when done, save the spreadsheet under some meaningful name such as “addresses”; the file ending .ods will get attached automatically.
  1. Now again open a New File, only this time a Database; choose the option Connect to an existing database and select Spreadsheet from the drop-down menu; confirm Next, locate the spreadsheet you saved in previous step and open it; confirm Yes, register the database for me (this only means that you can communicate with the database from any open file); remove the tick from Open the database for editing, since you don’t want to edit your addresses but simply read the information contained in the spreadsheet; press Finish, give your new database the same name as your spreadsheet (the file ending .odb will get attached automatically, so the two are separate files in spite of having the same name) and save; now close your new database, which doesn’t contain anything anyway, but is rather just a “window” through which you can reach your addresses listed in the actual spreadsheet.
  1. Now create a new labels’ file: go to the menu File › New and select Labels; under the tab Labels select your Database from the drop-down list and again the pertaining Table from the next drop-down list just underneath the first one; at this point you will be presented with only one option, namely “sheet1”, because your spreadsheet only contains one flat list of addresses; now choose your first Database Field (“Name”) and transport it with the left arrow to the white area on the left; press Return for a new line, then transport your next Database Field (this time “Street”), and press Return twice to leave an empty line before inserting your last Database Field, which is “City”; the other fields (Telephone, Mobile and Mail) are of no interest to you for the purpose of your bulk mail.
  1. Open the tab Format and insert the values listed in table 8 (for an A4-paper with 3 x 8 labels) (see also illustration 27).
  1. Press button New document.
  1. At this point a new page will appear full of Field names (see illustration 28), which, as soon as you choose to print your document – whether directly to a physical printer or to a file – will get replaced by the actual names, streets and cities of your spreadsheet.
Horizontal pitch 7,00 cm
Vertical pitch 3,70 cm
Width 7,00 cm
Height 3,70 cm
Left margin 1,20 cm
Top margin 0,60 cm
Columns 3
Rows 8

Table 8: Sizes and spacing for a 3x8 layout paper size A4

Wfs027-format menu.png

wfs028-placeholders_labels Illustration 27: The Format menu of the module "Labels": insert values shown and then press "New Document"

Wfs028-placeholders labels.png

Illustration 28: The new file in format A4 contains place holders which will be replaced by actual addresses while printing (whether to printer or to file)

To create a bulk letter you basically follow the same steps. So for instance after writing “Dear ”, you simply go to Insert › Fields › Other › Database. Under Type select Mail merge fields and under Database selection select your address database › sheet1. Pressing the + next to sheet1 will open a list of all your fields (Name, Street, City etc.). Click on Name and now all the names will be inserted automatically one after the other, one per each copy of your letter, after the “Dear ”.

Personal tools