Difference between revisions of "Documentation/OOo3 User Guides/Writer Guide/Using the Navigator"

From Apache OpenOffice Wiki
Jump to: navigation, search
m
 
(5 intermediate revisions by 3 users not shown)
Line 9: Line 9:
  
 
To open the Navigator, click its icon [[Image:CH13_NavigatorIcon.png]] on the Standard toolbar, or press ''F5'', or choose '''View > Navigator''' on the menu bar. You can dock the Navigator to either side of the main Writer window or leave it floating (see [[Documentation/OOo3_User_Guides/Writer_Guide/The_Writer_interface#Docking/floating windows and toolbars|Docking/floating windows and toolbars]]).
 
To open the Navigator, click its icon [[Image:CH13_NavigatorIcon.png]] on the Standard toolbar, or press ''F5'', or choose '''View > Navigator''' on the menu bar. You can dock the Navigator to either side of the main Writer window or leave it floating (see [[Documentation/OOo3_User_Guides/Writer_Guide/The_Writer_interface#Docking/floating windows and toolbars|Docking/floating windows and toolbars]]).
 
The Navigator displays lists of all the headings, tables, text frames, graphics, bookmarks, and other objects contained in a document.
 
  
 
To hide the list of categories and show only the icons at the top, click the '''List Box On/Off''' icon [[Image:listbox-icon.png]]. Click this icon again to show the list. Click the + sign by any of the lists to display the contents of the list.
 
To hide the list of categories and show only the icons at the top, click the '''List Box On/Off''' icon [[Image:listbox-icon.png]]. Click this icon again to show the list. Click the + sign by any of the lists to display the contents of the list.
Line 16: Line 14:
 
[[Image:Nav3.png|thumb|none|500px|''The Navigator'']]
 
[[Image:Nav3.png|thumb|none|500px|''The Navigator'']]
  
{{Documentation/Note|The Navigator has different functions in a master document. See Chapter 13 (Working with Master Documents).}}
+
{{Note|The Navigator has different functions in a master document. See [[Documentation/OOo3_User_Guides/Writer_Guide/Master_Documents|Chapter 13 (Working with Master Documents)]].}}
  
 
Table 1 summarizes the functions of the icons at the top of the Navigator.
 
Table 1 summarizes the functions of the icons at the top of the Navigator.
Line 78: Line 76:
 
</ul>
 
</ul>
  
{{Documentation/Tip|Objects are much easier to find if you have given them names when creating them, instead of keeping OOo’s default graphics1, graphics2, Table1, Table2, and so on—which may not correspond to the position of the object in the document.}}
+
{{Tip|Objects are much easier to find if you have given them names when creating them, instead of keeping OOo’s default graphics1, graphics2, Table1, Table2, and so on—which may not correspond to the position of the object in the document.}}
  
{{Documentation/Note|A hidden section (or other hidden object) in a document appears gray in the Navigator, and displays the word “hidden” as a tooltip.}}
+
{{Note|A hidden section (or other hidden object) in a document appears gray in the Navigator, and displays the word “hidden” as a tooltip.}}
  
 
== Using the Navigation toolbar ==
 
== Using the Navigation toolbar ==
Line 102: Line 100:
 
<p>To move only the selected heading and not the text associated with the heading, hold down ''Control'', and then click the icon.</p>
 
<p>To move only the selected heading and not the text associated with the heading, hold down ''Control'', and then click the icon.</p>
  
{{Documentation/Tip| The tooltips (Promote Chapter and Demote Chapter) are misleading; all headings defined in '''Tools > Outline Numbering''' can be rearranged using this function.}}
+
{{Tip| The tooltips (Promote Chapter and Demote Chapter) are misleading; all headings defined in '''Tools > Outline Numbering''' can be rearranged using this function.}}
  
 
<li>To quickly change the outline level of a heading and its associated subheadings, select the heading in the Navigator, and then click either the '''Promote Level''' or '''Demote Level''' icon. This action does not change the location of the heading, only its level.</li>
 
<li>To quickly change the outline level of a heading and its associated subheadings, select the heading in the Navigator, and then click either the '''Promote Level''' or '''Demote Level''' icon. This action does not change the location of the heading, only its level.</li>
Line 110: Line 108:
 
[[Image:reorg.png|thumb|none|500px|''Reorganizing with the Navigator'']]
 
[[Image:reorg.png|thumb|none|500px|''Reorganizing with the Navigator'']]
  
{{Documentation/Note|Users of Microsoft Word will note the similarity between this functionality and Word's Outline View.}}
+
{{Note|Users of Microsoft Word will note the similarity between this functionality and Word's Outline View.}}
  
 
== Setting reminders ==
 
== Setting reminders ==
One of the little known features of Writer which you may find quite useful is the possibility of jumping between reminders. ''Reminders'' are not highlighted in any way in the document, so you cannot see where they are, but they are a handy tool.
+
One of the little known features of Writer which you may find quite useful is the possibility of jumping between reminders. ''Reminders'' let you mark places in your document that you want to return to later on, to add or correct information, make some other change, or simply mark where you finished editing. The possible uses of reminders are limited only by your imagination.
 +
 
 +
To set a reminder at the cursor's current location, click on the [[Image:reminder-icon.png]] icon in the Navigator. You can set up to 5 reminders in a document (setting another causes the first to be deleted).
 +
 
 +
Reminders are not highlighted in any way in the document, so you cannot see where they are, except when you jump from one to the next —the location of the cursor then shows the location of the reminder.  
  
To set a reminder at the cursor's current location, click on the [[Image:reminder-icon.png]] icon in the Navigator. You can set up to 5 reminders in a document (setting another causes the first to be deleted). To jump between reminders, first select the same icon on the Navigation toolbar. Now the Previous and Next icons are active for reminders.
+
To jump between reminders, first select the '''Reminder''' icon on the Navigation toolbar. Then click the '''Previous''' and '''Next''' icons.
  
 
== Choosing drag mode ==
 
== Choosing drag mode ==

Latest revision as of 21:27, 14 July 2018


In addition to the Page Number field on the Status bar (described in Status bar), Writer provides other ways to move quickly through a document and find specific items by using the many features of the Navigator, the Navigation toolbar, and related icons.

To open the Navigator, click its icon CH13 NavigatorIcon.png on the Standard toolbar, or press F5, or choose View > Navigator on the menu bar. You can dock the Navigator to either side of the main Writer window or leave it floating (see Docking/floating windows and toolbars).

To hide the list of categories and show only the icons at the top, click the List Box On/Off icon Listbox-icon.png. Click this icon again to show the list. Click the + sign by any of the lists to display the contents of the list.

The Navigator
Documentation note.png The Navigator has different functions in a master document. See Chapter 13 (Working with Master Documents).

Table 1 summarizes the functions of the icons at the top of the Navigator.

Table 1: Function of icons in the Navigator

Md-icon.png Not active in ordinary documents. In a master document, switches between the master document file and its subdocuments.
Navbar-icon.png Opens the Navigation toolbar (see Using the Navigation toolbar).
Prevnext-icon.png Jumps to the previous or next item in the document. To select the category of items, see Using the Navigation toolbar.
Pgno-icon.png Jumps to the page number in the box. Type the page number or select it using the up and down arrows.
Dm-icon.png Drag Mode. Select hyperlink, link, or copy. See Choosing drag mode for details.
Listbox-icon.png List Box On/Off. Shows or hides the list of categories.
Contentview-icon.png Content View. Switches between showing all categories and showing only the selected category.
Reminder-icon.png Inserts a reminder. See Setting reminders.
Hfjump-icon.png Jumps between the text area and the header or footer area (if the page has them).
Fnjump-icon.png Jumps between a footnote anchor and the corresponding footnote text.
Hl-icon.png Choose the number of heading levels to be shown.

Moving quickly through a document

The Navigator provides several convenient ways to move around a document and find items in it:

  • To jump to a specific page in the document, type its page number in the box at the top of the Navigator.
  • When a category is showing the list of objects in it, double-click on an object to jump directly to that object’s location in the document.
  • To see the content in only one category, highlight that category and click the Content View icon. Click the icon again to display all the categories. You can also change the number of heading levels shown when viewing Headings.

  • Use the Previous and Next icons to jump to other objects of the type selected in the Navigation toolbar. (See below for details.)
Tip.png Objects are much easier to find if you have given them names when creating them, instead of keeping OOo’s default graphics1, graphics2, Table1, Table2, and so on—which may not correspond to the position of the object in the document.


Documentation note.png A hidden section (or other hidden object) in a document appears gray in the Navigator, and displays the word “hidden” as a tooltip.

Using the Navigation toolbar

To display the Navigation toolbar, click the Navigation icon [[Image:]] in the Navigator or the small Navigation icon near the lower right-hand corner of the window below the vertical scroll bar.

Previous, Navigation, and Next icons

The Navigation toolbar shows icons for all the object types shown in the Navigator, plus some extras (for example, the results of a Find command).

Navigation toolbar

Click an icon to select that object type. Now all the Previous and Next icons (in the Navigator itself, in the Navigation Toolbar, and on the scroll bar) will jump to the next object of the selected type. This is particularly helpful for finding items like index entries, which can be difficult to see in the text. The names of the icons (shown in the tooltips) change to match the selected category; for example, Next Graphic or Next Bookmark.

Rearranging chapters using the Navigator

You can arrange chapters and move headings in the document by using the Navigator.

  1. Click the Content View icon to expand the headings, if necessary.
  2. (Optional) If you have several subheading levels, you can more easily find the headings you want, by changing the Heading Levels Shown selection to show only 1 or 2 levels of headings.
  3. Click on the heading of the block of text that you want to move and drag the heading to a new location on the Navigator, or click the heading in the Navigator list, and then click either the Promote Chapter or Demote Chapter icon. All of the text and subsections under the selected heading move with it.
  4. To move only the selected heading and not the text associated with the heading, hold down Control, and then click the icon.

    Tip.png The tooltips (Promote Chapter and Demote Chapter) are misleading; all headings defined in Tools > Outline Numbering can be rearranged using this function.


  5. To quickly change the outline level of a heading and its associated subheadings, select the heading in the Navigator, and then click either the Promote Level or Demote Level icon. This action does not change the location of the heading, only its level.
  6. To increase the outline level of only the selected heading, but not its associated subheadings, hold down Control, and then click the icon.

Reorganizing with the Navigator
Documentation note.png Users of Microsoft Word will note the similarity between this functionality and Word's Outline View.

Setting reminders

One of the little known features of Writer which you may find quite useful is the possibility of jumping between reminders. Reminders let you mark places in your document that you want to return to later on, to add or correct information, make some other change, or simply mark where you finished editing. The possible uses of reminders are limited only by your imagination.

To set a reminder at the cursor's current location, click on the Reminder-icon.png icon in the Navigator. You can set up to 5 reminders in a document (setting another causes the first to be deleted).

Reminders are not highlighted in any way in the document, so you cannot see where they are, except when you jump from one to the next —the location of the cursor then shows the location of the reminder.

To jump between reminders, first select the Reminder icon on the Navigation toolbar. Then click the Previous and Next icons.

Choosing drag mode

Sets the drag and drop options for inserting items into a document using the Navigator.

Insert As Hyperlink

Creates a hyperlink when you drag and drop an item into the current document.

Insert As Link

Inserts the selected item as a link where you drag and drop in the current document. Text is inserted as protected sections. However, you cannot create links for graphics, OLE objects, references, or indexes using this method.

Insert As Copy

Inserts a copy of the selected item where you drag and drop in the current document. You cannot drag and drop copies of graphics, OLE objects, or indexes.


Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools
In other languages