Pictures and 3D objects

From Apache OpenOffice Wiki
Jump to: navigation, search



Editing pictures

Draw contains a number of functions for editing raster graphics (bitmaps)—for example, photos, scanned pictures, and so on—including import and and export as well as conversion from one format to another. Draw can read in all the usual range of graphic file formats. However, it does not have the same capabilities as the specialized raster graphics programs like Adobe Photoshop or The Gimp.

See Chapter 6 (Editing Pictures) in the Draw Guide for details.

Working with 3D objects

Although Draw does not match the functionality of the leading drawing or picture editing programs, it does offer a wide array of tools and methods to produce and edit very good 3D drawings and pictures.

Draw offers two types of 3D objects: the ones carried forward from OOo version 1, 3D bodies, and the ones newly introduced in version 2, 3D shapes. Depending on which type you choose, there are different possibilities for further editing of the object (rotation, illumination, perspective). Setting up and editing 3D objects is simpler with 3D shapes than with 3D bodies, but 3D bodies currently allow for more customizing than 3D shapes.

See Chapter 7 (Working with 3D Objects) in the Draw Guide for details.

Inserting pictures from other sources

You can add pictures from several sources:

  • The Gallery—see Chapter 11 (Graphics, the Gallery, and Fontwork)
  • Directly from a scanner (Insert > Picture > Scan)
  • Images created by another program, including photographs from a digitial camera (Insert > Picture > From File)

Draw provides tools for working with bitmap images such as photographs: the Picture toolbar and the bitmap image management palette. See the Draw Guide for details and examples.

Exporting objects to other programs

To save a Draw image in a foreign format, use File > Export. Draw can save to many graphic file formats.

You can also export Draw files to HTML, PDF, or Flash. PDF export is the same as for any part of OpenOffice.org, as described in Chapter 10 (Printing, E-mailing, and Exporting). Flash export creates a .swf file.

HTML export uses a conversion wizard that creates as many web pages as there are pages in your Draw document. You can optionally choose to display the pages in frames with a navigator and can set an index page. For more information, see Chapter 12 (Creating Web Pages: Saving Documents as HTML Files).

Adding Comments to a Drawing

Draw supports comments (formerly called notes) similar to those in Writer and Calc.

  1. To insert a comment choose Insert > Comment from the menu bar. A small box containing your initials appears in the upper left-hand corner of the Draw page,with a larger yellow text box beside it. Draw has automatically added your name and the date at the bottom of this text box.
Inserting a Comment into a drawing
  1. Type or paste your comment into the text box. You can optionally apply some basic formatting to parts of the text by selecting it, right-clicking,and choosing from the pop-up menu. (From this menu, you can also delete the current comment, all the comments from the same author,or all the comments in the document.)
  2. You can move the small comment markers to anywhere you wish on the page. Typically you might place it on or near an object you refer to in the comment.
  3. To show or hide the comment markers, choose View > Comments.
  4. Select Tools > Options > User Data to configure the name you want to appear in the Author field of the comment, or to change it.

Template:Documentation/Note

Content on this page is licensed under the Creative Common Attribution 3.0 license (CC-BY).
Personal tools