Why is Java needed in Apache OpenOffice.org?

From Apache OpenOffice Wiki
< Documentation‎ | FAQ‎ | Installation
Revision as of 23:26, 27 August 2018 by KNMcKenna (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search


Why is Java needed in Apache OpenOffice?


Java is necessary for use of the following in Apache OpenOffice:

  • The built-in default database HSQLDB
  • JDBC database drivers
  • Many wizards, like the Autopilot/wizard form generators
  • Using the XSLT, flat XML filters
  • Using Java applets in OpenOffice.org
  • Using Java-based languages in the scripting framework
  • Java Application Interface (API) programs for 3rdparty modules
  • All accessibility functions
  • The Apache OpenOffice testtool and QaTestDev programs
  • The Search function of the built in help.

See also: Documentation/FAQ/Installation/The installer is looking for Java. Does it really need it to work correctly?

Personal tools