Difference between revisions of "DE/VCLTesttool"

From Apache OpenOffice Wiki
< DE
Jump to: navigation, search
(CVS/SVN)
 
(14 intermediate revisions by 6 users not shown)
Line 1: Line 1:
{{De.OOo}}
+
{{DE/OOo}}
 
== Über das VCLTesttool ==
 
== Über das VCLTesttool ==
  
Das VCLTesttool ist ein eigenständiges Programm, das zum automatischen Testen  von OpenOffice.org benutzt wird. Das VCLTesttool kommuniziert über die TCP/IP-Schnittstelle mit OpenOffice.org. Es ist geeignet, jede Installation von OpenOffice.org auf einem PC oder in einem lokalen Netzwerk (LAN) zu testen. Die aktuelle Version des VCLTesttool kann für OpenOffice.org 1.1beta und höher verwendet werden. Da allerdings Inkompatibilitäten mit zukünftigen Builds von OpenOffice.org nicht auszuschließen sind, müssen Sie dann möglicherweise eine neuere Version des VCLTesttool verwenden. Die jeweils aktuelle Versionen von VCLTesttool kann immer  [http://qa.openoffice.org/ooQAReloaded/AutomationTeamsite/ooQA-TeamAutomationBin.html  hier] gefunden werden.
+
Das VCLTesttool ist ein eigenständiges Programm, das zum automatischen Testen  von OpenOffice.org benutzt wird. Das VCLTesttool kommuniziert über die TCP/IP-Schnittstelle mit OpenOffice.org. Mit dem Testtool kann jede Installation von OpenOffice.org auf einem PC oder in einem lokalen Netzwerk (LAN) getestet werden. Die aktuelle Version des VCLTesttool kann für OpenOffice.org 1.1beta und höher verwendet werden. Da allerdings Inkompatibilitäten mit zukünftigen Versionen von OpenOffice.org nicht auszuschließen sind, müssen Sie dann möglicherweise eine neuere Version des VCLTesttool verwenden. Die jeweils aktuelle Versionen von VCLTesttool kann immer  [http://qa.openoffice.org/ooQAReloaded/AutomationTeamsite/ooQA-TeamAutomationBin.html  hier] gefunden werden.
  
 
== Schnellstart ==
 
== Schnellstart ==
Line 16: Line 16:
 
Lesen Sie [http://qa.openoffice.org/servlets/ProjectSource CVS client setup], wenn Sie für OpenOffice.org CVS auf Ihrem Rechner einrichten wollen.
 
Lesen Sie [http://qa.openoffice.org/servlets/ProjectSource CVS client setup], wenn Sie für OpenOffice.org CVS auf Ihrem Rechner einrichten wollen.
  
Lesen Sie [[OOo_and_Subversion]], um SubVersion für OpenOffice.org einzusetzen.
+
Lesen Sie [[OOo_and_Subversion]], um Subversion für OpenOffice.org einzusetzen.
  
Als einfache Alternative können Sie auch vorbereitete Pakete des VCLTesttool Frameworks herunterladen. Lesen Sie dazu [[VCLTesttool#VCLTesttool_framework_(testautomation)]].
+
Als einfache Alternative können Sie auch vorbereitete Pakete des VCLTesttool Frameworks herunterladen. Lesen Sie dazu [[http://wiki.services.openoffice.org/wiki/DE/VCLTesttool#VCLTesttool_Framework_.28testautomation.29]] für Details.
  
 
===== OpenOffice.org =====
 
===== OpenOffice.org =====
Line 29: Line 29:
  
 
im Installationsverzeichnis überprüfen.<br>
 
im Installationsverzeichnis überprüfen.<br>
(siehe <INSTALLDIR>OpenOffice.org 3/program)
+
(siehe <INSTALLDIR>/OpenOffice.org 3/program)
  
 
Öffnen Sie die Datei und sehen Sie sich die Sektion [Version] an:
 
Öffnen Sie die Datei und sehen Sie sich die Sektion [Version] an:
Line 42: Line 42:
  
 
===== VCLTesttool Framework (testautomation) =====
 
===== VCLTesttool Framework (testautomation) =====
Das VCLTesttool Framework umfasst alle Skripts, die als Modul '''testautomation''' auf dem aktuellen CVS/SVN-Zweig aufsetzend für die Tests eines Meilensteins bereitgestellt worden sind. Sie finden alle Dateien im OpenOffice.org CVS/SVN und können sie via cvs/svn checkout leicht auf Ihr lokales System herunterladen. Nehmen wir an, Sie möchten eine Version auf dem Zweig 'DEV300' mit dem Meilenstein 'm29' testen.
+
Das VCLTesttool Framework umfasst alle Skripte, die als Modul '''testautomation''' auf dem aktuellen CVS/SVN-Zweig aufsetzend für die Tests eines Meilensteins bereitgestellt worden sind. Sie finden alle Dateien im OpenOffice.org CVS/SVN und können Sie via cvs/svn checkout leicht auf Ihr lokales System herunterladen. Nehmen wir an, Sie möchten eine Version aus dem Zweig 'DEV300' mit dem Meilenstein 'm29' testen.
 +
 
 +
'''Bitte denken Sie daran, dass alle Skripte für DEV300 Milestones bis Version m32 im CVS zu finden sind und alle Milestones ab Version m32 im SVN.'''
  
 
Benutzen Sie das folgende cvs-Kommando, um die Programmquellen auszuchecken:
 
Benutzen Sie das folgende cvs-Kommando, um die Programmquellen auszuchecken:
Line 50: Line 52:
 
(der optionale Parameter -d wird verwendet, um in ein bestimmtes Verzeichnis auszuchecken, so dass mehrere Versionen parallel verwaltet werden können.)
 
(der optionale Parameter -d wird verwendet, um in ein bestimmtes Verzeichnis auszuchecken, so dass mehrere Versionen parallel verwaltet werden können.)
  
Auschecken mit SubVersion:
+
Auschecken mit Subversion:
  
 
''svn checkout svn://svn.services.openoffice.org/ooo/tags/DEV300_m32/testautomation testautomation_m32''
 
''svn checkout svn://svn.services.openoffice.org/ooo/tags/DEV300_m32/testautomation testautomation_m32''
Line 60: Line 62:
 
Um mit den automatischen Tests von OpenOffice.org beginnen zu können, brauchen Sie auch noch eine lokale Kopie des VCLTesttool auf Ihrem System.
 
Um mit den automatischen Tests von OpenOffice.org beginnen zu können, brauchen Sie auch noch eine lokale Kopie des VCLTesttool auf Ihrem System.
  
Laden Sie das zu Ihrem Betriebssystem passende [http://qa.openoffice.org/ooQAReloaded/AutomationTeamsite/ooQA-TeamAutomationBin.html aktuelle VCLTesttool] in ein Verzeichnis Ihrer Wahl auf Ihrem Rechner herunter und entpacken Sie das Archiv auf Ihrem lokalen System. Nachdem alle Dateien entpackt sind, starten Sie bitte testtool.bin (testtool.exe unter Windows). Sobald VCLTesttool gestartet ist, wählen Sie Tools->Options.
+
Laden Sie das zu Ihrem Betriebssystem passende [http://qa.openoffice.org/ooQAReloaded/AutomationTeamsite/ooQA-TeamAutomationBin.html aktuelle VCLTesttool] in ein Verzeichnis Ihrer Wahl auf Ihrem Rechner herunter und entpacken Sie das Archiv auf Ihrem lokalen System. Nachdem alle Dateien entpackt sind, starten Sie bitte testtool.bin (testtool.exe unter Windows). Sobald das VCLTesttool geladen ist, wählen Sie Tools->Options.
  
 
'''(Alle Einträge auf den Screenshots sind lediglich Beispiele, die Sie an Ihre Anforderungen anpassen müssen.)'''
 
'''(Alle Einträge auf den Screenshots sind lediglich Beispiele, die Sie an Ihre Anforderungen anpassen müssen.)'''
Line 74: Line 76:
 
1. Profile: DEV300m32
 
1. Profile: DEV300m32
  
2. Log base directory: (Alle Ergebnisdateien, die während eines Testdurchlaufs generiert werden, werden in diesem Verzeichnis abgelegt.)
+
2. Log Basisverzeichnis: (Alle Ergebnisdateien, die während eines Testdurchlaufs generiert werden, werden in diesem Verzeichnis abgelegt.)
  
3. Base directory: Das Basisverzeichnis der ausgecheckten testautomation-Skripts.
+
3. Basisverzeichnis: Das Basisverzeichnis der ausgecheckten testautomation-Skripte.
  
 
4. Default HID directory: Das Standard HID Verzeichnis wird automatisch gesetzt und muss in den meisten Fällen nicht angepasst werden.
 
4. Default HID directory: Das Standard HID Verzeichnis wird automatisch gesetzt und muss in den meisten Fällen nicht angepasst werden.
Line 86: Line 88:
 
[[Image: DE_Testtool-option-crashreport.png]]
 
[[Image: DE_Testtool-option-crashreport.png]]
  
Markieren Sie das Kontrollkästchen 'Allow contact' und geben Sie im Feld 'EMail' Ihre gültige OpenOffice.org-Mail-Adresse ein. Diese Mail-Adresse wird verwendet, wenn VCLTesttool einen Fehlerbericht (crashreport) sendet. Wenn Sie später mit dem automatischen Tests vertraut sind, können Sie Ihre Ergebnisse auf der [[QUASTe]]-Seite (Quality Assurance Statuspage) eintragen. Daher ist eine gültige Mail-Adresse erforderlich.
+
Markieren Sie das Kontrollkästchen 'Allow Contact' und geben Sie im Feld 'EMail' Ihre gültige OpenOffice.org-Mail-Adresse ein. Diese Mail-Adresse wird verwendet, wenn VCLTesttool einen Fehlerbericht (crashreport) sendet. Wenn Sie später mit dem automatischen Tests vertraut sind, können Sie Ihre Ergebnisse auf der [[QUASTe]]-Seite (Quality Assurance Statuspage) eintragen. Daher ist eine gültige Mail-Adresse erforderlich.
  
  
Line 94: Line 96:
 
[[Image: DE_Testtool-option-misc.png]]
 
[[Image: DE_Testtool-option-misc.png]]
  
Auf dieser Karteikarte könne Sie die Optionen eintragen, die vom VCLTesttool zur Kommunikation mit OpenOffice.org verwendet werden sollen. In den meisten Fällen können die Vorgabewerte beibehalten werden. Sofern VCLTesttool Ihre OpenOffice.org-Installation nicht starten kann, ist möglicherweise der 'Testtool Port' oder der 'Remote UNO Port' von Ihrem System blockiert oder reserviert.
+
Auf dieser Karteikarte können Sie die Optionen eintragen, die vom VCLTesttool zur Kommunikation mit OpenOffice.org verwendet werden sollen. In den meisten Fällen können die Vorgabewerte beibehalten werden. Sofern VCLTesttool Ihre OpenOffice.org-Installation nicht starten kann, ist möglicherweise der 'Testtool Port' oder der 'Remote UNO Port' von Ihrem System blockiert oder reserviert.
In das Feld 'OOo Program Dir' können Sie das Programmverzeichnis Ihrer OpenOffice.org-Installation eintragen, die mit VCLTesttool getestet werden soll. In den meisten Fällen kann dieses Feld leer bleiben; VCLTesttool sollte Ihre OpenOffice.org-Installation auch so finden. Wenn nicht, versuchen Sie es erneut, nachdem Sie hier den Pfad Ihrer Installation hinzugefügt haben, z.B. <INSTALLDIR>/openoffice.org3
+
In das Feld 'OOo Program Dir' können Sie das Programmverzeichnis Ihrer OpenOffice.org-Installation eintragen, die mit VCLTesttool getestet werden soll. In den meisten Fällen kann dieses Feld leer bleiben; VCLTesttool sollte Ihre OpenOffice.org-Installation auch so finden. Wenn nicht, versuchen Sie es erneut, nachdem Sie hier den Pfad Ihrer Installation hinzugefügt haben, z.B. <INSTALLDIR>/openoffice.org3.
  
 
Alle vorgenommenen Änderungen der VCLTesttool-Optionen werden in der Datei
 
Alle vorgenommenen Änderungen der VCLTesttool-Optionen werden in der Datei
Line 109: Line 111:
 
Damit sind alle Voraussetzungen erfüllt!
 
Damit sind alle Voraussetzungen erfüllt!
  
== einen automatischen Testlauf durchführen ==
+
== Einen automatischen Testlauf durchführen ==
  
 
Sobald Sie die Skripts erfolgreich auf Ihrer Maschine heruntergeladen und alle erforderlichen Einstellungen wie im Abschnitt 'Schnellstart' beschrieben vorgenommen haben, ist die Durchführung eines automatischen Testlaufs ziemlich einfach. Um herauszufinden welche automatischen Tests durchgeführt werden sollen, besuchen Sie [http://wiki.services.openoffice.org/wiki/QUASTe#Category_model diese Seite].
 
Sobald Sie die Skripts erfolgreich auf Ihrer Maschine heruntergeladen und alle erforderlichen Einstellungen wie im Abschnitt 'Schnellstart' beschrieben vorgenommen haben, ist die Durchführung eines automatischen Testlaufs ziemlich einfach. Um herauszufinden welche automatischen Tests durchgeführt werden sollen, besuchen Sie [http://wiki.services.openoffice.org/wiki/QUASTe#Category_model diese Seite].
  
* Starten Sie das VCLTesttool und wählen Sie File->Open
+
* Starten Sie das VCLTesttool und wählen Sie File->Open.
* ändern Sie den Dateityp nach *.bas
+
* Ändern Sie den Dateityp nach *.bas.
* wählen Sie das Verzeichnis aus, in dem die Testskripts gespeichert sind
+
* Wählen Sie das Verzeichnis aus, in dem die Testskripts gespeichert sind.
* wählen Sie die *.bas-Datei aus, die als nächstes gestartet werden soll
+
* Wählen Sie die *.bas-Datei aus, die als nächstes gestartet werden soll.
* wählen Sie 'OK' im Dateidialog
+
* Wählen Sie 'OK' im Dateidialog.
* Drücken Sie 'F5' oder wähle 'Program->start', um die automatischen Tests zu starten
+
* Drücken Sie 'F5' oder wählen Sie 'Program->start', um die automatischen Tests zu starten.
  
 
Jetzt müssen Sie nur noch warten, bis der Test abgeschlossen ist und danach die Testergebnisse analysieren, die in der *.res-Datei gespeichert sind.
 
Jetzt müssen Sie nur noch warten, bis der Test abgeschlossen ist und danach die Testergebnisse analysieren, die in der *.res-Datei gespeichert sind.
Line 124: Line 126:
  
  
[[Category:Quality_Assurance]]
+
[[Category:DE|VCLTesttool]]
[[Category:de.openoffice.org|VCLTesttool]]
+

Latest revision as of 02:06, 22 October 2012

De flag.jpg Deutschsprachiges OpenOffice.org-Projekt

Unsere Hauptseiten:

Unsere Seiten in diesem Wiki werden über folgende Kategorien erschlossen:


Über das VCLTesttool

Das VCLTesttool ist ein eigenständiges Programm, das zum automatischen Testen von OpenOffice.org benutzt wird. Das VCLTesttool kommuniziert über die TCP/IP-Schnittstelle mit OpenOffice.org. Mit dem Testtool kann jede Installation von OpenOffice.org auf einem PC oder in einem lokalen Netzwerk (LAN) getestet werden. Die aktuelle Version des VCLTesttool kann für OpenOffice.org 1.1beta und höher verwendet werden. Da allerdings Inkompatibilitäten mit zukünftigen Versionen von OpenOffice.org nicht auszuschließen sind, müssen Sie dann möglicherweise eine neuere Version des VCLTesttool verwenden. Die jeweils aktuelle Versionen von VCLTesttool kann immer hier gefunden werden.

Schnellstart

Wenn Sie bei den automatischen Tests helfen und schnell anfangen möchten, ist dieser Leitfaden richtig für Sie. Er bietet eine Schritt-für-Schritt-Anleitung für den Einstieg und ist für Tests von OpenOffice.org-Version 3.x anwendbar. Dieser Leitfaden ist sowohl für Tester mit Basiswissen als auch für Fortgeschrittene gedacht.

Voraussetzungen

Sobald die folgenden Voraussetzungen umgesetzt sind, können die automatischen Tests beginnen.

CVS/SVN

Ihr PC muss mit einer lauffähigen CVS- oder SVN-Installation ausgestattet sein. (Die Migration nach SubVersion wurde mit Erreichen des Meilensteins DEV300_m32 begonnen.)

Lesen Sie CVS client setup, wenn Sie für OpenOffice.org CVS auf Ihrem Rechner einrichten wollen.

Lesen Sie OOo_and_Subversion, um Subversion für OpenOffice.org einzusetzen.

Als einfache Alternative können Sie auch vorbereitete Pakete des VCLTesttool Frameworks herunterladen. Lesen Sie dazu [[1]] für Details.

OpenOffice.org

Sie müssen eine Installation von OpenOffice.org auf Ihrem System haben. Wichtig ist, die Version der zu prüfenden Installation zu kennen.

Wenn Sie unsicher sind, welche Version installiert ist, können Sie dies in der Datei

  • .versionrc (UNIX-Systeme) bzw.
  • version.ini (Windows-Systemen)

im Installationsverzeichnis überprüfen.
(siehe <INSTALLDIR>/OpenOffice.org 3/program)

Öffnen Sie die Datei und sehen Sie sich die Sektion [Version] an:

Beispiel:

ProductMajor=300

ProductMinor=29

ProductSource=DEV300

VCLTesttool Framework (testautomation)

Das VCLTesttool Framework umfasst alle Skripte, die als Modul testautomation auf dem aktuellen CVS/SVN-Zweig aufsetzend für die Tests eines Meilensteins bereitgestellt worden sind. Sie finden alle Dateien im OpenOffice.org CVS/SVN und können Sie via cvs/svn checkout leicht auf Ihr lokales System herunterladen. Nehmen wir an, Sie möchten eine Version aus dem Zweig 'DEV300' mit dem Meilenstein 'm29' testen.

Bitte denken Sie daran, dass alle Skripte für DEV300 Milestones bis Version m32 im CVS zu finden sind und alle Milestones ab Version m32 im SVN.

Benutzen Sie das folgende cvs-Kommando, um die Programmquellen auszuchecken:

cvs checkout -r DEV300_m29 -d testautomation_m29 testautomation

(der optionale Parameter -d wird verwendet, um in ein bestimmtes Verzeichnis auszuchecken, so dass mehrere Versionen parallel verwaltet werden können.)

Auschecken mit Subversion:

svn checkout svn://svn.services.openoffice.org/ooo/tags/DEV300_m32/testautomation testautomation_m32


Falls Sie CVS und SVN nicht benutzen möchten, können Sie fertige Archive (welche von Nakata Maho vorbereitet wurden) von den Good Day-Servern herunterladen. Laden Sie einfach ein zu Ihrer OpenOffice.org-Version passendes Archiv von http://ooopackages.good-day.net/pub/OpenOffice.org/qa/testautomation/ herunter und entpacken es dann.

VCLTesttool

Um mit den automatischen Tests von OpenOffice.org beginnen zu können, brauchen Sie auch noch eine lokale Kopie des VCLTesttool auf Ihrem System.

Laden Sie das zu Ihrem Betriebssystem passende aktuelle VCLTesttool in ein Verzeichnis Ihrer Wahl auf Ihrem Rechner herunter und entpacken Sie das Archiv auf Ihrem lokalen System. Nachdem alle Dateien entpackt sind, starten Sie bitte testtool.bin (testtool.exe unter Windows). Sobald das VCLTesttool geladen ist, wählen Sie Tools->Options.

(Alle Einträge auf den Screenshots sind lediglich Beispiele, die Sie an Ihre Anforderungen anpassen müssen.)


  • Karteikarte 'Profile'

DE Testtool-option-profile.png

Legen Sie ein Profil für das aktuell zu verwendende testautomation-Modul an. Geben Sie dazu ein

1. Profile: DEV300m32

2. Log Basisverzeichnis: (Alle Ergebnisdateien, die während eines Testdurchlaufs generiert werden, werden in diesem Verzeichnis abgelegt.)

3. Basisverzeichnis: Das Basisverzeichnis der ausgecheckten testautomation-Skripte.

4. Default HID directory: Das Standard HID Verzeichnis wird automatisch gesetzt und muss in den meisten Fällen nicht angepasst werden.


  • Karteikarte 'Crashreport'

DE Testtool-option-crashreport.png

Markieren Sie das Kontrollkästchen 'Allow Contact' und geben Sie im Feld 'EMail' Ihre gültige OpenOffice.org-Mail-Adresse ein. Diese Mail-Adresse wird verwendet, wenn VCLTesttool einen Fehlerbericht (crashreport) sendet. Wenn Sie später mit dem automatischen Tests vertraut sind, können Sie Ihre Ergebnisse auf der QUASTe-Seite (Quality Assurance Statuspage) eintragen. Daher ist eine gültige Mail-Adresse erforderlich.


  • Karteikarte 'Misc'

DE Testtool-option-misc.png

Auf dieser Karteikarte können Sie die Optionen eintragen, die vom VCLTesttool zur Kommunikation mit OpenOffice.org verwendet werden sollen. In den meisten Fällen können die Vorgabewerte beibehalten werden. Sofern VCLTesttool Ihre OpenOffice.org-Installation nicht starten kann, ist möglicherweise der 'Testtool Port' oder der 'Remote UNO Port' von Ihrem System blockiert oder reserviert. In das Feld 'OOo Program Dir' können Sie das Programmverzeichnis Ihrer OpenOffice.org-Installation eintragen, die mit VCLTesttool getestet werden soll. In den meisten Fällen kann dieses Feld leer bleiben; VCLTesttool sollte Ihre OpenOffice.org-Installation auch so finden. Wenn nicht, versuchen Sie es erneut, nachdem Sie hier den Pfad Ihrer Installation hinzugefügt haben, z.B. <INSTALLDIR>/openoffice.org3.

Alle vorgenommenen Änderungen der VCLTesttool-Optionen werden in der Datei

    • ${HOME}/.testtoolrc (auf UNIX-Systemen) bzw.
    •  %APPDATA%\testtool.ini (auf Windows-Systemen)

gespeichert.

Klicken Sie in den Optionen auf die Schaltfläche 'OK', um die Änderungen zu speichern und das VCLTesttool für dieses Mal zu beenden.


Damit sind alle Voraussetzungen erfüllt!

Einen automatischen Testlauf durchführen

Sobald Sie die Skripts erfolgreich auf Ihrer Maschine heruntergeladen und alle erforderlichen Einstellungen wie im Abschnitt 'Schnellstart' beschrieben vorgenommen haben, ist die Durchführung eines automatischen Testlaufs ziemlich einfach. Um herauszufinden welche automatischen Tests durchgeführt werden sollen, besuchen Sie diese Seite.

  • Starten Sie das VCLTesttool und wählen Sie File->Open.
  • Ändern Sie den Dateityp nach *.bas.
  • Wählen Sie das Verzeichnis aus, in dem die Testskripts gespeichert sind.
  • Wählen Sie die *.bas-Datei aus, die als nächstes gestartet werden soll.
  • Wählen Sie 'OK' im Dateidialog.
  • Drücken Sie 'F5' oder wählen Sie 'Program->start', um die automatischen Tests zu starten.

Jetzt müssen Sie nur noch warten, bis der Test abgeschlossen ist und danach die Testergebnisse analysieren, die in der *.res-Datei gespeichert sind.

Personal tools