Writer.Таблицы: Часто задаваемые вопросы

From Apache OpenOffice Wiki
(Redirected from Ru/FAQ/WriterTable)
Jump to: navigation, search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.
OOw.png Вопросы по ООо Writer
Графика
Импорт, внешние ссылки и связи

Интерфейс пользователя

Набор и форматирование
Поиск и замена
Сохранение и печать
Стили и шаблоны
Страницы, оглавление и сноски
Таблицы
Другие вопросы

Все вопросы по использованию таблиц в текстовом документе Writer

Есть ли функция рисования таблиц карандашом?

Пока нет. http://qa.openoffice.org/issues/show_bug.cgi?id=18179

3.1

Возможно ли вписать текст в ячейку таблицы так, чтобы размеры ячейки не менялись?

Да, можно. Высоту и ширину ячейки можно установить вручную через высоту строки и ширину столбца.

3.0

Как отключить автоматическое изменение высоты ячейки?

На нужной ячейке щёлкните правой клавишей мыши, в контекстном меню выберите Строка - Высота…    Отключите галочку Подбор размера и установите высоту вручную.

3.0

Как отключить автоматическое изменение ширины столбца?

Таблица - Свойства таблицы - Столбцы.    Установите требуемую ширину столбцов.

3.0

Возможно ли обрамить таблицу рамкой?

Да, добавьте врезку Вставка - Врезка    и вставьте в неё таблицу.

3

Если в таблице выделить несколько ячеек, на всплывающей панели "Таблица" нажать кнопку "Обрамление" и выбрать, предположим, решётку, то обрамление всё равно производится в виде рамки вокруг всех выделенных ячеек, но никак не в виде решётки. Эта проблема как-нибудь обходится? Возникла в версиях и под вин, и под линукс.

http://qa.openoffice.org/issues/show_bug.cgi?id=93855

Исправлено в версии 3.0.1.

3

Возможно ли, чтобы на каждом листе повторялась не первая строка заголовка таблицы, а только вторая. Это возможно?

Нет. Как вариант - заголовок таблицы оформляется отдельной таблицей.

2.4.1

В MS Word можно было в текстовую рамку с панели "рисование" засунуть таблицу. Возможно такое в Writer'е?

Используйте врезки - меню Вставка - Врезка.   

2.4.1

При вставке большой таблицы (несколько страниц) из Calc в Writer таблица вставляется как OLE объект. При этом он размещается только на одной странице и не получается разделить его на части. Можно ли как-то вставить в документ Writer'a большую таблицу, чтобы она корректно распределилась на несколько страниц?

Для вставки готовой таблицы из Calc лучше пользоваться Вставить как - Текст RTF    (через кнопку Вставить на панели инструментов) или меню Правка - Вставить как - Текст в формате RTF   

См. также #Как вставить содержимое столбца из Calc в столбец таблицы во Writer?

2.4

В MS Word, если таблица не имеет обрамления - её всё равно видно. Как настроить Writer, чтобы таблицы без обрамления было видно в тексте?

Меню Таблица - Координатная сетка   

2.3

Как добавить столбец не изменяя ширины имеющихся столбцов?

Нет такой возможности.

2.3

Как мышкой изменить ширину столбцов таблицы?

В ООо есть 4 режима настройки ширины столбцов {мышкой} внутри таблиц:

  1. простое перетаскивание разделителя - меняется только ширина 2х столбцов
  2. если нажать Shift - все столбцы справа пропорционально изменят ширину
  3. если нажать Ctrl - все столбцы справа изменят ширину поровну
  4. если нажать Ctrl+Shift - "рассинхронизация" или наоборот, "синхронизация" разделителя в строке: ширина столбцов изменится только в одной строке.

2.4

Каким образом можно расширить столбец за счёт увеличения ширины всей таблицы без изменения ширины остальных столбцов?

Вызвать контекстное меню "свойства таблицы", и на вкладке "столбцы" поставить галочку "подогнать ширину таблицы" и изменять ширину столбца - ширина таблицы выравняется автоматически.

3.2

Вставка двух таблиц в одну строку рядом по горизонтали возможна?

  1. Врезка позволяет вставить в себя таблицу, если сделать несколько врезок, разместить в них таблицу и установить привязку как символ, то удастся разместить несколько таблиц в строке.
  2. Используйте вложенные таблицы.

2.3

Нет возможности перетащить таблицу

Необходимо выделить строчку (абзац) до и строчку после таблицы

2.3

Есть ли возможность обтекания текста вокруг таблицы?

Непосредственно таблицы такой функции не имеют.

Однако, если таблица небольшая (не более одной страницы), то можно её вставить в объект "Врезка", для которого установить "обтекание текста".

Создать: Вставка - Врезка.    В диалоговом окне на кладке Обтекание установить необходимый Тип обтекания, на вкладке Обрамление в разделе Положение линий выбрать Убрать обрамление. Выделив мышкой Врезку, переместить в нужное место и установить размер. Щёлкнуть мышкой вне Врезки, для снятия фокуса с неё.

Щёлкнуть мышкой внутри Врезки и вставить таблицу любым доступным способом.

2.3

В таблице копируется первая строка таблицы, и вставляется в начало каждой следующей таблице в этом же документе.

Убрать галочку «Повторять заголовок» Таблица - Свойства таблицы - На странице   

2.3

Надо отобразить текст в таблицах вертикально в несколько строк

Для поворота текста выделите текст в нужной ячейке, войдите в меню Формат - Символы - Положение  - Вращение/Масштабирование  - поворот на 90 гр. 

Для печати в несколько строк используйте SHIFT+ENTER для перевода строки

Documentation note.png Возможны проблемы с отображением всей таблицы при наличии вертикального текста после экспорта в формат .doc


2.3

При открытии файла во Writer таблица обрезается и не переносится на следующие страницы

Такой видимый эффект наблюдается при импорте документов из формата DOC.

На самом деле таблица не обрезается и все данные сохраняются. При импорте все таблицы автоматически помещаются во врезки, а объект врезка по размеру не может быть более одной страницы.

Есть два способа решения данной задачи.

  • Воспользоваться связанными фреймами (врезками). В связанных врезках текст (и таблицы в том числе) могут свободно перетекать друг в друга. Для этого на следующей странице (страницах) где должно размещаться продолжение таблицы необходимо вставить столько пустых врезок, сколько нужно. Не забывайте - врезке можно придать любой размер в пределах страницы. Затем выделить первую врезку (фрейм) и на панели нажать кнопку "цепь" (связать фреймы) и щёлкнуть по следующему по порядку фрейму. Надо повторить эту операцию столько раз, сколько нужно, последовательно связав все фреймы (врезки).
  • Отказаться от фреймов (врезок). Для этого выделите таблицу (лучше делать это с помощью соответствующей команды меню), скопируйте её, поместите курсор за пределами врезки на свободном месте и вставьте таблицу. После этого врезку (фрейм) можно удалить.

Иногда удобнее использовать WordViewer: открыть документ с проблемной таблицей в нём, выделить всё и скопировать, а затем вставить в пустой документ OOo Writer

2.3

Можно ли копировать формулы в ячейках таблицы, как в Calc'e?

Да, необходимо выделить всю ячейку целиком, используя меню Таблица - Выделить - Ячейки,    скопировать её, затем вставить в нужном месте.

2.3

Как вставить разрыв страницы в таблицу?

Таблицы на следующие страницы переносятся только автоматически. Вставить разрыв страницы внутри таблицы нельзя. Единственный вариант - разорвать таблицу командой Таблица - Разбить таблицу.   

2.3

Как правильно нумеровать таблицы?

С помощью меню Вставка - Название.    Откроется диалоговое окно, в котором легко задать нужный шаблон именования таблицы или рисунка, а также задать параметры нумерации и расположение названия.

2.3

Как удалить абзац после таблицы?

Для этого необходимо встать в конец последней ячейки последней строки таблицы и нажать Ctrl+Shift+Del

Tip.png В некоторых ОС сочетание клавиш может перехватываться системой, поэтому можно заменить его --Helen 05:45, 15 April 2008 (CEST)


2.4

Как вставить абзац после таблицы?

Принять участие в проекте!

Общие вопросы

Форматирование ответов
Вопросы использования
Популярные разделы:
Writer: Часто задаваемые вопросы
Calc: Часто задаваемые вопросы
Орфография и грамматика
Полезности и секреты
Главная страница

Для этого необходимо встать в конец последней ячейки последней строки таблицы и нажать Alt+Enter

2.4

Как вставить абзац перед таблицей?

Для этого необходимо встать в начало первой ячейки первой строки таблицы и нажать Alt+Enter

2.4

Как вставить содержимое столбца из Calc в столбец таблицы во Writer?

  • Выделяем ячейки в таблице Calc, копируем
  • Во Writer'e ставим курсор на пустое место в документе, выбираем Правка - Вставить как - Текст HTML   
  • Получилась новая таблица с нашими данными во Writer'e
  • Выделяем и копируем полученную новую таблицу
  • Устанавливаем курсор в старую таблицу и нажимаем кнопку Вставить
  • Данные из Calc скопированы в таблицу Writer.
Tip.png Можно использовать также Вставить как - Текст RTF


2.3

Пишу в ячейке 1.2 или 1.2., а он мне возвращает 01.02.09

В России в качестве десятичного разделителя принята запятая, поэтому присутствие точки распознаётся как дата. Вводите вещественные числа с использованием запятой: 1,2.

Если всё-таки необходимо ввести именно 1.2 или 1.2., то, находясь в таблице вызвать контекстное меню (нажать правую кнопку мыши) и убрать галку Распознавать числа. Данное действие необходимо совершать до ввода данных в таблицу.

3.1.1


Перейти к разделу: Writer | Calc | Общее | UI | Глоссарий | Принятые сокращения | Полезности | Содержание
Personal tools