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Note for Mac Users

Some keystrokes and menu items differ on a Mac from those used in Windows and
Linux. The table below gives some common substitutions for the instructions in this
chapter. For a more detailed list, see the application Help.

Windows/Linux Mac equivalent Effect

Tools > Options OpenOffice > Access setup options

menu selection Preferences

Right-click Control+click Open context menu

Ctrl (Control) # (Command) Used with other keys

F5 Shift+3¥+F5 Open the Navigator

F11 #+T Open Styles & Formatting
window
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Drawing an Organization Chart

Even though Draw does not have an organization chart toolbar, you can draw these
charts by drawing rectangles and connector lines (see Figure 1). You can indicate
hierarchies by using a color progression, from dark to light tones or vice versa. Your
color choices should maintain a good contrast between text color and background so
you can easily read the printed diagram.

Management
Development Sales
Hardware Software Series Parts MNorth South

Figure 1: Example of an Organization Chart

Before you begin, prepare a setup page or draft with snap lines (shown in Figure 2)
to assist in drawing the various hierarchies, responsibility paths, and typical boxes
you will use in drawing the chart.

Figu're' 2: Drdft with snap lines

Place and dimension the individual boxes according to the size of the overall chart.
The exact size, and particularly the width, position, and color, will be fixed later. It is
sometimes easier to draw only one box per level. That way, you can copy and paste
this box and move the copies to the desired positions. Using styles can also be
helpful; see the relevant section in Chapter 4 (Changing Object Attributes).

You can also select one or more boxes and use Edit > Duplicate to make copies (see
Figure 3). The spacing of the duplicated objects relative to the original can be
controlled using the placement fields for the X and Y axes. Note that positive values
for X and Y are to the right and downwards from the original object.
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Figure 3: Duplicating an object

The replication technique to use is up to you. The draft for the example in this
chapter should look similar to that in Figure 4.

e B EE e

Figufe'él: The ﬁhiéhed draft |
The next step is to add text to the boxes, most easily by inserting it as a text element

within the box. Activate the ”Iﬂ_ﬁ]‘ icon on the Options toolbar, then double-click the box
to enter text into it. Alternatively, select the box and press F2. You should then see a
blinking cursor in the box, and the Text Formatting toolbar should be visible.

Set the text formatting and type the text. Depending on the length and format of the
text, you may need to adjust the size of the box and the spacing to neighboring boxes,
or change the formatting of the text to fit the box. Adjustments can be made initially
with the mouse and fine-tuned with the Position and Size dialog.

Now set up the fill colors and save the drawing. The connections between the boxes
are not drawn with ordinary lines, but rather with Draw’s connectors. How to draw
these connectors and add text to them is described in “Glue Points and Connectors”
starting on page 8.

In addition, you can use dynamic text frames instead of boxes. These frames offer the
advantage of automatic line breaks. Figure 5 shows the sequence of text input into a
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frame, adding borders, and setting the background color. The Line and Filling toolbar
may not be visible until you have set a line type for the frame. Set the line type using
Format > Line, or right-click the text frame and select Line. All of the tools for
setting the text properties, line type, and background color are also available in the
Sidebar once the text frame object is selected.
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Figure 5: Working with text frames

Drawing a Flow Diagram

For drawing flowcharts, Draw offers a separate toolbar (Figure 6); click the flowchart

icon = - on the main Drawing toolbar.

The easiest way to draw a flowchart is to follow the same setup procedure as for
organization charts. Select the symbols from the toolbar and drag them into position
as described in Chapter 2 (Drawing Basic Shapes). See Figure 7 for an example of a
typical flowchart.

The individual symbols must be exactly positioned if the connectors joining them are
to form a vertical line. The midpoints of all the symbols that lie in a vertical straight

line should have the same X coordinate, and those on the same level on a horizontal

line should have the same Y coordinate.
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Figure 6: The Flowchart toolbar

Select the shapes that should lie in a vertical straight line and center them using
Modify > Alignment > Centered. For those on a horizontal line, select the shapes
and center them with Modify > Alignment > Center. You can also set snap lines if
you need several vertical lines.
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Figure 7: Example of a flow diagram

After adding text and setting the fill color, you can join individual symbols together
and add text to the connectors. This technique is described in the next section.

Glue Points and Connectors

These elements were briefly introduced in Chapter 2 (Drawing Basic Shapes). This
section describes how to use them.

Connectors are lines or arrows whose ends automatically dock to a connection or
glue point on an object. Connectors are particularly useful when drawing
organization charts, flow diagrams, and mind maps. The connecting lines between
the symbols remain intact even when the latter are moved or rearranged.
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The Connector Toolbar

Click on the T arrow of the * button on the Draw toolbar to open the Connectors
toolbar.

If the type of Connectors  ~ x

connector you want by By 4, By oy Visible Buttons g onnector

isn't shown, drag the By By K G G Customize Toolbar... Connector Starts with Arrow
toolbar to make it ——— | Dock Toalbar Connector Ends with Arrow
float, then click the Dock All Toolbars Connector with Arrows

Connector Starts with Circle
Connector Ends with Circle
Connector with Circles

Lock Toolbar Position

arrow in the Close Toolbar

toolbar’s title bar. In
the list that appears,
click on Visible
buttons to open a
menu from which
you can activate
additional types of
connectors (Figure
8).

Line Connector

Line Connector Starts with Arrow
Line Connector Ends with Arrow
Line Connector with Arrows

Line Connector Starts with Circle
Line Connector Ends with Circle
Line Connector with Circles

Straight Connector

Straight Connector starts with Arrow
Straight Connector ends with Arrow
Straight Connector with Arrows
Straight Connector starts with Circle
Straight Connector ends with Circle
Straight Connector with Circles

Connector types fall
into four groups:

o Standard
connectors - the line
segments run
vertically and
horizontally. All
angles are right
angles. The
connector does not
bend around the
objects it binds. Figure 8: Activating additional connectors

Curved Connector

Curved Connector Starts with Arrow
Curved Connector Ends with Arrow
Curved Connector with Arrows
Curved Connector Starts with Circle
Curved Connector Ends with Circle
Curved Connector with Circles

F @SB <7 LADAH & Es@AFE S FSEE S (S

. Line connectors - consist of a line segment and two smaller horizontal or
vertical segments at the ends.

. Straight connectors - consist of a single line.

. Curved connectors - are based on Bézier curves, as described in Chapter 10
(Advanced Draw Techniques).

You can modify all the connector types from the context menu. Select Connector to
change from one connector type to another (as well as some other properties). With
the Line pane on the Sidebar, you can change the appearance of the line (color, arrow
style, and line style) but not the connector type.

Drawing Connectors—Basics

When you choose a connector from the toolbar, the mouse pointer changes to '.~. As
you move the cursor over an object, the available connection points (also referred to
as glue points) become visible. To connect two shapes, move the mouse cursor over a
glue point, click and hold down the left mouse button to establish the first point, and
then, while pressing the left mouse button, drag the mouse cursor to the other glue
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point. Then release the mouse button. The ends of the line are now docked, and the
connection is established (see Figure 9).

Figure 9: Gluing a connector to a shape

As with all other objects, connectors have one or more control points to simplify the
construction of the drawing. You can use these points to change the shape, length,
and proportions of the connector line (see Figure 10).

Figure 10: Control points of
a connector

To remove a connector from an object, either move the end of the connector away
from the glue point of the object or simply delete the connector entirely.

Editing Glue Points

Glue points can be edited using a separate toolbar (see Figure 11). This toolbar

appears when you click on the Glue Points icon #| on the Drawing toolbar or select
Edit > Glue Points from the main menu.

Glue points D
A =l

Figure 11: The Glue points toolbar

The following briefly describes the function of each button on this toolbar.
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Use this button to insert a new glue point into an object you have drawn. If
the object is filled, you can place a glue point anywhere inside the object or
on its frame. With unfilled objects, you can place a glue point only on the
outside frame, but you can then drag it inside the object, provided that the
Glue Points icon on the Drawing toolbar is still active.

The glue points you add remain visible while the Glue

. Points icon is active. They appear as small blue crosses.
= A selected glue point has a gray square behind the cross.
L You can move a selected glue point with the mouse or

delete it with the Del key.

Use these four buttons to choose one or more directions permitted for a
connector to join to a particular glue point.

Activate Glue Points and then choose the direction. If, for example, you

activate only the & button, every connector will be forced to come to that
glue point from the left side.

In the drawing on the left below is a glue point in the circle with a left entry,
and one in the square with a right entry. The effect of this when adding a
connector between the two glue points is shown in the drawing on the right

If you are in glue point editing mode and add another direction to a glue
point (for example, by activating the [ button), Draw tries to optimize the
length of the connector. For the example above, the connection inside the
circle would change as shown below.
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If the Glue Point Relative button is active (as it is by default), the glue point
will move when you change the size of the object, as shown below.

If the Glue Point Relative button is deactivated, the remaining buttons on
the toolbar, previously grayed out, become active. With these buttons, you
can decide how a glue point will be placed when the size of the object is
changed.

These buttons determine how the horizontal position of a glue point changes
when you resize the object containing the glue point. You can choose
whether the glue point remains at a fixed distance from the left edge of the
object, from a vertical line through the middle, or from the right edge of the
object when you change the size of the object. If the width of the object
becomes less than that distance, the glue point is attached to the object
frame.

The following example shows what happens when an object’s width is
changed, and the glue point is set to be a fixed distance from the left frame.

These buttons determine, in a similar manner, the vertical position of a glue
point when the size of the object is changed.

Adding Text to Connectors

To add text to a connector, double-click the connector. The end and control points
become active, and the familiar flashing text cursor appears, with the cursor position
determined by the most recent setting. The Text pane of the Sidebar appears, and the
Text Formatting toolbar also appears under the menu bar. Use this toolbar to set text
properties, then insert the text directly.

If you draw a connector and then click on it, only the endpoints and control points

become visible. Despite this, a connector has its own object frame—in this case, an
invisible one. You can picture it easily by imagining a rectangle enclosing the start
and end points of the connector (Figure 12).
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Figure 12: Object frame of a connector

When you add text to a connector, the location of the text is relative to this rectangle.
The exact position of the text can be set in the Text dialog (Figure 13). This dialog
appears when you double-click on text and then choose Text from the pop-up menu,
or when you single-click on the connector and select Format > Text from the menu

bar.

Take particular note of the Spacing to borders and Text anchor sections in the Text
dialog. In the Text anchor section, you can see the possible locations for the text. In
the example below, the text is anchored at the top left. In the Spacing to borders
section at the lower left, negative values of spacing will position the text outside the

frame.

Text| Text Animation

Text

[ Adjust to contour

Spacing to borders
Left

Right
Top

Bottom

Text anchor

0.25cm

0.25cm

0.13cm

0.13cm

[ Full width

[ OK H Cancel H Help H Reset l

Figure 13: The Text dialog
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Adjusting Text to Suit the Connecting Line
If you want the text to follow the slope or curve of a line, you need to activate and use
the Fontwork tool. To add this tool to the Draw toolbar:

1) Choose Tools > Customize from the menu bar.

2) On the Toolbars tab, select Drawing from the Toolbars pull-down list. In the
Toolbar content section, click Add.

3) In the Add Commands dialog, select Format from the left-hand list, and select
the command Fontwork. Click Add, then Close to return to the Customize
dialog.

4) In the list of commands under Toolbar Content, move the Fontwork icon ¥ to
the location you want by using the up/down arrows, and then click OK.
To write slanting text, follow these steps:

1) Add the text to the connector as described earlier. The anchor location of the
text is not important at this stage (Figure 14).

2) Select the object with the text (in this case, the connector) and click on the

Fontwork icon i to open the Fontwork dialog (Figure 15).

3) To make the text lie along the inclined line, click the Rotate icon and set the
distance to the line you wish.

Text line

Figure 14: Adding text to an inclined line, Step 1
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Figure 15: Adding text to an inclined line, Step 2

The Fontwork dialog provides many other possibilities for manipulating text. You can,
for example, rotate the text 180 degrees with the Orientation ¥ icon, as done in the

example above, or place the text under the line by assigning a negative value to the
spacing between text and line.

In addition, you can use the Fontwork dialog to generate curved text that follows the
shape of a curved line. Experiment a little to investigate the possibilities.
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