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Chapter 1 
Introducing Apache 

OpenOffice

What Is Apache OpenOffice?

Apache OpenOffice is a freely available, full-featured office productivity suite. Its 
native file format is OpenDocument, an open standard format that is supported by 
several office suites but is not controlled by any one company and has been adopted 
by some governments (e.g., the United Kingdom) as a required file format for 
publishing and accepting documents. Apache OpenOffice can also open and save 
documents in many other formats, including those used by various versions of 
Microsoft Office.

Apache OpenOffice includes the following components.

Writer (word processor)
Writer is a feature-rich tool for creating letters, books, reports, newsletters, 
brochures, and other documents. You can insert graphics and objects from other 
components into Writer documents. Writer can export files to several versions of 
Microsoft Word files, Adobe’s Portable Document Format (PDF), HTML and other 
formats.

Calc (spreadsheet)
Calc has all the advanced analysis, charting, and decision-making features expected 
from a high-end spreadsheet. It includes over 300 functions for financial, statistical, 
and mathematical operations, among others. The Scenario Manager provides “what 
if” analysis. Calc generates 2-D and 3-D charts, which can be integrated into other 
Apache OpenOffice documents. You can also open and work with Microsoft Excel 
workbooks and save them in some Excel formats. Calc can also export spreadsheets 
to PDF and HTML.
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Impress (presentations)
Impress provides all the common multimedia presentation tools, such as special 
effects, animation, and drawing tools. It is integrated with the advanced graphics 
capabilities of Apache OpenOffice’s Draw and Math components. Slide shows can be 
further enhanced with Fontwork’s special effects text, as well as sound and video 
clips. Impress is compatible with Microsoft’s PowerPoint file format and can also save 
your work in numerous graphics formats.

Draw (vector graphics)
Draw is a vector drawing tool that can produce everything from simple diagrams or 
flowcharts to 3-D artwork. Its Smart Connectors feature allows you to define your 
own connection points. You can use Draw to create drawings for use in any of Apache 
OpenOffice’s other components, and you can create your own clip art and add it to 
the Gallery. Draw can import graphics from many common formats and save them in 
over 20 formats, including PNG, HTML, and PDF.

Base (database)
Base provides tools for day-to-day database work within a simple interface. It can 
create and edit forms, reports, queries, tables, views, and relations, so that managing 
a connected database is much the same as in other popular database applications. 
Base provides many features, such as the ability to analyze and edit relationships 
from a diagram view. In its default configuration, Base uses HSQLDB, which is 
included in Apache OpenOffice, as its database engine and stores the database tables 
in the Base document. It can also use dBASE, Microsoft Access, MySQL, Oracle, or 
any ODBC compliant or JDBC compliant database engine and connect to external 
tables. 

Math (formula editor)
Math is Apache OpenOffice’s formula or equation editor. You can use it to create 
complex equations that include symbols or characters not available in standard font 
sets. While it is most commonly used to create formulas in other documents, such as 
Writer and Impress files, Math can also work as a standalone tool. You can save 
formulas in the standard Mathematical Markup Language (MathML) format for 
inclusion in web pages and other documents not created by Apache OpenOffice.

Advantages of Apache OpenOffice

Here are some of the advantages of Apache OpenOffice over proprietary office suites:

• No licensing fees. Apache OpenOffice is free for anyone to use and distribute 
at no cost. There are no hidden charges now or in the future.

• Open source. You can distribute, copy, and modify the software as much as 
you wish, in accordance with the Apache 2 license.

• Cross-platform. Apache OpenOffice runs on several hardware architectures 
and under multiple operating systems, such as Microsoft Windows, macOS, 
and Linux.

• Extensive language support. The user interface for Apache OpenOffice is 
available in several languages, along with spelling, hyphenation, and thesaurus 
dictionaries. It supports bidirectional text and complex text layout for many 
scripts.
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• Consistent user interface. All the components have a similar “look and feel,” 
making them easy to use and master.

• Integration. The components of Apache OpenOffice are well integrated with 
one another.

– All the components share a common spelling checker and other tools, 
which are used consistently across the suite. For example, the drawing 
tools available in Writer are also found in Calc, with similar but enhanced 
versions in Impress and Draw.

– You do not need to know which application was used to create a particular 
file. For example, you can open a Draw file from Writer; it will open 
automatically in Draw.

• Granularity. Usually, if you change an option, it affects all components. 
However, Apache OpenOffice options can be set at a component level or even 
document level.

• File compatibility. In addition to its native OpenDocument formats, Apache 
OpenOffice includes support for opening and saving files in many common 
formats including Microsoft Office (does not include saving in the newer 
formats DOCX, XLSX for example), HTML, XML and PDF (export only).

• No vendor lock-in. Apache OpenOffice uses OpenDocument, an XML 
(eXtensible Markup Language) file format developed as an industry standard 
by OASIS (Organization for the Advancement of Structured Information 
Standards). These files can easily be unzipped and read by any text editor, and 
their framework is open and published.

• You have a voice. Enhancements, software fixes, and release dates are 
community-driven. You can join the community and affect the course of the 
product you use.

Minimum Requirements

Apache OpenOffice 4.1 requires one of the following operating systems:

• Microsoft Windows XP, 2003, 2012, Vista, 7, 8, 8.1, 10 or 11

• GNU/Linux Kernel version 2.6 and glibc 2.5 or higher

• macOS 10.7 (Lion) or higher

For more details, see https://www.openoffice.org/dev_docs/source/sys_reqs_aoo41.html

Some features (wizards, some accessibility features, and the HSQLDB database 
engine) require that a Java Runtime Environment (JRE) be installed on your 
computer. Although Apache OpenOffice will work without Java support, those 
features will not be available. The current versions of Apache OpenOffice work 
reliably with a variety of JREs including Oracle Java, versions 6, 7 and 8, openJDK, 
versions 6, 7 and 8 and AdoptOpenJDK, versions 8 and 11. You should use the most 
recent version of whichever JRE you choose for the best security and reliability.

Note For Microsoft Windows,a 32-bit JRE MUST be installed, even on a 64-
bit machine
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How to Get and Install the Software

You can download the installation package (approximately 150 MB) from the project’s 
website, https://www.openoffice.org/download/index.html. The download process 
automatically redirects to a SourceForge web page which starts the download 
without the need to take any action on that page.
To install Apache OpenOffice, follow the same procedure that you used to install 
other software.

Extensions and Add-Ons

Extensions and add-ons that enhance Apache OpenOffice are collected in the official 
extensions repository, https://extensions.openoffice.org/. Most are free, but some are not. 
See Chapter 11 (Setting up and Customizing Apache OpenOffice) for more 
information.

Starting Apache OpenOffice

In general, you start Apache OpenOffice the same way you start any other program 
on your computer.

On Windows and Linux, entries for Apache OpenOffice and each of its components 
appear in the system menu of your computer. On macOS, only an entry for Apache 
OpenOffice is added to the Applications menu. You can make a desktop icon for 
Apache OpenOffice or a component in the same way you can make a desktop icon for 
any other program; see your operating system’s help for how to do this.

• Clicking on the Apache OpenOffice menu entry, desktop icon, or tile opens the 
Apache OpenOffice Start Center (Figure 13 on page 15) from where you can 
select the individual components. You can also choose to open an existing file 
or use a template.

• On Windows, you can use the Quickstarter (see below).

• You can double-click on the filename of a document with an OpenDocument 
extension such as .odt, .ods, .odp in a file manager such as Windows Explorer, 
Finder on macOS, or Nautilus on Linux. The appropriate component will start, 
and the document will be loaded.

Note for Windows Users
If you have associated Microsoft Office file types with Apache OpenOffice, then when 
you double-click on a *.doc (Word) file, it opens in Writer; *.xls (Excel) files open in 
Calc, and *.ppt (PowerPoint) files open in Impress.

If you did not associate the file types, then when you double-click on a Microsoft 
Word document, it opens in Microsoft Word (if Word is installed on your computer), 
Excel files open in Excel, and PowerPoint files open in PowerPoint.

You can search the Windows help for Default Apps to see how to associate each file 
type with OpenOffice. In addition to associating Microsoft Office file types with 
OpenOffice, it may also be necessary to reestablish the association between 
OpenOffice and its native file formats when a Windows update causes Microsoft 
Office to claim those file types. 

Chapter 1 Introducing Apache OpenOffice | 7

https://extensions.openoffice.org/
https://www.openoffice.org/download/index.html


Using the Quick-Starter Under Windows
The Quick-starter is an icon that is placed in the Windows system tray during system 
startup. It indicates that Apache OpenOffice has been loaded and is ready to use. 
(The Quickstarter shortens the startup time for Apache OpenOffice components by 
about half.) If the Quickstarter is disabled, see “Reactivating the Quick-Starter” if you 
want to enable it.

Using the Quick-Starter Icon
Right-click the Quick-starter icon in the system tray to open a pop-up menu (Figure 1) 
from which you can open a new document, open the Templates and Documents 
dialog, or choose an existing document to open. You can also double-click the 
Quickstarter icon to directly open the Templates and Documents dialog.

Disabling the Quick-Starter
To close the Quickstarter, right-click on the icon in the system tray, and then click 
Exit Quickstarter on the pop-up menu. The next time the computer is restarted, the 
Quick-starter will be loaded again.

To prevent Apache OpenOffice from loading during system startup, deselect the Load 
OpenOffice during system start-up item on the pop-up menu. You might want to 
do this if your computer has insufficient memory, for example.

Reactivating the Quick-Starter
If the Quickstarter has been disabled, you can reactivate it by selecting the Load 
OpenOffice during system start-up checkbox in Tools > Options > OpenOffice 
> Memory.

Using the Quick-Starter in Linux and macOS
Apache OpenOffice under Linux has a Quick-starter that looks and acts like the one 
described above for Windows. (The checkbox on the Memory page is labeled Enable 
systray quickstarter. If you do not have this checkbox, the Quick-starter module is 
not installed on your system.)

macOS provides similar functionality through a pop-up menu from the dock.
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Parts of the Main window

The main window is similar in each component of Apache OpenOffice, although some 
details vary. See the chapters in this book about Writer, Calc, Draw, and Impress for 
descriptions of those details.

Common features include the menu bar, the standard toolbar, and the formatting 
toolbar at the top of the window and the status bar at the bottom.

Menu Bar
The Menu bar is located across the top of the Apache OpenOffice window, just below 
the Title bar. (On macOS it is at the top of the screen in the same location as the 
menu bar for other programs.) When you choose one of the menus listed below, a 
sub-menu drops to show commands.

• File contains commands that apply to the entire document such as Open, Save, 
and Export as PDF.

• Edit contains commands for editing the document such as Undo: xxx (where 
xxx is the command to undo) and Find & Replace. It also contains commands 
to cut, copy, and paste selected parts of your document.

• View contains commands for controlling the display of the document such as 
Zoom and Web Layout.
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• Insert contains commands for inserting elements into your document such as 
Header, Footer, and Picture.

• Format contains commands, such as Styles and Formatting and AutoCorrect, 
for formatting the layout of your document.

• Table shows all commands to insert and edit a table in a text document.

• Tools contains functions such as Spelling and Grammar, Customize, and 
Options.

• Window contains commands for the display window.

• Help contains links to the OpenOffice Help file, What’s This?, and information 
about the program.

Toolbars
Apache OpenOffice has several types of toolbars: docked, floating, and tear-off. 
Docked toolbars can be moved to different locations or made to float, and floating 
toolbars can be docked.

The top docked toolbar is called the Standard toolbar. The Standard toolbar is 
consistent across the OpenOffice applications.

The second toolbar at the top is the Formatting toolbar. It is a context-sensitive bar 
that shows the relevant tools in response to the cursor’s current position or selection. 
For example, when the cursor is on a graphic, the Formatting bar provides tools for 
formatting graphics; when the cursor is in text, the tools are for formatting text.

Displaying or Hiding Toolbars
To display or hide toolbars, choose View > Toolbars, then click on the name of a 
toolbar in the list. An active toolbar shows a check mark beside its name. Tear-off 
toolbars are not listed in the View menu.

Submenus and Tear-Off Toolbars
Toolbar icons with a small triangle to the right will display submenus, tear-off 
toolbars, and other ways of selecting things, depending on the icon.

Figure 3 shows a tear-off toolbar from the Drawing toolbar.

The tear-off toolbars can be floating or docked along an edge of the screen or in one 
of the existing toolbar areas. To move a floating tear-off toolbar, drag it by the title 
bar. See “Moving Toolbars” below.
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Floating Toolbars
Apache OpenOffice includes several additional context-sensitive toolbars, whose 
defaults appear as floating toolbars in response to the cursor’s current position or 
selection. For example, when the cursor is in a table, a floating Table toolbar appears, 
and when the cursor is in a numbered or bullet list, the Bullets and Numbering 
toolbar appears. You can dock these toolbars to the top, bottom, or side of the 
window, if you wish (see “Moving Toolbars” below).

Moving Toolbars
To move a docked toolbar, place the mouse pointer over the toolbar handle (the small 
vertical bar to the left of the toolbar), hold down the left mouse button, drag the 
toolbar to the new location, and then release the mouse button (Figure 4). To move a 
floating toolbar, click on its title bar and drag it to a new location (Figure 5).

 

Figure 4: Moving a docked toolbar

 

 

Docking Floating Windows and Toolbars
Toolbars and some windows, such as the Navigator and the Styles and Formatting 
window, are dock-able. You can move, resize, or dock them to an edge.

To dock a window or toolbar, hold down the Ctrl key and double-click on the frame of 
the floating window (or in a vacant area near the icons at the top of the floating 
window) to dock it in its last position.

Figure 6: Ctrl+click to dock or 
undock  

To undock a window, hold down the Ctrl key and double-click on the frame (or a 
vacant area near the icons at the top) of the docked window.
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Customizing Toolbars
You can customize toolbars in several ways, including choosing which icons are 
visible and locking the position of a docked toolbar. You can also add icons and create 
new toolbars, as described in Chapter 11.

To access a toolbar’s customization options, use the down-arrow at the end of the 
toolbar or on its title bar.

 

To show or hide icons defined for the selected toolbar, choose Visible Buttons from 
the drop-down menu. Visible icons are indicated by an outline around the icon. Click 
on icons to hide or show them on the toolbar.

 

Right-Click (context) Menus
You can quickly access many menu functions by right-clicking on a paragraph, 
graphic, or other object. A context menu will pop up. Often the context menu is the 
fastest and an easier way to reach a function. If you are not sure where a function is 
located in the menus or toolbars, you can frequently find it by right-clicking.

Status Bar
The status bar is located at the bottom of the workspace. It provides information 
about the document and convenient ways to quickly change some features. It is 
similar in Writer, Calc, Impress, and Draw, although each component includes some 
component-specific items.
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Common status bar items are described below.

Page, sheet, or slide number
Shows the current page, sheet, or slide number and the total number of pages, 
sheets, or slides in the document. Double-click on this field to open the Navigator. 
Other uses of this field depend on the component.

Page style or slide design
Shows the current page style or slide design. To edit the current page style or 
slide design, double-click on this field.

Unsaved changes
An asterisk (*) appears here if changes to the document have not been saved.

Digital signature
If the document has been digitally signed, an icon shows here. You can double-
click the icon to view the certificate.

Object information
Displays information relevant to the cursor’s position or the selected element of 
the document. Double-clicking in this area usually opens a relevant dialog.

Zoom slider and percent
To change the view magnification, drag the Zoom slider, or click on the + and — 
signs, or right-click on the zoom level percent to pop up a list of magnification 
values from which to choose. Double-clicking on the zoom level percent opens the 
Zoom & View Layout dialog.

Sidebar
The Sidebar (Figure 11) is located on the right side of the edit views of Writer, Calc, 
Impress, and Draw. It contains one or more decks, based on the current document 
context. Decks are organized into panels. A tab bar on the right side of the sidebar 
allows you to switch between different decks.

All four components contain the Properties, Styles, Gallery, and Navigator decks. 
Some components have additional decks, such as Master Pages, Custom Animation, 
and Slide Transition for Impress and Functions for Calc.

A panel is like a combination of a toolbar and a dialog. For example, you can freely 
mix working on the text in the main edit window and using the Styles panel in the 
sidebar to change text attributes.

Toolbars and Sidebar panels share many functions. For example, the buttons for 
making text bold or italic exist in both the Formatting toolbar and the Properties 
panel.

If the Sidebar is not visible, you can show it by using View > Sidebar on the menu 
bar. To hide the Sidebar, click on the gray Hide button on the left. Click on the same 
button to show the Sidebar again.
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To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the 
Sidebar settings drop-down list at the top of the tab bar (see Figure 11 ). From the 
same list you can choose which items to show in the Sidebar.

Figure 11: Properties panel of Sidebar in Writer

Figure 12: Floating (undocking) or docking the 
Sidebar

Starting a New Document

You can start a new, blank document in Apache OpenOffice in several ways.

When Apache OpenOffice is open, but no document is open (for example if you close 
all the open documents but leave the program running), the Start Center is shown. 
Click one of the icons to open a new document of that type, or click the Templates 
icon to start a new document using a template.
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You can also start a new document in one of the following ways.

• Use File > New and choose the type of document.

• Use the arrow next to the New button on the main toolbar. From the drop-
down menu, select the type of document to be created.

• Press Ctrl+N on the keyboard.

• Use File > Wizards for some special types of documents.

If a document is already open in Apache OpenOffice, the new document opens in a 
new window.

Opening an Existing Document
When no document is open, the Start Center provides an icon for opening an existing 
document or choosing from a list of recently-edited documents.

You can also open an existing document in one of the following ways.

• Choose File > Open.

• Click the Open button on the main toolbar.

• Press Ctrl+O on the keyboard.
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In each case, the Open dialog appears. Select the file you want, and then click Open. 
If a document is already open in Apache OpenOffice, the second document opens in a 
new window.

In the Open dialog, you can reduce the list of files by selecting the type of file you are 
looking for. For example, if you choose Text documents as the file type, you will only 
see documents Writer can open (including .odt, .doc, .txt); if you choose 
Spreadsheets, you will see .ods, .xls, and other files that Calc opens.

You can also open an existing document that is in an OpenDocument format by 
double-clicking on the file’s icon on the desktop or in a file manager such as Windows 
Explorer.

If you have associated Microsoft Office file formats with Apache OpenOffice, you can 
also open these files by double-clicking on them.

Saving a Document

To save a new document, do one of the following:

• Press Ctrl+S.

• Choose File > Save from the menu bar.

• Click the Save button on the main toolbar.

When the Save As dialog appears, enter the file name, verify the file type (if 
applicable), and click Save.

To save an open document with the current file name, choose File > Save. This will 
overwrite the last saved state of the file.

Password Protection

To protect an entire document from being viewable without a password, use the 
option on the Save As dialog to enter a password.

1) On the Save As dialog, select the Save with password option, and then click 
Save. You will receive a prompt (Figure 14).

Figure 14: Entering a password for a document
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2) Type the same password in both fields, and then click OK. If the passwords 
match, the document is saved password protected. If the passwords do not 
match, you receive an error message. Close the message box to return to the 
Set Password dialog and enter the password again.

Caution Apache OpenOffice uses a very strong encryption mechanism that 
makes it almost impossible to recover the contents of a document if 
you lose the password.

Writer and Calc provide a second level of protection, which allows a file to be viewed 
but not changed without a password; that is, the file opens in read-only mode.

To protect a document from being changed:
1) Choose More Options from the Set Password dialog.
2) Enter the password in the Enter password to allow editing field. Repeat the 

password in the Confirm password field. Click OK.

Saving a Document Automatically
You can choose to have Apache OpenOffice save a temporary version of your file 
automatically. This temporary version is stored separately from the original file, and 
it allows AutoRecovery if the program should crash. However, automatic saving does 
not overwrite the last saved state of the file and does not substitute for periodically 
saving your work. To set up automatic file saving:

1) Choose Tools > Options > Load/Save > General.
2) Mark Save AutoRecovery information every, and set the time interval.

Using the Navigator

The Navigator lists objects contained in a document, collected into categories. For 
example, in Writer it shows Headings, Tables, Text frames, Comments, Graphics, 
Bookmarks, and other items, as shown in Figure 15. In Calc it shows Sheets, Range 
Names, Database Ranges, Graphics, Drawing Objects, and other items. In Impress 
and Draw it shows Slides, Pictures, and other items.

To open the Navigator, click its icon  on the sidebar or the Standard toolbar, or 
press F5, or choose View > Navigator on the menu bar. The Sidebar is often the 
most convenient location for the Navigator.
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Figure 15: The Navigator

Click the marker (+ or triangle) by any of the categories to display the list of items in 
that category. 

To hide the list of categories and show only the toolbars at the top, click the List Box 

On/Off icon . Click this icon again to show the list box.

The Navigator provides several convenient ways to move around a document and find 
items in it:

• When a category is showing the list of objects in it, double-click on an object to 
jump directly to that object’s location in the document.

• Objects are easier to find if you have given them names when creating them, 
instead of keeping Apache OpenOffice’s default graphics1, graphics2, Table1, 
Table2, and so on—which may not correspond to the position of the object in 
the document.

• If you only want to see the content in a certain category, highlight the category 

and click the Content View icon . Until you click the icon again, only the 
objects of that category will be displayed.

• Click the Navigation icon  to display the Navigation toolbar (Figure 16). 
Here you can pick one of the categories and use the Previous and Next icons 
to move from one item to the next. This is particularly helpful for finding items 
like bookmarks and indexes, which can be difficult to see.

• The names of the icons (shown in the tooltips) change to match the selected 
category; for example, Next Graphic or Next Bookmark.

• To jump to a specific page in the document, type its page number in the box at 
the top of the Navigator.

A bit of experimentation with the other icons will demonstrate their functions. Some 
component-specific uses are described in the chapters on Writer and the other 
components.
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Figure 16: Navigation toolbar

Using the Open and Save As Dialogs

You can choose whether to use the OpenOffice Open and Save As dialogs or the ones 
provided by your operating system.

To view or change which type of dialog OpenOffice uses:
1) Choose Tools > Options > OpenOffice > General.
2) Select the Use OpenOffice dialogs option.

This section discusses the OpenOffice Open and Save As dialogs. Figure 17 shows the 
Save As dialog; the Open dialog is similar.

Figure 17: The OpenOffice Save As dialog

The three buttons in the top right of the OpenOffice Open and Save As dialogs are, 
from left to right:

• Go Up One Level in the folder (directory) hierarchy. Click and hold this button 
for a second to open a list of higher level folders; to go to one of the folders on 
the list, move the mouse pointer over its name and release the mouse button.

• Create New Folder.
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• Default Directory.

For documents (in OpenDocument format) that have been saved with more than one 
version, use the Version drop-down to select which version you wish to open in read-
only mode. For Microsoft Office documents, only the current version can be opened.

Use the File type field to specify the type of file to be opened or the format of the file 
to be saved.

The Read-only option on the Open dialog opens the file for reading and printing only. 
Consequently, most of the toolbars disappear, and most menu options are disabled. 
An Edit File button is displayed on the Standard toolbar to open the file for editing.

You can open files from the Web by typing a URL in the File name field on the Open 
dialog.

Undoing and Redoing Changes

To undo the most recent change, press Ctrl+Z, or click the Undo icon  on the 
Standard toolbar, or choose Edit > Undo from the menu bar.

The Edit menu shows the latest change that can be undone (see below for an example 
from Writer).

Figure 18: Edit > Undo last action

Click the small triangle to the right of the Undo icon to get a list of all the changes 
that can be undone. You can select multiple changes and undo them at the same time.

Figure 19: List of actions that can be 
undone

After changes have been undone, Redo becomes active. To redo a change, select Edit 
> Redo, or press Ctrl+Y or click on the Redo icon. As with Undo, click on the triangle 
to the right of the arrow to get a list of the changes that can be reapplied.

To modify the number of changes Apache OpenOffice remembers, choose Tools > 
Options > OpenOffice > Memory and in the Undo section change Number of 
steps. Be aware that asking Apache OpenOffice to remember more changes 
consumes more computer memory.
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Reloading a Document

Reloading is useful in two situations.

• You may want to discard all the changes made in an editing session after the 
last document save.

• You may have made some formatting changes that do not show until the 
document has been closed and reopened; reloading has the same result.

To reload a document, go to File > Reload on the Menu bar. If you have made 
changes to a file since the last save, a confirmation dialog will warn you that 
reloading will discard your last changes. Choose whether to save or discard the 
changes.

On reloading the document, the File dialog does not open, because the file is already 
selected.

Closing a Document

To close a document, choose File > Close.

You can also close a document by clicking on the Close icon on the document 
window. This button may look like the X shown in Figure 20. It may be in a different 
location on your operating system.

In Windows and Linux, if more than one OpenOffice window is open, each window 
looks like the sample shown on the left in Figure 20. Closing this window leaves the 
other OpenOffice windows open.

If only one OpenOffice window is open, it looks like the sample shown on the right in 
Figure 20. Notice the small X below the large X. Clicking the small X closes the 
document but leaves OpenOffice open. Clicking the large X closes Apache OpenOffice 
completely.

If the document has not been saved since the last change, a message box is 
displayed. Choose whether to save or discard your changes.

• Save: The document is saved and then closed.

• Discard: The document is closed, and all modifications since the last save are 
lost.

• Cancel: Nothing happens, and you return to the document.

Caution
Not saving your document could result in the loss of recently made 
changes, or worse still, your entire file.

Chapter 1 Introducing Apache OpenOffice | 21



Closing Apache OpenOffice

To close Apache OpenOffice completely, choose File > Exit, or close the last open 
document as described in “Closing a Document” above.

If all the documents have been saved, Apache OpenOffice closes immediately. If any 
documents have been modified but not saved, a warning message appears. Follow the 
procedure in “Closing a Document” to save or discard your changes.
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