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What is mail merge?

What is mail merge?

OpenOffice.org (OOo) Writer provides very useful features to create and print:

• Multiple copies of a document to send to a list of different recipients (form letters)

• Mailing labels

• Envelopes

All these facilities, though different in application, are based around the concept of a 
registered “data source”, from which is derived the variable address information necessary to 
their function.

This chapter describes the entire process. The steps include:

1. How to create and register a data source.

2. How to create and print form letters, mailing labels, and envelopes.

3. Optionally, how to save the output in an editable file instead of printing it directly.

Creating the data source

A data source is a database containing the name and address records (and optionally other 
information) from which a mailing list may be derived. Although you can create and print 
mailing labels and envelopes without using a data source, in most cases using one is the best 
approach. This chapter assumes that you are using a data source.

OOo can access a wide variety of data sources, including spreadsheets, text files and 
databases such as MySQL, Adabas, and ODBC. If the information to be used in the mail 
merge is currently in a format that OOo cannot access directly, you need to convert it, for 
example by exporting it to a comma-separated values (CSV) file.

For the following example we use a spreadsheet with the following column (field) headers: 
Title, First name, Last name, Address, State/County, Country, Post Code, Sex, Points. A 
sample data source is shown in Figure 1.

Figure 1: Spreadsheet data source
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Registering a data source

Registering a data source

For a data source to be directly accessible from within an OOo document, it must first be 
registered as described below.

1) Click File > Wizards > Address Data Source.

Figure 2: Starting the Address Data Source wizard

2) Select the appropriate type of external address book (in this case, Other external data 
source). Click Next.
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Registering a data source

Figure 3: Select type of external address book

3) On the next page of the Wizard (Figure 4), click Settings.

Figure 4: Starting the Settings part of the Wizard
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Registering a data source

4) In the Data Source Properties dialog (Figure 5), select the Database type (in this case, 
Spreadsheet). Click Next.

Figure 5: Selecting the database type

5) In the next dialog (Figure 6), click Browse and navigate to the spreadsheet that 
contains the address information. Select the spreadsheet and click Open to return to 
this dialog. At this time you may wish to test that the connection has been correctly 
established by clicking on the Test Connection button.

Figure 6: Selecting the spreadsheet document

6) Click Finish.

7) In the following dialog (Figure 7), click Next. (Do not click Field Assignment.)
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Registering a data source

Figure 7: Because this is a spreadsheet, do not click Field Assignment.

8) Name the file in the Location field. The default is ...\Addresses.odb; but you may 
replace Addresses with another name if you wish. You may also change the name in 
the “Address book name” field. In our example, the name “Points” was used for both.

Figure 8: Name the .odb file and the address book. 

9) Click Finish. The data source is now registered.
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Creating a form letter

Creating a form letter

Example: Sending a letter to your customer base

A mail order company organized a campaign to assign credit points to their 
customers according to the quantity of goods they buy during one year.

At the end of the year, they want to send a letter to each customer to show the total of 
credit points collected.

You can create a form letter manually, which is the simplest and most comprehensive method 
and is described here, or you can use the Mail Merge wizard as described in “Using the Mail
Merge Wizard to create a form letter” starting on page 21. If you elect to use the wizard, pay 
close attention to its current (OOo V2.3) limitations, as identified within its description.

1) Create a new text document: File > New > Text Document, or open a pre-existing 
form letter with File Open.

2) Display the registered data sources: View > Data sources (or press F4).

3) Find the data source that you wish to use for the form letter, in this case Points. 
Expand the Points and Tables folders, and select Sheet1. The address data file is 
displayed. (See Figure 9.)

Figure 9: Selecting the data source.

4) Now create or modify the form letter by typing in text, punctuation, line breaks, and so 
on that will be present in all of the letters, and adding fields where needed by clicking 
in the field heading and dragging to the appropriate point in the letter. (See Figure 10.)

Note that address lines should be in individual paragraphs, not separated by line 
breaks as might seem preferable. The reason for this will be made clear in the next 
paragraph.
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Creating a form letter

Figure 10: Dragging fields to the body of the form letter

5) Continue until you have composed the entire document. (See Figure 11 for an 
example.) At this time you may wish to consider suppressing any blank lines that may 
appear in the resulting letters. If not, skip ahead to Step 7.

Figure 11: The completed form letter
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Creating a form letter

6) To suppress blank lines:

a) Click at the end of the first paragraph to be suppressed and then select 
Insert > Fields > Other. 

b) Select the Functions tab and then click on Hidden Paragraph in the Type column.

c)  Now click in the Condition box and enter the details of the condition that defines 
a blank address field. It has the general form of:
![Database.Table.Database field]
where the ‘!’ (NOT) character indicates the negative case and the square brackets 
delineate the condition.

For example, in our Points database the condition to test if the Last Name field is 
empty would be:
![Points.Sheet1.Last Name] as illustrated in Figure 18

d) To test for multiple conditions use the operators AND and/or OR between the 
conditional statements, for example:
![Points.Sheet1.Title]AND![Points.Sheet1.Last Name].

e) Click Insert, but do not close the dialog until all lines have been amended.

7) The document is now ready to be printed. Click File > Print and respond with Yes in 
the resulting dialog.

Figure 12: Mail Merge advisory dialog

8) In the Mail Merge dialog (Figure 13), you can choose to print all records or selected 
records. To select records to be printed, use Ctrl+click to select individual records. To 
select a block of records, select the first record in the block, scroll to the last record in 
the block, and Shift+click on the last record.
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Creating a form letter

Figure 13: The Mail Merge dialog

9) Click OK to send the letters directly to the printer.

If you prefer to save the letters to a file, perhaps to allow proofreading or some later 
editing such as changing the typeface or paragraph format, then you should select File 
in the output section of the Mail Merge dialog, instead of using the default Printer 
selection. This changes the dialog to display the Save merged document section, where 
Save as single document is pre-selected. You can choose to save each letter as a 
single, individual document, if preferred.

In this case, clicking OK brings up the Save as dialog (Figure 14), where a file name 
can be entered for the saved letters. They will be saved consecutively in the single 
document, or numbered consecutively in individual files if saved as single documents.

If you have not saved the original, prototype form letter document (template) 
previously, then you will be prompted to do so now by another Save as dialog. This 
could greatly simplify the creation of other form letters in the future and is highly 
recommended.
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Creating a form letter

Figure 14: Mail Merge Save as dialog

Printing mailing labels

Before beginning this process, note the brand and type of labels you intend to use.

To print mailing labels:

1) Click File > New > Labels.

2) On the Options tab, ensure that the Synchronise contents checkbox is selected.

3) On the Labels tab (Figure 15), select the Database and Table. Select the Brand of 
labels to be used, and then select the Type of label.

TIP If the type of label you wish to use is not on the list, you need to use the Format tab 
to define a new Brand and Type. This is beyond the scope of this document, but is 
relatively simple to implement, given knowledge of the dimensions of the label .
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Printing mailing labels

Figure 15: Select Database, Table, label Brand, and label Type.

4) Click the dropdown arrow under Database field. Select the first field to be used in the 
label (in this example, Title). Click the left arrow button to move this field to the 
Label text area (Figure 16).

Figure 16: Move fields from Database field list to Label text area.

5) Continue adding fields and inserting desired punctuation, spaces, and line breaks until 
the label is composed. Figure 17 shows the completed label.
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Printing mailing labels

Figure 17: The completed label.

6) Click New Document. You now have a new, single-page document containing a series 
of frames, one for each label of the selected type and filled with the data source 
address fields that you selected. Quite often some of the fields in your address data 
source will be unused, leading to blank lines in your labels. If this is not important, 
you can skip the next few paragraphs and go straight to Step 7, otherwise continue as 
described here.

a) First ensure that the label frames are showing the field contents (data source 
headings), rather than their underlying field names. If this is not the case, then 
either press Ctrl+F9 or select View>Field Names to toggle the view.

b) Next, ensure that you can see non-printing characters, such as paragraph marks, 
line breaks and so on. If these are not already visible, select 
View > Nonprinting Characters from the menu bar, or press Ctrl+F10, or click 
on the paragraph icon  in the Standard toolbar.

You will now see that address field separation is created by line breaks , rather 
than paragraphs . As the suppression of blank address fields depends on hiding 
paragraphs, not lines, you need to replace line breaks with paragraphs as follows.

c) Click in the first label, at the end of the first data source address field. Press Delete 
to remove the new line and then press Return (or the Enter key) to insert a 
paragraph. Repeat this action for each data source address field.
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Printing mailing labels

If the line spacing in the first label is not satisfactory, you may wish to correct this 
before proceeding, by modifying the paragraph style associated with the address. 
Unless you have changed it, the address uses the Default style.

Caution The objective of step c) is to replace all line breaks at the end of data source address 
fields with paragraphs. Sometimes the address data field may be longer than the 
width of the label and will wrap to the next physical line: make sure that you are not 
misled by this into deleting and replacing anything other than line break characters.

d) Click again at the end of the first paragraph to be suppressed and then select 
Insert > Fields > Other. Select the Functions tab and then click on Hidden 
Paragraph in the Type column. Now click in the Condition box and enter the 
details of the condition that defines a blank address field. It has the general form 
of:
![Database.Table.Database field]
where the ‘!’ (NOT) character indicates the negative case and the square brackets 
delineate the condition.

For example, in our Points database the condition to test if the Last Name field is 
empty would be ![Points.Sheet1.Last Name] as illustrated in Figure 18.

To test for multiple conditions, use the operators AND and/or OR between the 
conditional statements, for example:
![Points.Sheet1.Title]AND![Points.Sheet1.Last Name].

Click Insert, but do not close the dialog until all lines have been amended.
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Printing mailing labels

Figure 18: Hidden paragraph insertion

e) Repeat for each paragraph to be conditionally suppressed, remembering to advance 
the cursor to the end of the line in question before changing the last element of the 
condition and Inserting the result.

Caution The last paragraph of the label address block ends with a special field, 
Next record:Database.Table (Next record:Points.Sheet1 in our example), and the 
Hidden paragraph field MUST be inserted before this field. This can generally be 
accomplished by clicking at the end of the paragraph and then using the Left Arrow 
key once to skip back over it.

A clue that you omitted this action is the observation that some records have been 
skipped and are missing from the final output.

f) Remembering that we selected Synchronise 
contents earlier, you should now be able to see a 
small window containing a button labelled 
Synchronise Labels. Click on this button and 
the hidden paragraph fields are propagated to all the labels in your document.

You now have a template suitable for future use with the same data source and 
type of label. If you wish to save it, use either File > Templates > Save as, or 
save it as an Open Document Text Template (.ott) into the private template 
directory (folder) that you have previously defined in 
Tools > Options > OpenOffice.org > Paths > Templates.
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Printing mailing labels

7) Click File > Print. The following dialog appears. Click Yes.

Figure 19: Mail Merge advisory dialog

8) In the Mail Merge dialog (Figure 20), you can choose to print all records or selected 
records. To select records to be printed, use Ctrl+click to select individual records. To 
select a block of records, select the first record in the block, scroll to the last record in 
the block, and Shift+click on the last record.

Figure 20: Mail Merge dialog

9) Click OK to send the labels directly to the printer.

If you prefer to save the labels to a file, perhaps to allow some later editing such as 
changing the typeface or paragraph format, then you should select File in the output 
section of the Mail Merge dialog, rather than using the default Printer selection. This 
changes the dialog to highlight the Save merged document section, where Save as 
single document is pre-selected.

In this case, clicking OK brings up the Save as dialog shown in Figure 14, where a file 
name can be entered for the saved labels.

If you did not save the prototype label fields document (template) in step 6f, then you 
are prompted to do so now by another Save as dialog.

In either case, whether printing or saving to file, despite there apparently being only one page 
of labels, the printed or saved output will be expanded to include all of the selected records 
from the data source.
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Printing mailing labels

Editing a saved file of mailing labels
To edit a saved file of mailing labels, open the saved label 
file in the normal way. You will be prompted as to whether 
you wish to update all links. Choose No for the following 
reason: The first label on the page is termed the “Master 
Label” and all other labels are linked to it: if you update the 
links then all labels will end up containing the same data, 
which may not be what you want.

You can edit individual records in the normal way, by 
highlighting and changing the font name, for example.

However, you cannot edit all labels globally (for example, to 
change the font name for all records) by the technique of 
selecting the entire document. To achieve this result you have to 
edit the paragraph style associated with the label records as 
follows:

1) Right-click any correctly spelled word in a label record. 
Select Edit Paragraph Style from the pop-up menu. 
(Note: If you click on a misspelled word, a different menu 
appears.)

2) Then from the Paragraph Style dialog, you can make 
changes to the font name, the font size, the indents, and 
other attributes.

Printing envelopes

Instead of printing mailing labels, you may wish to print directly onto envelopes. There are 
two basic ways to create envelopes, one where the envelope is embedded within a letter, 
generally as the first page (Insert in the Envelope dialog), and another where the envelope is 
an independent document (New Doc. in the dialog). In each case the addressing data may be 
manually entered, for example by copying and pasting from the letter with which it is 
associated, or it may originate within an address data source.

This section assumes the use of an address data source and, for convenience, a free-standing 
envelope.

The production of envelopes involves two steps, set-up and printing, as described in this 
section.

Setting up envelopes for printing
1) Click Insert > Envelope from the menu bar.
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Printing envelopes

2) In the Envelope dialog, select the Format tab (Figure 21), where you can select the 
envelope format to use. You can then arrange the layout of the envelope to suit your 
requirements, together with the character and paragraph attributes to be used in the 
Sender and Addressee areas. These attributes are accessed using the Edit buttons to 
the right of the dialog, next to the word Format.

Tip At this stage it is not possible to vary the dimensions of the frames that will hold the 
Sender and Addressee information, but once the envelope has been created this will 
become possible and you may wish to make some cosmetic adjustments.

Figure 21: Envelope formatting dialog

3) The next step is to select the Printer tab (Figure 22), from where you may choose the 
printer you intend to use, its setup—for example, specification of the tray holding 
envelopes--and other printer-related options such as envelope orientation and shifting. 
You may need to experiment with these settings to achieve the best results with your 
printer.

4) You now have the choice of creating the Addressee fields by dragging and dropping 
from the data source headings (as described in “Creating a form letter” on page 6, and 
in particular in Figure 10) or using the facilities of the Envelope tab. 

If you prefer dragging and dropping, than click New Doc., drag your data source 
headings into the Addressee area on your new envelope and skip to step 7), otherwise 
continue with steps 5 and 6.
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Printing envelopes

Figure 22: Choosing printer options for an envelope

5) Select the Envelope tab (Figure 23). Verify, add, or edit the information in the 
Addressee and Sender boxes (Sender is the “from” on the envelope). You can use the 
right-hand dropdown lists to select the database and table from which you can access 
the Addressee information, in a similar fashion to that described for “Printing mailing
labels”, paragraphs 3, 4 and 5 on page 10. The similarity of the method with Figure
16 and Figure 17 will be clear.

6) When you have finished formatting, click either the New Doc. or Insert button to 
finish. As might be expected, New Doc creates only the envelope template in a new 
document, whereas Insert inserts the envelope into your current document as page 1.

If you don’t want to proceed with this envelope, click Cancel or press the Esc key. 
You can also click Reset to remove your changes and return to the original settings 
extant when the dialog opened.
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Printing envelopes

Figure 23: Choosing addressee and sender information for envelopes

7) Quite often some of the fields in your address data source will be unused, leading to 
blank lines in your envelope Addressee area. If this is not important, you can skip the 
next few paragraphs and go straight to “Merging and printing the envelopes” on page 
20, otherwise continue as described here.

Tip The following procedure is very similar to that used for a similar purpose in the 
section on printing mailing labels. It is reproduced here for purposes of clarity.

a) First ensure that the envelope is showing the field contents (data source headings), 
rather than their underlying field names. If this is not the case, then either press 
Ctrl+F9 or select View > Field Names to toggle the view.

b) Next, ensure that you can see non-printing characters, such as paragraph marks, 
line breaks and so on. If these are not already visible, select 
View > Nonprinting Characters from the menu bar, or press Ctrl+F10, or click 
on the large paragraph icon  in the Standard toolbar.

You will now see that address field separation is created by line breaks , rather 
than paragraphs . As the suppression of blank address fields depends on hiding 
paragraphs, not lines, you need to replace line breaks with paragraphs as follows.

c) Click at the end of the first data source address field. Press Delete to remove the 
new line and then press Return (or the Enter key) to insert a paragraph. Repeat this 
action for each data source address field.
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Printing envelopes

If the line spacing in the Addressee area is not satisfactory, you may wish to 
correct this before proceeding, by modifying the paragraph style associated with 
the address. Unless you have changed it, the address uses the Default style.

Caution The objective of c) above is to replace all line breaks at the end of data source 
address fields with paragraphs. 

d) Click again at the end of the first paragraph to be suppressed and then select 
Insert > Fields > Other. Select the Functions tab and then click on Hidden 
Paragraph in the Type column. Now click in the Condition box and enter the 
details of the condition that defines a blank address field. It has the general form 
of:
![Database.Table.Database field]
where the ‘!’ (NOT) character indicates the negative case and the square brackets 
delineate the condition.

For example, in our Points database the condition to test if the Last Name field is 
empty would be: ![Points.Sheet1.Last Name] as illustrated in Figure 18.

To test for multiple conditions, use the operators AND and/or OR between the 
conditional statements, for example:
![Points.Sheet1.Title]AND![Points.Sheet1.Last Name].

Click Insert, but do not close the dialog until all lines have been amended.

e) Repeat for each paragraph to be conditionally suppressed, remembering to 
advance the cursor to the end of the line in question before changing the last 
element of the condition and Inserting the result.

Merging and printing the envelopes
To merge addresses and print the envelopes:

1) Choose File > Print. The following dialog appears. Click Yes.

Figure 24: Confirmation dialog for merging database fields

2) The Mail Merge dialog (Figure 25) appears. As with form letters and mailing labels, 
you can choose to print envelopes for one, several or all address records in the 
database. 
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Printing envelopes

3) Make your selections and then click OK to print direct to the printer. If you wish to 
check the envelopes before printing them, see Step 9) of “Creating a form letter” on 
page 9 for instructions.

Figure 25: Choosing records to use when printing envelopes

Using the Mail Merge Wizard to create a form 
letter

The recommended way to create a form letter is the manual method described in “Creating a
form letter“ on page 6. If however you prefer to use the Mail Merge wizard, the technique is 
described below.

Before starting you should note the following limitations, current in OOo V2.3:

• In Step 4 creating the salutation will only allow the sex-related Mr. and Mrs. It makes 
no allowance for Miss, nor does it permit sexless addressing such as Dr., or The Right 
Honourable.

• Still in Step 4, it is possible to bodge something like Dr. Crippen, but only by creating 
an impossible trigger for recognising a female recipient, such that the merge defaults 
to male. Of course one cannot have a prefix such as ‘Dear’ in this case and it has to be 
manually entered in Step 6.

• Again in Step 4, the General salutation is not editable and the default values are 
somewhat limited.

• In Step 5 the layout is idiosyncratic, with paragraph marks all over the place so as to 
space the address block frame and salutation. To create a professional looking 
document will require significant editing.
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Using the Mail Merge Wizard to create a form letter

If the above limitations are not a hindrance to you, then open a new document with 
File > New > Text Document and start the Mail Merge wizard using 
Tools > Mail Merge Wizard. The wizard opens, as shown in Figure 26.

Step 1: Select starting document
The wizard gives various options to select your starting document:

• Use the current document.

• Create a new document.

• Use a template.

• Use an existing document.

For the purposes of this description we assume that you opened a new text document. This 
will ensure that all the steps in the wizard are fully explored, although with experience you 
may find it more practical to use a draft you prepared earlier, which will allow skipping some 
steps.

Select Use the current document and click Next.

Figure 26:  Select starting document
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Using the Mail Merge Wizard to create a form letter

Step 2: Select document type
The wizard can produce letters or, if a Java Mail connection exists, email messages. You can 
see these options in Figure 27. In this example, we are producing a letter. Select Letter and 
click Next.

Figure 27:  Choose document type

Step 3: Insert address block
This is the most complex step in the wizard. In this step (Figure 28) you will do three things:

1) Tell the wizard which data source to use. The data source must be an existing file; in 
this example it is the “Points” spreadsheet created earlier. 

2) Select the address block to use in the document. This means choosing which fields 
appear (for example, whether the country is included) and how they look.

3) Make sure that the fields all match correctly. This is very important. For example, the 
wizard has a field called <Last Name>. If your spreadsheet has a column called 
“Surname”, you need to tell the wizard that <Last Name> and “Surname” are 
equivalent. This is described in “Matching the fields” on page 27.
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Using the Mail Merge Wizard to create a form letter

Figure 28: Insert address block

Selecting the data source (address list)

1) If the current address list, identified beneath the “Select Different Address List...” 
button in section 1, is not the one you wish to use click the button to open the Select 
Address List dialog (Figure 29) for choosing a data source.

2) If you have not already created the address list, you may click Create to do so now. 
This step will allow you to create a CSV (Comma Separated Values) file with a new 
list of address records.

If you already have an address list, as we have in the “Points” spreadsheet example, 
but which is not the one you wish to use, click Add and select the file in which it 
resides.

In each of the above cases a new data source will be created and registered.
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Using the Mail Merge Wizard to create a form letter

Figure 29: Select address list dialog

3) Select the address list and click OK to return to step 3 of the wizard. For this example, 
the preceding steps are all you need to do. The wizard can also exclude certain records; 
click Filter to choose them. 

Selecting the address block

1) In step 3 of the wizard (shown in Figure 28), look at section 2. This is where you 
select the address block to appear on the letter, and define its appearance and the fields 
it contains. The main page gives two examples. If neither of those is exactly what you 
want, click More to see more choices, in the Select Address Block dialog (shown in 
Figure 30).

2) The Select Address Block dialog offers six choices for the format of the address block 
(scroll down to see the last two choices). You can also optionally include or exclude 
the country (for example, only include the country if it is not England). The six 
formats provided are relatively common, but they might not exactly match your 
preference. If this is the case, select the address block that is closest to what you want 
and click Edit, which opens the New Address Block dialog.
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Using the Mail Merge Wizard to create a form letter

Figure 30: Select address block

3) In the New Address Block dialog (Figure 31), you can add or delete address elements 
using the arrow buttons on the left. To move elements around, use the arrow buttons 
on the right. For example, to add an extra space between first and last names in Figure
31, click <Last Name> and then click the right arrow button.

Figure 31: New address block
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Using the Mail Merge Wizard to create a form letter

Matching the fields

Finally, it is time to match the wizard’s fields with the spreadsheet fields, so that items like 
<Last Name> and “Surname” match correctly.

1) Look at section 3 of step 3 of the wizard (shown in Figure 28 on page 24). The box at 
the bottom displays one record at a time, using the address block format you selected. 
Use the right and left arrow buttons below that address box to step through the 
addresses, checking that they display correctly. Do not assume that all the records 
display correctly, just because one or two do. Check them all if you can, or at least a 
good proportion.

2) If the addresses do not display correctly (and they probably will not right away), click 
Match Fields. The Match Fields dialog opens, as shown in Figure 32.

Figure 32: Match fields dialog

The Match Fields dialog has three columns.

• Address Elements are the terms the wizard uses for each field, such as <First 
Name> and <Last Name>.

• The Matches to Field column allows you to select, for each address element, 
the field from your data source that matches it.

• The Preview column shows what will be shown for this field from the selected 
address block, so you can double-check that the match is correct.
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3) When you have matched all the fields, click OK to return to step 3 of the wizard. Now, 
when you use the arrow buttons to look at all the addresses, they should all look 
correct. If not, go back and change anything you’re not happy with, before clicking 
Next to move to step 4.

Note that you will not be able to continue until you have correctly matched all the 
fields in your chosen address block. If you see <not available> in a field position it 
indicates that the field in question is not correctly matched.

Step 4: Create salutation
The salutation is the initial greeting, for example, Dear Mr Jones. In step 4, select the 
salutation that will appear in the letter.

Figure 33: Create a salutation

You can use a different greeting for men and women. To do this, Writer must have some way 
of knowing whether a person is male or female. In our spreadsheet we had a column called 
Sex. In the section Address list field indicating a female recipient, set the field name to Sex 
and the field value to F. The male salutation is then printed for all men and the female 
salutation for all women.

Note You do not need to tell OOo who is a male, because it assumes that all non-female 
records are males.
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If you do not select Insert Personalized Salutation, you can use a more general salutation 
without referring to the recipient directly, such as “To whom it may concern”.

As in step 3, step 4 of the wizard has a preview pane at the bottom. You should check more 
than one record to ensure that other records look the way you expect.

Step 5: Adjust layout
In step 5, you can adjust the position of the address block and salutation on the page. You can 
place the address block anywhere on the page. The salutation is always on the left, but you 
can move it up and down the page. Use the buttons shown in Figure 34 to move the elements.

A point to note here is that the address block positional dimensions are shown in the Metric 
system, irrespective of the chosen measurement system in the rest of OOo. This is a reported 
error in V2.3.

Figure 34: Adjust layout
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Step 6: Edit document and insert extra fields
In step 6 you have another opportunity to exclude particular recipients from the mail merge, 
as shown in Figure 35.

Figure 35: Edit document

You can also edit the body of the document. If you started with a blank document, you can 
write the whole letter in this step. Click Edit Document to shrink the wizard to a small 
window (Figure 36) so you can easily edit the letter.

Figure 36: Minimized mail merge wizard

You need to perform another important task in this step. The wizard only inserts information 
from the name and address fields, but you may wish to add additional data. In our example, 
we want to tell each person how many points they had accumulated during the year; that 
information is in the spreadsheet. 
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To do this:

1) Click Edit Document in step 6 of the wizard.

2) Select Insert > Fields > Other. The Fields dialog opens, as shown in Figure 37.

Figure 37: Insert mail merge fields dialog

3) Click the Database tab.

4) On the left hand side, select Mail merge fields.

5) Under Database selection find your data source (in this example, it is a spreadsheet). 
Expand it to see the fields.

6) Click the field you want to insert, then click Insert to insert the field.

You can insert any number of fields any number of times into your mail merge 
document.

7) Click Close when you are done.

Note The Database selection lists the data source you selected in step 3. All the 
information you need for the letter must be contained in that data source.
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Step 7: Personalize documents
In step 7, OOo creates all your letters, one per recipient.

Clicking the Edit individual Document button here is similar to step 6. The difference is 
that you now edit a long file containing all of the letters, so you can make changes to a 
particular letter to one person. In this step of the Mail Merge wizard (Figure 38), click Find 
to open a dialog that allows searches within the document, perhaps for an individual 
addressee.

Figure 38: Personalize document

As with step 6, when editing the document, the wizard shrinks to small window. Click on this 
window (see Figure 36 on page 30) to expand the wizard to its full size.
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Step 8: Save, print or send
You have now completed the mail merge process. The last step is to do something with it. In 
step 8, you can save the original sample letter, save the merged document, print the letters 
right away or, if you created email messages, send them.

Figure 39: Save,print or send

You probably want to save the starting (prototype) document and the merged document. To 
do this, select Save starting document  to reveal the Save starting document section 
containing the Save starting document button. This button will be active only if the 
document has not already been saved. Clicking on this button brings up the standard Save as 
dialog. Once you have named and saved the document you return to the Step 8 dialog as 
shown in Figure 40.

The merged document can now be saved by selection of Save merged document. This will 
reveal the Save merged document settings section, from which you can select to save either 
as one large file containing all the individual, generated letters or as a separate file for each 
letter.

When you have saved the merged document, you can print the final letters now or later; and 
you can still manually check and edit the letters if necessary. If you elect to print at this stage, 
the dialog shown in Figure 41 appears; it should be self-explanatory.
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Figure 40: Step 8: Save, print or send

Figure 41: Printing the merged document
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