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Printing

Printing

OpenOffice.org Calc offers a powerful and highly configurable printing system. You can 
select many different details to print or not to print. You can choose the order the sheets will 
print in, the size of the sheets, and particular rows or columns to be printed on all sheets,and 
the print range.

Printing a spreadsheet 
To print a spreadsheet either to a printer or a file, choose File > Print. 

Use the Print dialog (Figure 1) to change printer settings and quickly set what to print: the 
whole document, specific sheets or a group of selected cells. You can also set the number of 
copies, and whether to collate the copies, in this dialog. 

Click OK to start printing.

Figure 1. The Print dialog

Print options
You can set printer options for the current document only or for all spreadsheets. To select 
options for the current document, on the Print dialog, click the Options button in the bottom 
left. To set print options permanently, go to Tools > Options > OpenOffice.org Calc > 
Print. The dialog boxes for both are very similar. See Figure 2.

Chapter Title 1



Printing

Selecting sheets to print
You can select one or more sheets for printing. This can be useful if you have a large 
spreadsheet with multiple sheets and only want a certain sheet to print. An example would be 
an accountant recording costs over time where there was one sheet for each month. If only the 
November sheet were to be printed, this is the procedure to follow.

1) Select the sheets to be printed. (For multiple sheets, hold down the Control key as you 
click on each sheet tab.)

2) Go to File > Print and select Options.

Note The Options button is different from the Properties button. Properties deals with 
the settings of the printer, whereas Options deals with OOo’s settings.

3) Check the Print only selected sheets checkbox.

4) Click OK.

Figure 2. Printer Options dialog

Details, order, and scale

Details

In OOo Calc you can specify certain details to print or not to print. Those details include:

• Row and column headers

• Sheet grid

• Notes
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Printing

• Objects and graphics

• Charts

• Drawing objects

• Formulas

To select the details to be printed:

1) Choose Format > Page.

2) Select the Sheet tab (Figure 3).

3) In the Print area, mark the details to be printed and click OK.

Note Remember that since the print detail options are a part of the page’s properties, they are 
also a part of the page style’s properties. Therefore, different page styles can be set up 
to quickly change the print properties of the sheets in the  spreadsheet.

Figure 3. The Sheet tab of the Page Style dialog

Page Order

Set the order in which pages print on a sheet of paper. This is especially useful in a large 
document. For example, controlling the print order can save time if you have to collate the 
document a certain way.

Chapter Title 3



Printing

Select Format > Page from the main menu. The selection for page order is made in the Sheet 
tab. Where a sheet prints to more than one page of paper, it can be printed either by column, 
where the first column of pages prints, and then the second column and so on, or by row as 
shown in the graphic on the top right of the page order dialog in Figure 3.

Scale

Use the scale features to control the number of pages the data will print on. This can be useful 
if a large amount of data needs to be printed smaller, or. if the reader has poor eyesight text 
can be enlarged when it prints.

• Reduce/Enlarge printout – scale the data in the printout either larger or smaller. For 
example if a sheet would normally print out as four pages (two high and two wide), a 
scaling of 50% would print as one page (both width and height are halved).

• Fit print range(s) on number of pages - define exactly how many pages the printout 
will take up. This option will only reduce a printout, it will not enlarge it. To enlarge a 
printout, the reduce/enlarge option must be used.

• Fit print range(s) to width/height – define how high and wide the printout will be, in 
pages.

Adjusting the print range

Printing rows or columns on every page
If a sheet will be printed on multiple pages, you can set up certain rows or columns to repeat 
on each printed page.

As an example, if the top two rows of the sheet as well as column A need to be printed on all 
pages, do the following:

1) Choose Format > Print Ranges > Edit.

2) The Edit Print Ranges dialog (Figure 6) appears. Click on - none - to the left of the 
Rows to repeat area, and change it to - user defined -.

3) In the text entry box in the center, type in the rows to repeat. For example, to repeat 
rows one and two, type $1:$2.

4) Columns can also repeat; click on - none - to the left of the Columns to repeat area, 
and change it to - user defined -..

5) In the text entry box in the center, type in the columns to repeat. For example, to repeat 
column A, type $A.
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Adjusting the print range

Figure 4: Edit Print Ranges dialog

6) Click OK.

Note You do not need to select the entire range of the rows to be repeated. Just selecting one 
cell in each row will work.

Defining a print range
Use this option to modify or set a defined print range. This could be useful if, in a large 
spreadsheet, you need to print only a specific area of data. 

To define a print range:

1) Highlight the range of cells that comprise the print range.

2) Choose Format > Print Ranges > Define.

The page break lines will display on screen.

Note You can check the print range by using File > Page Preview. OOo will only display the 
cells in the print range.

Adding to the print range
After defining a print range, you can add more cells to it. This allows multiple, non-
contiguous areas of the same sheet to be printed, while not printing the whole sheet. Once 
you have defined a print range:

1) Highlight the range of cells to be added to the print range.

2) Choose Format > Print Ranges > Add.

This will add the extra cells to the print range.

Chapter Title 5

Click to shrink dialog



Adjusting the print range

The page break lines will no longer show up on the screen.

Note The additional print range will print as a separate page, even if both ranges are on the 
same sheet.

Removing a print range
It may become necessary to remove a defined print range, for example if the whole sheet 
needs to printed at a later time. 

To remove the print range, choose Format > Print Ranges > Clear.

This will remove all defined print ranges on the sheet.

After the print range is removed, the default page break lines will appear on the screen

Editing a print range
At any time, the print range can be directly edited with Format > Print Ranges > Edit. If 
you have already selected a print range, you'll see something like Figure 5.

Figure 5: Edit Print Ranges dialog

In this example, three rectangles are selected, each separated by a semicolon. The first is 
bounded by cell A3 ($A$3) in the top left and cell C9 ($C$9) in the bottom right corners. 
Clicking anywhere in the text entry box will show the currently selected print range on the 
screen, with each rectangle in a different color as in Figure 6.

After making any changes, click the shrink icon to the right of the text entry box (see Figure
4) to redisplay the rectangles with their new values. 

Click the right-hand icon (a window with an arrow pointing down) to re-expand the dialog 
box.
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Adjusting the print range

Figure 6: Edit print range

Defining a custom print range
In addition to highlighting a print range for each print job, you can define a range of cells to 
be used repeatedly. This may be useful, for example, if there are different areas of a large 
spreadsheet that need to be printed for different reports. Several different print ranges can be 
defined to meet this need.

1) To define a print range, use the same procedure as labeling an area of the sheet. 
Highlight the cells you want to define as a print range and select Insert > Names > 
Define. (The cells can be highlighted after opening the Define Names dialog as well.)

2) On the Define Names dialog (Figure 7), create a name for the range and enter it into 
the text box.

3) Click the More button and then select the Print range checkbox.

4) To include more than one group of cells in the selection, type in the additional ranges. 
For example, to select the rectangle with A3 as the top left cell and F20 as the bottom 
right cell, enter ;$A$3:$F$20 or ;A3:F20 (both work and are equivalent) after the 
initial selection. Make sure that each group of cells is separated with a semicolon. 

5) Click OK.

Note The name of your range cannot contain any spaces.
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Adjusting the print range

Figure 7: Define Names dialog

To print this range:

1) Go to Format > Print Ranges > Edit.

The previously defined area now appears in the drop-down box under Print range.

2) Select the defined print range and click OK.

This method can be useful to quickly change the print range without highlighting a large area 
of cells every time.

Page breaks

While defining a print range can be a powerful tool, it may sometimes be necessary to 
manually tweak Calc’s printout. To do this, you can use a manual break. A manual break 
helps to ensure that your data prints properly. You can insert a horizontal page break above, 
or a vertical page break to the left of, the active cell.

Inserting a page break
To insert a page break:

1) Navigate to the cell where the page break will begin.

2) Select Insert > Manual Break.

3) Select Row Break or Column Break depending on your need.

The break is now set.
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Row break

Selecting Row Break will create a page break above the selected cell. For instance if the 
active cell is H15, then the break will be created between rows 14 and 15.

Column break

Selecting Column Break will create a page break to the left of the selected cell. For instance if 
the active cell is H15, then the break will be created between columns G and H.

Deleting a page break
To remove a page break:

1) Navigate to a cell that is next to the break you want to remove.

2) Select Edit > Delete Manual Break.

3) Select Row Break or Column Break depending on your need.

The break is now removed.

Note Multiple manual row and column breaks can exist on the same page. When you 
want to remove them, you have to remove each one individually. This may be 
confusing at times, because although there may be a column break set on the page, 
when you go to Edit > Manual Break column break may be grayed out.
In order to remove the break, you have to be in the cell next to the break. So, for 
example if you set the column break while you are in H15, you can not remove it if 
you are in cell D15. However, you can remove it from any cell in column H.

Headers and footers

Headers and footers are pre-defined pieces of text that are printed at the top or bottom of a 
sheet outside of the sheet area. Headers and footers are assigned to a sheet or to a sheet style.

Headers print on the top of a sheet and footers print on the bottom of a sheet. There are set 
the same way.

Setting a header or a footer
To set a header or footer:

1) Navigate to the sheet that you want to set the header or footer for.

2) Select Format > Page.

3) Select the header (or footer) tab. You should see Figure 8.
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Headers and footers

Figure 8: Header dialog

4) Select the Header on checkbox.

From here you can also set the margins, the spacing, and height for the header or footer. You 
can check the AutoFit height box to have the height of the header or footer automatically 
adjust.

Margin

Changing the size of the left or right margin adjusts how far the header or footer is from the 
side of the page.

Spacing

Spacing affects how far above or below the sheet the header or footer will print. So, if 
spacing is set to 1.00”, then there will be 1 inch between the header or footer and the sheet.

Height

Height affects how big the header or footer will be.
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Header or footer appearance
You can change the appearance of the header or footer by clicking on the More button. This 
opens the dialog shown in Figure 9.

Figure 9: Header/Footer Border/Background

From this dialog you can set the background and border of the header or footer.

Setting the contents of the header or footer
The header or footer of a Calc spreadsheet has three columns for text. Each column can have 
different contents.

To set the contents of the header or footer, click the Edit button in the header or footer dialog 
shown in Figure 8. The dialog shown in Figure 10 will display.
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Headers and footers

Figure 10: Edit contents of header or footer

Areas

Each area is independent and can have different information in it.

Header

In the header drop down list there are several preset choices.

Custom header

Here there are several buttons to add custom elements to the headers.

 Opens the Text Attributes dialog.

 Inserts the file name field.

 Inserts the sheet name field.

 Inserts the current page number.

 Inserts the total number of pages.

 Inserts the date field.

 Inserts the time field.
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