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Why use multiple sheets

Why use multiple sheets

Chapter 1 of the Calc guide introduced the concept of multiple sheets in a spreadsheet. 
Multiple sheets help keep information organized; once you link those sheets together, you 
unleash the full power of Calc. Consider this case:

John is having trouble keeping track of his personal finances. He has 
several bank accounts and the information is scattered and 
disorganized. He can’t get a good grasp on his finances until he can see 
everything at once. 

To resolve this, John decided to track his finances in OOo Calc. John 
knows Calc can do simple mathematical computations to help him keep 
a running tab of his accounts, and he wants to set up a summary sheet 
so that he can see all of his account balances at once.

This can be accomplished easily.

Note For users with experience using Microsoft Excel, a Calc sheet is called either a 
sheet or worksheet in Excel. What Excel calls a workbook, Calc calls a spreadsheet 
(the whole document).

Setting up multiple sheets in a spreadsheet

Chapter 1 of the Calc guide gives a  detailed explanation of how to set up multiple sheets. 
Here is a quick review.

Identifying sheets
When you open a new spreadsheet it has, by default, three sheets named Sheet1, Sheet2, and 
Sheet3. Sheets in Calc are managed using tabs at the bottom of the spreadsheet as shown in 
Figure 1.

Figure 1: Default sheet tabs
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Setting up multiple sheets in a spreadsheet

Inserting new sheets
There are several ways to insert a new sheet. The first step, in all cases, is to select the sheet 
that will be next to the new sheet . Then any of the following options can be used.

• Select Insert > Sheet from the pull-down menu or

• Right-click on the tab and select Insert Sheet, or

• Click in an empty space at the end of the line of sheet tabs (see Figure 2).

Figure 2: Creating a new sheet

Each method will open the Insert Sheet dialog (Figure 3). Here you can choose to put the new 
sheet before or after the selected sheet and how many sheets to insert.

Figure 3. Insert Sheet dialog

We need 6 sheets, one for each of the 5 accounts and one as a summary sheet so we will add 
3 more:. We also want to name each of these sheets for  the account they represent: summary, 
checking account, savings account, credit card 1, credit card 2 and car loan. 
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Setting up multiple sheets in a spreadsheet

Note The From file option will add a sheet  from a different spreadsheet file (for 
example, another Calc or Excel spreadsheet). Select the file and a list of the 
available sheets will appear in the box. Select the sheet to import. If, after you select 
the file, no sheets appear you probably selected an invalid file type (not a 
spreadsheet, for example).

Renaming sheets
Sheets can be renamed at any time. To give a sheet a more meaningful name:

• Enter the name in the name box when you create the sheet, or

• Right-click on a sheet tab, select Rename Sheet from the popup menu and replace the 
existing name.

Note Sheet names must start with either a letter or a number. Spaces are allowed after 
that. Other characters are not allowed. An invalid name will produce the  error 
message: Invalid Sheet Name.

Your sheet tab area should now look like this.

Figure 4: Six renamed sheets

Now we will set up the account ledgers. This is just  a simple summary that includes the 
previous balance plus the amount of the current transaction. For withdrawals, we enter the 
current transaction as a negative  number so the balance gets smaller. A basic ledger is shown 
in Figure 5.

Figure 5: Checking ledger

This ledger is set up in the sheet named Checking Account. The total balance is summed in 
cell F3. You can see the equation for it in the formula bar. It is the summary of the opening 
balance, cell C3, and all of the subsequent transactions.
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Referencing other sheets

Referencing other sheets

On the  Summary sheet we display the balance from each of the other sheets. If you followed 
the example in Figure 5, the balance for each account will be in cell F3 in each sheet. 

There are two ways to reference cells in other sheets: by entering the formula directly using 
the keyboard or by  using the mouse. We will look at the mouse method first.

Creating the reference with the mouse
On the Summary sheet, set up a place for all five account balances, so we know where to put 
the cell reference. Figure 6 shows a blank summary sheet. We want to place the reference for 
the checking account balance in cell B3.

Figure 6: Blank summary

To make the cell reference in cell B3, select the cell and  follow these steps.

1) Click on the = icon next to the input line. The icons will change and an equal sign will 
appear in the input line as in Figure 7.

Figure 7: Equal sign in input line

2) Now, click on the sheet tab for the sheet containing the cell to be referenced. In this 
case that is the Checking Account sheet as shown in Figure 8.

Figure 8: Click on the checking account tab

3) Click on cell F3 (where the balance is) in the Checking Account sheet.

4) Return to the original sheet.

5)  The phrase ‘Checking Account’.F3 should appear in the input line as in Figure 9.
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Referencing other sheets

Figure 9: Cell reference selected

6) Click the green checkmark next to input line to finish.

7) On the Summary sheet you should now see Figure 10.

Figure 10: Finished checking account reference

Creating the reference with the keyboard
Looking at Figure 10 you can deduce how the cell reference is constructed. The reference has 
two parts: the sheet name and the cell name.

 In Figure 10 the reference is =’Checking Account’.F3 and in general the format is =’Sheet  
Name’.Cell Reference.

So, you can fill in the Savings Account cell reference by just typing it in. Assuming that the 
balance is in the same cell in the Savings Account sheet, F3, the cell reference should be 
=’Savings Account’.F3.

Note The sheet name is in single quotes, and the period (.) is outside of the quotes.
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Referencing other sheets

 

Figure 11: Savings account cell reference

Referencing other documents

John decides to keep his family account information in a different spreadsheet file than his 
own summary. Fortunately Calc  can link different files together. The process is the same as 
described for different sheets in a single spreadsheet, but we add one more parameter  to 
indicate which file the sheet is in.

Creating the reference with the mouse
To create the reference with the mouse, both spreadsheets need to be open.  Select the cell in 
which the  formula is going to be entered.

1) Click the = icon next to the input line.

2) Switch to the other spreadsheet (the process to do this will vary depending on which 
operating system you are using.)

3) Select the sheet and then the reference cell.

4) Switch back to the original spreadsheet.

5) Click on the green check mark next to the input line.

Your spreadsheet should now resemble Figure 12.
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Referencing other documents

Figure 12: Linked files

You will get a good feel for the format of the reference if you look closely at the input line as 
in Figure 13.

Figure 13: Input Line for linked file

Based on this line you can create the reference using the keyboard.

Creating the reference with the keyboard
Typing  the reference  is simple once you know the format the reference takes. The reference 
has three parts to it:

• File name & path

• Sheet name

• Cell

Looking at Figure 13 you can see the the general format for the reference is 

=’file:///Path & File Name’#$SheetName.CellName.

Note The reference for a file has three forward slashes /// and the reference for a 
hyperlink has two forward slashes //.

Hyperlinks and URLs

Hyperlinks can be used in OOo Calc to create spreadsheets that will be used in a web 
interface or to jump to a different location from within a spreadsheet. This section covers 
inserting, editing, removing, and using hyperlinks. 

Creating hyperlinks
Hyperlinks can be created  as you type,  as a cut and paste, or inserted  using the  command: 
Insert > Hyperlink. Creating the hyperlink as you type or as a cut and paste is faster. 
.However, it will appear in the form <http://www .xyxyx.oog>.  If we use the Insert > 
Hyperlink command we have better control of how it appears and we can give it a 
meaningful name.
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Hyperlinks and URLs

Automatically creating hyperlinks

Creating hyperlinks by typing  or pasting is very simple.

1) Navigate to the cell where the hyperlink should be, (B3 in our example.)

2) In the active cell, B3 in the example shown in Figure 14, type or paste the URL for the 
link.

3) Press Enter, and the text will automatically turn into a hyperlink. 

Figure 14: Creating an automatic hyperlink

Note Automatic URL recognition can be turned off in the AutoCorrect menu. Select 
Tools > AutoCorrect > Options > URL Recognition.

Inserting hyperlinks with the Insert command

 This method allows you to specify  a name or message for the hyperlink.

1) Navigate to the cell where the hyperlink will be.Select Insert > Hyperlink, or click on 
the Insert Hyperlink button on the Main toolbar, . The Hyperlink dialog window, 
shown in Figure 15,will appear. 
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Hyperlinks and URLs

Figure 15: Hyperlink dialog

2) There are four options on the left of the screen to choose from:

• Internet – Makes a link to a site on the Internet. You can make a link to a web site, 
a FTP site, or a telnet site.

• Mail & News – Makes a link to an e-mail address or news list.

• Document – Makes a link to another place in the current document or a different 
document. This type of link will jump to a place in another document. It does not 
copy or  display data as the links discussed earlier in the chapter do.

• New Document – Makes a link to a document that is yet to be created. You must 
select the document type, name, and location of the new document.

3) To set the destination of the link, type the URL (e-mail address or document name) 
into the Target input box.

4) Choose the different options under Further settings.

• Frame – Enter the name of the frame that you want the linked file to open in. If you 
leave this box blank, the linked file opens in the current browser window. 

• Form – Specify whether the hyperlink is inserted as text or as a button.

• Text – Specify the visible text or button caption for the hyperlink.

• Name – Enter a name for the hyperlink. OpenOffice.org inserts a NAME tag in the 
hyperlink.

5) Click Apply.

In Figure 17 you can see the results from the settings in Figure 16. The button option was 
selected, to contrast the display in Figure 17 with the display in Figure 14 where the link is 
text.
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Hyperlinks and URLs

Figure 16: Insert hyperlink dialog with settings

Figure 17: OOo Authors hyperlink as button

Note A hyperlink  button, is a type of form control. As with all form controls, it can be 
anchored or positioned by right-clicking on the button in design mode. More 
information about forms can be found in Chapter 15 of the Writer Guide.

For the button to work , the spreadsheet must not be in design mode. To toggle 
design mode on and off, view the Form Controls toolbar (View > Toolbars > Form 
Controls) and press the Design Mode On/Off button .

Editing hyperlinks
You can edit a hyperlink at any time after it is created. This can be  very useful for modifying 
hyperlinks that were created as text hyperlinks. Text and button hyperlinks are edited 
differently.

Editing text hyperlinks

1) Navigate to the cell that contains the hyperlink.

2) Click on the hyperlink button in the toolbar, , or select Insert > Hyperlink. (This 

will not insert a new hyperlink.)

3) Both of these methods will open the Hyperlink dialog window seen in Figure 15.
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Hyperlinks and URLs

Note Clicking on a text hyperlink makes OOo try to open a browser window instead of 
selecting the hyperlink. Select the link by navigating to the cell using the arrow keys 
and opening the Hyperlink dialog window from the toolbar or from Insert > 
Hyperlink.

Editing button hyperlinks

1) Click on the Hyperlink button to select it (you must be in design mode, otherwise 
clicking it will launch your web browser).

2) Click on the the Hyperlink button in the toolbar, , or select Insert > Hyperlink. 
(This will not insert a new hyperlink.)

3) Either method will open the Hyperlink dialog window seen in Figure 15.

Note The only way to select a Hyperlink button is to click on it (while in design 
mode).You cannot use the arrow keys to navigate to the cell where the button 
appears to be. 

Removing hyperlinks
To remove a hyperlink, select it and press Delete. The  Delete dialog will open if it is a text 
hyperlink.

Relative and absolute hyperlinks
Hyperlinks can be saved either as absolute or relative. An absolute hyperlink says, “Here is 
how to get there from this known starting point” and a relative hyperlink says, “Here is how 
to get there starting from where you are now”.

To change the way that OOo saves the hyperlinks choose Tools > Options > Load/Save > 
General and choose if you want URLs saved relative to the File System, to the Internet, or 
both.

Calc always displays an absolute hyperlink. Don't be alarmed when it does this when you 
have chosen a relative hyperlink

If you have a relative hyperlink and you move files (the document and any linked files) on 
your computer, you shouldn’t have to remake your hyperlink as long as you maintain the 
same directory structure. For instance, if you have two spreadsheets in the same folder linked 
to each other and you move the entire folder to a new location, the hyperlink will not break. 
This is only true as long as the files’ locations relative to each other do not change.

In Figure 12 the path is D:\My Documents for the linked file. That is because the folder both 
sheets are in is in that directory as shown in Figure 18.
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Hyperlinks and URLs

Figure 18: Files on D drive

If I move that folder to my H:\ drive (Figure 19) the links in Calc will automatically update 
(Figure 21) because I haven’t changed the location of the files relative to each other. Both 
files are still in the working with multiple sheets folder as shown in Figure 20.

Figure 19: Files on H drive
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Hyperlinks and URLs

Figure 20: Directory with linked files

Figure 21: Updated links on H drive

Again, note that in both Figure 12 and Figure 21 the path is displayed as absolute even 
though it is relative.

Note Make sure that the folder structure on your computer is the same as the file structure 
on your web server if you save your links as relative to the file system and you, are 
going to upload pages to the Internet. 

TIP When you rest your mouse on a hyperlink, a help tip displays the absolute reference, 
since OOo uses absolute path names internally. The complete path and address can 
only be seen when you view the result of the HTML export (Saving the spreadsheet 
as and HTML file), by loading the HTML file as "Text" or opening it with a text 
editor.
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Embedding spreadsheets

Embedding spreadsheets

Spreadsheets can be embedded in other OOo files. This is often used in Writer documents so 
that Calc data can be used in a text document. You can embed the spreadsheet as either an 
OLE or DDE object.

Object Linking and Embedding (OLE)
Object Linking and Embedding (OLE) objects can be linked to a target document or be 
embedded in the target document. Embedding inserts a copy of the object and details of the 
source program in the target document. If you want to edit the embedded spreadsheet, double 
click on the object.

To add an OLE object:

1) Place the cursor in the document and location you want the OLE object to be.

2) Select Insert > Object > OLE Object. The dialog in Figure 22 will open.

Figure 22: Insert OLE object dialog

3) You can either create a new OLE object or create from a file.

4) To create from a file, click on the Create from file radio button.

5) Put the file name in the input box (or click the Search button to find it).

6) If you want to create a link, check the Link checkbox. To embed the object so that it 
will not update, do not check the Link checkbox. 

Non-Linked OLE object

If the OLE object is not linked, it can be edited in the new component. For instance, if you 
insert a spreadsheet into a Writer document, you can essentially treat it as a Writer table (with 
a little more power). To edit it, double click on it.

Linked OLE object

 When the spreadsheet OLE object is linked, if you change it in Writer it will change in Calc; 
if you change it in Calc, it will change in Writer. This can be a very powerful tool if you 
create reports in Writer using Calc data, and   want  to make a quick change without  opening 
Calc.
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Embedding spreadsheets

Note You can  only edit one copy of  a spreadsheet at t a time. If you have a linked OLE 
spreadsheet object in an open Writer document and then open the same spreadsheet 
in Calc,  the Calc spreadsheet will be a read-only copy.

Dynamic Data Exchange (DDE)
DDE is a predecessor of OLE. With DDE, objects are linked through file reference, but not 
embedded. You can create DDE links either within Calc cells in a Calc sheet, or in Calc cells 
in another OOo doc such as in Writer.

DDE in Calc

Creating a DDE link in Calc is very similar to creating a cell reference. The process is a little 
different, but the result is the same.

1) In Calc, select the cells that you want to make the DDE link to.

2) Copy them: Edit > Copy.

3) Go to the place in the spreadsheet where you want to the link to be.

4) Select Edit > Paste Special.

5) When the Paste Special dialog opens, click the link checkbox on the bottom of the 
dialog.

6) Click OK.

The cells  now  reference the copied data, which may be from a different sheet. You can now 
edit the original cells and the linked cells will update.

Caution

 

You can update the original cells, but if you change the cells where you created the 
DDE link, the link will be erased.

DDE link in Writer

The  process for creating a DDE link from Calc to Writer is similar to  creating a link within 
Calc.

1) In Calc, select the cells to make the DDE link to.

2) Copy them.

3) Go to the place in your Writer document where you want  the DDE link. 

4) Select Edit > Paste Special.

5) Select DDE Link.

6) Click OK.

Now the link has been created in Writer. When the Calc spreadsheet is updated, the table in 
Writer is automatically updated. Remember, if you change the table in Writer, the link will be 
broken. 
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